indicator-applet does not have an icon in the panel

Bug #433274 reported by Christoph Korn on 2009-09-19
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Messaging Menu
Fix Released
Medium
Unassigned
indicator-messages (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: indicator-applet

The indicator-applet does not have an icon in the gnome panel currently.

ProblemType: Bug
Architecture: amd64
Date: Sat Sep 19 23:36:02 2009
DistroRelease: Ubuntu 9.10
Package: indicator-applet 0.2.0-0ubuntu1
ProcEnviron:
 LANG=de_DE.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-10.34-generic
SourcePackage: indicator-applet
Uname: Linux 2.6.31-10-generic x86_64

Related branches

Christoph Korn (c-korn) wrote :

On Sat, 2009-09-19 at 21:38 +0000, Christoph Korn wrote:
> The indicator-applet does not have an icon in the gnome panel currently.

Wow, that's odd. Could you try killing everything and running the
messages service capturing it's console output?

  $ killall indicator-applet indicator-messages-service
  $ /usr/lib/indicator-messages/indicator-messages-service

That might tell us more of what is going on.

  status triaged
  importance medium

Changed in indicator-applet (Ubuntu):
importance: Undecided → Medium
status: New → Triaged
Christoph Korn (c-korn) wrote :

This is the output of those two commands.

On Mon, 2009-09-21 at 17:00 +0000, Christoph Korn wrote:
> This is the output of those two commands.

My guess, without looking at the code, would be that it's trying to hide
the icon on any entry being blacklisted not if all the entires are
blacklisted. Then the menu is still being shown (not completely hidden)
as there are entries in it.

  assign ted

Ted Gould (ted) on 2009-09-23
affects: indicator-applet (Ubuntu) → indicator-messages (Ubuntu)
Changed in indicator-messages:
importance: Undecided → Medium
status: New → Triaged
Ted Gould (ted) wrote :

Christoph,

I really can't reproduce this. Are you still getting it?

Ted

Christoph Korn (c-korn) wrote :

Yes,
I think it occurred after I disabled in evolution that evolution should appear in the applet.

Christoph Korn (c-korn) wrote :

Here is a screen video to proof I am not crazy :)

Basically when I open evolution the icon appears.
Then I untick those two options again and log out.
After logging in the icon is disappeared again.

Ted Gould (ted) on 2009-09-30
Changed in indicator-messages:
milestone: none → 0.2.5
status: Triaged → Fix Committed
Ted Gould (ted) on 2009-10-01
Changed in indicator-messages:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package indicator-messages - 0.2.5-0ubuntu1

---------------
indicator-messages (0.2.5-0ubuntu1) karmic; urgency=low

  * Upstream release 0.2.5 (LP: #440217)
    * Adding a check on addition of launchers to ensure icon is correctly
      visible. (LP: #433274)
    * Making it so that if applications don't set the time on an indicator
      the time isn't shown in the menu. (LP: #438237)
    * Putting icons in the right places. (LP: #436460)

 -- Ted Gould <email address hidden> Thu, 01 Oct 2009 23:34:28 +0200

Changed in indicator-messages (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers