[TOPBLOCKER] should use rotationLock bool rather than the newer orientation enum

Bug #1378078 reported by Charles Kerr on 2014-10-06
62
This bug affects 10 people
Affects Status Importance Assigned to Milestone
Indicator Display
Fix Released
High
Charles Kerr
indicator-display (Ubuntu)
Undecided
Unassigned
indicator-display (Ubuntu RTM)
Critical
Charles Kerr

Bug Description

the rotation lock indicator's currently using com.ubuntu.touch.system.gschema.xml's "orietnation-lock" setting (which is a ScreenOrientation enum).

However this isn't going to be adopted for RTM, so we should switch to the older "rotation-lock" setting (which is a bool).

Related branches

Charles Kerr (charlesk) on 2014-10-06
tags: added: rtm14 touch-2014-10-23
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package indicator-display - 0.1+14.10.20141009-0ubuntu1

---------------
indicator-display (0.1+14.10.20141009-0ubuntu1) utopic; urgency=low

  [ Charles Kerr ]
  * Use com.ubuntu.touch.system's "rotation-lock" boolean for the
    rotation lock indicator. (LP: #1378078)
 -- Ubuntu daily release <email address hidden> Thu, 09 Oct 2014 13:44:22 +0000

Changed in indicator-display (Ubuntu):
status: New → Fix Released
Olli Ries (ories) on 2014-10-22
Changed in indicator-display:
importance: Critical → High

This didn't get into RTM seemingly - at least the indicator doesn't work there anyway

Ted Gould (ted) wrote :

If someone wants to SRU this to the RTM branch they can. Setup an RTM bug task for that purposed, but marking the others to correctly handle the bug's state.

Changed in indicator-display:
status: In Progress → Fix Released
Changed in indicator-display (Ubuntu RTM):
status: New → Confirmed
importance: Undecided → High
status: Confirmed → Triaged
Changed in indicator-display (Ubuntu RTM):
importance: High → Critical
assignee: nobody → Charles Kerr (charlesk)
summary: - should use ratationLock bool rather than the newer orientation enum
+ [TOPBLOCKER] should use ratationLock bool rather than the newer
+ orientation enum

This didn't land last week because it exposed a regression in u-s-s tracked at bug #1390643. That's apparently fixed and is being backported to RTM.

At this point, all this bug needs in order to land is QA signoff.

Charles Kerr (charlesk) on 2014-11-17
summary: - [TOPBLOCKER] should use ratationLock bool rather than the newer
+ [TOPBLOCKER] should use rotationLock bool rather than the newer
orientation enum
tags: added: lt-blocker lt-category-visible
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package indicator-display - 0.1+15.04.20141117~rtm-0ubuntu1

---------------
indicator-display (0.1+15.04.20141117~rtm-0ubuntu1) 14.09; urgency=low

  [ Charles Kerr ]
  * Use com.ubuntu.touch.system's "rotation-lock" boolean for the
    rotation lock indicator. (LP: #1378078)
 -- Ubuntu daily release <email address hidden> Mon, 17 Nov 2014 23:49:33 +0000

Changed in indicator-display (Ubuntu RTM):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers