gnome-control-center crashed with SIGSEGV in gtk_widget_get_toplevel()

Bug #942450 reported by Steve Langasek on 2012-02-28
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Indicator Date and Time
Fix Released
High
Charles Kerr
indicator-datetime (Ubuntu)
Medium
Unassigned

Bug Description

no idea what caused this crash.

ProblemType: Crash
DistroRelease: Ubuntu 12.04
Package: indicator-datetime 0.3.90-0ubuntu1
ProcVersionSignature: Ubuntu 3.2.0-16.25-generic 3.2.6
Uname: Linux 3.2.0-16-generic x86_64
ApportVersion: 1.93-0ubuntu2
Architecture: amd64
CheckboxSubmission: 017452a27eca3c8b498abbfa5ef91db9
CheckboxSystem: ecaaad6fa1e0799a0aa1126bf620f39e
Date: Mon Feb 27 23:47:49 2012
ExecutablePath: /usr/bin/gnome-control-center
InstallationMedia: Ubuntu 10.04.1 LTS "Lucid Lynx" - Release amd64 (20100816.1)
ProcCmdline: gnome-control-center indicator-datetime
ProcEnviron:
 SHELL=/bin/bash
 PATH=(custom, user)
 LANG=en_US.UTF-8
SegvAnalysis:
 Segfault happened at: 0x7f6fa1c5d017 <gtk_widget_get_toplevel+87>: mov 0x70(%rax),%rax
 PC (0x7f6fa1c5d017) ok
 source "0x70(%rax)" (0xaaaaaaaaaaaaab1a) not located in a known VMA region (needed readable region)!
 destination "%rax" ok
SegvReason: reading unknown VMA
Signal: 11
SourcePackage: indicator-datetime
StacktraceTop:
 gtk_widget_get_toplevel (widget=0x7f6fa356cec0) at /build/buildd/gtk+3.0-3.3.16/./gtk/gtkwidget.c:9615
 gtk_widget_is_focus (widget=0x7f6fa35c75c0) at /build/buildd/gtk+3.0-3.3.16/./gtk/gtkwidget.c:6784
 gtk_widget_propagate_state (widget=0x7f6fa35c75c0, data=0x7fff280c38b0) at /build/buildd/gtk+3.0-3.3.16/./gtk/gtkwidget.c:10718
 gtk_widget_set_sensitive (widget=0x7f6fa35c75c0, sensitive=1) at /build/buildd/gtk+3.0-3.3.16/./gtk/gtkwidget.c:7708
 ?? () from /usr/lib/control-center-1/panels/libindicator-datetime.so
Title: gnome-control-center crashed with SIGSEGV in gtk_widget_get_toplevel()
UpgradeStatus: Upgraded to precise on 2011-11-08 (111 days ago)
UserGroups: adm admin cdrom dialout libvirtd lpadmin mythtv plugdev sambashare src

Related branches

Steve Langasek (vorlon) wrote :

StacktraceTop:
 gtk_widget_get_toplevel (widget=0x7f6fa356cec0) at /build/buildd/gtk+3.0-3.3.16/./gtk/gtkwidget.c:9615
 gtk_widget_is_focus (widget=0x7f6fa35c75c0) at /build/buildd/gtk+3.0-3.3.16/./gtk/gtkwidget.c:6784
 gtk_widget_propagate_state (widget=0x7f6fa35c75c0, data=0x7fff280c38b0) at /build/buildd/gtk+3.0-3.3.16/./gtk/gtkwidget.c:10718
 gtk_widget_set_sensitive (widget=0x7f6fa35c75c0, sensitive=1) at /build/buildd/gtk+3.0-3.3.16/./gtk/gtkwidget.c:7708
 ntp_query_answered (object=<optimized out>, res=<optimized out>, self=0x7f6fa35c7170) at /build/buildd/indicator-datetime-0.3.90/./src/datetime-prefs.c:226

Changed in indicator-datetime (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace
visibility: private → public
Olli Ries (ories) on 2012-03-27
Changed in indicator-datetime:
assignee: nobody → Charles Kerr (charlesk)
importance: Undecided → High
Charles Kerr (charlesk) wrote :

Thanks for reporting this.

Looks like a dbus proxy callback function wasn't getting cancelled properly when the datetime prefs panel was closed.

Changed in indicator-datetime:
status: New → In Progress
Charles Kerr (charlesk) on 2012-03-28
Changed in indicator-datetime:
status: In Progress → Fix Committed
Charles Kerr (charlesk) on 2012-03-29
Changed in indicator-datetime:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package indicator-datetime - 0.3.93-0ubuntu1

---------------
indicator-datetime (0.3.93-0ubuntu1) precise; urgency=low

  * New upstream release.
    * Fix g-c-c crash caused by datetime's prefs panel (LP: #942450)
    * Fix several memory leaks in datetime's preferences page (LP: #965533)
 -- Charles Kerr <email address hidden> Wed, 28 Mar 2012 16:10:35 -0700

Changed in indicator-datetime (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers