indicator-datetime does not update date after change

Bug #917236 reported by Dan Halbert on 2012-01-16
28
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Indicator Date and Time
Fix Released
Medium
Charles Kerr
OEM Priority Project
High
James M. Leddy
Precise
High
James M. Leddy
indicator-datetime (Ubuntu)
Medium
Charles Kerr

Bug Description

After setting the date manually via "sudo date", the short display of the date in indicator-datetime did not update. The calendar display DID update.

See the attached screenshot.

Today's date is Jan 16, 2012. To test an issue with another program, I set the date forward to July 12, 2012, using "sudo date 07121034".

This seems to be similar to bug #793450, but that bug was supposedly fixed, and this is indicator-datetime, 0.3.1-0ubuntu1 in oneiric.

Related branches

Dan Halbert (dhalbert) wrote :
tags: added: oneiric
Charles Kerr (charlesk) on 2012-03-29
Changed in indicator-datetime:
status: New → Triaged
assignee: nobody → Charles Kerr (charlesk)
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in indicator-datetime (Ubuntu):
status: New → Confirmed
Charles Kerr (charlesk) on 2012-03-29
Changed in indicator-datetime:
importance: Undecided → Medium
Bilal Akhtar (bilalakhtar) wrote :

Reproduced on Precise too. Affects only changing date from the command line.

Changed in indicator-datetime:
status: Triaged → Confirmed
importance: Medium → Low
Changed in indicator-datetime (Ubuntu):
importance: Undecided → Low
Changed in indicator-datetime:
status: Confirmed → Triaged
Changed in indicator-datetime (Ubuntu):
status: Confirmed → Triaged
Kent Lin (kent-jclin) on 2012-05-29
Changed in oem-priority:
importance: Undecided → High
James M. Leddy (jm-leddy) wrote :

From Kent:

We find that when first time we change the time, the time will be changed after 1 mins.
But when you set it again, the time will not be changed at all.

Harmen H (harmenh) wrote :

Setting the date/time manually from settings -> time & date has the same impact. The displayed date above the calendar doesn't change at all. The calendar however does change to the correct date.

Tested with 12.04

Changed in oem-priority:
assignee: nobody → David Barth (dbarth)
tags: added: rls-q-incomming
Colin Watson (cjwatson) on 2012-06-26
tags: added: rls-q-incoming
removed: rls-q-incomming
James M. Leddy (jm-leddy) wrote :

Huh, this is actually screwy. Most of the labels are in control of datetime-service, but some of them (the calendar and the time that you have to click on) are part of indicator-datetime. I can fix the problem of 'date MMDDhhmm' pretty simply for the label that you have to click on, but it doesn't update the "Wednesday, 29 August 2012" bit directly under it because that's under datetime-service. I think we need to add a new signal.

No idea on how to fix setting the time manually, probably will need to call the same signal.

James M. Leddy (jm-leddy) wrote :

Looks like this is shared by means of a DBUSMENU_CALENDAR_MENUITEM_TYPE in dbus-shared.h . So we need something similar for the date label so it can be updated from either.

James M. Leddy (jm-leddy) wrote :

I have fixed it so the time updates on the label that you click on. Still todo is to fix the date label exactly underneath.

Changed in oem-priority:
assignee: David Barth (dbarth) → James M. Leddy (jm-leddy)
Omer Akram (om26er) wrote :

If I understand this correct, James you are working to fix this bug, right?

James M. Leddy (jm-leddy) wrote :

Yes, but is turning out to be more compliacated than I initially thought.

Changed in oem-priority:
status: New → Confirmed
status: Confirmed → Triaged
Omer Akram (om26er) on 2012-09-12
tags: added: pspriority
Omer Akram (om26er) on 2012-09-12
Changed in indicator-datetime:
importance: Low → Medium
Changed in indicator-datetime (Ubuntu):
importance: Low → Medium
Omer Akram (om26er) on 2012-09-12
Changed in indicator-datetime:
assignee: Charles Kerr (charlesk) → James M. Leddy (jm-leddy)
Changed in indicator-datetime (Ubuntu):
assignee: nobody → James M. Leddy (jm-leddy)
Changed in indicator-datetime:
assignee: James M. Leddy (jm-leddy) → nobody
Changed in indicator-datetime (Ubuntu):
assignee: James M. Leddy (jm-leddy) → Charles Kerr (charlesk)
Charles Kerr (charlesk) on 2012-09-20
Changed in indicator-datetime:
assignee: nobody → Charles Kerr (charlesk)
milestone: none → 12.10.1
Changed in indicator-datetime:
status: Triaged → Fix Committed
Charles Kerr (charlesk) on 2012-09-20
Changed in indicator-datetime:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package indicator-datetime - 12.10.1-0ubuntu1

---------------
indicator-datetime (12.10.1-0ubuntu1) quantal; urgency=low

  * New upstream release.
    - Gracefully handle clock skew (LP: #917236)
    - Raise the version number of our EDS dependency (LP: #1024437)
    - Fix X-Ubuntu-Gettext-Domain entries in the .desktop file (LP: #1048834)
    - Remove unnecessary watching for geoclue address provider changes
  * build-dep on newer e-d-s stack
 -- Didier Roche <email address hidden> Thu, 20 Sep 2012 18:51:34 +0200

Changed in indicator-datetime (Ubuntu):
status: Triaged → Fix Released
Changed in oem-priority:
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers