[master] Support menu activation via the keyboard

Reported by Jorge O. Castro on 2010-07-19
40
This bug affects 6 people
Affects Status Importance Assigned to Milestone
Application Menu Indicator
Critical
Cody Russell
indicator-appmenu (Ubuntu)
Undecided
Unassigned

Bug Description

Keyboard shortcuts don't work with the menu. For example, I should be able to hit "Ctrl-F" and the file menu should open. Same with Ctrl-E for edit, etc.

David Barth (dbarth) on 2010-07-20
Changed in indicator-appmenu:
assignee: nobody → Cody Russell (bratsche)
importance: Undecided → Critical
milestone: none → maverick-alpha-3
status: New → Triaged
David Barth (dbarth) on 2010-07-20
summary: - Support menu activation via the keyboard
+ [master] Support menu activation via the keyboard
David Barth (dbarth) wrote :

That task actually covers 3 different aspects:
- using shortcuts like CTRL-V or CTRL-O from the application window should still work (it does at the moment with the appmenu-gtk module)
- shortcuts should be able to trigger a popup menu (like CTRL-F in g-terminal)
- ideally, pressing ALT in the application window should highlight the mnemonics in the panel menu

Cody Russell (bratsche) on 2010-07-28
Changed in indicator-appmenu:
status: Triaged → In Progress
Tobias Wolf (towolf) wrote :

Just a minor correction. Opening menus is usually Alt + <Initial letter>, not Ctrl.

David Barth (dbarth) on 2010-08-23
Changed in indicator-appmenu:
milestone: maverick-alpha-3 → ubuntu-10.10-beta
David Barth (dbarth) on 2010-08-27
Changed in indicator-appmenu:
milestone: ubuntu-10.10-beta → ubuntu-10.10
David Barth (dbarth) wrote :

This is a request for a Feature Freeze Exception, per https://wiki.ubuntu.com/FreezeExceptionProcess#General Instructions

Proposed changes: The change is about adding the ability to support keyboard shortcuts with the new panel menubar (appmenu)
Rationale for the exception: Without the feature, users can't use keyboard shortcuts to either open menu items or activate actions registered in the menus (ALT-F, or CTRL-S)
Additional information: can be also considered a regression, since appmenu is the default on UNE and it breaks menu shortcuts.

David Barth (dbarth) wrote :

Further elements to document the exception request will follow, according to https://wiki.ubuntu.com/FreezeExceptionProcess#FeatureFreeze Exceptions and https://wiki.ubuntu.com/FreezeExceptionProcess#FeatureFreeze for new upstream versions

David Barth (dbarth) wrote :

Additional information: patches have been integrated in the respective projects trunk codebase, but a remaining issue subsists with a broken keyboard grab.

Cody Russell (bratsche) on 2010-08-30
Changed in indicator-appmenu:
status: In Progress → Fix Committed
Tobias Wolf (towolf) wrote :

Right now pressing Alt+<letter> traps keyboard focus in the panel. The only way to get keyboard input back to the app window is pressing F10 twice as far as i can tell.

Is this what you referred to with «a remaining issue subsists with a broken keyboard grab»?

Paul Kishimoto (khaeru) on 2010-09-15
Changed in indicator-appmenu (Ubuntu):
status: New → Confirmed
Scott Kitterman (kitterman) wrote :

Is this change still desired for Maverick?

Changed in indicator-appmenu (Ubuntu):
status: Confirmed → Incomplete
Ted Gould (ted) wrote :

Yes, and it is also in. Thanks again Scott, sorry to forget it.

Changed in indicator-appmenu (Ubuntu):
status: Incomplete → Fix Released
Changed in indicator-appmenu:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers