Desktop freezes if new window takes focus while menu is open

Reported by Hernando Torque on 2010-07-09
192
This bug affects 31 people
Affects Status Importance Assigned to Milestone
Application Menu Indicator
High
Unassigned
indicator-appmenu (Ubuntu)
High
Unassigned

Bug Description

appmenu-gtk 0.1.1-0ubuntu1, indicator-appmenu 0.0.8-0ubuntu1
appmenu-gtk 0.1.7-0ubuntu1, indicator-appmenu 0.0.9-0ubuntu1, Ubuntu Maverick

1. Focus a window for which indicator-appmenu displays the window menus, e.g. Character Map or Calculator.
2. Start "Take Screenshot".
3. Choose "Grab the whole desktop" and "Grab after a delay of" 5 seconds, and choose "Take Screenshot".
4. Within 5 seconds, open any of the window menus for the previously-focused window, and wait for the remaining time to elapse.

What happens:
* A "Save Screenshot" window takes focus (with a thumbnail showing that Take Screenshot successfully snapped the open menu).
* The menu then goes blank, and the entire screen becomes unresponsive.

What should happen: As soon as the Save Screenshot window takes focus, the menu you had open should automatically close, because it is no longer a menu for the focused window.

To recover after testing:
5. Ctrl Alt F1.
6. At the console, enter "killall indicator-applet-appmenu". If your volume was up, you should hear a twang sound.
7. Alt F7.
8. In the error alert, choose "Reload".

Omer Akram (om26er) wrote :

confirmed but its not the case with every application

Changed in indicator-appmenu:
status: New → Confirmed
Omer Akram (om26er) wrote :

oops I meant it happens with every app.

Yes, seems you are right.

summary: - Simple-scan: desktop freezes if using the menu while pop-up is shown
+ Desktop freezes if using the menu while pop-up is shown
David Barth (dbarth) wrote :

Confirmed. This is a serious issue.

Changed in indicator-appmenu:
importance: Undecided → High
milestone: none → maverick-alpha-3
Matthew Paul Thomas (mpt) wrote :

This is no longer reproducible using Simple Scan, because it now uses a banner rather than an alert box. Replacing with alternative steps.

From duplicate bug:
1. Open gnome-screenshot in interactive mode.
2. Set a delay, then click on "Take Screenshot".
3. Focus on an application, then open one of its menus in appmenu-gtk.
4. Wait for the screenshot delay.
5. A window from gnome-screenshot will open, causing appmenu-gtk to switch to generic menu entries (File and Edit).
6. Notice that there is a white box replacing the menu previously open, and that the desktop is frozen.

description: updated
summary: - Desktop freezes if using the menu while pop-up is shown
+ Desktop freezes if new window takes focus while menu is open
Hernando Torque (htorque) wrote :

Or run the attached python snippet (5 sec. after the start a dialog will show).

Omer Akram (om26er) on 2010-09-20
Changed in indicator-appmenu (Ubuntu):
importance: Undecided → Medium
status: New → Triaged

I can confirm that this is still a problem in the final release of Maverick. I've had to reboot several times because of it (I didn't know the recovery steps until now).

ScayTrase (scaytrase) wrote :

its enough to restart X, or run `killall gnome-panel` to unfreeze system. I am affected to, Maverick amd64.

Anurag Panda (anurag-panda) wrote :

Confirmed. I am affected in Maverick AMD64. The desktop freezes, and only way to recover is `killall gnome-panel'.

saksmlz (saksmlz) wrote :

it's better to kill only the applet process `killall indicator-applet-appmenu' to unfreeze desctop

Sebastien Bacher (seb128) wrote :

Dx, could you make sure that issue is addressed in natty? Getting the desktop to freeze is a real issue

Changed in indicator-appmenu (Ubuntu):
assignee: nobody → Canonical Desktop Experience Team (canonical-dx-team)
importance: Medium → High
David Barth (dbarth) wrote :

This is still there in natty, yes.

Changed in indicator-appmenu:
assignee: nobody → Ted Gould (ted)
Changed in indicator-appmenu (Ubuntu):
assignee: Canonical Desktop Experience Team (canonical-dx-team) → Ted Gould (ted)
milestone: none → natty-alpha-3

On Fri, 2011-01-21 at 18:18 +0000, David Barth wrote:
> This is still there in natty, yes.

Did you confirm with the indicator-appmenu released yesterday as it
adjusted this behavior?

Hernando Torque (htorque) wrote :

It's happening here in a classic session (with or without Compiz) with indicator-appmenu 0.1.91-0ubuntu1.

This works for me on a recent natty daily in Unity.

I can reproduce the bug on maverick in a gnome-panel session, but I didn't try reproducing this on natty in a gnome-panel session. (Will gnome-panel sessions in natty come with the appmenu indicator by default?)

Hernando Torque (htorque) wrote :

This never was an issue in Unity (Maverick/Natty), and no, the appmenu is not there by default (at least that's the current state).

David Barth (dbarth) on 2011-01-24
Changed in indicator-appmenu:
assignee: Ted Gould (ted) → Michael Terry (mterry)
David Barth (dbarth) on 2011-01-24
Changed in indicator-appmenu (Ubuntu):
assignee: Ted Gould (ted) → Michael Terry (mterry)
tags: added: iso-testing
Fred (eldmannen+launchpad) wrote :

This bug may get fixed, but there is still an underlaying issue here.
How can one little application freeze the WHOLE desktop?
Something is seriously wrong here.

Michael (michaeljt) wrote :

Fred, you are right of course, but the underlying issue is well known. The X Window specification lets an application "grab" the mouse pointer or the keyboard, preventing any other application from using them until they are released again. Like many things in the X Window System, this only works if the application behaves itself and doesn't have a bug in the wrong place. There would probably be ways to work around this - X has a "give me back my mouse" key combination which you can activate - but fundamentally this can only be changed by replacing X with something else (Wayland?) And hoping that the replacement doesn't have any equally silly problems that no one thought of in time!

Take a look at http://www.x.org/wiki/Development/X12 if you are interested in other shortcomings of X11.

Sam Spilsbury (smspillaz) wrote :

On Fri, Feb 4, 2011 at 5:55 PM, Fred <email address hidden> wrote:
> This bug may get fixed, but there is still an underlaying issue here.
> How can one little application freeze the WHOLE desktop?
> Something is seriously wrong here.

XGrabPointer.

http://tronche.com/gui/x/xlib/input/XGrabPointer.html

It is fundamental to the design of X that if something needs to
collect pointer motion (like a menu) then it needs to stop other
things from doing so/

>
> --
> You received this bug notification because you are a member of Indicator
> Applet Developers, which is the registrant for Application Menu
> Indicator.
> https://bugs.launchpad.net/bugs/603482
>
> Title:
>  Desktop freezes if new window takes focus while menu is open
>
> Status in The Application Menu:
>  Confirmed
> Status in “indicator-appmenu” package in Ubuntu:
>  Triaged
>
> Bug description:
>  appmenu-gtk 0.1.1-0ubuntu1, indicator-appmenu 0.0.8-0ubuntu1
>  appmenu-gtk 0.1.7-0ubuntu1, indicator-appmenu 0.0.9-0ubuntu1, Ubuntu Maverick
>
>  1. Focus a window for which indicator-appmenu displays the window menus, e.g. Character Map or Calculator.
>  2. Start "Take Screenshot".
>  3. Choose "Grab the whole desktop" and "Grab after a delay of" 5 seconds, and choose "Take Screenshot".
>  4. Within 5 seconds, open any of the window menus for the previously-focused window, and wait for the remaining time to elapse.
>
>  What happens:
>  * A "Save Screenshot" window takes focus (with a thumbnail showing that Take Screenshot successfully snapped the open menu).
>  * The menu then goes blank, and the entire screen becomes unresponsive.
>
>  What should happen: As soon as the Save Screenshot window takes focus,
>  the menu you had open should automatically close, because it is no
>  longer a menu for the focused window.
>
>  To recover after testing:
>  5. Ctrl Alt F1.
>  6. At the console, enter "killall indicator-applet-appmenu". If your volume was up, you should hear a twang sound.
>  7. Alt F7.
>  8. In the error alert, choose "Reload".
>
>
>

--
Sam Spilsbury

Michael Terry (mterry) on 2011-02-11
Changed in indicator-appmenu:
status: Confirmed → Fix Released
Changed in indicator-appmenu (Ubuntu):
assignee: Michael Terry (mterry) → nobody
status: Triaged → Fix Released
Changed in indicator-appmenu:
assignee: Michael Terry (mterry) → nobody
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments