clicking on rhythmbox icon does nothing

Bug #554375 reported by hourna on 2010-04-03
116
This bug affects 26 people
Affects Status Importance Assigned to Milestone
Application Indicators
Invalid
Low
Unassigned
indicator-application (Ubuntu)
Low
Unassigned
rhythmbox (Ubuntu)
Low
Unassigned

Bug Description

when i start rhythmbox, the rhythmbox icon appears on the indicator applet. however, when i click on it, rhythmbox won't appear and icon in the notification area gets highlighted but nothing happens. after further investigations, i found out the following: if indicator applet is removed from the panel, rhythmbox just starts fine and it minimizes to the lower panel. if i add indicator applet to the panel while rhythmbox is running, it minimizes to its icon and when i click on the icon everything looks fine. it works as it should. however, when i close the rhythmbox and start again, its icon on the indicator applet appears but clicking on it does not work.

also i have reported this problem in the lucid testing forum.

http://ubuntuforums.org/showthread.php?p=9062767

Ted Gould (ted) wrote :

This is likely an issue with the indicator support from Rhythmbox. Can you run Rhythmbox from the command line and see if it outputs any more information? Thanks.

affects: indicator-applet → null
hourna (cagri-demir) wrote :

terminal output when i run command "rhythmbox":

*** Invalid PAC URL! Falling back to direct...
*** Invalid PAC URL! Falling back to direct...

that's all. again icon appears in the indicator applet and it is still not functioning.

description: updated
Changed in rhythmbox (Ubuntu):
importance: Undecided → Low
Vish (vish) wrote :

Opening indicator-application task as per Tedg's comment that this bug might be due to the application-indicator port

affects: null → indicator-application
Changed in indicator-application (Ubuntu):
importance: Undecided → Low
Changed in indicator-application (Ubuntu):
status: New → Incomplete
Changed in rhythmbox (Ubuntu):
status: New → Incomplete
Ted Gould (ted) on 2010-05-21
Changed in indicator-application:
status: New → Triaged
importance: Undecided → Low

This happens to me only once in a blue moon: I cannot reproduce this with reliable success, but the bug still hits me every once in a while on rhythmbox startup.

Strangely, this is happening every time for me now, even after killing indicator-applet or restarting.

David Ordenes D. (radioboy-2) wrote :

It also happens to me. Not very often, but it's difficult to reproduce. After killing Rhythmbox 2 or 3 times, then the menu appears correctly.
Interestingly, sometimes the same problem happens with the indicator session applet. A manual logout fixes it.

Lucid x64, kernel 2.6.32-22-generic.

Sebastien Bacher (seb128) wrote :

the update in bug #592507 could solve the issue

Omer Akram (om26er) wrote :

could anyone affected by this issue please enable the lucid-proposed repository from software sources and check if the version of libdbusmenu there solves the problem.

NeilGreenwood (neil-greenwood) wrote :

I've installed the lucid-proposed versions of libdbusmenu-glib1 and libdbusmenu-gtk1. It seems to be better, but I need to do more testing before I can confirm this bug is fixed.

Stephen Rees-Carter (valorin) wrote :

I am running 10.04.1 i386, fully updated, with lucid-proposed and still experience this issue.

I notice that it happens every time I run Rhythmbox, and as it starts minimized I need to run it again before the window will come up and be useful.

On 26 July 2010 00:45, Stephen Rees-Carter <email address hidden> wrote:
> I am running 10.04.1 i386, fully updated, with lucid-proposed and still
> experience this issue.
>
> I notice that it happens every time I run Rhythmbox, and as it starts
> minimized I need to run it again before the window will come up and be
> useful.
>

I'm also not seeing the problem fixed. I had to 'killall gnome-panel'
to get things working this morning, even after manually starting and
stopping Rhythmbox. The icon was shown in the notification area but
did nothing when clicked.

clockworkpc (clockworkpc) wrote :
Download full text (30.6 KiB)

I have the same problem as Neil. Fully updated Lucid and can't even get into Rhythmbox:

(19:27:16) [0x9304028] [rhythmdb_query_model_add_results] rhythmdb-query-model.c:2247: adding 0 entries
(19:27:16) [0x9304028] [idle_process_update] rhythmdb-query-model.c:1186: inserting 0 rows
(19:27:16) [0x9304028] [rhythmdb_query_internal] rhythmdb.c:4132: completed
(19:27:16) [0x9304028] [rhythmdb_query_model_dispose] rhythmdb-query-model.c:730: disposing query model 0x9638a30
(19:27:16) [0x9304028] [rhythmdb_query_model_finalize] rhythmdb-query-model.c:778: finalizing query model 0x9638a30
(19:27:16) [0x9304028] [rb_sourcelist_append] rb-sourcelist.c:1111: inserting source 0x9bb9000 to group library
(19:27:16) [0x9304028] [rb_plugin_find_file] rb-plugin.c:329: found '/usr/lib/rhythmbox/plugins/iradio/iradio-ui.xml' when searching for file 'iradio-ui.xml' for plugin 'iradio'
(19:27:16) [0x9304028] [rb_plugins_engine_load] rb-plugins-engine.c:116: Loading plugin: /usr/lib/rhythmbox/plugins/jamendo/jamendo.rb-plugin
(19:27:16) [0x9304028] [rb_plugins_engine_load] rb-plugins-engine.c:206: Could not find 'Icon' in /usr/lib/rhythmbox/plugins/jamendo/jamendo.rb-plugin
(19:27:16) [0x9304028] [rb_plugins_engine_load_cb] rb-plugins-engine.c:299: Plugin Jamendo loaded
(19:27:16) [0x9304028] [rb_python_module_init] rb-python-module.c:440: Init of python module
(19:27:16) [0x9304028] [rb_python_object_get_type] rb-python-plugin.c:274: Registering python plugin instance: Jamendo+RBPythonPlugin
(19:27:16) [0x9304028] [rb_python_module_new_object] rb-python-module.c:413: Creating object of type Jamendo+RBPythonPlugin
(19:27:16) [0x9304028] [rb_python_object_init] rb-python-plugin.c:204: Creating python plugin instance
(19:27:16) [0x9304028] [rhythmdb_tree_entry_type_registered] rhythmdb-tree.c:2691: no entries of newly registered type JamendoEntryType loaded from db
(19:27:16) [0x9304028] [rb_find_user_file] rb-file-helpers.c:224: found user dir path for 'jamendo': /home/clockworkpc/.cache/rhythmbox/jamendo
(19:27:16) [0x9304028] [rb_property_view_selection_changed_cb] rb-property-view.c:834: selection changed
(19:27:16) [0x9304028] [rhythmdb_query_model_chain] rhythmdb-query-model.c:896: query model 0x9652008 chaining to base model (nil)
(19:27:16) [0x9304028] [rb_entry_view_insert_column_custom] rb-entry-view.c:1755: appending column: 0x9bc0ae0 (Track)
(19:27:16) [0x9304028] [rb_entry_view_insert_column_custom] rb-entry-view.c:1755: appending column: 0x9bc0be0 (Title)
(19:27:16) [0x9304028] [rb_entry_view_insert_column_custom] rb-entry-view.c:1755: appending column: 0x9bc0ce0 (Genre)
(19:27:16) [0x9304028] [rb_entry_view_insert_column_custom] rb-entry-view.c:1755: appending column: 0x9bc0de0 (Artist)
(19:27:16) [0x9304028] [rb_entry_view_insert_column_custom] rb-entry-view.c:1755: appending column: 0x9bc0ee0 (Album)
(19:27:16) [0x9304028] [rb_entry_view_insert_column_custom] rb-entry-view.c:1755: appending column: 0x9bc6058 (Year)
(19:27:16) [0x9304028] [rb_entry_view_insert_column_custom] rb-entry-view.c:1755: appending column: 0x9bc62d8 (Time)
(19:27:16) [0x9304028] [rb_entry_view_insert_column_custom] rb-entry-view.c:1755: appending column: 0x9bc6158 (Quality...

For me the issue is slightly fixed:

The menu-less click happens during rhythmbox's scan-on-startup of my music folder. Once it is finished the menu works as normal.

Bruce Heerssen (bheerssen) wrote :

I've noticed another strange behavior that may be related to this bug. When selecting the rhythmbox indicator icon, the last used icon in the panel is highlighted. See video for an example.

Sebastien Bacher (seb128) wrote :

rhythmbox stopped using an indicator in favor of the indicator-sound mpris support

Changed in rhythmbox (Ubuntu):
status: Incomplete → Invalid
Changed in indicator-application (Ubuntu):
status: Incomplete → Invalid
Changed in indicator-application:
status: Triaged → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers