Application Indicators too wide

Reported by Fabien Tassin on 2010-02-24
682
This bug affects 152 people
Affects Status Importance Assigned to Milestone
Indicator Applet
Medium
Unassigned
Linux Mint
Undecided
Unassigned
Shiki-Colors Packaging
Unknown
Unknown
light-themes (Ubuntu)
Low
Kenneth Wimer
shiki-colors-murrine (Ubuntu)
Undecided
Unassigned

Bug Description

the Application Indicators applet is wider than the regular systray.

3 Indicators icons are slightly bigger than 4 tray icons, incl. the left part.
See the screenshot. The two highlighted boxes are ~100 pixels wide.

With more applications moving to the app indicator, it will result in less usable space in the panel, which in my case is already pretty full.

Fabien Tassin (fta) wrote :
Vish (vish) wrote :

I'm not sure this is a problem , It looks more organized and well spaced than the cramped icons on the left.
The current spacing can to be left as is .

The indicator-application guidelines mention what apps should and should not use the panel. [from this screenshot itself , the xchat needs to be in the messaging menu ] When we take into account the guidelines , it is probably less common for the apps to over load the panel and have space shortage.

However , the possibility of more apps using the app-indicator and there being no space is probably a valid scenario and probably corner case.

For these scenarios only when there is less space , we should consider reducing the space , in steps, for all the indicators *equally*. [ie , if the normal spacing is 6px on either side of the icon ; once overloaded , it is reduced to 5px for the new icon to be added ; if more apps are launched then reduced to 4px , then 3px => 2px]

Jorge O. Castro (jorge) on 2010-02-25
Changed in indicator-application:
status: New → Confirmed
LarryGrover (lgrover) wrote :

There are two problems with the wide spacing of the indicator applet. The first is aesthetic: if you have the notification area and indicator applet in the same panel, the difference in spacing is visually jarring. The second is reduced usability: if you have the window list applet and indicator applet on the same panel, the wasted space by the indicator applet causes the window list to lose icons more quickly as the number of open applications increases (see attached screenshot).

Rocko (rockorequin) wrote :

I agree that it's a issue. It didn't used to be an issue prior to ubuntu 10.04 because hardly anything used the indicator applet, so I always removed it. Now I am forced to use it if (eg) I want the bluetooth indicator.

The indicator applet is using a standard menu with icons representing the menu headers. The number of pixels allocated for the header width is a fair bit wider than that allocated for the icon width and hence a fair bit wider than required.

I think it would be a useful enhancement if the user could configure the number of pixels allocated for header width, even if only via a setting in gconf-editor.

Oded Arbel (oded-geek) wrote :

I also have this problem - with the current Lucid alpha, I have 5 icons in the indicator applet (see screenshot: volume, bluetooth, battery, keyboard and messaging) which take up a whopping 150px out of my 1024px wide laptop screen (almost 15% of screen width).

As I'm very short on screen real-estate with this small screen, I only have 1 panel and even without a window list in it (I exiled it to an auto-hidden dock due to lack of space) I find it hard to fit all the applets and launchers I need to be visible, without the indicator applet taking up 20% more space then it need be.

In the screnshot, compare the icon spacing between the indicator in the middle (the widest spacing), panel launchers on the left side (with medium spacing) and the notification area on the right side (with very little spacing). I think I can fit too more launchers in the panel if the indicator would use spacing similar to what launchers use. I don't think the spacing should be as small as in the notification area but there is a visual problem if different icon collections on the panel use different spacing.

Rocko (rockorequin) wrote :

In the latest version (0.3.2-0ubuntu3) it's even worse! The icons are spaced even further apart than before!

Changed in indicator-applet (Ubuntu):
importance: Undecided → Low
Jan Nekvasil (jan-nekvasil) wrote :

As the 1024x768 resolution is still used on many older laptops and it's users are often trying to save some precious screen space by reducing number of panels to one, please reconsider the current width of items in indicator-applet. In attached mock-up You can see the default state in comparison with item's width reduced to 32px. I think that's possibly can be a good compromise between the eye-pleasing padding and space-saving (for myself, I'm using 1440x900 on my laptop and still can benefit from that change.).

Vish (vish) on 2010-03-07
Changed in indicator-applet (Ubuntu):
status: New → Confirmed
Jan Nekvasil (jan-nekvasil) wrote :

This seems to be fixed now in 0.3.2-0ubuntu3. Maybe another package update brought the change.

@Jan: I don't see that fix with that version. Could you post an updated screenshot?

Jan Nekvasil (jan-nekvasil) wrote :

@Jan its fixed for Ambiance but still exists for Radiance (but I dont know
if it is by design.)

On Wed, Mar 10, 2010 at 1:42 PM, Jan Nekvasil <email address hidden>wrote:

>
> ** Attachment added: "fixed-for-me.png"
> http://launchpadlibrarian.net/40675914/fixed-for-me.png
>
> --
> Application Indicators too wide
> https://bugs.launchpad.net/bugs/527267
> You received this bug notification because you are subscribed to
> indicator-applet in ubuntu.
>
> Status in Application Indicators: Confirmed
> Status in “indicator-applet” package in Ubuntu: Confirmed
>
> Bug description:
> the Application Indicators applet is wider than the regular systray.
>
> 3 Indicators icons are slightly bigger than 4 tray icons, incl. the left
> part.
> See the screenshot. The two highlighted boxes are ~100 pixels wide.
>
> With more applications moving to the app indicator, it will result in less
> usable space in the panel, which in my case is already pretty full.
>
>
>

Oded Arbel (oded-geek) wrote :

For Ambiance the situation is much better - still wider then toolbar buttons but the fix allows me to fit two more toolbar buttons in the space that was vacated by narrowing the indicator width for 4 indicators.

I'm pretty its safe to remove 2 or 3 more padding pixels from each side of a notification icon - the widest icons (like the battery meter) has about 4 pixels padding from each side.

Sebastien Bacher (seb128) wrote :

the issue has been fixed in the default theme but not the light one, reassigning the bug

affects: indicator-applet (Ubuntu) → light-themes (Ubuntu)
Changed in light-themes (Ubuntu):
assignee: nobody → Kenneth Wimer (kwwii)
Kenneth Wimer (kwwii) on 2010-03-11
Changed in light-themes (Ubuntu):
status: Confirmed → Fix Committed
Changed in indicator-application:
status: Confirmed → Invalid
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package light-themes - 0.1.5.8

---------------
light-themes (0.1.5.8) lucid; urgency=low

  * Fixing panel spacing in Radiance (lp: #527267)
  * Fixing menuitem look in Ambiance
 -- Kenneth Wimer <email address hidden> Thu, 11 Mar 2010 12:15:31 +0000

Changed in light-themes (Ubuntu):
status: Fix Committed → Fix Released
Jack Leigh (leighman) wrote :

applets are still taking up about double the amount of space they should for me, especially if you compare the distance between them to the distance between them and the weather and time

Changed in indicator-application:
status: Invalid → New
Ted Gould (ted) wrote :

This is a theme setting so I'm marking it as invalid for application indicators. App Indicators are adding no padding of their own, only that which the theme has for menu items.

Changed in indicator-application:
status: New → Invalid
Aurélien Leblond (blablack) wrote :

I am not sure it is linked to the theme... I browsed through all the ones available in Ubuntu and still get the exact same issue (c.f. screenshot space between the sound icon and the battery one).

In addition, I set the applet up to not show the envelope for GWibber, Evolution and so on, but now instead of the envelope I have a huge gap (c.f. screenshot space between the sound icon and tomboy).

CyrusCT (cyrusct) wrote :

I am experiencing this with 10.04 beta 1 (the new themes are not as bad, but still problematic; I'm using the crux controls in my theme). This is causing menu length problems on my netbook. Could someone direct me to method for fixing this? (preferably a GUI for configuring the applet, but I'll take what I can get.)

On a side note, if anyone knows how to selectively hide or configure the icons showing in applet, that would be a great help too. I used to remove the applet from my panel because I use different IM and email clients, but now that power, volume and bluetooth are there, I'm stuck with it.

Conscious User (conscioususer) wrote :

I don't think this is fixed in neither Radiance or Ambiance. In the screenshot (fully updated Lucid Beta), you can see that the two Notification Area itens (NetworkManager and Tomboy) have a noticeable smaller horizontal padding than the indicators in Ambiance. Radiance is exactly the same.

ignasi (igp-oenus) wrote :

It looks terrible one week prior to official launch. Check the image.

DukeOfContention (duke-fm) wrote :

yeh icons looks nice but gaps between them are terrible ... coz rest of icons on tray got different gaps ;/

Robert (robrwo) wrote :

Changing themes does not fix this.

Changed in shiki-colors-murrine (Ubuntu):
status: New → Incomplete

Neither Ambiance nor Radiance theme fix this for me. The issue is especially problematic with the small screen of my Eee PC.

Michal Voců (michal-vocu) wrote :

I am using the Human theme and the spacing there is even wider than in Ambiance or Radiance.

bergkler (andreas-berg) wrote :

I am using elementary theme and same problem. Actually I checked all themes and the problem remains. If anyone has a solution how to fix this with settings in gtkrc-2.0 would be great if he could post it. I don't like the look at all at the moment :-(

Adam Conrad (adconrad) wrote :

I hate to not be on the "this is a theme bug, fix it" bandwagon that everyone else is, but this isn't a theme bug, it's a bug in indicator-applet for overloading the gtkrc panel definitions. I've mangled my human theme to turn off all panel padding, which brings the indicator icons closer to each other, but it doesn't actually fix the bug (there's still more padding in indicator-applet than anywhere else on the panel) and has the nasty side-effect of, duh, removing all padding on the rest of the panel.

So, my clock is now shoved against the right of my screen, other panel applets and icons have zero padding between them, but the indicator-applet icons are still slightly excessively padded (though less so than before the change).

This really needs fixing in the code itself. indicator-applet, like the old skool notification area, shouldn't be using gtkrc panel padding and overloading its meaning while, seemingly, adding even more padding of its own. If we want our icons nearly touching (mobile devices, tiny screens?), we should be allowed that.

Notification Area may have offended some people due to the hideously non-standard ways in which it was used and abused, but the way it rendered icons (shove 'em in, side-by-side, let icon pack designers worry about making sure they don't space stupidly) seemed. Well. Usable.

Oloryn (oloryn) wrote :

I'll agree this needs to be fixed. See attached screengrab. I don't know the pixel count, but it looks to me like it's using 7 icons of panel space to display 4 icons. W-a-a-a-y too much padding, particularly on this 1024x768-max resolution laptop.

Changed in indicator-application:
status: Invalid → Incomplete
status: Incomplete → New
emghazal (emghazal) wrote :

It affects me using 'Clearlooks' theme. I really don't care that the icons with more spacing are 'more organized', all I see is inconsistency with Notification Area. Either decrease spacing in indicator-applet or increase spacing in Notification Area. Or better yet, give users the option to choose the spacing they want.

I'd suggest to add a configuration setting for defining the distance between each indcator... Also, the "systray" should keep the same distance.

after poking around in the indicator-applet sources i suppose i've found the issue..

before/after comparison of icon spacing: http://i43.tinypic.com/11cfo6g.png

diff against indicator-applet-0.3.7 is attached

Felipe Morales (hel-sheep) wrote :

I confirm Andreas patch works. Please include it in next release.

quaker (quaker) wrote :

I also confirm, that patch works.

I hate this bug. I'm using version 0.3.7

Ted Gould (ted) wrote :

This is a theme issue, so I'm marking it as invalid for the indicator-application project.

Changed in indicator-application:
status: New → Invalid

Ted, could you please explain why this is a theme issue and not a problem for indicator-application project? This report includes a patch against indicator-applet that a few people have said resolves the issue. Could you point to a theme that doesn't have this issue as an example for how other themes could fix this?

This is not a theme issue, please fix it in the indicator-application.
The patch works for me, too.

emghazal (emghazal) wrote :

+1 for the patch, it works for me as well.
Ted, what theme do you use? Can you show a screenshot of how it looks?

Nivelir (z32.nivelir) wrote :

Thank you Andreas for the patch. It works well!
I also hope those gigantic gaps between icons will be reduced in next version.
May be it is good idea to add menu Preferences in which user can adjust size of gaps?

tags: removed: indicator-application
tags: added: patch
Karl Martin (klein-km) wrote :

I played around a bit with some theme settings. Ted is actually right as the indicator-application uses a theme setting to generate the spacing around the icons. If you put or change the following line in the default style in your theme's gtkrc the gap between the icons in the panel should disappear (make sure that it is nor overwritten by another style later):

GtkMenuItem::horizontal-padding = 0

However, this setting also affects the menu which looks quite ugly afterwards (no spacing between menu items). To avoid this you can put the following line in the style which is assigned to GtkMenuItem:

xthickness = 5

I think this value should be increased by the same amount as horizontal-padding was reduced.

Ok, this is fine, but why not setting the default value for the indicator horizontal padding to a more reasonable value directly in its sources instead of waiting that every available theme would adapt to it (and we all know that we can't wai that)... So I think that by default the indicator should use a correct padding also if the used gtkrc is not considering it, then if you want to change (increase) it, edit your gtkrc file! This should be the way, not the current one.

Changed in linuxmint:
status: New → Triaged
Changed in indicator-application:
status: Invalid → New
status: New → Invalid
hackel (hackel) on 2010-10-12
Changed in indicator-application:
status: Invalid → Opinion
28 comments hidden view all 108 comments
cablop (cablop) wrote :

It is not a Theme Issue, for the sake of heaven!
Themes had it's own standards BEFORE you started to use this applet, now you are telling they that they have to rewrite the whole themes with all the side effects of that, that is spacing between menus and other theme sections, just cause you are tooooo lazy to fix your own code and adapt to an ALREADY EXISTING design pattern?
At least give us a place to select by ourselves how to space those things, people, we users of netbooks can't just survive seeing how when you add icons your menus or clock or other elements dissapear just cause one applet is tooooo wide... you can't also expect for us to tweak the whole interface with too many effects aside, like misplacing menu entries and other items just to fix an issue in one AND JUST ONE item in our screens...

sorry for being mad, but i think if you do something new you will be mature enough to accept the responsibility of doing things well for everyone...

and this is not mac... so i think it is not a high priority to look like mac if the community users are not pleasan with it

also it is a usability issue... i can't access the help icon or the clock due to this error, so priority is higher than low...

cablop (cablop) wrote :

how can i use this fix on Maverick? is the ppa Lucid only?

Changed in indicator-application:
status: Opinion → Confirmed
cablop (cablop) wrote :

A note in why it is not a theme issue and an applet indicator one

the variable used to fix it on themes is:

GtkMenuItem::horizontal-padding

Why are you using a variable for MENU ITEMS to space ICONS?
it is not called applet indicator icon padding or anything like that...

so the bug is using the value intended and designed for a different kind of visual element in screen to space or pad icons in a different context

cablop (cablop) wrote :

As a workaround you can remove this applet indicator and almost all icons from it are able to stand up by themselves in the old tray, except for the envelope one and the volume indicator. But you can grab the pulseaudio-mixer-applet to replace the volume icon.
http://www.webupd8.org/2010/04/pulseaudio-mixer-applet-lets-you-change.html
So you can get all your space back and still see batery, network, and so on...

It is ironic that they stated the new design is to save more space, but once removed and went back to the old behavior i have MORE space than with the new applet... meaning the purpose failed to be accomplished at least for some users like me, using Ubuntu on a netbook.

Martin Spacek (mspacek) wrote :

@cablop, yes, it looks like m0sia only has the patched indicator-applet compiled for lucid, but not maverick, which I'd love to see.

By the way, even as more stuff seems to be migrating to indicator-applet, both this spacing bug and the inability to customize its contents is, and always has been, enough to make me give it the axe. I have no need for the volume icon. I only lament that now libnotify-mozilla won't leave a visible indicator in the system tray when I have new mail in Thunderbird. Windows XP is a more advanced operating system in this respect. Zing! See Bug #1.

I'd like to remind those interested to sign Ivan Fomichev's petition to the SABDFL at http://www.petitiononline.com/buntubug/petition.html

tags: added: ui
m0sia (m0sia) wrote :

I made the same patch for maverick version of indicator applet.
Please check my PPA at https://launchpad.net/~m0sia/+archive/ppa.

Martin Spacek (mspacek) wrote :

Thanks m0sia! There is indeed still a fair bit of wasted space around each icon, but it's much better than before. (I'm using the Ambiance theme with Human controls and Humanity icons.) I suppose that's the best that can be done with a menu widget in gtk. Perhaps a custom widget really should be written up for this kind of a use case. But until then, can anyone offer up a good reason why this tiny patch still hasn't been accepted?

Also, I discovered that the volume icon can indeed be removed without having to ditch the whole indicator-applet. You can simply uninstall the volume indicator:

sudo aptitude purge indicator-volume

Same can be done for the message indicator:

sudo aptitude purge indicator-messages

cablop (cablop) wrote :

well... i'm living now without this applet indicator, and added the pulseaudio indicator, everything is ok, except i had no replacement of the envelope icon (in fact i didn't liked it, i found no use for it)
i saw a few other bugs solved by removing this applet, like some notifications being shown now and so on

i think we must create a new bug or question asking for people to completely rewrite this applet and using it's own settings rather than misusing settings from menu-items and related

1 comments hidden view all 108 comments
Mladen Jablanović (jablan) wrote :

You can clearly see the excessive spacing when you click on an item and open a dropdown (see the screenshot). Is there a replacement for keyboard layout switcher, in case I remove indicator applet completely?

cablop (cablop) wrote :

the keyboard layout switcher appears automatically if you remove the indicator applet, so don't worry

cablop (cablop) wrote :

everything except the useless envelope icon has an alternative

cablop (cablop) wrote :

i still insist... i don't understand why the priority is to looks like macintosh rather than make it customizable/USABLE for users?

X-Stranger (xstranger) wrote :

Thanks to m0sia for the patched package.
Why not to add patch functionality as an option to the official package?

redman (patrick-libert) wrote :

I'm really happy I found this thread, this large spacing between icons was really annoying me.

For your information, in Unity there's no this bug.

cablop (cablop) wrote :

I used m0sia pack, it works nice on my desktop, but it is still too much space for my netbook...
i left a few notes before, the unique icon i cannot restore once removing the applet-indicator was the useless envelope one xD

Turbid (turbidit) wrote :

This bug is also relevant for the beta 11.04

Martin Spacek (mspacek) on 2011-04-17
Changed in hundredpapercuts:
status: New → Confirmed
Peshko R. (peshko-us) wrote :

@Marco Trevisan #84

In 11.04 Unity does not have this problem....for those that like Unity. I don't like it and I prefer Ubuntu Classic, which is horrendous in respect of indicator-applet. I hope that m0sia would update his ppa for 11.04.

CyrusCT (cyrusct) wrote :

After extensive google-ing, and A LOT of trial and error, I FINALLY figured out how to implement the patch. Since others have requested instructions, but nobody was kind enough to post them, I WILL. That said, I'm sure that there's an easier way than then the one I am about to provide, so I welcome people to post improvements to my methodology. Well, here it is:

----------------------------------------------------------------------------------------------

----- In the terminal type -----

wget https://launchpad.net/ubuntu/+archive/primary/+files/indicator-applet_0.4.12.orig.tar.gz
tar -xzf indicator-applet_0.4.12.orig.tar.gz
cd indicator-applet-0.4.12/src
gedit applet-main.c

----- search for -----

 g_object_set_data(G_OBJECT(menuitem), MENU_DATA_INDICATOR_ENTRY, entry);
 g_object_set_data(G_OBJECT(menuitem), MENU_DATA_INDICATOR_OBJECT, io);

 return;
}

----- and replace it with -----

 g_object_set_data(G_OBJECT(menuitem), MENU_DATA_INDICATOR_ENTRY, entry);
 g_object_set_data(G_OBJECT(menuitem), MENU_DATA_INDICATOR_OBJECT, io);

 gtk_widget_set_name(GTK_WIDGET (menuitem), "fast-user-switch-menuitem");

 return;
}

----- then search for -----

        " GtkWidget::focus-line-width = 0\n"
        " GtkWidget::focus-padding = 0\n"
        " GtkMenuItem::horizontal-padding = 0\n"
        "}\n"
        "widget \"*.fast-user-switch-applet\" style \"indicator-applet-style\""
        "widget \"*.fast-user-switch-menuitem\" style \"indicator-applet-menuitem-style\""

----- and replace it with -----

        " GtkWidget::focus-line-width = 0\n"
        " GtkWidget::focus-padding = 0\n"
        " GtkMenuItem::horizontal-padding = 1\n"
        "}\n"
        "widget \"*.fast-user-switch-applet\" style \"indicator-applet-style\""
        "widget \"*.fast-user-switch-menuitem\" style \"indicator-applet-menuitem-style\""

----- then save the file and close gedit, and enter the following commands -----

cd ..
sudo apt-get build-dep indicator-applet
sudo apt-get install devscripts
sudo ./configure
sudo make
sudo make install

CyrusCT (cyrusct) wrote :

Now that I have the patch implemented in 11.04 Natty, I find the following: Indicator Applet Application Menu is also affected by the patch:

For the Ambiance and Radiance themes, this is problematic since the patch removes the spaces between the text, drastically reducing readability.

For other themes, where the patch only represents an improvement for Indicator Applet and not a fix, the portion of the space/gap that is NOT eliminated is necessary to retain good readability for Indicator Applet Application Menu.

This demonstrates that the true nature of the bug is that Indicator Applet is using a padding/spacing/gap methodology that is inappropriate for Indicator Applet, but is appropriate for Indicator Applet Application Menu. Hopefully this will clarify the fact that the bug is NOT with the themes, but with the Indicator Applet, and maybe if we're lucky, the bug will finally get assigned to somebody who is developing Indicator Applet.

Now if I can just manage to use one or less items in Notification Area, I will have something I can live with in the meantime.

____________________
Currently running: Ubuntu 11.04 Natty on Dell Inspiron 1420n, Franken-HP media center, Samsung Q1 UMPC.
http://cyrusct.tk/linux.shtml http://cyrusct.tk/ubuntu.shtml

cablop (cablop) wrote :

Yes, it is a design flaw, why they use a menu for an applet indicator? It just makes no sense at all... hopefully they solve the issue... there's also a chance for them to let this issue fade into Obivlion now they're pushing us with Unity

redman (patrick-libert) wrote :

m0sia

Are you willing to make a ppa for ubuntu 11.04 ubuntu classic?

Thanks

eros2 (eros2) wrote :

Found good workagound - crate ~/.gtkrc-2.0 file with content:

----------- cut here -----------
style "mythin"
{
 xthickness = 0
 GtkMenuItem::horizontal-padding = 2
}

widget "*fast-user-switch*" style "mythin"
----------- cut here -----------

You may play with numbers to achieve acceptable result.

Igal Koshevoy (igalko) wrote :

eros2 #92: Thank you, your workaround was just what I was looking for to set the padding between icons in the indicator applet to something reasonable.

Calendros (calendros) wrote :

On 06/13/2011 08:58 PM, eros2 wrote:
> Found good workagound - crate ~/.gtkrc-2.0 file with content:
>
> ----------- cut here -----------
> style "mythin"
> {
> xthickness = 0
> GtkMenuItem::horizontal-padding = 2
> }
>
> widget "*fast-user-switch*" style "mythin"
> ----------- cut here -----------
>
> You may play with numbers to achieve acceptable result.
>
Yes, It works really well for me. Thank you a lot, it is exactly what I
needed since a long time ago.

Thank you.

Martin Spacek (mspacek) wrote :

Thanks eros2! # 92 works perfectly for me in natty. I'm using the Ambiance theme with Human controls and Humanity icons. In this setup, indicator icons were taking up about twice the space before applying this fix.

It's a wonder a Canonical employee couldn't have posted such a fix say a year ago...

MBybee (mike-bybee) wrote :

#92 worked perfectly for me on Natty with Gnome Classic and the Ubuntu Studio theme.

Thanks!!

aleandro (aleandrodasilva) wrote :

Hi, this an awful bug.

 I tried to use the method of CyrusCT without results although the compilation was ok.

The method of eros2 does function by me. You can play with numbers as posted. Pay attention that you have to remove the applet and to set it again in order to see the results by having changed "the numbers". A very good workaround!!!

Thanks eros2, it was really bad to waste so much space.

aleandro (aleandrodasilva) wrote :

Hi again,

 related to this bug I noticed that the applet gets always the gray color. This is mostly unreadable with that color if the background of the systray is too bright or light.

Any way to change the indicator applet color with a similar simple workaround?

Bye

Paul Sladen (sladen) wrote :

aleandro: not easily. Currently they come from the SVG icons in the 'ubuntu-mono' package. These are (currently) hard-coded in the SVG files to match the text colour in the Ambiance/Radiance theme.

3 comments hidden view all 108 comments
Steve (steve-launchpad) wrote :

Still a problem for me in 11.04 Ubuntu Classic. Please fix it!

Ted Gould (ted) on 2011-09-20
affects: indicator-application → indicator-applet
Changed in indicator-applet:
importance: Undecided → Medium
eros2 (eros2) wrote :

Same problem in Precise Pangolin...

sokolov (daniel-sokolov) wrote :

The spacing is way too wide, especially on small screens. I have to fret with 800x600 because there are no drivers for Intel GMA 3600 yet. And even when there is, I'll be constrained to 1024 px. The spacing should be adjustable (as should be the number of icons shown, but that is a different story).

Frustrating. Perhaps the way forward is to figure out the appropriate CSS selector and have that added to the GTK 3.0 themes which ship with Ubuntu.

no longer affects: hundredpapercuts
1 comments hidden view all 108 comments
ralphl (lachenmaier) wrote :

I am looking for a fix to this problem (wide spacing of icons in Indicator-applet) for Ubuntu 12.04 Precise Pangolin LTS. Does anybody have one?

Displaying first 40 and last 40 comments. View all 108 comments or add a comment.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions

Remote bug watches

Bug watches keep track of this bug in other bug trackers.