get-bytevector-some missing from (library (ikarus))

Bug #184959 reported by Derick Eddington on 2008-01-22
2
Affects Status Importance Assigned to Milestone
Ikarus Scheme
Low
Abdulaziz Ghuloum

Bug Description

makefile.ss doesn't put it in 'i

Abdulaziz Ghuloum (aghuloum) wrote :

It's actually not implemented yet (calling it just signals an error). I'll add it soon. Thanks.

Changed in ikarus:
assignee: nobody → aghuloum
importance: Undecided → Low
status: New → Confirmed

On Tue, 2008-01-22 at 00:51 +0000, Abdulaziz Ghuloum wrote:
> It's actually not implemented yet (calling it just signals an error).
> I'll add it soon. Thanks.

Ah, right. My R6RS bindings checker thought it was implemented because
it doesn't do the raise "primitive not supported yet" when attempting to
reference the binding. I don't currently need the procedure.

--
: Derick
----------------------------------------------------------------

On Jan 21, 2008, at 9:13 PM, Derick Eddington wrote:

> My R6RS bindings checker thought it was implemented because
> it doesn't do the raise "primitive not supported yet" when
> attempting to
> reference the binding.

I figured that's what was happening. Are there any other
inconsistencies that your tool may discover?

> I don't currently need the procedure.

I'll add it anyways since all of its siblings are there already.

Thanks.

On Tue, 2008-01-22 at 02:53 +0000, Abdulaziz Ghuloum wrote:
> Are there any other
> inconsistencies that your tool may discover?

`real-part' and `imag-part' have implementations accessible from (rnrs)
but are not in (ikarus)

It looks like all the other implemented R6RS bindings are in (ikarus)

--
: Derick
----------------------------------------------------------------

Abdulaziz Ghuloum (aghuloum) wrote :

Added in revision 1363. Thanks.

Changed in ikarus:
status: Confirmed → Fix Committed
Abdulaziz Ghuloum (aghuloum) wrote :

This bug report is about to be closed as the fix comitted
previously will be incorporated in the next 0.0.3 release of
Ikarus Scheme, scheduled for January 31, 2008. A release
candidate tarball is available for download from:
http://www.cs.indiana.edu/~aghuloum/ikarus/ikarus-0.0.3-rc1.tar.gz
Please do test it if you have the time and report any issues
you might encounter. Thank you very much for your support.
(Sorry for the duplicates; I'm updating every open bug.)

Changed in ikarus:
milestone: none → 0.0.3
Changed in ikarus:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers