ERROR #27 on start (Debian Sid amd64)

Bug #1258468 reported by Ustilago on 2013-12-06
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
I-Nex
Undecided
Unassigned

Bug Description

Hi,

I installed I-Nex from the downloadable i-nex_0.5.6_amd64.deb and installed it on my Debian Sid, and I have this error when starting it :
i-nex

** Oops! Internal error! **
** Cannot find interface of library 'gb.geom'
ERROR: #27: Cannot load component 'gb.geom': cannot find component
** Program aborting. Sorry! :-(
** Please send a bug report at <email address hidden>

Here are my gambas libraries, installed when installing I-Nex :

dpkg -l |grep gambas
ii gambas3-gb-desktop 3.5.1-1 amd64 Gambas Portland project compatibility component
ii gambas3-gb-form 3.5.1-1 all Gambas native form component
ii gambas3-gb-form-stock 3.5.1-1 all Gambas form stock icons
ii gambas3-gb-gtk 3.5.1-1 amd64 Gambas GTK+ component
ii gambas3-gb-gui 3.5.1-1 amd64 Gambas graphical toolkit selector
ii gambas3-gb-image 3.5.1-1 amd64 Gambas image effects
ii gambas3-gb-qt4 3.5.1-1 amd64 Gambas Qt GUI component
ii gambas3-gb-settings 3.5.1-1 all Gambas utilities class
ii gambas3-runtime 3.5.1-1 amd64 Gambas runtime interpreter

Regards,

Sébastien KALT

eloaders (eloaders) wrote :

Paste command which returns

ls /usr/lib/gambas3/ | grep geom

Package gambas3-runtime have gb.geom lib.
Please reinstall gambas3-runtime package.

This is not a bug in I-Nex. This is gambas3 bug. Because I-Nex in control file have dependency gambas3-runtime, maybe gambas3-runtime not have a gb.geom library?

Changed in i-nex:
status: New → Incomplete
Download full text (4.4 KiB)

2013/12/6 Michał Głowienka aka (eloaders) <email address hidden>

> Paste command which returns
>
> ls /usr/lib/gambas3/ | grep geom
>
 It returns nothing.

> Package gambas3-runtime have gb.geom lib.
>
 apt-file search gb.geom => nothing
 apt-file search geom |grep gambas => nothing

Please reinstall gambas3-runtime package.
>
Doesn't change anything.

> This is not a bug in I-Nex. This is gambas3 bug. Because I-Nex in
> control file have dependency gambas3-runtime, maybe gambas3-runtime not
> have a gb.geom library?
>
Here are the possible gambas 3 packages for Debian Sid :

$ apt-cache search gambas
gambas3-examples - Gambas examples
gambas3-gb-cairo - Gambas bindings for cairo
gambas3-gb-dbus - Gambas bindings for DBUS
gambas3-gb-eval-highlight - Gambas syntax highlighting component
gambas3-gb-form - Gambas native form component
gambas3-gb-form-dialog - Gambas native mdi form component
gambas3-gb-form-mdi - Gambas native mdi form component
gambas3-gb-form-stock - Gambas form stock icons
gambas3-gb-mysql - Gambas MySQL component
gambas3-gb-option - Gambas option component
gambas3-gb-pcre - Gambas regexp component
gambas3-gb-pdf - Gambas pdf component
gambas3-gb-qt4 - Gambas Qt GUI component
gambas3-gb-signal - Gambas OS signal library
gambas3-gb-v4l - Gambas video for Linux component
gambas3-ide - Visual development environment for the Gambas programming
language
gambas3-runtime - Gambas runtime interpreter
gambas3-script - Gambas scripter
gambas3 - Complete visual development environment for Gambas
gambas3-dev - Gambas compilation tools
gambas3-gb-args - Gambas arguments parser
gambas3-gb-chart - Gambas charting component
gambas3-gb-clipper - Gambas Clipper component
gambas3-gb-complex - Gambas Complex component
gambas3-gb-compress - Gambas compression component
gambas3-gb-compress-bzlib2 - Gambas bzlib2 component
gambas3-gb-compress-zlib - Gambas zlib compression component
gambas3-gb-crypt - Gambas crypt encription component
gambas3-gb-data - Gambas abstract datatypes component
gambas3-gb-db - Gambas database access common libraries
gambas3-gb-db-form - Gambas database bound controls
gambas3-gb-db-mysql - MySQL driver for the Gambas database
gambas3-gb-db-odbc - ODBC driver for the Gambas database
gambas3-gb-db-postgresql - PostgreSQL driver for the Gambas database
gambas3-gb-db-sqlite2 - Gambas sqlite2 driver database
gambas3-gb-db-sqlite3 - Gambas sqlite3 driver database
gambas3-gb-desktop - Gambas Portland project compatibility component
gambas3-gb-gmp - Gambas GMP component
gambas3-gb-gsl - Gambas GNU Scientific Library component
gambas3-gb-gtk - Gambas GTK+ component
gambas3-gb-gtk-opengl - Gambas GTK+ OpenGL component
gambas3-gb-gui - Gambas graphical toolkit selector
gambas3-gb-gui-opengl - Gambas OpenGL selector
gambas3-gb-httpd - Gambas HTTP server
gambas3-gb-image - Gambas image effects
gambas3-gb-image-effect - Gambas image effects: effects
gambas3-gb-image-imlib - Gambas image effects: IMLIB bindings
gambas3-gb-image-io - Gambas image effects: I/O
gambas3-gb-jit - Gambas Just-In-Time compiler component
gambas3-gb-libxml - Gambas libxml component
gambas3-gb-map - Gambas online map viewer
gambas3-gb-memcached - Gambas memcached...

Read more...

eloaders (eloaders) wrote :

This is Debian Package Maintainer Bug.
Becouse gambas3-runtime must be have in package

gb.geom.so
gb.geom.so.0
gb.geom.so.0.0.0

In /usr/lib/gambas3/

the only solution is to install gambas3-runtime from ubuntu repository.
With branch distribution saucy or trusty.

Or install I-Nex.run

First solution:

https://launchpad.net/~nemh/+archive/gambas3/+files/gambas3-runtime_3.5.1-0saucy1_amd64.deb

Or download I-Nex.run current from:

This is 0.5.8 version
https://dl.dropboxusercontent.com/u/6746738/i-nex.tar.xz

Changed in i-nex:
status: Incomplete → Confirmed
Shirish Agarwal (shirishag75) wrote :

This might have been an issue in debian before but should not be any longer.

$ dpkg -l gambas3-runtime
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Name Version Architecture Description
+++-==============================-====================-====================-=================================================================
ii gambas3-runtime 3.5.2-2 amd64 Gambas runtime interpreter

$ ls /usr/lib/gambas3/gb.geom.so
gb.geom.so gb.geom.so.0 gb.geom.so.0.0.0

$ dpkg -L gambas3-runtime | grep gb.geom
/usr/lib/gambas3/gb.geom.so.0.0.0
/usr/lib/gambas3/gb.geom.so.0
/usr/lib/gambas3/gb.geom.so

Ustilago (ustilago) wrote :

Hi,

I confirm, whith Debian Sid's gambas3-runtime 3.5.4-2+b1 i-nex is working perfectly.

Sébastien

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers