Uninstalling Evolution through USC does not remove evolution-common

Bug #689523 reported by Zachary Dunn on 2010-12-13
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Evolution
Invalid
Undecided
Unassigned
One Hundred Papercuts
Undecided
Unassigned
evolution (Ubuntu)
Undecided
Unassigned
software-center (Ubuntu)
Undecided
Unassigned

Bug Description

If removing Evolution from the Ubuntu Software Center, the package evolution-common is not removed. This causes two known bugs:

- The "Email Settings" entry in the system preferences menu is not removed. https://bugs.launchpad.net/ubuntu/+source/apt/+bug/646609

- Evolution is not removed from the Applications > Office sub-menu.
https://bugs.launchpad.net/ubuntu/+source/evolution/+bug/465681

For users who remove Evolution through the software center, they are left with two dead menu entries.

Thanks a lot for reporting this, however a papercut is a problem with a package distributed in the default installation of Ubuntu. This bug is not a valid papercut because it involves the removal of default components of Ubuntu, when a papercut should be a problem in the actual use of those components. I have forwarded this to both the Evolution in Ubuntu project and the upstream Evolution project.

Changed in hundredpapercuts:
status: New → Invalid

Forgive me as I am not a developer and do not have knowledge in this area, but wouldn't this be an Ubuntu Software Center bug and not an Evolution bug? If you uninstall evolution-common through synaptic then the menu entries are removed as expected.

Yes, you're right. My mistake :P

Changed in evolution:
status: New → Invalid
Changed in evolution (Ubuntu):
status: New → Invalid

But its still not a valid papercut because it involves removing a default component? At the rates that people are switching to cloud based email I would think that this might be a fairly common occurrence.

You're right, many people will probably remove it when they install Ubuntu, however a papercut since it is not a usability flaw that negatively impacts the user epxerience, it still does not count as a papercut. Many, if not most users, will not even notice evolution-common being left on their system either because they don't bother to check or they are completely unaware of the fact that this can even happen - to them, an application is a single 'thing', and once it's removed via the Software Centre, it's gone.

I personally hate applications that can't clean up after themselves, and I hate Evolution in particular for the mess it makes of my system, but at the end of the day, the 'average user', which is the user the papercut project was create to help, will not be aware of this stuff going on 'under the hood'. If evolution-common was causing some problem that was felt at the higher levels of the OS, such as a certain application or filetype taking longer to open for instance, then that would be a papercut, but evolution-common itself being left behind is not.

A papercut has a very strict definition, and if you're interested in minutia of this definition, check out the Hundred Papercuts wikipage https://wiki.ubuntu.com/PaperCut

The usability problem is not the fact that an unused package is left on your computer taking up space, it is the fact that two dead menu entries are created.

Imagine an "average user" browsing through the software center sees Evolution and thinks "Hey, I use Gmail and never use that program. Ill uninstall it." Later they are finding a program in their 'Office' applications and see Evolution listed. This creates confusion. An average user might think to themselves, "why is that still there? Maybe I have to delete items manually?" There is also an item left in the system preferences menu titled "Email settings" which is specific to Evolution. Clicking either of these brings up the error message:

Could not launch 'Evolution'
Failed to execute child process "evolution" (No such file or directory)

The point is that this bug creates confusion and unnecessarily cluttered menus. I am no expert but it seems that it should be relatively easy to fix. Uninstalling evolution-common removes both the dead menu items, so the fix would be adding evolution-common to the list of packages removed when you uninstall Evolution from the software center.

Ah, now I understand your point. OK, I'll concede this is a papercut :)

Changed in hundredpapercuts:
status: Invalid → Confirmed
Changed in software-center (Ubuntu):
status: New → Confirmed

Since the two bugs highlighted in the initial report have a common cause, namely the non-removal of evolution-common by the Software Centre, I have marked those two bugs as duplicates of this one, thus consolidating the effort to fix the problem.

Okay great. Sorry to press the issue, but this bug has been annoying me for a long time. Everytime I do a clean install of Ubuntu and remove Evolution, I have been reminded of this.

Sebastien Bacher (seb128) wrote :

the bug is a duplicate, there has some open evolution bugs about the fact that the menu entry should be in the same binary than the commands, software-center could still be smarter about uninstalling common or data binaries though

Vish (vish) wrote :

Does it happen with any other app , other than Evolution?
If it's only with Evolution, Chris' comment #1 is good

Changed in hundredpapercuts:
status: Confirmed → Incomplete

Vish - Im not sure how to answer your question. This bug is about the specific case of two dead menu entries being created when Evolution is removed from the Software Center.

Thinking back now, I don't think this is a paper cut as the average user is unlikely to even uninstall Evolution if they don't need it. If they use webmail, then they're probably just going to make a b-line for Firefox without any consideration for Evolution. Computer maintenance isn't a concept the average user will likely grasp, and from experience (with my mums Windows XP computer) uninstalling unneeded packages probably isn't going to be a priority, if it even gets carried out at all.

Bug, yes. paper cut, no.

Changed in hundredpapercuts:
status: Incomplete → Invalid
Javier Moreno (elpasmo) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. This particular bug has already been reported and is a duplicate of bug 553733, so it is being marked as such. Please look at the other bug report to see if there is any missing information that you can provide. Additionally, any further discussion regarding the bug should occur in the other report. Feel free to continue to report any other bugs you may find.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers