~/Examples folder is full of crusty content with terrible filenames

Bug #531400 reported by David Siegel on 2010-03-03
86
This bug affects 15 people
Affects Status Importance Assigned to Milestone
One Hundred Papercuts
Low
Canonical User Experience and Design team
example-content (Ubuntu)
Wishlist
Canonical User Experience and Design team

Bug Description

[~]% ls /usr/share/example-content
logos/
Ubuntu_Free_Culture_Showcase/
Welcome_to_Ubuntu.odt
Aesop's_Fables,_Volume_1_(Fable_1)_-_The_Fox_and_The_Grapes.spx
Maxwell's_equations.odt
Derivatives_of_Ubuntu.doc
Payment_schedule.ods
Trigonometric_functions.xls
About_Ubuntu_[Russian].rtf
Presenting_Ubuntu.odp
Presenting_Kubuntu.odp
Kubuntu_leaflet.jpg
About_these_files.odt

  * Why are underscores used instead of spaces?
  * How old are these files? Are they out of date?
  * Are they interesting to anyone?
  * Are they examples of the best things people can create with Ubuntu?
  * Why are Ubuntu users being presented with stuff about Kubuntu (and vice versa)?

I would suggest including fewer but more interesting files.

summary: - ~/Examples folder is full of crusty, old content with terrible filenames
+ ~/Examples folder is full of crusty content with terrible filenames
description: updated
description: updated
Vish (vish) on 2010-03-09
Changed in example-content (Ubuntu):
importance: Undecided → Wishlist
status: New → Confirmed
Changed in hundredpapercuts:
importance: Undecided → Low
status: New → Confirmed
Dylan McCall (dylanmccall) wrote :

Should we file the "terrible filenames" part as a separate bug report? It strikes me as very odd. We have amazing support for all sorts of characters in file names, and it's fun to point it out. Spaces are not a problem! "Maxwell's_equations.odt" has a considerably riskier character: a single quote ;)

On another note, I think the use of final products that open in viewers really misses potential value of the Examples folder. Someone may look at it and think "hey, cool pictures!" but they aren't going to walk away feeling that they can do more with Ubuntu. At best they'll be mystified, wondering how the products they saw were created but nowhere closer to making them for themselves.

Instead of a bunch of .jpg files, how about a .xcf file? That way it opens in GIMP and the user is granted an immediate hands on view of what that application does, as well as how it works with a finished product. More inviting, and possibly more educational, than the usual blank canvas.

Jorge Castro (jorge) wrote :

We removed the .xcf because GIMP isn't on the CD. The terrible filenames and overall suckiness of example-content is on my radar and we'll be discussing how to make this nicer for people at UDS.

Changed in example-content (Ubuntu):
assignee: nobody → Jorge O. Castro (jorge)
Sense Egbert Hofstede (sense) wrote :

To illustrate the crustiness: the example spreadsheet seemed to use Dutch Guilders in a nl_NL environment. The Netherlands switched to the Euro in 2002, before Ubuntu was even started.

Vish (vish) on 2010-06-10
Changed in hundredpapercuts:
milestone: none → maverick-round-10-potpourri
status: Confirmed → Triaged
Vish (vish) on 2010-06-17
Changed in hundredpapercuts:
milestone: maverick-round-10-potpourri → maverick-round-8-potpourri
Andrew (and471) on 2010-07-06
Changed in hundredpapercuts:
assignee: nobody → Canonical User Experience and Design team (canonical-ux)
Changed in example-content (Ubuntu):
assignee: Jorge O. Castro (jorge) → nobody
assignee: nobody → Canonical User Experience and Design team (canonical-ux)
Vish (vish) wrote :

The names have been improved now, in maverick:
 * Josh Woodward - Swansong.ogg
 * How fast.ogg

Closing bug as fixed.

Changed in example-content (Ubuntu):
status: Confirmed → Fix Released
Changed in hundredpapercuts:
status: Triaged → Fix Released
Dylan McCall (dylanmccall) wrote :

Looks like Examples has been completely purged _except_ for the free culture showcase. Is that correct?

In that case, it's pretty unnecessary to have the Free Culture Showcase itself buried inside the otherwise empty Examples folder. In addition, I'm not sure if I would consider this completely fixed yet because there is still one offender: the actual folder titled "Ubuntu_Free_Culture_Showcase." It looks really ugly and foreboding for something so cool :)

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers