Installer's "Install them side by side" option is vague and confusing

Bug #400047 reported by Phylum on 2009-07-16

This bug report will be marked for expiration in 29 days if no further activity occurs. (find out why)

30
This bug affects 4 people
Affects Status Importance Assigned to Milestone
One Hundred Papercuts
Medium
Unassigned
ubiquity (Ubuntu)
Low
Unassigned
Nominated for Karmic by Vish

Bug Description

Right now, Ubuntu's Partitioner allows you do to these things
1. Install them (who?/what?) side by side (huh?), choosing between them (who?/what?) each start up.
2. Use Entire disk (explain)
3. Specify partitions manually - Advanced (OK)

The current Ubuntu Installer Partitioner should explain more clearly on what the the Installer is about to do when clicking "forward". Mandriva's drakInstall and Fedora's Anaconda currently wins over Ubuntu's Installer about clear explanation.

====
Screenshots:
http://tldp.org/HOWTO/html_single/Partition-Mass-Storage-Dummies-Linux-HOWTO/images/capture20.jpg
http://cache.gawker.com/assets/images/lifehacker/2008/09/fedora_install.jpg
====

Ubuntu's Partitioner should be explained similarly to the following
1. Resize existing operating system partition to make space for Ubuntu's Install. Leave current OS untouched.
2. Format existing operating system and install Ubuntu over current OS.
3. Advanced partitioner for experienced user.

Well, or at least similar to Mandriva's or Fedora's Partitioner.

This would help solve a lot of user's questions asking what the Installer is about to do and whether or not it's going to format their current OS.

Thanks

Vish (vish) wrote :

The same wording is used in the present Karmic installer too.

I agree with the OP about the *First option being unclear* . *Only the First option* needs to be re-worded .

Maybe: "Install beside the existing OS [ this allows you to choose , at each startup , which OS you want to use ] "

But the remaining 2 options are clear and simple the way they are now.

Changed in hundredpapercuts:
status: New → Confirmed

Phylum, can you please attach a screenshot of the current Ubuntu installer demonstrating what you find confusing, and offer suggestions for improvement? If you can demonstrate exactly what needs to be changed, the paper cut will be apparent.

Matthew Paul Thomas (mpt) wrote :

1. Install them (who?/what?) side by side (huh?), choosing between them (who?/what?) each start up."

That sentence in the installer is supposed to be immediately preceded by a description of the operating systems it's talking about. If it is not, please attach a screenshot. It's my impression that "side by side" is quite a common expression in English; if you think it is not, some evidence of this would be helpful.

The rest of this bug report seems to be a duplicate of bug 131084.

Changed in ubiquity (Ubuntu):
status: New → Incomplete
Changed in hundredpapercuts:
status: Confirmed → Incomplete
Vish (vish) wrote :

@mpt: After your comment I'm not sure if the wording needs to be changed...
Anyway attaching the screenshot

Vish (vish) on 2009-07-21
summary: - Partitioner should be more clear/specific
+ [Ubiquity]Partitioner can be more properly worded
Przemek K. (azrael) on 2009-07-23
tags: added: usability
Vish (vish) on 2009-08-10
Changed in hundredpapercuts:
status: Incomplete → New
Changed in ubiquity (Ubuntu):
status: Incomplete → New

Matthew, will you schedule this in Round 7 if you believe it's something we should fix?

summary: - [Ubiquity]Partitioner can be more properly worded
+ Installer's "Install them side by side" option is vague and confusing
Changed in hundredpapercuts:
assignee: nobody → Matthew Paul Thomas (mpt)
status: New → Confirmed

My suggested rewording of the options:

How would you like Ubuntu 9.10 to be installed?

  [ * ] Share space with existing installations, choosing between them when I start my computer

  [ ] Use the entire disk

  [ ] Specify partitions manually (advanced)

Evan (ev) wrote :

David,

My concern with your above suggestion is that it does not actually share the space; it divides it. I have absolutely no data to back this up, so take it with a grain of salt, but users might then be surprised when they find that Windows now has half the space it previously had and there's no way to access the Ubuntu files from Windows.

What are your thoughts on the following slight modification to your suggestion: "Install Ubuntu 9.10 alongside existing installations, choosing between them when I start my computer."

On a side note, I would really love to clean up the entire partitioning interface. This kind of bug shows that we've patched the original design along the way, adding bits of helpful information as they became available, and it looks quite sloppy. I would rather we start with that information and design a simple, but informative, interface.

Vish (vish) wrote :

@Evan Dandrea:
If you are going to clean up the installer interface, it would be great :)
We dont need to keep patching up apps.

If you start a new bug or a blueprint about it , kindly mention it here, so that this bug can be closed...

Side note:
Installers should not mention "I" , it should say "... when You start the computer" ,
or Maybe: "Install alongside the existing installation [ allows choosing between them when You start the computer ] "
or something better.

Evan, yes, I agree. The bug here is the unknown antecedent of "them" -- we should be able to ameliorate that without resigning the install experience. I tried the word "alongside" as well, but I think "share" is simpler, personified, friendly, and less archaic. How about "share the disk" instead of "share space" -- they share the disk, don't they?

mac_v, I am not sure about your suggestion. The question should use "you," but shouldn't the response be from the perspective of the respondent?

How would you like Ubuntu 9.10 to be installed?

  [*] Share the disk with existing installations, choosing between them when I start my computer

  [ ] Use the entire disk

  [ ] Specify partitions manually (advanced)

Vish (vish) wrote :

How would you like Ubuntu 9.10 to be installed?

  [*] Share the disk with existing installations, choosing between them when I start my computer

  [ ] Use the entire disk

  [ ] Specify partitions manually (advanced)

If you compare the options ,the first one sounds like the odd one out,
The latter 2 sound like commands. While the first one sounds like a response.

It needs to be consistent in all the options. either all are commands or all responses.
Installers generally use commands. My suggestion for the first one was:
 [*] Install alongside the existing OS [ allows choosing between them when You start the computer ]

Words within brackets are an explanation as with the 3rd option.

But if you want to keep it as a response, all 3 need to be changed,
 [ ] Use my entire disk
 [ ] I will specify partitions manually

The latter, as dialogues, does not right. Commands are generally used.

Phylum (metus-m) wrote :

Thankyou for sharing concern and interest in this bug.
Yes, I'd agree with "Share the disk with existing installations, choosing between them when I start my computer" rather than "Install them side by side, choosing them each start up" that would make a lot more sense and would be a lot more clear.

"Install alongside the existing OS [ allows choosing between them when You start the computer ]"
This message doesn't seem to make it clear that you are not going to erase your existing OS.

Ubuntu's Installer's descriptions had improved a lot since Hardy Heron when I accidentally erased my Windows Partition due to confusion of my options. But until today, the descriptions had improved a lot. "Share the disk with existing installations, choosing between them when I start my computer" will definitely put an end to confusing options.

Thankyou

Vish (vish) wrote :

After discussion with David Seigel, Suggested rewording of the options :

How would you like Ubuntu 9.10 to be installed?

 [*] Share the disk with existing installations, allow me to choose between them when I start the computer

 [ ] Use my entire disk.

 [ ] Use advanced partitioning...

Vish (vish) wrote :

oops, a small typo in second option... . not "my" , but rather , "the"

Vish (vish) wrote :

After discussion with David Siegel, Suggested rewording of the options :

How would you like Ubuntu 9.10 to be installed?

 [*] Share the disk with existing installations, allow me to choose between them when I start the computer

 [ ] Use the entire disk.

 [ ] Use advanced partitioning...

Vish (vish) on 2009-08-14
summary: - Installer's "Install them side by side" option is vague and confusing
+ [Ubiquity]Partitioner wording needs to be more user-friendly
Matthew Paul Thomas (mpt) wrote :

If this is to be widened to "Partitioner wording needs to be more user-friendly", then it's a duplicate of bug 131084. For now, let's just fix the "them".

"Existing installations" is a bit abstract. "This system" or "these systems" is simpler, and here the antecedent of "this" or "these" is the operating systems that are labelled in the diagram immediately above it.

So, please change the text of the first radio button to:

    Alongside this system, choosing between them each time the computer starts up

Please also internationalize the string so that it can be translated as appropriate based on the number of OSes already present. For example in English when the number of OSes already present is 2 or more:

    Alongside these systems, choosing between them each time the computer starts up

Thanks!

summary: - [Ubiquity]Partitioner wording needs to be more user-friendly
+ Installer's "Install them side by side" option is vague and confusing
Changed in hundredpapercuts:
assignee: Matthew Paul Thomas (mpt) → nobody
importance: Undecided → Medium
milestone: none → round-7
status: Confirmed → Triaged
Tim Macdonald (tsmacdonald) wrote :

"""
How would you like Ubuntu 9.10 to be installed?

 [*] Share the disk with existing installations, allow me to choose between them when I start the computer

 [ ] Use the entire disk.

 [ ] Use advanced partitioning..."""

The first response seems like it's in a different style to me--the last two are matter-of-fact, the first is more informal and conversational.

The use of "share" still makes it sound like Windows and Ubuntu would be on the same partition. Yes--they're on the same *disk*, not partition, but I think that's a distinction that beginners might not grasp.

What about:

[*] Divide the disk with the existing installations; dual-boot.

?

Sayantan Das (sayantan13) wrote :

I know this is a bug reporting area but I think this is the best place where I can place my request since you are doing some changes to the installer.

Can we have a seperate partition for /home and / automatically while installing?
Also, Can we have an option to re-use the space used by an existing Linux installation if the installer detects one? The option should be something like this

[ * ] Reuse the existing Linux space

This option is available in Fedora 11 Installer

These two options will ease out the installation procedure a lot more. The reason I am asking is that most people are all at sea when formatting or partitioning hard drives. Even, I have seen developers who are working in the Linux environment shying away from installing or partitioning.

Thanks and sorry again for placing my request at the wrong place.

John Gilmore (gnu-gilmore) wrote :

What's an "existing installation"? Do you mean an operating system? How about the almost jargon-free:

"Split the disk with the existing operating system(s), and let me choose which one to start when I turn on the computer"

Let me second sayantandas's call for an option to reinstall atop the existing Linux. Whenever there's a bug or problem in the installer, the user ends up with a half-installed Linux partition, which won't boot anyway. But when they reboot the install CD, there's no way to just install on top of that. Then there is no simple way to explain to a naive user how to recover. The easiest way appears to be to get out of the installer, run parted, delete the Linux partition(s), then restart the installer. I wouldn't want to have to explain that to my Dad...

(In such a state, the installer currently offers a "side by side" install, but it's completely unclear what will exist beside
what. Will it keep the Windows and the halfassed Linux install and make a SECOND Linux install? Which OS will it try to steal
the space from? I was way too chicken to try.)

Evan (ev) on 2009-10-18
Changed in ubiquity (Ubuntu):
importance: Undecided → Low
status: New → Confirmed

Please do not request new features on this bug report; only comment if you are discussing the subject of the bug...

Marking this as invalid in hundredpapercuts because I think larger improvements to the installer process are being considered.

Changed in hundredpapercuts:
milestone: round-7 → none
status: Triaged → Confirmed
status: Confirmed → Invalid
Ioannis Ramfos (isr81) wrote :

This is a serious issue for maverick (daily ISO 20100916), as the installer layout changed and the text does not even refer to additional operating systems.
The title just says "Allocate disk space" and the options begin with "Install them(?) side by side..." which does not make any sense.

This text should also refer to the next installation step, where the desired amount of space is determined. After all, if the layout remains this way (in two steps), there is enough room for an explanatory text.

Robert Roth (evfool) wrote :

In the Natty installer, this bug does not seem to be valid anymore, the install side by side option is entitled as "Install Ubuntu 11.04 alongside" with the description "Still on the fence? You can install Ubuntu 11.04 alongside your existing copy of Ubuntu Natty", where I guess copy of Ubuntu Natty would be replaced with the name of the other OS if I would have another, and if I was not trying to install Natty alongside Natty :) See the screenshot attached.

I agree: the new text is more clear and easy to understand.

Changed in ubiquity (Ubuntu):
status: Confirmed → Fix Released
Ioannis Ramfos (isr81) wrote :

In Natty daily 20110322.1 the partitioner text changed again and displays the option "Install Ubuntu alongside it", without any reference to what "it" means.

As the text on the other options suggests that the existing operating systems are detected, the word "it" should be replaced by the operating system name, or there should be a generic text such as "Install Ubuntu alongside existing operating systems".

Changed in ubiquity (Ubuntu):
status: Fix Released → Triaged

This release of Ubuntu is no longer receiving maintenance updates. If this is still an issue on a maintained version of Ubuntu please let us know.

Changed in ubiquity (Ubuntu):
status: Triaged → Incomplete
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers