Gnome doesn't emit any sound at logout/shutdown

Bug #391117 reported by Raffaele Carillo on 2009-06-23
This bug report is a duplicate of:  Bug #214370: Logout/Shutdown Sound Not Working. Edit Remove
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
GNOME Settings Daemon
Fix Released
Unknown
One Hundred Papercuts
Undecided
Unassigned
gnome-session
In Progress
Unknown
libcanberra
In Progress
Undecided
Unassigned

Bug Description

Gnome during logout (and during the shutdown of the PC) does not emit any sound, but the bios of the PC emits a "beep", despite the sound of logout and shutdown (included in package sound theme
 "Ubuntu-sounds") is active in the options of sound preferences (System > Preferences > Sounds).

This bug has been present for Gusty and it is confirmed by the requests for reactivation of the sound of logout by users of the forum who could not reactivate it because installing the package "esound" requires the removal of "Ubuntu-desktop" and "PulseAudio-esound - compat "in the subsequent release of Hardy.

After a little more detailed searches with Google, I discovered that the package is problematic "libcanberra", "canberra-gtk-play" and "gnome-session-canberra" who operate the sounds of login and logout, only that "gnome - canberra-session "and" canberra-gtk-play "are not present in Launchpad. Furthermore, "canberra-gtk-play" is not even in the source software Jaunty.

In Jaunty only you can solve the problem partly because the beeps remain during logout with shutdown, at least the sound of normal logout and then you hear is already a small step forward.
You only have to be terminal "sudo gedit /etc/gdm/PostSession/Default" file that you should be presented as follows:
#! / bin / sh

PATH = "/ usr/bin/X11: / usr/X11R6/bin: / opt/X11R6/bin: $ PATH: / bin: / usr / bin"
OLD_IFS = $ IFS

gdmwhich () (
   COMMAND = "$ 1"
   OUTPUT =
   IFS =:
   for dir in $ PATH
   do
     if test-x "$ dir / $ COMMAND"; then
       if test "x $ OUTPUT" = "x", then
         OUTPUT = "$ dir / $ COMMAND"
       fi
     fi
   done
   IFS = $ OLD_IFS
   echo "$ OUTPUT"
)

exit 0

Just add the last line above: /usr/bin/canberra-gtk-play - id = "desktop-logout "

I think that a "beep" of the pc is not very user-friendly, even the sounds may serve to give a good initial impression of the OS in use, mainly because the beep during shutdown is only used by the operating systems created before the year 2000.

description: updated
summary: - Gnome doesn't emit any sound at logout
+ Gnome doesn't emit any sound at logout and at shutdown
description: updated
description: updated
summary: - Gnome doesn't emit any sound at logout and at shutdown
+ Gnome doesn't emit any sound at logout/shutdown
description: updated
Changed in hundredpapercuts:
status: New → Confirmed
Changed in gnome-session:
status: New → Confirmed
Vish (vish) wrote :

 Thank you for bringing this bug to our attention.
Unfortunately a paper cut should be a small usability issue that affects many people and is quick and easy to fix. I'm afraid this bug can't be addressed as part of this project.

Your observations seem to be from older releases...
Kindly check this with Karmic hard/virtual install...

 A paper cut is a minor usability annoyance that an average user would encounter on his/her first day of using a new installation of Ubuntu 9.10.
 For further info about papercuts criteria , pls read > https://wiki.ubuntu.com/PaperCut
 Don't worry though, This bug has been marked as "incomplete" ONLY in the papercuts project.
 For resolution of the bug, kindly identify the packages affected and assign the bug to that package, otherwise the devs of the concerned package might not be notified of this problem.

Changed in hundredpapercuts:
status: Confirmed → Incomplete
description: updated

Thanks for responding. On your advice I did a more thorough search and I have updated the description of the bug, try the short alpha karmic on a virtual machine

description: updated
Vish (vish) wrote :

@Scott Ritchie:
No, This is a separate one.
In jaunty the login/logout sounds dont play that is because it shipped out with old version of libcanberra.

I upgraded to Karmik, but nothing has changed.

Changed in libcanberra:
status: New → Confirmed
Bernhard (b.a.koenig) wrote :

I think there is a missing quotation mark (") in the description of the line to be added. The following worked for me:

add to the file
/etc/gdm/PostSession/Default
the following line (inserted in line just before last line "exit 0"):

/usr/bin/canberra-gtk-play --file=/usr/share/sounds/ubuntu/stereo/desktop-logout.ogg

description: updated

Bernhard No, your modification of the file does not work, and even that does not work that I put in the description of the bug on karmic. Ideas?

Bernhard (b.a.koenig) wrote :

My suggestion works for me. Did you check

http://www.ubuntugeek.com/howto-enable-system-sound-in-ubuntu-intrepid.html

they add as line next to last:
/usr/bin/canberra-gtk-play --id=”desktop-logout”
that's why I meant there is a quotation mark missing in your description.

Bernhard (b.a.koenig) wrote :

Raffaele: you know you have to add that line BEFORE "exit 0" and not after that.

description: updated

I added the quote, but the problem persists and the text I have always added before "exit 0". The priority of this bug I think, is to understand the functioning of the beep, remove and put the sound of logout. The goal then is to understand what exactly is causing the bug (which is libcanberra but karmic is the latest version), and eradicate it, but for now, unfortunately we are not doing big steps forward ...

I have just discovered the bug on bugzilla, and I filled this bug on Lunchpad, we now have many more details in the bug on bugzilla which I think was already fixed, and any developer can understand something, ask him to implement/adapt the patch of the bug in karmic.

Changed in gnome-settings-daemon:
status: Unknown → Fix Released
Bernhard (b.a.koenig) on 2009-07-30
Changed in hundredpapercuts:
status: Incomplete → Confirmed
Changed in gnome-session:
importance: Undecided → Unknown
status: Confirmed → Unknown
Changed in gnome-session:
status: Unknown → New
Changed in gnome-session:
status: New → Confirmed

At this point the only goal that remains is to eliminate the beep. Modify the file works, and we have a lot of documentation on the bug, nothing more to do away with that beep. But you can not normally do by changing the configurations, we need somebody who (a developer) understands that the information you need on this page and external bug tracker. At this point, just to correct even the beep, enter the change of the file "/etc/gdm/PostSession/Default" with an updated to be made available for karmic and perhaps for Jaunty. Then send the patch to the Gnome team to make sure that it is officially included in Gnome 2.6.28.

The bug has been partially erased with the alpha 5 of Karmic, I put the state of progress on correction in progress, if anything I will come back confirmed. Updated the libcanberra the beep and then there are no more, now it only remains to understand how to hear the sound of logout.

Changed in hundredpapercuts:
status: Confirmed → In Progress
status: In Progress → Confirmed
Changed in gnome-session:
status: Confirmed → In Progress
Changed in libcanberra:
status: Confirmed → In Progress

The bug has finally been corrected, no more beeps, now there is the sound of logout (although when the PC is turned off quickly does not feel). I ask all developers to ensure that there are changes which affect the functionality of the sound. The beta of Ubuntu 9.10 should have the bugfix.

Changed in hundredpapercuts:
status: Confirmed → Fix Released
Changed in libcanberra:
status: In Progress → Fix Committed
status: Fix Committed → Fix Released
Jim in Chicago (jbcady) wrote :

Nope, ain't fixed. There are no beeps, but no shutdown sound either.

Changed in hundredpapercuts:
status: Fix Released → In Progress
Changed in libcanberra:
status: Fix Released → In Progress
Vish (vish) wrote :

Logout/Shutdown works on Lucid.

To test: Create a new user account. And when you logout of the new account the sound oes play.

However , the logout sound doesnt play in my old user account. Maybe something in /home is blocking this. Will report back if i find something.

Changed in hundredpapercuts:
status: In Progress → Fix Released
Vish (vish) wrote :

Further this is a dup of bug 214370

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.