In nautilus, the focus ring is not visible with the New Wave theme.

Bug #390601 reported by Wish!!! on 2009-06-22
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
New Wave
High
Dilomo
One Hundred Papercuts
Undecided
Unassigned
gnome-themes-ubuntu (Ubuntu)
Undecided
Unassigned

Bug Description

In New Wave theme:

While holding Ctrl and directing the navigation (Ctrl+directions) doesn't show the position of the selection.

In other themes the position of selection is shown by dotted rectangle around the name of the file or folder.

The position of the selection should be made known either by using another colour or by using the same rectangle of dots.

For the screen shots, visit the link:
http://buginnewwave.blogspot.com/

It will make it clear.

Related branches

Lightbreeze (nedhoy-gmail) wrote :

Could you post a screenshot, thanks :)

Ok, I will ...
--- On Mon, 22/6/09, Lightbreeze <email address hidden> wrote:

From: Lightbreeze <email address hidden>
Subject: [Bug 390601] Re: Ctrl+(direction buttons) doesn't show the position of selection in New Wave theme.
To: <email address hidden>
Date: Monday, 22 June, 2009, 4:02 PM

Could you post a screenshot, thanks :)

--
Ctrl+(direction buttons) doesn't show the position of selection in New Wave theme.
https://bugs.launchpad.net/bugs/390601
You received this bug notification because you are a direct subscriber
of the bug.

Status in One Hundred Paper Cuts: New

Bug description:
In New Wave theme:

While holding Ctrl and directing the navigation (Ctrl+directions) doesn't show the position of the selection.

In other themes the position of selection is shown by dotted rectangle around the name of the file or folder.

The position of the selection should be made known either by using another colour or by using the same rectangle of dots.

      ICC World Twenty20 England &#39;09 exclusively on YAHOO! CRICKET http://cricket.yahoo.com

Wish!!! (wishabhilash) wrote :

The screen shots have been posted. Just follow the link.

--- On Mon, 22/6/09, Lightbreeze <email address hidden> wrote:

From: Lightbreeze <email address hidden>
Subject: [Bug 390601] Re: Ctrl+(direction buttons) doesn't show the position of selection in New Wave theme.
To: <email address hidden>
Date: Monday, 22 June, 2009, 4:02 PM

Could you post a screenshot, thanks :)

--
Ctrl+(direction buttons) doesn't show the position of selection in New Wave theme.
https://bugs.launchpad.net/bugs/390601
You received this bug notification because you are a direct subscriber
of the bug.

Status in One Hundred Paper Cuts: New

Bug description:
In New Wave theme:

While holding Ctrl and directing the navigation (Ctrl+directions) doesn't show the position of the selection.

In other themes the position of selection is shown by dotted rectangle around the name of the file or folder.

The position of the selection should be made known either by using another colour or by using the same rectangle of dots.

      ICC World Twenty20 England &#39;09 exclusively on YAHOO! CRICKET http://cricket.yahoo.com

description: updated

You have customized the background color of the nautilus window to a light grey, hence you are not able to see the difference.
That is not a bug nor a papercut..

A paper cut is a minor usability annoyance that an average user would encounter on his/her first day of using a new installation of Ubuntu 9.10.

For further info about papercuts criteria , pls read > https://wiki.ubuntu.com/PaperCut

Don't worry though, This bug has been marked as "invalid" ONLY in the papercuts project.

Changed in hundredpapercuts:
status: New → Invalid
Vish (vish) wrote :

Also pls refrain from posting links to blogs.
In future ,Kindly attach screenshots here.

Changed in gnome-themes-ubuntu (Ubuntu):
status: New → Invalid
Lightbreeze (nedhoy-gmail) wrote :

I can confirm this for Jaunty (with a normal white background).

Changed in gnome-themes-ubuntu (Ubuntu):
status: Invalid → Confirmed
Vish (vish) wrote :

@Lightbreeze :
I can see a difference with a white background, the border is colored the same as the sidepane, i guess it is a design decision,
Pls check my *Jaunty* screen shot. the side pane also shows several extra dots once we hover over the border.

It is the same in Karmic too.

Kindly attach screen shot of the problem with the default background.

Lightbreeze (nedhoy-gmail) wrote :

Okay, here is a composite image. The top is New Wave and the bottom is Human. I have selected the first folder and then have used the ctrl+right-arrow shortcut to move to the '.tomboy' folder.

Kido (greasedbolt) wrote :

Another way to state this bug is that the focus ring isn't visible. Maybe it's because of a line similar to this in the gtkrc:

GtkWidget::focus-line-width = 0

Change this value to 1 for dotted lines. Alternatively, the theme could set an image for the focus ring:

engine "pixmap"{
 image
 {
  function = FOCUS
  recolorable = TRUE
  file = "focus.png"
  border = {5,5,5,5}
  stretch = TRUE
  }
}

Vish (vish) wrote :

Ok, I earlier misunderstood the problem for something totally different.
The last two comments are clear. Since New wave is in default install , this is a papercut.

@Wish!!!: In future, Kindly provide all details *only* here, and not on external links.

Changed in hundredpapercuts:
status: Invalid → Confirmed
Dilomo (ankere) wrote :

Hi guys, I come to see this bug just today. Unfortunately I don't have a Ubuntu near me (summer break) and won't be able to fix this till late September. I would just appreciate if somebody can tell me the match for that icon view widget. I have made the focus for the treeviews but I have missed this. I would like to ask if the new list view uses the icon view or has to be themed separately?

Lionel Dricot (ploum) wrote :

The bug in itself is perfectly valid but I strongly believe it doesn't qualify for a papercut because it's not the default theme. As far as I understand the papercut project, it is for bug that affect the default desktop. Changing the theme doesn't qualify.

Changed in hundredpapercuts:
status: Confirmed → Invalid
summary: - Ctrl+(direction buttons) doesn't show the position of selection in New
- Wave theme.
+ In nautilus, the focus ring is not visible with the New Wave theme.
Dilomo (ankere) on 2009-09-09
Changed in anton:
assignee: nobody → Dilomo (ankere)
importance: Undecided → High
milestone: none → newwave-0.8.2
status: New → Confirmed
Dilomo (ankere) on 2009-11-06
Changed in anton:
status: Confirmed → In Progress
Dilomo (ankere) on 2009-12-14
Changed in anton:
status: In Progress → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-themes-ubuntu - 0.6

---------------
gnome-themes-ubuntu (0.6) lucid; urgency=low

  [ Loïc Minier ]
  * Fix find snippet dropping -x bits to not touch the upstream files (only
    the installed one) and reverse logic to clear the bits of all files except
    *.sh files (only file needing +x in this package).

  [ Andrew Starr-Bochicchio ]
  * Update Dust{-Sand} to lp:~dusttheme-dev/dusttheme/0.5
   - gnome-panel clock should not be bold (LP: #439191).
   - Text overlaps with icon in window title bar (LP: #371743).
   - Remove depricate Murrine configuration option "gradients" (LP: #529811)
  * Update New Wave to version 0.8.2 (LP:508851).
   - Nautilus focus ring is not visible (LP: #390601).
   - Thumbnails corrupted in Appearance Preferences (LP: #416030).
  * debian/control: Bump Standards-Version to 3.8.4
 -- Andrew Starr-Bochicchio <email address hidden> Sun, 28 Feb 2010 21:22:08 -0500

Changed in gnome-themes-ubuntu (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers