"Do not disconnect" and "ok to disconnect" device notifications should not use the same icon

Bug #387791 reported by Loïc Alejandro on 2009-06-16
30
This bug affects 5 people
Affects Status Importance Assigned to Milestone
One Hundred Papercuts
Undecided
Unassigned
gnome-disk-utility (Ubuntu)
Low
Unassigned

Bug Description

When you unmount a usb stick, and Ubuntu still has things to write on it, a popup appears asking to wait. And when it is finished, another one says that I can remove the usb stick.
In these two popups the icon should be different.

Changed in hundredpapercuts:
status: New → Confirmed
summary: - icon in usb popup "no disconnect" and "ok disconnect" should be
- different
+ "Do not disconnect" and "ok to disconnect" device notifications should
+ not use the same icon
Changed in hundredpapercuts:
milestone: none → round-8
Radoslav Georgiev (valsodarg) wrote :

I agree but to add:
Pop-up for displaying writing to disk should not disappear until writing finishes (sometimes I have wondered off and had to manually verify if the device is still busy).

Alessio Gaeta (meden) wrote :

+1
I would add: "ok to disconnect" should appear in any case, even if no writes are needed (on my system it doesn't happen).

Nicolas (nicolas-espina) wrote :

Why not use the new notifications? Very simple and beautiful

Make the pop-up a floating windows without focus. OK to disconnect window should be shown as suggested by Alessio.
The window shouldn't have any buttons and should be closed by using the window decoration button (direct user interaction) or should close automatically when the user removes the drive (indirect user interaction).
Maybe add the minimize button so if the write is long the user can minimize the windows to the window list. Upon write completion the window should either pop-up or flash in the window list.

Any other suggestions?

Disclaimer: Not at my Ubuntu box so I'm just guessing that this isn't already implemented in some way.

John Montgomery (blueyonder64) wrote :

I agree with Nicolas' idea. Why not incorporate it into a notification system already in use rather than maintaining a separate, independent process just for this?
I also have to add that these notifications do not always appear 100% of the time or me. I would estimate that about 30% of the time I get no other indication that it's safe to remove the USB drive than the icon disappearing in the Nautilus sidebar. But that should probably be filed as it's own bug.

Vish (vish) wrote :

@John Montgomery:
There is already separate bug for that > Bug #386057

komputes (komputes) wrote :

I'm with Nicholas and John. "Safe to remove disk" should be an OSD notification. The "Wait to remove" notification should clearly show a different icon with a red X or a crossed circle in front of a usb symbol. The "Safe to remove" one should have a green check mark and an arrow indicating pulling out the plug.

Since we do not have a "Safely unmount all partitions to remove $DEVICE_NAME" option in gnome, Bug #387512 is crucial to fix, so that the notifications are shown every time it is safe to remove a device.

komputes (komputes) wrote :

Sorry, Bug #387512 is a duplicate. I meant Bug #386057 is crucial to fix along with this one.

Michael Rooney (mrooney) wrote :

I think the real fix for this is to use notify-osd for these, with proper icons, which I think belongs in gvfs.

A. Walton (awalton) wrote :

GVFS doesn't even link to libnotify and is in no way responsible for sending notifications anywhere. This is coming from somewhere even lower in the stack.

Changed in gvfs (Ubuntu):
status: New → Invalid
Changed in hundredpapercuts:
milestone: round-8 → lucid-round-8
Sense Egbert Hofstede (sense) wrote :

Assigning this to gnome-disk-utility since it is the application responsible for the notifications.

affects: gvfs (Ubuntu) → gnome-disk-utility (Ubuntu)
Changed in gnome-disk-utility (Ubuntu):
importance: Undecided → Low
status: Invalid → Triaged
Matthew Paul Thomas (mpt) wrote :

Notification bubbles are not a "notification system", they are just one notification mechanism. See <https://wiki.ubuntu.com/NotificationDesignGuidelines> for an overview of other mechanisms.

gnome-disk-utility used to use a notification bubble for this situation. But with Notify OSD, when a bubble disappeared, the unmounting wouldn't necessarily have finished yet. So we fixed gnome-disk-utility to use a progress window instead, as it really should have in the first place. (After all, other kinds of file moving and copying use a progress window.)

From the design specification for the progress window <https://wiki.ubuntu.com/NotifyOSD#gnome-disk-utility>: "The title and icon for the progress window should be the name and icon for the volume." For that reason, in the absence of an explanation for why it should change icons part-way through, I'm closing this bug report.

If there are indeed "two popups" instead of one, please report a separate papercut about that. And if the window sometimes doesn't appear at all, please report a separate papercut about that. Either of those situations could have made it seem as if two separate icons should be used.

Changed in gnome-disk-utility (Ubuntu):
status: Triaged → Invalid
Changed in hundredpapercuts:
status: Confirmed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers