OOo/LO F11 key brings up Style and Formatting instead of Full Screen

Reported by Rick Spencer on 2009-06-15
This bug report is a duplicate of:  Bug #891539: Fullscreen via F11 should work. Edit Remove
40
This bug affects 6 people
Affects Status Importance Assigned to Milestone
One Hundred Papercuts
Low
Unassigned
OpenOffice
Won't Fix
Unknown
libreoffice (Ubuntu)
Undecided
Unassigned
openoffice.org (Ubuntu)
Low
Chris Cheney

Bug Description

Title pretty much says it all. Perhaps we could simply patch the Keyboard Configuration file?

In Precise, LibreOffice, that replaced OOo, wants Ctrl-Shift-J for fullscreen.
$ apt-cache policy libreoffice-writer
libreoffice-writer:
  Installed: 1:3.5.2-2ubuntu1

Changed in hundredpapercuts:
status: New → Confirmed
Changed in hundredpapercuts:
milestone: none → round-6

Please don't fix this in OO!

There are so many programs out there with the exact same sort of problem. Keybindings being catched, not even used sometimes, and the default gnome-behaviour isn't executed.

Please make the gnome-session deamon (or whatever is responsible for catching the keys) enforce it's bindings.
If the default bindings overlap with any program, than _thats_ a bug we can and should fix in that particular program.

Examples of places where this is all an issue:
  - All SDL apps (try changing the volume, switching desktops, etc.)
  - Full-screen flash (it leaves fullscreen because somehow it received a keypress intended for gnome)

Just being able to use my volume keys everywhere; when playing a game; when watching youtube fullscreen, would be so brilliant.

And it is possible: control+alt+f1/f2/etc. always work.
So why not for all other gnome-bindings?

Chris Cheney (ccheney) wrote :

I am thoroughly confused by what Ralf said in his comment.

Martin Emrich (emme) wrote :

Hmm, Ralf describes another problem (which should be in a different bug report): Applications are able to catch (almost) any key combination, before they reach g-s-d or whatever session-wide service executes (not-so)-global shortcuts like volume control. This obviously has nothing to do with OOo.

@Ralf: This bug seems to be about replacing CTRL-SHIFT-J with F11 in OOo, which both are application-level shortcuts (where the latter is more and more getting a standard for fullscreen, as in Firefox, Evince, Sudoku etc.). Neither the settings-daemon nor the window-manager should "force" an application to fullscreen. CTRL-ALT-Fn AFAIK work almost always because the kernel catches them before X.Org.

And by the way: Please don't replace F5 with F11 in OOo Impress, many USB presenters have a hardwired F5 button because of MS Office PowerPoint.

This is a non issue.

F11 may be commonly used as the Fullscreen toggle in a lot of programs, but its not mandatory.

OO have found another use for the button. If you feel strongly then feel free to take the issue to their designers but I;m afraid this is not a papercut or even a bug.

Changed in hundredpapercuts:
status: Confirmed → Invalid
Vish (vish) wrote :

There needs to be a consistency throughout the OS , we can not be having each app choosing its own shortcut.

That affects usability as a whole [ users would have to remember shortcuts for each app which is not ideal]

Changed in hundredpapercuts:
importance: Undecided → Low
status: Invalid → Confirmed

On Tue, Aug 11, 2009 at 9:35 PM, mac_v wrote:
> There needs to be a consistency throughout the OS , we can not be having
> each app choosing its own shortcut.
>
> That affects usability as a whole [ users would have to remember
> shortcuts for each app which is not ideal]

Yes, I agree, especially for a core application. Thanks for updating this :)

@martin: I think Ralf has a interesting idea RE: making F11 a window manager job by default. It would seem that Fullscreen means always on top+hide window decorations which are both things an application would have to request that the window manager does for them (presumably through EWMH). If this were implemented in the WM the applications wouldn't need to hard-code this logic for this simple case. Obviously the application would still need to be able to override this behaviour if desired to allow the custom behaviour seen in Firefox, etc.

Of course expanding the scope of this bug to include this would make it invalid for paper cut status so I'll just shut-up now.

While I applaud the idea of a WM-enforced shortcut for this that would automatically apply to all apps, William rightly points out that that is out of scope for this paper cut. Simply patching OOo's keyboard configuration to map F11 to Fullscreen appears to be an appropriate fix.

thing (stp-things) wrote :

Please, let us try to work upstream first. http://www.openoffice.org/issues/show_bug.cgi?id=104109

Michael Rooney (mrooney) wrote :

Thing, thanks for the upstream bug, I'll link it and add an Ubuntu task as wel!

Changed in openoffice:
importance: Undecided → Unknown
status: New → Unknown
Changed in openoffice:
status: Unknown → In Progress
Daniel K (sinani201) on 2009-08-12
Changed in openoffice.org (Ubuntu):
status: New → Confirmed
Chris Cheney (ccheney) wrote :

Marking as triaged as the bug has been sent upstream.

Changed in openoffice.org (Ubuntu):
importance: Undecided → Low
status: Confirmed → Triaged
thing (stp-things) wrote :

This is not a paper cut because it is not trivial. It might be trivial to change F11 to Full Screen, but doing so will break existing user experience for many users.

Vish (vish) wrote :

Quoting thing's suggestion upstream:
Complete suggestion for shortcuts changes in Writer, Calc and Impress/Draw are
as follows:
Writer before:
F4 = [unused]
F11 = Styles and Formatting
F12 = Numbering On/Off
Writer after:
F4 = Numbering On/Off
F11 = Full screen
F12 = Styles and Formatting

Calc before:
F3 = [unused]
F11 = Styles and Formatting
F12 = Grouping
Calc after:
F3 = Grouping
F11 = Full screen
F12 = Styles and Formatting

Impress/Draw before:
F11 = Styles and Formatting
F12 = [unused]
Impress/Draw after:
F11 = [unused]
F12 = Styles and Formatting
------------
thing , These suggestions seem a fairly simple change,
what was the conclusion of the discussion in upstream Mailing list.
Any links to the ML discussion upstream?

Vish (vish) wrote :

thing, thanks for discussion this upstream. :)

David, this has a milestone assigned to it , what's your opinion ?

Upstream is right to be concerned , this is a huge task for them since they have to deal will all the different OS and documentations.

But , IMO , we could change this in Ubuntu alone , which would be simpler.

Changed in hundredpapercuts:
assignee: nobody → David Siegel (djsiegel)
thing (stp-things) wrote :

@mac_v, you misrepresent the concern upstream. The concern is not about the tasks involved. The concern is about breaking existing user experience for a very seldomly used functionality.

IMO it is not worth it.

Vish (vish) wrote :

@thing , I'v read all those comments too.
But those problems have occurred due to a bad design decision early on in the app's development.

So , the real question now is ,
 - Is it alright to leave this mistake as such and make *all* future new users to suffer, just to not discomfort the existing users?
 - Or correct this sooner and existing users[already experienced with the app] will adjust quicker to the shortcuts , since we are not drastically rearranging them. We are setting the shortcuts more in tune with all apps.

This will adversely affect the new users more than the existing ones , who are sure to raise alarm once the change is done but will adjust quicker.
Since we are accustomed to a mistake , it doesnt justify the mistake.

In my mind, this is not complicated. On Ubuntu, F11 is Full Screen. The fact that Styles and Formatting is bout to this key is annoying to me as a *heavy* user of OO.

I agree with mac_v, existing users who do not celebrate that change to a sane and consistent key binding will adjust. If they can't, well, keybindings remain configurable. If it's a huge mistake we can roll it back before launch.

Great to see upstream considering this change as well. Reading the upstream bug reports suggests to me that it would be helpful for us to try this in Ubuntu. If it works out as well I as I expect it to, that will be good information for them as they prioritize and plan.

Chris, if it's as simple as it seems, could you please patch our keyboard configuration file? If it's not simple, please advice on how to fix this. Thanks.

Changed in openoffice.org (Ubuntu):
assignee: nobody → Chris Cheney (ccheney)
Chris Cheney (ccheney) wrote :

mac_v / Rick,

OOo aka SO is older than even Gnome 1.x so claiming it was a bad design decision is unlikely to actually be true.

This is also not as clear cut as some may think due to the fact that OOo runs on many platforms and has consistent keybindings across them. Changing it on Ubuntu will probably confuse as many users as it helps. The keybindings are also localized so it may be more complicated to change than just a small patch. But I can look into seeing how to change it.

Chris

Tim Macdonald (tsmacdonald) wrote :

Maybe I'm overcomplicating things, but what if there was an option to change the keyboard shortcuts? Everything minus Ubuntu could have the defaults be F11=S&F, and Ubuntu could have the default be F11=Fullscreen. I don't have hard numbers, but I'd be willing to bet that a lot of Ubuntu-users are first-time OO.o users, so they're used to F11 being fullscreen. If it bothers older OO.o users, they'll presumably know how to change the settings.

Chris Cheney (ccheney) wrote :

Except it wouldn't really be just 'older OO.o users' it would be any OO.o user that uses more than just Ubuntu, any other Linux, Windows, or Mac. Eg the Ubuntu user who uses OOo in the uni Windows lab, etc.

(I am beginning to understand the reasoning for the trademark licensing rules that apparently are going into effect soon, I just don't particularly like them. Its partly to keep user noticeable divergent stuff like this from happening.)

I assume that platform incompatible features are annoying on other platforms as well.

Please just fix this in Ubuntu for now, and if it turns out to be a bad choice, we can roll it back during beta.

Well, consider the ratio of users who learn "F11 is fullscreen" to
users who have previously learned that OpenOffice uses F11 for Style
and Formatting. Is it 1:1? 10:1? 1000:1?

If more users expect F11 to invoke fullscreen than expect F11 to open
Style and Formatting, then this change would do more good than harm.

Would anyone care to conduct a test that randomly asks people to name
the Fullscreen shortcut or the Style and Formatting shortcut? If more
people know F11 is Fullscreen, I don't see any good reason not to
change this.

My personal opinion, which doesn't really matter, is that OOo should have keybindings that make sense on a per platform basis, like what is wanted in this case. There are other issues related to keybindings such as conflicts with gnome unicode direct input, etc. It seems, thought it may not be the case, that they determined which keybindings worked on on Windows (or maybe Solaris) and just forced them on the rest of the platforms.

Chris Cheney (ccheney) wrote :

Oh, and if someone wants to make this a broader fix of the keybindings in general to match Gnome better we may be able to get buyin from the Go-OO ooo-build distributions to switch to the new keybindings. I think that includes everyone except for RedHat/Fedora.

Chris

Chris Cheney (ccheney) wrote :

There is a problem with at least calc:

Calc before:
F3 = [unused]
F11 = Styles and Formatting
F12 = Grouping

Calc after:
F3 = Grouping
F11 = Full screen
F12 = Styles and Formatting

Seems simple right? Except that Shift-F12 is ungroup and shift-F3 is already used.

Chris Cheney (ccheney) wrote :

I also see this:

<accel:item accel:code="KEY_F12" accel:shift="true" accel:mod1="true" xlink:href=".uno:RemoveBullets"/>
<accel:item accel:code="KEY_F12" accel:shift="true" xlink:href=".uno:DefaultBullet"/>
<accel:item accel:code="KEY_F12" xlink:href=".uno:DefaultNumbering"/>

And just remapping part of the bullet options to another key isn't exactly intuitive or helpful to the user.

I am continuing with making the patch to work as originally listed but it seems it wasn't investigated very well, imho.

Chris Cheney (ccheney) wrote :

Oh and to be clear even the F11 keybindings are related before this change eg:

<accel:item accel:code="KEY_F11" xlink:href=".uno:DesignerDialog"/>
<accel:item accel:code="KEY_F11" accel:shift="true" xlink:href=".uno:StyleNewByExample"/>
<accel:item accel:code="KEY_F11" accel:shift="true" accel:mod1="true" xlink:href=".uno:StyleUpdateByExample"/>
<accel:item accel:code="KEY_F11" accel:mod1="true" xlink:href=".uno:ActivateStyleApply"/>

So just remapping F11 without the rest is probably going to annoy users as well, and remapping the whole set of keybindings leads to the other problem of not having anywhere to remap to...

Chris, you are investigating it well now! If it really looks like OpenOffice cannot easily support F11 for Fullscreen (if it involves all of the changes you mention) then this is not a paper cut and upstream should be involved.

Chris Cheney (ccheney) wrote :

Ok.

I am not sure upstream will want to do the level of invasive change that making F11 work would entail... However if Wikipedia is correct in that Vista/Win7 also uses F11 for Fullscreen we probably could persuade them to do so. I agree this is not really a papercut with the level of change needed and also documentation preferrably would also need to be changed to match up with the new keybindings which would be quite a lot of work.

Chris

Changed in openoffice.org (Ubuntu):
assignee: Chris Cheney (ccheney) → nobody

This should be addressed, but it cannot be considered a paper cut.

Changed in hundredpapercuts:
assignee: David Siegel (djsiegel) → nobody
milestone: round-6 → none
status: Confirmed → Invalid
thing (stp-things) wrote :

@ccheney, I investigated along with upstream to the level you reached at #29 and concluded it was not a Ubuntu paper cut as I stated in #12. Since I do not regard this a Ubuntu paper cut I will follow-up on the upstream bug. Sorry for the late reply there.

Regarding #31, even if Vista/Win7 uses F11 for Full Screen (e.g. IE) I doubt that Word and Excel uses F11 for Full Screen.

FWIW, I don't think different application short cuts on different platforms is the way to go.

Chris Cheney (ccheney) wrote :

It seems Office 2007 doesn't have a way to enter full screen mode from a keyboard shortcut by default. You have to map it yourself.

http://news.office-watch.com/t/n.aspx?a=777

Vish (vish) wrote :

@Chris Cheney / Rick Spencer:
Is this being considered for Lucid?

Chris Cheney (ccheney) on 2009-12-11
Changed in openoffice.org (Ubuntu):
assignee: nobody → Chris Cheney (ccheney)
milestone: none → ubuntu-10.04
Changed in openoffice:
status: In Progress → Won't Fix
Chris Cheney (ccheney) on 2010-03-22
Changed in openoffice.org (Ubuntu):
milestone: ubuntu-10.04 → ubuntu-10.04-beta-2
Chris Cheney (ccheney) wrote :

Vish,

Yes I am going to try to implement this change in the next upload sometime in the next week (not 4ubuntu1).

Chris Cheney (ccheney) wrote :

Apparently changing just the following is not enough to actually make it do what it says:

<accel:item accel:code="KEY_F11" xlink:href=".uno:DesignerDialog"/>

I am looking into what could possibly control this. I am not sure why the xml files exist if they aren't what are controlling the settings.

Chris Cheney (ccheney) wrote :

I found another spot it is set, I imagine this is probably the setting that is actually being used and all the others are probably just cruft or something along those lines.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package openoffice.org - 1:3.2.0-4ubuntu2

---------------
openoffice.org (1:3.2.0-4ubuntu2) lucid; urgency=low

  * Disable check_for_running_ooo as it appears to not be needed anymore and
    causes problems with upgrades. Closes LP: #450569
  * debian/patches/f11-fullscreen.diff: Change OOo to use F11 for fullscreen.
    Closes LP: #387562
  * debian/patches/human-icons-add.diff: Update patch to permit icon switching.
    Closes LP: #516595
 -- Chris Cheney <email address hidden> Fri, 26 Mar 2010 01:30:00 -0500

Changed in openoffice.org (Ubuntu):
status: Triaged → Fix Released

This is a good change, and I am counting it as a fixed paper cut.

Changed in hundredpapercuts:
status: Invalid → Fix Released
Anmar Oueja (anmar) wrote :

I just updated to this version of office and pressing F11 still shows the styles window . Tested it with OOo Writer.

Anmar Oueja (anmar) wrote :

got more updates and it works now. looks good.

Chris Cheney (ccheney) wrote :

For users who have modified their keybindings they might have to reset the F11 keybinding manually since it appears to copy the settings to their local user config.

joris (joris-dobbelaer-gmail) wrote :

Maybe I missed it, but I cannot find any alternative key mapped for 'Styles and formatting' The Openoffice manual in Lucid is also still referring to F11.

Styles and formatting is one of the most useful keyboard short-cuts Openoffice has. Is just breaking the F11 shortcut in openoffice really the right thing to do here?

ubuntolo (ovitaerc) wrote :

Well, it's just an opinion of course, but one ot the first things I've done after installing Lucid is restoring the F11 behaviour in OOo (i.e. opening the style and format window). I work a lot with OOo on different operating systems, and Ubuntu is the only one interpreting F11 in a more abstract and system-wide way.
I don't think that changing the default key for such a frequent use functionality on such an heavy piece of software (we're not talking about a media player, but about a software that people actually use to work) is a good idea.
We should start being worried about people already working with Ubuntu and OOo, not just about first-time users with no pc experience at all, shouldn't we?

tags: added: precise regression-release
summary: - OOo F11 key brings up Style and Formatting instead of Full Screen
+ OOo/LO F11 key brings up Style and Formatting instead of Full Screen
description: updated
Changed in libreoffice (Ubuntu):
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.