Eject/Unmount icon in Nautilus sidebar should have hover and click states

Bug #383255 reported by Mat Tomaszewski on 2009-06-03
38
This bug affects 6 people
Affects Status Importance Assigned to Milestone
Nautilus
Fix Released
Medium
One Hundred Papercuts
Low
Marcus Carlson
nautilus (Ubuntu)
Wishlist
Unassigned

Bug Description

Lack of hover state for this icon makes it feel non-clickable. Click action does not feel right either, as you don't see any immediate feedback (e.g. color or bg change).

I'd suggest making the icon glow on hover (similar to folder icon behaviour) and go darker on click.

Mat Tomaszewski (mat.t.) on 2009-06-03
summary: - "Eject/Unmount" Human theme icon in Nautilus should have a hover and
- click states
+ "Eject/Unmount" Human theme icon in Nautilus should have hover and click
+ states
Revision history for this message
Andrew Starr-Bochicchio (andrewsomething) wrote : Re: "Eject/Unmount" Human theme icon in Nautilus should have hover and click states
Changed in nautilus:
importance: Undecided → Unknown
status: New → Unknown
Changed in nautilus (Ubuntu):
assignee: nobody → Ubuntu Desktop Bugs (desktop-bugs)
importance: Undecided → Wishlist
status: New → Triaged
Changed in nautilus:
status: Unknown → New
Mat Tomaszewski (mat.t.) on 2009-06-10
Changed in hundredpapercuts:
importance: Undecided → Low
status: New → Confirmed
Ivanka Majic (ivanka) on 2009-06-17
Changed in hundredpapercuts:
status: Confirmed → Triaged
Revision history for this message
Mat Tomaszewski (mat.t.) wrote :

Since we know this one waits to be fixed... would anyone like to submit their design proposals?

Changed in hundredpapercuts:
milestone: none → round-2
Revision history for this message
Milan Bouchet-Valat (nalimilan) wrote :

Mat: See upstream bug for an explanation of the problems behind this seemingly trivial improvement.

summary: - "Eject/Unmount" Human theme icon in Nautilus should have hover and click
+ Eject/Unmount icon in Nautilus sidebar should have hover and click
states
Changed in libgtk:
status: Unknown → New
Revision history for this message
Sebastien Bacher (seb128) wrote :

The change is not trivial and required modifications to gtk to allow doing such changes in nautilus later

Revision history for this message
Lorenzo (lorenzo-delledonne) wrote :

Isn't this a feature implemented in Gtk-Sharp by the Banshee team? I'm thinking about the "Rating" row.

Revision history for this message
A. Walton (awalton) wrote :

Banshee has a completely different tree view code base.

Revision history for this message
David Siegel (djsiegel-deactivatedaccount) wrote :

Upstream bug report indicates that this is a difficult fix due to GtkTreeview complexity; not a paper cut.

Changed in hundredpapercuts:
milestone: round-2 → none
status: Triaged → Invalid
Changed in nautilus:
status: New → Invalid
Omer Akram (om26er) on 2010-05-01
Changed in nautilus:
status: Invalid → Unknown
Changed in nautilus:
status: Unknown → Confirmed
Revision history for this message
Vish (vish) wrote :

Marcus is making progress on this one. So re-opening this bug.

Changed in hundredpapercuts:
milestone: none → maverick-round-1-file-management
status: Invalid → Triaged
Changed in libgtk:
status: New → Confirmed
Revision history for this message
Vish (vish) wrote :

Marcus is working on this.

Changed in hundredpapercuts:
assignee: nobody → Marcus Carlson (0-launchpad-mejlamej-nu)
Changed in nautilus:
status: Confirmed → Fix Released
Revision history for this message
Sebastien Bacher (seb128) wrote :

the bug has been fixed upstream but not in the 2.32 serie which maverick is using

Changed in nautilus (Ubuntu):
assignee: Ubuntu Desktop Bugs (desktop-bugs) → nobody
status: Triaged → Fix Committed
Vish (vish) on 2010-08-23
Changed in hundredpapercuts:
status: Triaged → Fix Committed
Vish (vish) on 2010-08-23
tags: added: natty
Changed in nautilus:
importance: Unknown → Medium
Changed in libgtk:
importance: Unknown → Wishlist
Vish (vish) on 2010-11-23
Changed in hundredpapercuts:
milestone: maverick-round-1-file-management → nt4-nautilus
Revision history for this message
Luca Ferretti (elle.uca) wrote :

For the record, crrently hover (highlight) is available on git master (nautilus 2.91.x)

Revision history for this message
Omer Akram (om26er) wrote :

nautilus 3.0 is now in Oneiric

Changed in hundredpapercuts:
status: Fix Committed → Fix Released
Changed in nautilus (Ubuntu):
status: Fix Committed → Fix Released
Changed in libgtk:
status: Confirmed → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.