LibreOffice in Xubuntu should be using Elementary theme as default

Bug #1548647 reported by Kev Bowring on 2016-02-23
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
One Hundred Papercuts
Medium
Unassigned
libreoffice (Ubuntu)
Undecided
Björn Michaelsen

Bug Description

LO in Xubuntu should be using Elementary theme as default - set to Breeze (and on live session)

ProblemType: Bug
DistroRelease: Ubuntu 16.04
Package: xubuntu-artwork 15.12.2
ProcVersionSignature: Ubuntu 4.4.0-6.21-generic 4.4.1
Uname: Linux 4.4.0-6-generic x86_64
ApportVersion: 2.20-0ubuntu3
Architecture: amd64
CasperVersion: 1.367
CurrentDesktop: XFCE
Date: Tue Feb 23 07:11:10 2016
LiveMediaBuild: Xubuntu 16.04 LTS "Xenial Xerus" - Alpha amd64 (20160222.1)
PackageArchitecture: all
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: xubuntu-artwork
UpgradeStatus: No upgrade log present (probably fresh install)

Kev Bowring (flocculant) wrote :
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1548647

tags: added: iso-testing
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xubuntu-artwork (Ubuntu):
status: New → Confirmed
Changed in hundredpapercuts:
status: New → Confirmed
importance: Undecided → Medium
Changed in xubuntu-artwork (Ubuntu):
importance: Undecided → Medium
Pasi Lallinaho (knome) wrote :

Alberto,
please stop changing importances for Xubuntu packages without consulting the Xubuntu team.

Changed in xubuntu-artwork (Ubuntu):
importance: Medium → High
Pasi Lallinaho (knome) wrote :

One option to fix this is to set libreoffice-style-elementary as a Recommends for libreoffice-gtk.

Sean Davis (bluesabre) wrote :

This is partly related to the fact that the libreoffice-gtk recommends

libreoffice-style-breeze | libreoffice-style-tango

One of Xubuntu 16.04's release goals is to ship only a single theme. We have attempted this in the past with this bug report:
https://bugs.launchpad.net/ubuntu/+source/libreoffice/+bug/1483914

Now that the libreoffice-style-elementary theme is built with the libreoffice package, we'd like to propose libreoffice-style-elementary as an alternate recommends. I have attached a debdiff which should resolve this issue.

I am also marking libreoffice as an affected project. Please let me know if there are any questions or concerns.

The attachment "debdiff for libreoffice-style-elementary" seems to be a debdiff. The ubuntu-sponsors team has been subscribed to the bug report so that they can review and hopefully sponsor the debdiff. If the attachment isn't a patch, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are member of the ~ubuntu-sponsors, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issue please contact him.]

tags: added: patch

Self-assigning, will try to merge/include that for xenial still. Note the debdiff cant be used as-is as ./debian/control in libreoffice is a generated file, so the important change is actually in ./debian/control.in.

Changed in libreoffice (Ubuntu):
assignee: nobody → Björn Michaelsen (bjoern-michaelsen)
Sean Davis (bluesabre) wrote :

Thanks Björn, please let me know if you need anything from me.

Kev Bowring (flocculant) wrote :

Currently we have

live session is breeze
installed system has Galaxy (set Automatic)

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in libreoffice (Ubuntu):
status: New → Confirmed
Mathias Dietrich (theghost) wrote :

I have the Breeze theme set on a fresh installed Ubuntu 16.04 daily ISO.
Please use another theme for non Qt-Desktops. The Breeze theme is unpleasant on Gtk.

setting back title to "LibreOffice in Xubuntu should be using Elementary theme as default" as per original report. Please dont scope creep reported bugs.

The relevant changes to allow this in Xubuntu have been done as per comment #6 and comment #8 in libreoffice_5.1.1-0ubuntu1.

For the Ubuntu Unity desktop, see bug 1506544 which has been discussed with John Lea/Canonical Design Team.

As for othe desktops: Dont use this bug as per above.

summary: - LibreOffice uses breeze style
+ LO in Xubuntu should be using Elementary theme as default
Changed in libreoffice (Ubuntu):
status: Confirmed → Fix Released
summary: - LO in Xubuntu should be using Elementary theme as default
+ LibreOffice in Xubuntu should be using Elementary theme as default
Pasi Lallinaho (knome) on 2016-03-27
no longer affects: xubuntu-artwork (Ubuntu)
Changed in hundredpapercuts:
status: Confirmed → Fix Released
Kev Bowring (flocculant) on 2016-04-13
Changed in libreoffice (Ubuntu):
status: Fix Released → Confirmed
Kev Bowring (flocculant) on 2016-04-13
Changed in libreoffice (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related blueprints