libreoffice-style-elementary as alternate to libreoffice-style-human

Bug #1483914 reported by Sean Davis on 2015-08-11
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
LibreOffice
Fix Released
Medium
libreoffice (Ubuntu)
Medium
Björn Michaelsen

Bug Description

The Xubuntu team has started to maintain a new icon theme for LibreOffice.

Upstream: https://github.com/shimmerproject/libreoffice-style-elementary
Source Package: https://launchpad.net/ubuntu/+source/xubuntu-artwork
Package: http://packages.ubuntu.com/wily/libreoffice-style-elementary

Please consider adding this theme as an alternate Recommends for libreoffice-gtk and libreoffice-gtk3 in Ubuntu. Ultimately, we would like to include this upstream in LibreOffice, and there is an initial upstream bug report where work was started on this (though it seems progress has slowed).

Upstream report: https://bugs.documentfoundation.org/show_bug.cgi?id=92458

The “Human” theme is so named because it is derived from Humanity, an icon theme originally developed for Ubuntu as a derivation of the original elementary theme. Nowadays, this LibreOffice theme is unmaintained, highly incomplete, and visually obsolete.

The Shimmer Project (known for Xubuntu and the Numix GTK+ theme) is creating an updated icon theme, based on Human, but including the newest elementary icons as well as creating original new ones.

@Michael: I added you to the CC list because of a licensing question: Simon, one of the Shimmer Project developers, asked me if it is necessary to put together a list of the individual icons and their license (à la icon-themes/human/CopyrightsHuman). [1] Based on what I understand of [2], that would mean “attribution bloat”, right?

-----

[1]: https://github.com/shimmerproject/libreoffice-style-elementary/issues/1#issuecomment-117154479
[2]: https://wiki.documentfoundation.org/License_Policy

Sigh - if we can possibly avoid it - I'd -really- prefer to avoid having masses of copies of new licenses with un-necessary individual (or corporate) copyright claims in them. Then again - if you're going to do the work - its good to poke Andras with the changes to the license language you want.

Of course - crediting the authors of the icons is best done by people committing them to git and getting credited in our credit page - that's something we're enthusiastic about =)

Does that help ? either way upgrading Human sounds sensible to me if people want to work on that. Thanks !

Though the human theme isnt bundled by default with libreoffice, it is the default icon theme used for LO in Ubuntu and its flavours, except Kubuntu, so i'd assume it would be good to make sure that Canonical doesnt have an issue with this. I believe Ubuntu uses the human theme as its default icon theme for its unity desktop, so it maybe important to them to keep that consistency. CCing Bjoern for his thoughts.

During my work on tango, i have copied a few of human icons into tango that looked suitable, when tango was falling back on industrial or galaxy. Human should really be falling back on tango rather than industrial with the amount of improvements that are going into tango.

(In reply to Yousuf (Jay) Philips from comment #2)
> Though the human theme isnt bundled by default with libreoffice, it is the
> default icon theme used for LO in Ubuntu and its flavours, except Kubuntu,
> so i'd assume it would be good to make sure that Canonical doesnt have an
> issue with this.

Right. I would really not enjoy killing the Human theme, as likely it would just mean that I would need to carry it as a cumbersome vendor patch anyway, just creating lots of pointless work along the way.

What is the point/goal of this anyway? The human theme can be turned off by a configure switch and IIRC isnt even enabled by default. If the goal is to make Ubuntu ship a different default, this certainly isnt the way towards that goal (see above).

If you want a different default in Ubuntu, the way to go about that is filing a request on launchpad at Ubuntu and get that nodded of by Ubuntus design team.

(As a general note this bug doesnt seem to be too well scoped: it describes no clear goal and mixes too many things: removing themes, adding themes, changing defaults with the latter being off-topic here beyond TDF builds.)

@Björn: Honestly, Canonical’s design team is so embroiled in the phone project that they would ignore my bug report anyway.

I’m dropping the Human theme from this to make you more comfortable.

Sean Davis (bluesabre) wrote :

Attaching required debdiff to make this possible.

The attachment "debdiff" seems to be a debdiff. The ubuntu-sponsors team has been subscribed to the bug report so that they can review and hopefully sponsor the debdiff. If the attachment isn't a patch, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are member of the ~ubuntu-sponsors, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issue please contact him.]

tags: added: patch
Changed in df-libreoffice:
importance: Unknown → Medium
status: Unknown → Confirmed
Daniel Holbach (dholbach) wrote :

<Sweet5hark> dholbach: soo, releasing the theme independant from LibreOffice will likely get messy with different versions and people having the theme from one archive and LibreOffice from another (e.g. from PPAs). Thus I would love to have this upstream.
 dholbach: (see tdf#92458)
 dholbach: I'd love to help with that as time allows. https://bugs.documentfoundation.org/show_bug.cgi?id=92458#c1 is the relevant piece there: We'd need the license statement-foo from the authors and look at the stuff being clean from an IP PoV. Probably best we get the git history into the LibreOffice core repo and get a license statement from the authors.
<ubot5> bugs.documentfoundation.org bug 92458 in UI "Integrate the “elementary” theme into LibreOffice" [Normal,New]
<Sweet5hark> dholbach: the git stuff should be doable reasonably easy with some git filter-branch foo, I will try to find time for that.
<Sweet5hark> dholbach: (getting the commits into the LibreOffice core repo has the added benefit of creating LibreOffice authoring credits for the theme creators ...)
<Sweet5hark> dholbach: beyond that: the debdiff in bug seems rather superfluous to me: No need to recommend -elementary -- we dont do that with e.g. the sifr or breeze themes either. We recommend -human to have it in the default install, we recommend -tango because ... well, actually we dont need to. We do as Debian (which doesnt have -human) does that.
<Sweet5hark> dholbach: ;)
<Sweet5hark> <- just won an action item
 achievement unlocked, I guess.
<dholbach> Sweet5hark, I'm just going through the sponsoring queue and trying to get as many done or looked at as possible
<Sweet5hark> dholbach: right. nothing to sponsor here, the debdiff isnt what we'd want.
<dholbach> I'll unsubscribe the u-sponsors team then

Sean Davis (bluesabre) wrote :

Thanks for looking into this item.

Just as a side note, we would like the theme in Recommends for libreoffice-gtk at least to be able to ship only a single theme in the xubuntu iso. Currently libreoffice-gtk is pulling in libreoffice-style-human and our image is already pretty oversized.

Sean Davis (bluesabre) wrote :

Please do consider including this patch. With the inclusion of LibreOffice 5, the Xubuntu iso now ships with elementary, Galaxy, and Human themes.

Adolfo Jayme (fitojb) on 2015-10-02
Changed in libreoffice (Ubuntu):
importance: Undecided → Medium

(In reply to Björn Michaelsen from comment #5)
> Done with:
> http://cgit.freedesktop.org/libreoffice/core/commit/
> ?id=2b383d19e716863134087fe83d0aa5ba156006bd

All of the icons are in elementary/src/... when they should be in elementary/...

Will these icons be available in daily master builds, as it would be good to test them and help the elementary team improve it. Would also be useful to have human in the daily builds as well to test against it for ubuntu, just like we have tango_testing, but these shouldnt be available in releases.

Would be good to optimize the size of the elementary zip file by removing duplicates from galaxy and likely tango and also to set its fallback icon theme.

(In reply to Yousuf (Jay) Philips from comment #6)
> All of the icons are in elementary/src/... when they should be in
> elementary/...

moved in 7949ca85c526f2f22367900b5213e8df806ce873.

> Will these icons be available in daily master builds, as it would be good to
> test them and help the elementary team improve it. Would also be useful to
> have human in the daily builds as well to test against it for ubuntu, just
> like we have tango_testing, but these shouldnt be available in releases.

Having them in the daily build is up to the tinderbox owners.

> Would be good to optimize the size of the elementary zip file by removing
> duplicates from galaxy and likely tango and also to set its fallback icon
> theme.

Yeah maybe, but thats not part of this bug. Lets not featurecreep the scope here ...

Changed in df-libreoffice:
status: Confirmed → Fix Released

Was reading through another bug report and it mentioned that icon themes have entries in officecfg/registry/schema/org/openoffice/Office/Common.xcs under 'SymbolStyle' and one wasnt added for elementary, so should this have been added as part of the integration?

(In reply to Yousuf (Jay) Philips from comment #8)
> Was reading through another bug report and it mentioned that icon themes
> have entries in officecfg/registry/schema/org/openoffice/Office/Common.xcs
> under 'SymbolStyle' and one wasnt added for elementary, so should this have
> been added as part of the integration?

Good question. It seems to work happily without that. The constraints on the config provide two possible benefits:
- having longer descriptions for the values -> but we dont seem to use those anywhere
- limiting to a known set of values

The second seems questionable with new themes popping up quite often (and initially out-of-tree), while I see no benefit of the first.

@Stephan: Given the above, how about killing the constraint in officecfg altogether now?

(In reply to Björn Michaelsen from comment #9)
> @Stephan: Given the above, how about killing the constraint in officecfg
> altogether now?

yes, done with <http://cgit.freedesktop.org/libreoffice/core/commit/?id=5ab2bb87d9039e7c3f2dde87698df065967a731e> "Clean up documentation of SymbolStyle prop" (those constraints are not used anyway nowadays and effectively only serve as documentation for readers of the .xcs source files)

Changed in libreoffice (Ubuntu):
assignee: nobody → Björn Michaelsen (bjoern-michaelsen)
status: New → Fix Committed
status: Fix Committed → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libreoffice - 1:5.1.0-0ubuntu1

---------------
libreoffice (1:5.1.0-0ubuntu1) xenial; urgency=medium

  * finalize version, rc3 = 5.1.0
  * depend on libreoffice-sdbc-hsqldb from libreoffice-subsequentcheckbase for
    autopkgtests
  * add libreoffice-style-elementary from upstream (LP: #1483914)
  * continue building libreoffice-gtk3, but dont default-deploy (yet)
  * use system ucpp instead of bundling (LP: #1524638)
  * add google drive bits (LP: #1389936)
  * update indic fonts package names (LP: #958345)

 -- Bjoern Michaelsen <email address hidden> Sun, 21 Feb 2016 15:23:45 +0100

Changed in libreoffice (Ubuntu):
status: In Progress → Fix Released

Bjoern Michaelsen committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=c0da1080b61a1d51654fc34fdaeba373226065ff

lp#1506544 tdf#92458: default to breeze theme on unity desktops

It will be available in 5.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.

> Please do consider including this patch. With the inclusion of LibreOffice 5, the Xubuntu iso now ships with elementary, Galaxy, and Human themes.
@Sean: Should be fixed now too with 5.1.1-0ubuntu1.

Elementary is implemented but not used (if not used on the system). So the question is whether or not we make it the default for Gnome (proposal was done in patch 3/5 at https://gerrit.libreoffice.org/#/c/51959/3)

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related blueprints

Patches

Remote bug watches

Bug watches keep track of this bug in other bug trackers.