Comment 2 for bug 1785230

Hi Srinivas!

I also tried to package this version on Gentoo Linux. There seem to be more issues.

 * QA Notice: The following files contain writable and executable sections
 * Files with such sections will not work properly (or at all!) on some
 * architectures/operating systems. A bug should be filed at
 * https://bugs.gentoo.org/ to make sure the issue is fixed.
 * For more information, see:
 *
 * https://wiki.gentoo.org/wiki/Hardened/GNU_stack_quickstart
 *
 * Please include the following list of files in your report:
 * Note: Bugs should be filed for the respective maintainers
 * of the package in question and not hardened@g.o.
 * --- --- RWX usr/lib64/libImageProcessor-x86_64.so

 * QA Notice: The following shared libraries lack a SONAME
 * /usr/lib64/libImageProcessor-x86_64.so

Already mentioned by Hans-Peter

 * QA Notice: The following shared libraries lack NEEDED entries
 * /usr/lib64/libImageProcessor-x86_64.so

 * QA Notice: Pre-stripped files found:
 * /usr/lib64/libImageProcessor-x86_64.so

Additionally $DESTDIR is not honored, but Hans-Peter already mentioned this. I will try to add a patch to fix this issue.
This seems also be the case for the linking of the scan stuff the install-data-hook section of Makefile.am. However this does not affect Gentoo as the directories $(libdir)/x86_64-linux-gnu/sane and $(libdir)/i386-linux-gnu do not exist thus these links are not created.

Any chance that this issues get fixed?

You also mentioned that libImageProcessor is currently not open source. This indicates that it might get open source at some point. Is there any ETA when this will happen?

Regards,
Daniel