hp-setup fails with ImportError undefined symbol hpmud_make_par_uri

Bug #1777361 reported by Bernard_des_chères on 2018-06-17
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
HPLIP
Undecided
srinivas

Bug Description

Hello, I come back to you because I can not solve the problem with the hplip program on my PC.

Distributor ID: Debian
Description: Debian GNU / Linux 8.10 (Jessie)
Release: 8.10
Code name: jessie

My printer is an HP Photosmart C 4380

I enclose the result of the hp-check command in the attached file.

The hp-doctor command returns the same result as hp-setup either:
$ hp-doctor
Traceback (most recent call last):
  File "/usr/bin/hp-doctor", line 37, in <module>
    from base import utils, tui, module,queues, os_utils, services, smart_install
  File "/usr/share/hplip/base/module.py", line 30, in <module>
    import tui, utils, device
  File "/usr/share/hplip/base/device.py", line 42, in <module>
    import status
  File "/usr/share/hplip/base/status.py", line 59, in <module>
    import hpmudext
ImportError: /usr/lib/python2.7/dist-packages/hpmudext.so: undefined symbol: hpmud_make_par_uri.

Hoping that you will have a solution to offer me, thank you for your support.
Best regards

srinivas (srinivas5) wrote :

Hi Bernard,

Please try the below steps.
1. Uninstall the HPLIP by entering `sudo make uninstall`.
2. Do and OS update.
3. Download and install HPLIP latest driver and plugin from the site, https://developers.hp.com/hp-linux-imaging-and-printing/gethplip
4. Do hp-setup to add device.
See if it resolves the issue.

Thanks,
Srinivas Teja.

srinivas (srinivas5) on 2018-06-20
Changed in hplip:
assignee: nobody → srinivas (srinivas5)
status: New → In Progress
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments