hp-setup failed retrieve missing plugin

Bug #1442734 reported by monostory on 2015-04-10
52
This bug affects 12 people
Affects Status Importance Assigned to Milestone
HPLIP
Undecided
Unassigned

Bug Description

I bought a HP Laserjet Pro MFP M125nw printer.
After installation of HPLIP and while running hp-setup I got an error message:

error: Required plug-in status: Not installed

I let the script downloading the plugin from HP's website, however, after downloading I got another error message:

error: /home/monostory/.hplip/hplip-3.15.2-plugin.run file does not match its checksum. File may have been corrupted or altered

And the process ended.

hp-check.log is the following:

hp-check[30358]: info: :
hp-check[30358]: info: :[01mHP Linux Imaging and Printing System (ver. 3.15.2)[0m
hp-check[30358]: info: :[01mDependency/Version Check Utility ver. 15.1[0m
hp-check[30358]: info: :
hp-check[30358]: info: :Copyright (c) 2001-15 Hewlett-Packard Development Company, LP
hp-check[30358]: info: :This software comes with ABSOLUTELY NO WARRANTY.
hp-check[30358]: info: :This is free software, and you are welcome to distribute it
hp-check[30358]: info: :under certain conditions. See COPYING file for more details.
hp-check[30358]: info: :
hp-check[30358]: info: :[01mNote: hp-check can be run in three modes:[0m
hp-check[30358]: info: :1. Compile-time check mode (-c or --compile): Use this mode before compiling the
hp-check[30358]: info: :HPLIP supplied tarball (.tar.gz or .run) to determine if the proper dependencies
hp-check[30358]: info: :are installed to successfully compile HPLIP.
hp-check[30358]: info: :2. Run-time check mode (-r or --run): Use this mode to determine if a distro
hp-check[30358]: info: :supplied package (.deb, .rpm, etc) or an already built HPLIP supplied tarball
hp-check[30358]: info: :has the proper dependencies installed to successfully run.
hp-check[30358]: info: :3. Both compile- and run-time check mode (-b or --both) (Default): This mode
hp-check[30358]: info: :will check both of the above cases (both compile- and run-time dependencies).
hp-check[30358]: info: :
hp-check[30358]: info: :Check types:
hp-check[30358]: info: :a. EXTERNALDEP - External Dependencies
hp-check[30358]: info: :b. GENERALDEP - General Dependencies (required both at compile and run time)
hp-check[30358]: info: :c. COMPILEDEP - Compile time Dependencies
hp-check[30358]: info: :d. [All are run-time checks]
hp-check[30358]: info: :PYEXT SCANCONF QUEUES PERMISSION
hp-check[30358]: info: :
hp-check[30358]: info: :Status Types:
hp-check[30358]: info: : OK
hp-check[30358]: info: : MISSING - Missing Dependency or Permission or Plug-in
hp-check[30358]: info: : INCOMPAT - Incompatible dependency-version or Plugin-version
hp-check[30358]: info: :
hp-check[30358]: info: :
hp-check[30358]: info: :---------------
hp-check[30358]: info: :| SYSTEM INFO |
hp-check[30358]: info: :---------------
hp-check[30358]: info: :
hp-check[30358]: info: : Kernel: 3.13.0-48-generic #80-Ubuntu SMP Thu Mar 12 11:16:18 UTC 2015 GNU/Linux
 Host: monostory-note
 Proc: 3.13.0-48-generic #80-Ubuntu SMP Thu Mar 12 11:16:18 UTC 2015 GNU/Linux
 Distribution: ubuntu 14.04
hp-check[30358]: info: : Bitness: 32 bit

hp-check[30358]: info: :
hp-check[30358]: info: :-----------------------
hp-check[30358]: info: :| HPLIP CONFIGURATION |
hp-check[30358]: info: :-----------------------
hp-check[30358]: info: :
hp-check[30358]: info: :HPLIP-Version: HPLIP 3.15.2
hp-check[30358]: info: :HPLIP-Home: /usr/share/hplip
hp-check[30358]: info: :HPLIP-Installation: Auto installation is supported for ubuntu distro 14.04 version
hp-check[30358]: info: :
hp-check[30358]: info: :[01mCurrent contents of '/etc/hp/hplip.conf' file:[0m
hp-check[30358]: info: :# hplip.conf. Generated from hplip.conf.in by configure.

[hplip]
version=3.15.2

[dirs]
home=/usr/share/hplip
run=/var/run
ppd=/usr/share/ppd/HP
ppdbase=/usr/share/ppd
doc=/usr/share/doc/hplip-3.15.2
html=/usr/share/doc/hplip-3.15.2
icon=/usr/share/applications
cupsbackend=/usr/lib/cups/backend
cupsfilter=/usr/lib/cups/filter
drv=/usr/share/cups/drv/hp
bin=/usr/bin

# Following values are determined at configure time and cannot be changed.
[configure]
network-build=yes
libusb01-build=no
pp-build=no
gui-build=yes
scanner-build=yes
fax-build=yes
dbus-build=yes
cups11-build=no
doc-build=yes
shadow-build=no
hpijs-install=no
foomatic-drv-install=no
foomatic-ppd-install=no
foomatic-rip-hplip-install=no
hpcups-install=yes
cups-drv-install=yes
cups-ppd-install=no
internal-tag=3.15.2
restricted-build=no
ui-toolkit=qt4
qt3=no
qt4=yes
policy-kit=no
lite-build=no
udev_sysfs_rules=no
hpcups-only-build=no
hpijs-only-build=no

hp-check[30358]: info: :
hp-check[30358]: info: :[01mCurrent contents of '/var/lib/hp/hplip.state' file:[0m
hp-check[30358]: info: :Plugins are not installed. Could not access file: No such file or directory
hp-check[30358]: info: :
hp-check[30358]: info: :[01mCurrent contents of '~/.hplip/hplip.conf' file:[0m
hp-check[30358]: info: :[installation]
date_time = 04/10/2015 19:14:51
version = 3.15.2

[upgrade]
notify_upgrade = true
last_upgraded_time = 1428679347
pending_upgrade_time = 0
latest_available_version = 3.15.2

[settings]
systray_visible = 0
systray_messages = 0

[last_used]
device_uri = hp:/net/HP_LaserJet_Pro_MFP_M125nw?ip=192.168.0.202
printer_name =
working_dir = .

[commands]
scan = /usr/bin/xsane -V %SANE_URI%

[refresh]
rate = 30
enable = false
type = 1

[polling]
enable = false
interval = 5
device_list =

[fax]
voice_phone =
email_address =

hp-check[30358]: info: : <Package-name> <Package-Desc> <Required/Optional> <Min-Version> <Installed-Version> <Status> <Comment>
hp-check[30358]: info: :
hp-check[30358]: info: :--------------------------
hp-check[30358]: info: :| External Dependencies |
hp-check[30358]: info: :--------------------------
hp-check[30358]: info: :
hp-check[30358]: info: : gs GhostScript - PostScript and PDF language interpreter and previewer REQUIRED 7.05 9.10 OK -
hp-check[30358]: info: : scanimage scanimage - Shell scanning program OPTIONAL 1.0 1.0.23 OK -
hp-check[30358]: info: : xsane xsane - Graphical scanner frontend for SANE OPTIONAL 0.9 0.998 OK -
hp-check[30358]: info: : cups CUPS - Common Unix Printing System REQUIRED 1.1 1.7.2 OK 'CUPS Scheduler is running'
hp-check[30358]: info: : policykit PolicyKit - Administrative policy framework OPTIONAL - 0.105 OK -
hp-check[30358]: info: : network network -wget OPTIONAL - 1.15 OK -
hp-check[30358]: info: : avahi-utils avahi-utils OPTIONAL - 0.6.31 OK -
hp-check[30358]: info: : dbus DBus - Message bus system REQUIRED - 1.6.18 OK -
hp-check[30358]: info: :
hp-check[30358]: info: :-------------------------
hp-check[30358]: info: :| General Dependencies |
hp-check[30358]: info: :-------------------------
hp-check[30358]: info: :
hp-check[30358]: info: : libcrypto libcrypto - OpenSSL cryptographic library REQUIRED - 1.0.1 OK -
hp-check[30358]: info: : python-dbus Python DBus - Python bindings for DBus REQUIRED 0.80.0 1.2.0 OK -
hp-check[30358]: info: : reportlab Reportlab - PDF library for Python OPTIONAL 2.0 3.0 OK -
hp-check[30358]: info: : python-notify Python libnotify - Python bindings for the libnotify Desktop notifications OPTIONAL - - OK -
hp-check[30358]: info: : pyqt4 PyQt 4- Qt interface for Python (for Qt version 4.x) REQUIRED 4.0 4.10.4 OK -
hp-check[30358]: info: : python-xml Python XML libraries REQUIRED - 2.1.0 OK -
hp-check[30358]: info: : libusb libusb - USB library REQUIRED - 1.0 OK -
hp-check[30358]: info: : cups-image CUPS image - CUPS image development files REQUIRED - 1.7.2 OK -
hp-check[30358]: info: : libnetsnmp-devel libnetsnmp-devel - SNMP networking library development files REQUIRED 5.0.9 5.7.2 OK -
hp-check[30358]: info: : sane-devel SANE - Scanning library development files REQUIRED - 1.0.23 OK -
hp-check[30358]: info: : pil PIL - Python Imaging Library (required for commandline scanning with hp-scan) OPTIONAL - 1.1.7 OK -
hp-check[30358]: info: : python2X Python 2.2 or greater - Python programming language REQUIRED 2.2 2.7.6 OK -
hp-check[30358]: info: : pyqt4-dbus PyQt 4 DBus - DBus Support for PyQt4 REQUIRED 4.0 4.10.4 OK -
hp-check[30358]: info: : libjpeg libjpeg - JPEG library REQUIRED - - OK -
hp-check[30358]: info: : libpthread libpthread - POSIX threads library REQUIRED - 2.19 OK -
hp-check[30358]: info: : python-devel Python devel - Python development files REQUIRED 2.2 2.7.6 OK -
hp-check[30358]: info: : cups-devel CUPS devel- Common Unix Printing System development files REQUIRED - 1.7.2 OK -
hp-check[30358]: info: : sane SANE - Scanning library REQUIRED - 1.0.23 OK -
hp-check[30358]: info: :
hp-check[30358]: info: :---------------
hp-check[30358]: info: :| COMPILEDEP |
hp-check[30358]: info: :---------------
hp-check[30358]: info: :
hp-check[30358]: info: : libtool libtool - Library building support services REQUIRED - 2.4.2 OK -
hp-check[30358]: info: : gcc gcc - GNU Project C and C++ Compiler REQUIRED - 4.8.2 OK -
hp-check[30358]: info: : make make - GNU make utility to maintain groups of programs REQUIRED 3.0 3.81 OK -
hp-check[30358]: info: :
hp-check[30358]: info: :----------------------
hp-check[30358]: info: :| Python Extentions |
hp-check[30358]: info: :----------------------
hp-check[30358]: info: :
hp-check[30358]: info: : cupsext CUPS-Extension REQUIRED - 3.15.2 OK -
hp-check[30358]: info: : hpmudext IO-Extension REQUIRED - 3.15.2 OK -
hp-check[30358]: info: :
hp-check[30358]: info: :-----------------------
hp-check[30358]: info: :| Scan Configuration |
hp-check[30358]: info: :-----------------------
hp-check[30358]: info: :
hp-check[30358]: info: : scanext Scan-SANE-Extension REQUIRED - 3.15.2 OK -
hp-check[30358]: info: : hpaio HPLIP-SANE-Backend REQUIRED - 3.15.2 OK 'hpaio found in /etc/sane.d/dll.conf'
hp-check[30358]: info: :
hp-check[30358]: info: :-----------------------
hp-check[30358]: info: :| Other Dependencies |
hp-check[30358]: info: :-----------------------
hp-check[30358]: info: :
hp-check[30358]: info: :
hp-check[30358]: info: :------------------------------
hp-check[30358]: info: :| DISCOVERED SCANNER DEVICES |
hp-check[30358]: info: :------------------------------
hp-check[30358]: info: :
hp-check[30358]: info: :device `hpaio:/net/HP_LaserJet_Pro_MFP_M125nw?zc=DEV32050B' is a Hewlett-Packard HP_LaserJet_Pro_MFP_M125nw all-in-one

hp-check[30358]: info: :
hp-check[30358]: info: :--------------------------
hp-check[30358]: info: :| DISCOVERED USB DEVICES |
hp-check[30358]: info: :--------------------------
hp-check[30358]: info: :
hp-check[30358]: info: :No devices found.
hp-check[30358]: info: :
hp-check[30358]: info: :---------------------------------
hp-check[30358]: info: :| INSTALLED CUPS PRINTER QUEUES |
hp-check[30358]: info: :---------------------------------
hp-check[30358]: info: :
hp-check[30358]: info: :
hp-check[30358]: info: :[01mHP[0m
hp-check[30358]: info: :[01m--[0m
hp-check[30358]: info: :Type: Printer
hp-check[30358]: info: :Device URI: hp:/net/HP_LaserJet_Pro_MFP_M125nw?zc=DEV32050B
hp-check[30358]: info: :PPD: /etc/cups/ppd/HP.ppd
hp-check[30358]: info: :PPD Description: HP LaserJet Pro MFP m125nw, hpcups 3.14.3, requires proprietary plugin
hp-check[30358]: info: :Printer status: printer HP is idle. enabled since Fri 10 Apr 2015 03:33:51 PM CEST
 Rendering completed
error: Required plug-in status: Not installed
hp-check[30358]: info: :Communication status: Good
hp-check[30358]: info: :
hp-check[30358]: info: :[01mHPLocal[0m
hp-check[30358]: info: :[01m-------[0m
hp-check[30358]: info: :Type: Printer
hp-check[30358]: info: :Device URI: hp:/usb/HP_LaserJet_Pro_MFP_M125nw?serial=CNB7GDB7CF
hp-check[30358]: info: :PPD: /etc/cups/ppd/HPLocal.ppd
hp-check[30358]: info: :PPD Description: HP LaserJet Pro MFP m125nw, hpcups 3.14.3, requires proprietary plugin
hp-check[30358]: info: :Printer status: printer HPLocal disabled since Fri 10 Apr 2015 04:54:45 PM CEST -
 Unplugged or turned off
error: Required plug-in status: Not installed
error: Device not found
error: Communication status: Failed
hp-check[30358]: info: :
hp-check[30358]: info: :
hp-check[30358]: info: :--------------
hp-check[30358]: info: :| PERMISSION |
hp-check[30358]: info: :--------------
hp-check[30358]: info: :
hp-check[30358]: info: :
hp-check[30358]: info: :-----------
hp-check[30358]: info: :| SUMMARY |
hp-check[30358]: info: :-----------
hp-check[30358]: info: :
hp-check[30358]: info: :[01mMissing Required Dependencies[0m
hp-check[30358]: info: :[01m-----------------------------[0m
hp-check[30358]: info: :None
hp-check[30358]: info: :
hp-check[30358]: info: :[01mMissing Optional Dependencies[0m
hp-check[30358]: info: :[01m-----------------------------[0m
hp-check[30358]: info: :None

hp-check[30358]: info: :
hp-check[30358]: info: :[01mPlug-in Status[0m
hp-check[30358]: info: :[01m--------------[0m
error: Plug-ins need to be installed
hp-check[30358]: info: :
hp-check[30358]: info: :Total Errors: 3
hp-check[30358]: info: :Total Warnings: 0
hp-check[30358]: info: :
hp-check[30358]: info: :Run 'hp-doctor' command to prompt and fix the issues.
hp-check[30358]: info: :
hp-check[30358]: info: :Done.

Some screenshots are available at http://monostory.hu/hp

Ivo Steinmann (isteinmann) wrote :

Hi, same probleme here with 3.15.2

Maybe download the file hplip-3.15.2-plugin.run from https://www.openprinting.org/download/printdriver/auxfiles/HP/plugins/ and run

sudo hp-plugin

then select this plugin file instead of downloading it.

goutam (goutamkk) wrote :

Hi,

Please provide us the terminal output of the command 'sudo hp-plugin -i -g'.

Regards,
goutam

monostory (monostory) wrote :

@goutam,
here you are:

monostory@monostory-desktop:~$ sudo hp-plugin
[sudo] password for monostory:

[begin output]

HP Linux Imaging and Printing System (ver. 3.15.2)
Plugin Download and Install Utility ver. 2.1

Copyright (c) 2001-15 Hewlett-Packard Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

Checking for network connection...
Downloading plug-in from:
error: /home/monostory/.hplip/hplip-3.15.2-plugin.run file does not match its checksum. File may have been corrupted or altered

Done.

[end output]

Regards

Miklos

Aimo Ella (aimo-ella) wrote :

With me, this bug appeared right after upgrading to Ubuntu 15.04. Since the plug-in installer (the part that tries to make the gpg check) has been buggy for quite a while,so I suspected yet another bug in that area. However, the release notes (http://hplipopensource.com/hplip-web/release_notes.html) says that the version 3.15.2, which comes with Vivid, does not support Vivid yet. We need 3.15.4 to get support for Vivid. I have not tried installing that version yet because I would rather like to get it with Ubuntu's software updates, so I do not know if it would fix the bug or not.

Aimo Ella (aimo-ella) wrote :

It seems my problem may be separate, because when I run hp-plugin on command line, the error I get is different:

error: Python gobject/dbus may be not installed
error: Plug-in install failed.

This happens on Ubuntu 15.04. If I run hp-plugin with a specific version on python, hp-plugin fails to run with python2, whereas with python3 it runs otherwise fine, but fails with this missing gobject error.

goutam kodu (goutam-hplip) wrote :

@monostory

This issue is fixed now. We have updated the 3.15.2 plugin files and its checksum. Can you retry running command 'hp-plugin' in terminal and let us know if the issue is solved for you.

@Aimo

Can you try running command "sudo apt-get install python-dbus python-gobject python3-dbus python3-gi " and retry running command 'hp-plugin' and let us know if the issue still remains same.

Aimo Ella (aimo-ella) wrote :

@goutam kodu (goutam-hplip)

I ran the install command and then tried "sudo hp-plugin" again, but it still fails with the exact same error message.

monostory (monostory) wrote :

@goutam,
The offered solution, together with the 'walktrough' at http://hplipopensource.com/hplip-web/install/manual/distros/ubuntu.html led to success.
From my part the issue can be marked as solved.
Thank you for your effort.
Miklos

goutam kodu (goutam-hplip) wrote :

@ Aimo,

Can you please download hplip-3.15.4.run file from http://hplipopensource.com/hplip-web/gethplip.html and install it by running command 'sh hplip-3.15.4.run' in terminal. This should install the required dependencies and solve the problem.

Please let us know on the same.

Thanks,
Goutam

Aimo Ella (aimo-ella) wrote :

the LATEST version? I was hoping to avoid doing that, because I don't know how to undo all of it. Besides, https://bugs.launchpad.net/hplip/+bug/1448771 seems to indicate it might not work anyway. But since you asked, I have now run the installation, and then reinstalled my printer, and everything has succeeded so far, except one thing: after I had installed the printer via USB cable, I saw an error message on command line. It said "/usr/lib/python2.7/dist-packages/gtk-2.0/gtk/__init__.py:127: RuntimeWarning: PyOS_InputHook is not available for interactive use of PyGTK
  set_interactive(1)"
Printing works though.

Thank you.

Gray (gray-green) wrote :

in hplip-3.15.4.run:
error: Unable to recieve key from keyserver
Do you still want to install the plug-in? (y=yes, n=no*, q=quit) ? y

same as 3.15.2, but after answering "y" it continued (hplip-3.15.2 did not) and now printing.

Gray (gray-green) wrote :

BTW, both versions detected, libtools not installed, but apt-get says it is installed.

Rick M (rick3104) wrote :

 I downloaded both hplip-3.15.2-plugin.run and hplip-3.15.2-plugin.run.asc from https://www.openprinting.org/download/printdriver/auxfiles/HP/plugins/. I put them both on the desktop (but could be anywhere). I opened HP Device manager, clicked "Install Required Plugin", chose "Select and install an existing local copy of the plug-in file" and agreed to the license terms.

Now I can scan again!

Changed in hplip:
status: New → Confirmed
mathieu (mgagnon303) wrote :

I got same problem...

I'd tried to download the file from https://www.openprinting.org/download/printdriver/auxfiles/HP/plugins/ to ~/.hplip/ and then select it with hp-plugin but each time i got an error and the file disappear from ~/.hplip.

So last post of Rick M gave me a cue and then I'd tried to put the file in a different folder and then it's worked and my old printer worked again!

Tank you guys !

mgagnon303 Got it but here is another way of describing the workflow:

0. Use hplip from the Repos! Do not try to install the latest from HP unless you want to waste time like I did.
1. Download the plugin for your printer at https://www.openprinting.org/download/printdriver/auxfiles/HP/plugins/
2. run 'hp-plugin' and select the file you downloaded in step 1.
3. run 'hp setup' and you will likely have to select the file downloaded in step 1 again.?

4. Avoid HP printers. I have wasted hours with HP printers on Unix/Linux. Try Brother printers since they package their drivers as .dep installers.

Ra (raffamaiden) wrote :

I still have this problem with HPLIP 3.17.11 on Ubuntu 17.10 (installing from source of course).
When are you going to solve it?

I worked around this problem by downloading and installing the plugin manually

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers