shortcuts for time steps "<" or ">" not working

Reported by Elie Soubrié on 2010-09-23
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Helioviewer.org
Medium
Keith Hughitt

Bug Description

Usage tips indicates that it is possible to step backward or forward in time with the > and < keys.

However, it doesn't seem to have any effect on the requested date and on the images displayed (I'm using Ubutun 9.10 and firefox but I think I've already had the same problem with a newer version of Ubuntu).

It's a pity because these shortcuts would really be very usefull (especially in fullscreen mode)!

Keith Hughitt (keith-hughitt) wrote :

Thanks for reporting this Elie. What version of Firefox are you using?

It is possible that the keys are not responding because of a lack of focus. In order for any of the keyboard shortcuts to work, the document must have focus. The easiest way to do this is to simply left-click some unused portion of the web-page, then try using the shortcut. Does that work for you? Unfortunately I don't think there is too much I can do about that issue other than to try and let the users know, this is just another limitation of web applications.

Changed in helioviewer.org:
assignee: nobody → Keith Hughitt (keith-hughitt)
importance: Undecided → Medium
Elie Soubrié (elie-soubrie) wrote :

No, I don't think it's a problem of focus in the document : the fullscreen shortcut "f" works fine for example, and the "m", "+" and "-" also give the expected results.

My firefox is 3.6.10 (and my keyboard is french, in case this helps...)

Elie Soubrié (elie-soubrie) wrote :

And I've just verified that I have the same behaviour with firefix 3.6.8 under Windows (Vista) : all shortcuts seem to work except the > and < .

Elie Soubrié (elie-soubrie) wrote :

I had a look at the code and found the reason why ">" and "<" are not working :

It seems the KeyboardManager.js uses other shortcuts : "," and "." :

    onKeyPress: function (e) {
        var key, character;

        // Letters use Event.which, while arrows, etc. use Event.keyCode
        if (e.keyCode) {
            key = e.keyCode;
        }
        else if (e.which) {
            key = e.which;
        }

        // Get character pressed (letters, etc)
        character = String.fromCharCode(key);

        if (key === 37 || key === 38 || key === 39 || key === 40) {
            //Right-arrow
            if (key === 37) {
                $(document).trigger('move-viewport', [-8, 0]);
            }
[.....]
        else if (character === "f") {
            $("#fullscreen-btn").click();
        }
        else if (character === ",") {
            $("#timeBackBtn").click();
        }
        else if (character === ".") {
            $("#timeForwardBtn").click();
        }

Keith Hughitt (keith-hughitt) wrote :

Hi Elie,

Thanks for verifying the issue, and for looking into the code. The code does indeed use the "," and "." keys (since they are on the same key as the arrow brackets).

Are the keys for "<" and "," the same on your keyboard? Are you holding the shift key when you are trying to use the shortcut?

Last, can you go to:

http://helioviewer.org/keith/keyboard_input_test/

and tell me what the output of each of the arrow bracket keys are, when not holding shift?

If it is simply a matter of you following the instructions literally and typing the "<" character instead of pressing the key which has that, then the problem is again due to poor explanation on my part.

Elie Soubrié (elie-soubrie) wrote :

I got it : you suppose we all have a US keyboard ;-) like this one :
http://en.wikipedia.org/wiki/File:KB_United_States-NoAltGr.svg

That's why you put '>' and '<' instead of "," and "." in the usage tips...

But I use a french one, and it looks like that : http://en.wikipedia.org/wiki/File:KB_France.svg
And spanish people often use another one : http://en.wikipedia.org/wiki/File:KB_Spanish.svg

For non english people, I guess you'd better put the real key "," and "." in the usage tips...

concerning the http://helioviewer.org/keith/keyboard_input_test/ :
when I strike ">" it gives
keycode : 0
which : 62
char : >

and the other one gives :
keycode : 0
which : 60
char : <

Keith Hughitt (keith-hughitt) wrote :

Okay got it. I'll update the usage tips description to say "," and "." instead. Sorry for the US-focus with respect to keyboard layouts: so far we haven't really had many people from Europe to give us feedback. You are the first, and it's very much appreciated :)

Keith Hughitt (keith-hughitt) wrote :

Actually,

Another option would be to accept either "<" or "," to move backward in time, and either ">" or "." to move forward in time.
Which would you prefer? Accepting both shortcuts, or only "."/"," ?

Elie Soubrié (elie-soubrie) wrote :

Accepting both solutions is much better from my point of view :
the "." needs <SHIFT> and the "," doesn't on a french keyboard...

Keith Hughitt (keith-hughitt) wrote :

Okay, I added support for using either character, and updated the usage tips dialog to reflect the changes. The changes should show up by the end of next week when I hope to do a release of Helioviewer.org 2.0.3 (https://edge.launchpad.net/helioviewer.org/+milestone/2.0.3)

Changed in helioviewer.org:
status: New → Fix Committed
milestone: none → 2.0.3
Changed in helioviewer.org:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers