add qpid-python to requirements.txt

Bug #1225191 reported by Richard Su on 2013-09-13
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
OpenStack Compute (nova)
Medium
Ben Nemec
OpenStack Heat
Fix Released
Medium
Ben Nemec

Bug Description

If one tries using qpid instead of rabbitmq with heat, when heat-engine starts up it will complain that the qpid.messaging library is missing. To fix this, qpid-python should be included in requirements.txt.

2013-09-13 20:47:51.624 7031 INFO heat.engine.environment [-] Registering AWS::CloudFormation::WaitCondition -> <class 'heat.e
ngine.resources.wait_condition.WaitCondition'>
2013-09-13 20:47:51.634 7031 ERROR heat.openstack.common.threadgroup [-] Failed to import qpid.messaging
2013-09-13 20:47:51.634 7031 TRACE heat.openstack.common.threadgroup Traceback (most recent call last):
2013-09-13 20:47:51.634 7031 TRACE heat.openstack.common.threadgroup File "/opt/stack/venvs/heat/local/lib/python2.7/site-pa
ckages/heat/openstack/common/threadgroup.py", line 117, in wait
2013-09-13 20:47:51.634 7031 TRACE heat.openstack.common.threadgroup x.wait()
2013-09-13 20:47:51.634 7031 TRACE heat.openstack.common.threadgroup File "/opt/stack/venvs/heat/local/lib/python2.7/site-pa
ckages/heat/openstack/common/threadgroup.py", line 49, in wait
2013-09-13 20:47:51.634 7031 TRACE heat.openstack.common.threadgroup return self.thread.wait()
2013-09-13 20:47:51.634 7031 TRACE heat.openstack.common.threadgroup File "/opt/stack/venvs/heat/local/lib/python2.7/site-pa
ckages/eventlet/greenthread.py", line 168, in wait
2013-09-13 20:47:51.634 7031 TRACE heat.openstack.common.threadgroup return self._exit_event.wait()
2013-09-13 20:47:51.634 7031 TRACE heat.openstack.common.threadgroup File "/opt/stack/venvs/heat/local/lib/python2.7/site-pa
ckages/eventlet/event.py", line 116, in wait
2013-09-13 20:47:51.634 7031 TRACE heat.openstack.common.threadgroup return hubs.get_hub().switch()
2013-09-13 20:47:51.634 7031 TRACE heat.openstack.common.threadgroup File "/opt/stack/venvs/heat/local/lib/python2.7/site-pa
ckages/eventlet/hubs/hub.py", line 187, in switch

Steven Hardy (shardy) wrote :

Hmm, I'm not sure we want to do this - requirements.txt reflects the requirements for the default configuration, and I don't think everyone using rabbit will really want to be forced to install qpid-python?

Clint Byrum (clint-fewbar) wrote :

Seems unfair to decline to make the opposite statement.. qpid users likely don't want kombu.

Angus Salkeld (asalkeld) on 2013-12-11
Changed in heat:
status: New → Opinion
Robert Collins (lifeless) wrote :

So this is a real problem: we're faced with patching upstream requirements to install heat on redhat platforms. Whats the actual objection to bringing in the library?

Changed in heat:
status: Opinion → New
Steve Baker (steve-stevebaker) wrote :

I have no problem including qpid-python in heat's requirements.txt, especially since we have downstream people attempting to deploy heat with qpid that depend on having a complete requirements.txt.

It appears that the the burden to those not using qpid-python will be minimal.

Changed in heat:
status: New → Confirmed
importance: Undecided → Medium
milestone: none → icehouse-3

Fix proposed to branch: master
Review: https://review.openstack.org/69704

Changed in heat:
assignee: nobody → Ben Nemec (bnemec)
status: Confirmed → In Progress
Matt Riedemann (mriedem) wrote :

I don't want to speak for all of nova so I brought it up in IRC, but this is more than just nova and heat, it would also be other core projects like cinder and glance, why aren't those listed here?

Matt Riedemann (mriedem) wrote :

Seems like this is something that should be brought up in the openstack-dev mailing list.

Changed in nova:
status: New → Opinion
Russell Bryant (russellb) wrote :

I don't see any reason not to add this, personally. It's a pure python lib on pypi. It should be listed like everything else

Changed in nova:
status: Opinion → Confirmed
importance: Undecided → Medium
Matt Riedemann (mriedem) wrote :

Would be nice if we could get at least version 0.23 on pypi so we could pin on that to get this fix:

https://issues.apache.org/jira/browse/QPID-4903

And this is something else I've had to patch internally with 0.22:

https://issues.apache.org/jira/browse/QPID-4804

Ben Nemec (bnemec) on 2014-01-29
Changed in nova:
assignee: nobody → Ben Nemec (bnemec)
Ben Nemec (bnemec) wrote :

Yeah, I'm planning to add more projects to this bug as I clean out the workarounds in tripleo. For some reason we didn't have a workaround in place for Nova though so it was higher priority for me. This was already open for Heat, and there's a separate existing bug for Neutron as well.

Also, I created https://issues.apache.org/jira/browse/QPID-5523 for the qpid-python version on pypi.

Changed in nova:
status: Confirmed → In Progress
Thierry Carrez (ttx) on 2014-03-05
Changed in heat:
milestone: icehouse-3 → icehouse-rc1
Changed in heat:
status: In Progress → Fix Committed
Thierry Carrez (ttx) on 2014-03-31
Changed in heat:
status: Fix Committed → Fix Released
Thierry Carrez (ttx) on 2014-04-17
Changed in heat:
milestone: icehouse-rc1 → 2014.1
Joe Gordon (jogo) wrote :

There was a discussion about this a while back and the consensus was to create a requirements.d directory to better reflect the nuances in requirements

Changed in nova:
status: In Progress → Opinion
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers