Request: Please backport "tor" 0.2.xx to Hardy

Bug #275438 reported by Sandeep on 2008-09-28
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Hardy Backports
Undecided
Unassigned

Bug Description

Please backport a 0.2.xx release of "tor" to Hardy. The latest version in the Hardy repositories is 0.1.2.19-2, whereas the latest stable release of tor is 0.2.0.31. Stable 0.2.xx releases have been out for sometime now.
     As tor is in its infancy and is actively under development, a 0.2.xx release should be significantly improved compared to a 0.1.xx one.

Thanks,
 Sandeep.

Valentin Rocher (bishiboosh) wrote :

You have to wait until it's in intrepid, only packages in Intrepid can be backported

Changed in hardy-backports:
status: New → Incomplete

Marked invalid since there is no intrepid version. Please feel free to reopen once a newer package is available in intrepid or jaunty.

Changed in hardy-backports:
status: Incomplete → Invalid

Okay, I understand. Thanks, Sandeep.

On Wed, Oct 1, 2008 at 2:05 AM, Michael Casadevall
<email address hidden>wrote:

> Marked invalid since there is no intrepid version. Please feel free to
> reopen once a newer package is available in intrepid or jaunty.
>
> ** Changed in: hardy-backports
> Status: Incomplete => Invalid
>
> --
> Request: Please backport "tor" 0.2.xx to Hardy
> https://bugs.launchpad.net/bugs/275438
> You received this bug notification because you are a direct subscriber
> of the bug.
>

--
It is surely a great calamity for a human being to have no obsessions.
                                                 - Robert Bly (American
poet, 1926- )

ubuntu_demon (ubuntu-demon) wrote :
Download full text (5.1 KiB)

tor is availble from Intrepid. It builds fine using prevu but it's not installable because it seems to want to have libssl0.9.8 uninstalled :

$ sudo aptitude install tor
Reading package lists... Done
Building dependency tree
Reading state information... Done
Reading extended state information
Initializing package states... Done
Building tag database... Done
The following packages are BROKEN:
  apache2-utils bind9-host dnsutils encfs hpijs hplip inkscape libcurl3 libdns32 libdns35 libneon26 libneon27 libopal-2.2 libpq5 libpt-1.10.10
  libsasl2-modules libsnmp15 libwvstreams4.4-extras linuxdcpp miro nmap ntp ntpdate openoffice.org-core openssh-client openssh-server openssl
  python-openssl python2.5 rdesktop socat tcpdump tor transmission-gtk w3m wget wpasupplicant xchat
The following NEW packages will be automatically installed:
  libevent1 privoxy tor-geoipdb tsocks
The following packages will be automatically REMOVED:
  libssl0.9.8
The following NEW packages will be installed:
  libevent1 privoxy tor-geoipdb tsocks
The following packages will be REMOVED:
  libssl0.9.8
0 packages upgraded, 6 newly installed, 1 to remove and 0 not upgraded.
Need to get 1938kB/3875kB of archives. After unpacking 2974kB will be used.
The following packages have unmet dependencies:
  linuxdcpp: Depends: libssl0.9.8 (>= 0.9.8f-1) but it is not installable
  apache2-utils: Depends: libssl0.9.8 (>= 0.9.8f-1) but it is not installable
  openoffice.org-core: Depends: libssl0.9.8 (>= 0.9.8f-1) but it is not installable
  miro: Depends: libssl0.9.8 (>= 0.9.8f-1) but it is not installable
  libneon26: Depends: libssl0.9.8 (>= 0.9.8e-1) but it is not installable
  libneon27: Depends: libssl0.9.8 (>= 0.9.8e-1) but it is not installable
  bind9-host: Depends: libssl0.9.8 (>= 0.9.8f-1) but it is not installable
  libsnmp15: Depends: libssl0.9.8 (>= 0.9.8f-1) but it is not installable
  nmap: Depends: libssl0.9.8 (>= 0.9.8f-1) but it is not installable
  encfs: Depends: libssl0.9.8 (>= 0.9.8c-1) but it is not installable
  dnsutils: Depends: libssl0.9.8 (>= 0.9.8f-1) but it is not installable
  xchat: Depends: libssl0.9.8 (>= 0.9.8f-1) but it is not installable
  hpijs: Depends: libssl0.9.8 (>= 0.9.8f-1) but it is not installable
  libdns32: Depends: libssl0.9.8 (>= 0.9.8f-1) but it is not installable
  libdns35: Depends: libssl0.9.8 (>= 0.9.8f-1) but it is not installable
  libsasl2-modules: Depends: libssl0.9.8 (>= 0.9.8f-1) but it is not installable
  hplip: Depends: libssl0.9.8 (>= 0.9.8f-1) but it is not installable
  libwvstreams4.4-extras: Depends: libssl0.9.8 (>= 0.9.8f-1) but it is not installable
  libpt-1.10.10: Depends: libssl0.9.8 (>= 0.9.8f-1) but it is not installable
  python2.5: Depends: libssl0.9.8 (>= 0.9.8f-1) but it is not installable
  socat: Depends: libssl0.9.8 (>= 0.9.8e-1) but it is not installable
  tcpdump: Depends: libssl0.9.8 (>= 0.9.8e-1) but it is not installable
  openssh-client: Depends: libssl0.9.8 (>= 0.9.8g-4ubuntu3.1) but it is not installable
  python-openssl: Depends: libssl0.9.8 (>= 0.9.8f-1) but it is not installable
  libcurl3: Depends: libssl0.9.8 (>= 0.9.8f...

Read more...

Changed in hardy-backports:
status: Invalid → Incomplete
ubuntu_demon (ubuntu-demon) wrote :

This is what I get when trying to install tor (build using prevu) using apt-get :

$ sudo apt-get install tor
[sudo] password for roald:
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.

Since you only requested a single operation it is extremely likely that
the package is simply not installable and a bug report against
that package should be filed.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
  tor: Depends: libssl0.9.8 (>= 0.9.8f-1) but it is not going to be installed
E: Broken packages

ubuntu_demon (ubuntu-demon) wrote :

~$ dpkg -l | grep libssl
ii libssl0.9.8 0.9.8g-4ubuntu3.3 SSL shared libraries

ubuntu_demon (ubuntu-demon) wrote :

The strange thing is that both tor 0.1.2.19-2 and tor 0.2.0.31-1~8.04prevu1 depend on the same libssl0.9.8 (>= 0.9.8f-1)

After removing tor from /var/cache/prevu/hardy-debs/Packages installing tor 0.1.2.19-2 is no problem :

$ sudo aptitude install tor
Reading package lists... Done
Building dependency tree
Reading state information... Done
Reading extended state information
Initializing package states... Done
Building tag database... Done
The following NEW packages will be automatically installed:
  libevent1 privoxy socat tsocks
The following NEW packages will be installed:
  libevent1 privoxy socat tor tsocks
0 packages upgraded, 5 newly installed, 0 to remove and 0 not upgraded.
Need to get 2908kB of archives. After unpacking 6685kB will be used.
Do you want to continue? [Y/n/?]

agent 8131 (agent-8131) wrote :

In no way do I want to discourage a backporting effort but I did want to note that people might want to consider using the tor repository:

To get version 0.2.0.34 add these lines to your sources:

deb http://mirror.noreply.org/pub/tor hardy main
deb-src http://mirror.noreply.org/pub/tor hardy main

To get version 0.2.1.14 add these lines to your sources:

deb http://mirror.noreply.org/pub/tor experimental-0.2.1.x-hardy main
deb-src http://mirror.noreply.org/pub/tor experimental-0.2.1.x-hardy main

This works for all Ubuntu versions from dapper to jaunty.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers