libgranite1 not inclused in ppa

Bug #1192223 reported by Devin on 2013-06-18
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
GWoffice
Undecided
Unassigned

Bug Description

Simple as the title. The package libgranite1 is missing from the ppa. Gwoffice can not be installed without it in Ubuntu 13.04 64bit. This package should be part of this ppa.

I've seen some post where people suggest installing the entire elementary-os ppa to get this package, but asking people to install another ppa, just to use yours is nuts. Put libgranite1 in your ppa so users don't have to risk thier system by installing a huge ppa full of possible package conflicts.

Thank you.

Jason Schrader (whoabuddy) wrote :

I was hoping to try out the software and I am having the same dependency issue on Linux Mint, additional info below:

Output of uname -a:

Linux whoabuddy-mint 3.5.0-17-generic #28-Ubuntu SMP Tue Oct 9 19:31:23 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux

Commands Run:

sudo add-apt-repository ppa:tombeckmann/ppa
sudo apt-get update && sudo apt-get install gwoffice

Error Message:

Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 gwoffice : Depends: libgranite1 but it is not installable
E: Unable to correct problems, you have held broken packages.

Máthé Zoltán (mathzol) wrote :

Yep, here is, too!

:~# uname -a
Linux mathe-laptop 3.5.0-37-generic #58~precise1-Ubuntu SMP Wed Jul 10 17:48:11 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux

Jan Abramek (janovov) wrote :

And me too
Linux JPMA-uVAIO 3.8.0-27-generic #40-Ubuntu SMP Tue Jul 9 00:17:05 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux

Petulko (peter-gazo) wrote :

And me too

petulko@lenovo:~$ uname -a
Linux lenovo 3.8.0-31-generic #46-Ubuntu SMP Tue Sep 10 20:03:44 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux

Petulko (peter-gazo) wrote :

If you encounter this kind of error "gwoffice : Depends: libgranite1 but it is not installable", you might need to add Elemntary OS daily PPA which provides libgranite1 package. So, all you need to do is execute this command to solve such error:

sudo add-apt-repository ppa:elementary-os/daily
sudo apt-get update
sudo apt-get install gwoffice #repeat the installation

Devin (thatguyweallknow) wrote :

As I said in the description of the bug report; "I've seen some post where people suggest installing the entire elementary-os ppa to get this package, but asking people to install another ppa, just to use yours is nuts. Put libgranite1 in your ppa so users don't have to risk thier system by installing a huge ppa full of possible package conflicts."

Why are you asking people to risk their systems just so you don't have to add ONE package to your PPA?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers