Doesn't work on Intrepid Ibex

Bug #297324 reported by markuz on 2008-11-12
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Gwibber
Undecided
Unassigned

Bug Description

I was a happy gwibber user with Ubuntu hardy, but now in intrepid it just don't work. every time I launch it it dies with a sementation fault error.

I have accounts for twitter, facebook, flickr and identi.ca.

I don't know if this is a bug of python-webkitgtk or simplejson, but even using just one of these accounts it breaks.

I event try to purge gwibber (which also purges simplejson and python-webkitgtk) and reinstall, and doesnt work.

These are the packages Im using

gwibber version 0.7~bzr120~intrepid~ppa0
python-webkitgtk version 1.0.1-0ubuntu2
python-simplejson version 1.9.1-1

Any Idea about how to debug to give you more info ?

Ryan Paul (segphault) wrote :

Do you see anything else besides a segmentation fault? Any error message at stdout? Does the window appear at all?

Could you please try copy/pasting following at the command line and let me know what happens?

python -c 'import gtk, webkit; print webkit; w = gtk.Window(); w.add(webkit.WebView()); w.connect("destroy", gtk.main_quit); w.show_all(); gtk.main()'

Thanks!

Changed in gwibber:
status: New → Incomplete
markuz (markuz) wrote :

Hi. I've got nothing else besides the segmentation fault, nothing is prnted to the stdout or stderr.

The window does appear, then it fetch the data from the accounts and then before it can show anything it dies. When the only account enabled is the identi.ca account gwibber let me see the updates once, but when it refresh it cash again.

using the command you ask me to run I see a white window and this is all I got in the shell:

markuz$ python -c 'import gtk, webkit; print webkit; w = gtk.Window();
> w.add(webkit.WebView()); w.connect("destroy", gtk.main_quit);
> w.show_all(); gtk.main()'
<module 'webkit' from '/var/lib/python-support/python2.5/gtk-2.0/webkit.so'>

Anything else where I can help please let me know.

Ryan Paul (segphault) wrote :

Thanks for providing more information! The white window and the module output line from the test command confirms that WebKit and the Python bindings are working for you. It seems like the problem comes up when it tries to load content into the frame. That narrows it down a lot, so now I know where to look.

Did you do a fresh install for Intrepid, or did you use Ubuntu's software upgrade feature? I've heard from several users who upgraded from Hardy to Intrepid that it has caused Gwibber bugs for them. The bug you are experiencing seems to be different, but it might be related in some way.

markuz (markuz) wrote :

I do use Ubuntu dist-upgrade method to install Intrepid. I knew this upgrades where not so "clean" but I have no time to stop my machine for one day installing the clean OS and then all the whole applications I use in my every day.

Anything else I can do you know I'm here.

Ursula Junque (ursinha) wrote :

My versions are:
python-simplejson (1.9.1-1ubuntu1~ppa0)
python-webkitgtk (1.0.1-0ubuntu2)
gwibber (0.7~bzr120~hardy~ppa1)

I'm in a Intrepid box that was updated with dist-upgrade from a hardy one. I'm not able to use gwibber now with this last gwibber update, it hangs, but only when I set it up to also receive messages, not just send them. I have one identi.ca and one twitter account set up.

It freezes and spits the following in the console:

Exception in thread Thread-1:
Traceback (most recent call last):
  File "/usr/lib/python2.5/threading.py", line 486, in __bootstrap_inner
    self.run()
  File "/usr/lib/python2.5/threading.py", line 446, in run
    self.__target(*self.__args, **self.__kwargs)
  File "/usr/lib/python2.5/site-packages/gwibber/client.py", line 685, in process
    view.load_messages()
  File "/usr/lib/python2.5/site-packages/gwibber/gwui.py", line 52, in load_messages
    indent=4, default=str)
  File "build/bdist.linux-i686/egg/simplejson/__init__.py", line 216, in dumps
TypeError: __init__() got an unexpected keyword argument 'default'

I've also tried the remove --purge approach, with no results.

Ursula Junque (ursinha) wrote :

What else information would be helpful?

Changed in gwibber:
status: Incomplete → New
Ryan Paul (segphault) wrote :

@Ursula: your problem is not the same as the one that Markuz is experiencing. The "unexpected keyword argument" error indicates that the version of simplejson you are using is too old to be supported by Gwibber. Please upgrade to version 1.9.1 or higher of simplejson.

Ursula Junque (ursinha) wrote :

Hi Ryan, I'm using the version 1.9.1, as I posted above.

Ryan Paul (segphault) wrote :

Are you sure it's uing simplejson 1.9.1? It should not be giving you that error message. :-(

markuz (markuz) wrote :

Just wanna let you know that I have just updated my libwebkit ( 1.0.1-4+r38688~intrepidppa1) and now gwibber is working fine!

Ryan Paul (segphault) wrote :

Thanks, Markuz!

Changed in gwibber:
status: New → Invalid

I know that the instructions for Gwibber on Intrepid say that you DON't need the PPA for webkit, but after trying to remove Gwibber, Python-webkit and libwebkit and then reinstalling...

I get the error:

     libwebkit-1.0-1:

     Package libwebkit-1.0-1 has no available version, but exists in the database.
     This typically means that the package was mentioned in a dependency and never uploaded, has been obsoleted or is not available with the contents of sources.list

Only if I add the appropriate lines for http://ppa.launchpad.net/webkit-team/ubuntu intrepid main to my sources is Synaptic able to find THEIR version of libwebkit. Shouldn't libwebkit be in the Intrepid repos?

If I add their PPA, I am able to install gwibber, python-webkit (and force version to the Intrepid repos) and libwebkit...

...but Gwibber still won't run. Same error before (not finding the right library)

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers