Recent changes in Foursquare's API result in plugin failing to parse results

Bug #1012231 reported by Mark Tully on 2012-06-12
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Gwibber
Low
Mark Tully
gwibber (Ubuntu)
Low
Unassigned
Precise
Low
Unassigned

Bug Description

Impact:

Foursquare recently introduced a website redesign, with accompanying changes in their API. As a result of this, the Foursquare plugin can no longer parse results correctly and wll not display any.

Test case:

ensure the gwibber-service process has been restarted since apply the update then verify foursquare check-ins are showing up in your stream.

Regression potential:

There isn't really any regression potential, since foursquare changed the API without this change it isn't working at all.

---

The 'canonicalurl' key has been removed from the API result. Currently, the plugin uses this to determine the sender url. Instead, the user id must be used to construct an sender url.

Related branches

Changed in gwibber:
assignee: nobody → Mark Tully (markjtully)
status: New → Confirmed
Changed in gwibber (Ubuntu):
status: New → Confirmed
Changed in gwibber:
importance: Undecided → Low
Changed in gwibber (Ubuntu):
importance: Undecided → Low
Changed in gwibber (Ubuntu Precise):
importance: Undecided → Low
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gwibber - 3.5.2-0ubuntu1

---------------
gwibber (3.5.2-0ubuntu1) quantal; urgency=low

  * New upstream release
    - New twitter icons better matching twitter's guidelines, thanks
      Mark Tully (LP: #1012408)
    - foursquare: Changed to using urls based off Foursquare user ids rather
      than 'canonicalurl' due to 'canonicalurl' being removed from
      Foursquare's API (LP: #1012231)
    - foursquare: Added support for displaying 'likes', new to Foursquare API
  * debian/patches/lp_934530.patch
    - Catch IOError when opening a url with urllib2, prevents crash for
      connection reset errors (LP: #934530)
 -- Ken VanDine <email address hidden> Thu, 14 Jun 2012 22:56:53 -0400

Changed in gwibber (Ubuntu):
status: Confirmed → Fix Released
Ken VanDine (ken-vandine) wrote :

To verify this fix for 12.04, ensure the gwibber-service process has been restarted since apply the update then verify foursquare check-ins are showing up in your stream.

There isn't really any regression potential, since foursquare changed the API without this change it isn't working at all.

Changed in gwibber (Ubuntu Precise):
status: New → In Progress
description: updated

Hello Mark, or anyone else affected,

Accepted gwibber into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/gwibber/3.4.2-0ubuntu2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please change the bug tag from verification-needed to verification-done. If it does not, change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in gwibber (Ubuntu Precise):
status: In Progress → Fix Committed
tags: added: verification-needed
Mark Tully (markjtully) wrote :

Verified. With 3.4.2-0ubuntu2, Foursquare results once again show up in the stream.

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gwibber - 3.4.2-0ubuntu2

---------------
gwibber (3.4.2-0ubuntu2) precise-proposed; urgency=low

  * debian/patches/lp_1012231.patch
    - foursquare: Changed to using urls based off Foursquare user ids rather
      than 'canonicalurl' due to 'canonicalurl' being removed from
      Foursquare's API (LP: #1012231)
  * debian/patches/lp_934530.patch
    - Catch IOError when opening a url with urllib2, prevents crash for
      connection reset errors (LP: #934530)
 -- Ken VanDine <email address hidden> Wed, 27 Jun 2012 15:42:00 -0400

Changed in gwibber (Ubuntu Precise):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers