when change bookmark order, application crashed

Bug #149468 reported by Young-Ho Cha
22
Affects Status Importance Assigned to Milestone
GTK+
Unknown
Critical
gtk+2.0 (Debian)
Fix Released
Unknown
gtk+2.0 (Ubuntu)
Medium
Ubuntu Desktop Bugs

Bug Description

It can reproduce following step.

1. open nautilus window.

2. go user home directory

3. click your "Desktop" directory and drag'n drop bookmark pane.

4. run "zenity --file-selection"

5. move "Desktop" bookmark for change bookmark order.

6. zenity will be crashed.

Other information.

In gtkfilechooser, "Desktop" directory can't be added bookmark, because it is already in "Volume" bookmark.

but Nautilus can add.

Revision history for this message
Sebastien Bacher (seb128) wrote :

Thanks for your bug report. Please try to obtain a backtrace http://wiki.ubuntu.com/DebuggingProgramCrash and attach the file to the bug report. This will greatly help us in tracking down your problem.

Changed in gtk+2.0:
assignee: nobody → desktop-bugs
importance: Undecided → Medium
status: New → Incomplete
Revision history for this message
Sebastien Bacher (seb128) wrote :

What version of Ubuntu do you use?

Revision history for this message
Young-Ho Cha (ganadist-gmail) wrote :

I'm using Gutsy and libgtk2.0-0 2.12.0-1ubuntu2.

I'll attach backtrace

Revision history for this message
Sebastien Bacher (seb128) wrote :

Thank you for the details

Changed in gtk+2.0:
status: Incomplete → Confirmed
Revision history for this message
Sebastien Bacher (seb128) wrote :
Changed in gtk+2.0:
status: Confirmed → Triaged
Changed in gtk:
status: Unknown → New
Revision history for this message
Young-Ho Cha (ganadist-gmail) wrote :

I found zenity didn't crashed on other distribution based gtk+ 2.12(Rawhide, Gentoo with gnome-experimental layout).

Just disappeared Desktop icon in bookmark when release mouse button.

So, I propose that reassign bug to nautilus in gnome bugzilla, and change priority to enhanced. cause nautilus might have same behavier with gtkfilechooser.

And assertion is happened only ubuntu. It need some more tracking.

Revision history for this message
Sebastien Bacher (seb128) wrote :

The bug is a GtkFileChooser crasher, it has nothing to do with nautilus. Are you sure you tried the same GTK version in other distribution and not the new 2.12.1 which is available now?

Revision history for this message
Young-Ho Cha (ganadist-gmail) wrote :

The point is that bookmark behaviers of nautilus and gtkfilechooser are different. It is not consistent in desktop environment. So I propose that reassign in upstream issue tracker.

Of course, GtkFileChooser crasher must be resolved. But it seems that is not role of upstream. That is ubuntu specific bug.

And My gentoo desktop has gtk+ 2.12.0 vanilla, rawhide has gtk+2.12.1.

Revision history for this message
Sebastien Bacher (seb128) wrote :

Looks like the issue is due to a Debian patch indeed, I've sent them a bug on http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=447279

Changed in gtk+2.0:
status: Unknown → New
Revision history for this message
Young-Ho Cha (ganadist-gmail) wrote :
Changed in gtk:
status: New → Invalid
Changed in gtk+2.0:
status: New → Fix Released
Revision history for this message
Greg A (etulfetulf) wrote :

This bug was fixed upstream and synced before Hardy. I am unable to reproduce this bug on Intrepid testing so I am marking this fixed.

Changed in gtk+2.0:
status: Triaged → Fix Released
Changed in gtk:
importance: Unknown → Critical
status: Invalid → Unknown
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.