Introductory task set should suggest organizing tasks in a tag hierarchy

Bug #615027 reported by Christoph Haas on 2010-08-08
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Getting Things GNOME!
Low
Bertrand Rousseau

Bug Description

[Problem]
It's not evident to newbies how best to organize their tasks. The default set of tasks on initial start up do suggest using tags, but don't suggest much about tag hierarchies. However, the tool is sort of designed with this organizational scheme in mind.

So even if it's not the *only* way to organize tasks in gtg, perhaps gtg could be more explicit in suggesting it. It could help reduce some of the confusion and impedance mismatch we see from people who are still getting up to speed with the tool and have progressed beyond the "simple shopping list" stage to where they need deeper organization.

[Original Report]
I would like to be able to group my tasks per category. Take a look at "gtodo" - it's the list of categories on the bottom-left side of the windows there.

Example:

- "Household" category: vacuuming the appartment, buying cat food, painting walls, paying taxes
- "Open-source projects" category: fixing bugs in GTD, submitting Firefox extension, answering user requests
- "Work" category: repair the UPS, tidy up the server room, replace faulty patch cable in conference room

That way I could just switch to the right context and would just see tasks that belong to this context. Currently I see all the householding tasks at work which doesn't help because I'm kilometers away.

Related branches

  Le 08/08/2010 16:27, Christoph Haas a écrit :
> Public bug reported:
>
> I would like to be able to group my tasks per category. Take a look at
> "gtodo" - it's the list of categories on the bottom-left side of the
> windows there.
>
> Example:
>
> - "Household" category: vacuuming the appartment, buying cat food, painting walls, paying taxes
> - "Open-source projects" category: fixing bugs in GTD, submitting Firefox extension, answering user requests
> - "Work" category: repair the UPS, tidy up the server room, replace faulty patch cable in conference room
>
> That way I could just switch to the right context and would just see
> tasks that belong to this context. Currently I see all the householding
> tasks at work which doesn't help because I'm kilometers away.
>
> ** Affects: gtg
> Importance: Undecided
> Status: New
>
Can't you do that with tags ? I think they are exactly what you want.

Christoph Haas (chaas) wrote :

Am 08.08.2010 18:39, schrieb Pititjo:
> Can't you do that with tags ? I think they are exactly what you want.

On second thoughts you are probably right. Contexts/categories would be
another layer working like tags. I've been experimenting with tags now
and it seems it does that. Tag hierarchy:

- Work
  - Delegated
    - John
    - Jack
    - Gina
  - Boss
  - WeeklyMeeting
- Private
  - Supermarket
  - Housework

So clicking on "Work" hides everything "Private". Different than I
expected but seems to work. So I guess my bug/wishlist report can be closed.

Changed in gtg:
importance: Undecided → Wishlist

Hi Chris,

It's funny - your hierarchy in comment #2 is basically the same way I came to organize my own tasks. :-)

- Work
  - Ubuntu
    - Arsenal
    - Xorg
  - Launchpad
- Personal
  - house
  - software
    - gtg
    - inkscape

Anyway, so yeah tags is 100% the way to solve this need. Perhaps we could be more explicit in suggesting this layout via the default initial tasks by having @work and @personal parent tasks. I'll look into adding that.

Fwiw, using a hierarchy like this will tend to play into gtg's strengths. For instance, during my work day I turn on the Work View and watch the total task count next to @work as a measure of my day's work. Another example is the Export plugin, which lets you select say, '@work', so you can export a list of tasks completed for the past week. The gtcli tool also has some functions which are useful to use on all of your work tasks, or all your personal tasks. I think as more and more features get added they'll also build on the assumption that one's tasks are organized via tags in a tag hierarchy of some fashion.

Changed in gtg:
status: New → Triaged
summary: - Different set of tasks per context/category
+ Introductory task set should suggest organizing tasks in a tag hierarchy
Bryce Harrington (bryce) on 2010-08-08
description: updated
Bryce Harrington (bryce) wrote :

I think to solve this bug we should update the default set of tasks. Currently they include a couple tags (@money and @to_pay IIRC).

Instead, I think we should have the default task set include two more tags: @personal and @work. If possible, one of the original tags should be a child of one or the other of these, to show the tag hierarchy explicitly. The tutorial should also direct the user in moving the original tags to be children of @personal or @work.

By using @personal and @work high level tags, and walking the user through adding tags to them, it will subtly nudge them towards organizing their projects and tasks according to this type of split, since I think this approach enables them to best maximize the use of gtg's features.

I could easily see people wanting to ultimately have separate backends each for personal and work tasks, so getting them pointed in the direction to organize tasks by @personal and @work will help get them started in a direction that will simplify their life if/when they want to split things into two backends.

Luca, does this make sense? Bertrand if you're watching I'd also like to hear your feedback on this from a UI perspective.

It makes sense. I was thinking that we should rewrite the initial set of
task as an interactive tutorial, like videogames have(like "try making this
task as done", or "set a due date" to continue). This would be a plugin. The
nice thing is that it can be done over time, when one feels like it, and
it's more entertaining than the current one.

On Aug 8, 2010 10:40 PM, "Bryce Harrington" <email address hidden>
wrote:

I think to solve this bug we should update the default set of tasks.
Currently they include a couple tags (@money and @to_pay IIRC).

Instead, I think we should have the default task set include two more
tags: @personal and @work. If possible, one of the original tags
should be a child of one or the other of these, to show the tag
hierarchy explicitly. The tutorial should also direct the user in
moving the original tags to be children of @personal or @work.

By using @personal and @work high level tags, and walking the user
through adding tags to them, it will subtly nudge them towards
organizing their projects and tasks according to this type of split,
since I think this approach enables them to best maximize the use of
gtg's features.

I could easily see people wanting to ultimately have separate backends
each for personal and work tasks, so getting them pointed in the
direction to organize tasks by @personal and @work will help get them
started in a direction that will simplify their life if/when they want
to split things into two backends.

Luca, does this make sense? Bertrand if you're watching I'd also like
to hear your feedback on this from a UI perspective.

--
Introductory task set should suggest organizing tasks in a tag hierarchy
https://bugs.launchpad.net/bugs/615027
You received this bug notification because you are subscribed to Getting
Things GNOME!.

Status in Getting Things GNOME!: Triaged

Bug description:
[Problem]
It's not evident to newbies how best to organize their tasks. The default
set of tasks on initial start up do suggest using tags, but don't suggest
much about tag hierarchies. However, the tool is sort of designed with this
organizational scheme in mind.

So even if it's not the *only* way to organize tasks in gtg, perhaps gtg
could be more explicit in suggesting it. It could help reduce some of the
confusion and impedance mismatch we see from people who are still getting up
to speed with the tool and have progressed beyond the "simple shopping list"
stage to where they need deeper organization.

[Original Report]
I would like to be able to group my tasks per category. Take a look at
"gtodo" - it's the list of categories on the bottom-left side of the windows
there.

Example:

- "Household" category: vacuuming the appartment, buying cat food, painting
walls, paying taxes
- "Open-source projects" category: fixing bugs in GTD, submitting Firefox
extension, answering user requests
- "Work" category: repair the UPS, tidy up the server room, replace faulty
patch cable in conference room

That way I could just switch to the right context and would just see tasks
that belong to this context. Currently I see all the householding tasks at
work which doesn't help because I'm kilometers away.

Chris Johnston (cjohnston) wrote :

I don't like how, if you complete all of the tasks of a certain tag, say @Ubuntu, the tag disappears.. I would like to have the ability to have the tag remain visible.

Lionel Dricot (ploum) wrote :

Chris > well, then come the problem : how would gtg know that it should display or not some tags ? Displaying all tags is not an option because when you write "@tag", you create the tag "@t" then remove it for "@ta" and again.

A feature we could have (but it would be a separate report), would have the ability to "pinpoint" a tag, so the user specificaly ask for that specific tag to be permanently displayed.

Am 09.08.2010 03:59, schrieb Chris Johnston:
> I don't like how, if you complete all of the tasks of a certain tag, say
> @Ubuntu, the tag disappears.. I would like to have the ability to have
> the tag remain visible.

Indeed. I'd go one step further and wish for a more seperate tags
editor. At first I right-clicked on the left pane trying to add a tag. I
was surprised to see that didn't work. Same for getting rid of a tag by
opening every single task and remove the tag text manually.

After all assigning tags to tasks is easy by dragging the task over the
tag. So adding tags freely and keeping them regardless if they have
tasks assigned would be great.

 Christoph

Izidor Matušov (izidor) on 2011-08-13
Changed in gtg:
milestone: none → 0.3
Izidor Matušov (izidor) on 2011-08-15
Changed in gtg:
importance: Wishlist → Low
Changed in gtg:
status: Triaged → Fix Committed
status: Fix Committed → Confirmed
Izidor Matušov (izidor) on 2012-07-23
Changed in gtg:
assignee: nobody → Bertrand Rousseau (bertrand-rousseau)
status: Confirmed → Fix Committed
Changed in gtg:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers