D-Bus name should be a reverse DNS

Bug #582453 reported by Will Thompson on 2010-05-18
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Getting Things GNOME!
Low
Bryce Harrington

Bug Description

Getting Things Gnome claims the bus name "org.GTG". But I'm pretty sure http://gtg.org/ is not Getting Things Gnome's site, and infer that gtg.org is not actually owned by the GTG team. D-Bus names follow http://en.wikipedia.org/wiki/Reverse-DNS — they're not just org.whatever.

GTG should probably be com.fritalk.gtg. Or, you could purchase gtg.org for a mere US$ 9, 888 from its current owner!

Luca Invernizzi (invernizzi) wrote :

It's true that Dbus name should be a reverse dns, but we need a dbus name that is clear to people reading dbus messages.
So:
- we could ask gnome for gtg.gnome.org
- we could become buddist
- ..?

Changed in gtg:
status: New → Confirmed
milestone: none → 0.3
importance: Undecided → Low
summary: - Claims a D-Bus name for someone else's domani.
+ D-Bus name should be a reverse DNS
Will Thompson (wjt) wrote :

I don't see anything particularly wrong with com.fritalk.gtg — it's no more or less self-explanatory than org.GTG. The bus name reversed doesn't actually have to be a valid domain name (consider org.gnome.Terminal, etc.); it's just meant to be namespaced by one. So org.gnome.GTG should be fine.

Will Thompson (wjt) wrote :

...or you could attempt to convince the Guatemalan domain registrar to let you buy g.gt, so that the bus name could be gt.g ☺

Luca Invernizzi (invernizzi) wrote :

eheh, that's nice.
How can we do this transition smoothly? We do have several projects which use our dbus interface (Hamster, AWN and Docky come to mind, if I'm not wrong).
Anyway, since Paul is splitting GTG in front-end and back-end, well ... I'll leave this bug to you, Paul! ^_^

Will Thompson (wjt) wrote :

You're right, it'd be a pain to transition. Maybe it's just something to keep in mind for when you next break the D-Bus API anyway?

On Tue, May 18, 2010 at 10:55:06PM -0000, Will Thompson wrote:
> You're right, it'd be a pain to transition. Maybe it's just something to
> keep in mind for when you next break the D-Bus API anyway?

Actually, we've just broken the api with 0.3 within the last month or
so. We've been recommending external folks use the 0.2 api, so they've
likely not yet gone through the break, and so now is as good a time as
any to change the name. Plus, sounds like this summer we have some
plans to really beef up the dbus command set, so would probably be
preferable to settle the api name itself before then.

Bryce Harrington (bryce) wrote :

On Tue, May 18, 2010 at 09:45:11PM -0000, Luca Invernizzi wrote:
> How can we do this transition smoothly? We do have several projects which use our dbus interface (Hamster, AWN and Docky come to mind, if I'm not wrong).

The easiest (and most neighborly) way to make for a smooth transition
would involve us sending patches to projects that are affected...

Luca Invernizzi (invernizzi) wrote :

I agree, but who keeps track of that?

Bryce Harrington (bryce) wrote :

On Tue, May 18, 2010 at 11:46:22PM -0000, Luca Invernizzi wrote:
> I agree, but who keeps track of that?

Anyway, so what should our plan be? The changes themselves to our tree
are straightforward enough, should I just change it, or post a branch
for review? Should we put out any announcements? Pre-announcements?

Luca Invernizzi (invernizzi) wrote :

I think a mail in gtg-users will do. I *hope* that the people who have
been developing with GTG will be listening.

On Tue, May 25, 2010 at 9:02 AM, Bryce Harrington
<email address hidden> wrote:
> On Tue, May 18, 2010 at 11:46:22PM -0000, Luca Invernizzi wrote:
>> I agree, but who keeps track of that?
>
> Anyway, so what should our plan be?  The changes themselves to our tree
> are straightforward enough, should I just change it, or post a branch
> for review?  Should we put out any announcements?  Pre-announcements?
>
> --
> D-Bus name should be a reverse DNS
> https://bugs.launchpad.net/bugs/582453
> You received this bug notification because you are subscribed to Getting
> Things GNOME!.
>
> Status in Getting Things GNOME!: Confirmed
>
> Bug description:
> Getting Things Gnome claims the bus name "org.GTG". But I'm pretty sure http://gtg.org/ is not Getting Things Gnome's site, and infer that gtg.org is not actually owned by the GTG team. D-Bus names follow http://en.wikipedia.org/wiki/Reverse-DNS — they're not just org.whatever.
>
> GTG should probably be com.fritalk.gtg. Or, you could purchase gtg.org for a mere US$ 9, 888 from its current owner!
>
>
>

Bryce Harrington (bryce) wrote :

I've switched trunk to use the org.gnome.GTG service name. I tested with gtcli that it works, and posted to the mailing list as the announcement. Hopefully that's enough to get word out about the change.

Changed in gtg:
assignee: nobody → Bryce Harrington (bryceharrington)
status: Confirmed → Fix Committed
Changed in gtg:
milestone: 0.3 → 0.2.9
Izidor Matušov (izidor) on 2012-02-13
Changed in gtg:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers