plugin selections are not remembered when app is not closed properly

Bug #533157 reported by Sven Bendel on 2010-03-06
44
This bug affects 9 people
Affects Status Importance Assigned to Milestone
Getting Things GNOME!
Medium
Luca Invernizzi

Bug Description

using version 0.2.3 on Ubuntu 9.10 amd64

For me there are two cases concerning the plugin selections:

1) CORRECT CASE
 - start gtg
 - modify plugins
 - close gtg
 -> plugin settings are successfully stored

2) FAILURE CASE
 - start gtg
 - modify plugins
 - shut down the system without closing gtg manually before
 -> plugin settings get lost

The plugins I use are:
- Notification area
- Evolution
- Hamster Time Tracker Integration

description: updated
mrk (cvs-src) wrote :

btw, i can't confirm that here on FreeBSD with 0.2.3.
I've activate all the plugins (apart from Bugzilla and Geolocalized tasks, because FreeBSD ports repository didn't has required dependencies), then restart GTG and all the plugins appeared on panel and in Plugins menu.
So this seems some ubuntu-specific thingie.
Is there any errors when you start gtg from terminal and trying to activate the plugins?

Sven Bendel (ubuntudroid) wrote :

When activating the Hamster plugin I get the following error message:

** (gtg:4386): CRITICAL **: atk_object_set_name: assertion `name != NULL' failed

I additionally noticed, that closing gtg manually (in opposite to when it's closed by the OS during OS shutdown) and opening it afterwards again *during the same session* keeps the plugins activated (though the above error message is also generated on startup).

Sven Bendel (ubuntudroid) wrote :

Forgot to mention, that the line number (I think, it's the line number -> gtg:xxx) where the error is thrown changes. So far I have seen lines 4386, 4458 and 4473. Hope that helps!

Sven Bendel (ubuntudroid) wrote :

Another thing I noticed:
I just booted my computer and saw, that the plugin settings are still like they were when I logged off. It seems, that the issue just occures, if you modify the plugin settings and then log off without having closed the application manually before. To put it in a nutshell:

1)
 - start gtg
 - modify plugins
 - close gtg
 -> plugin settings are successfully stored

2)
 - start gtg
 - modify plugins
 - shut down the system without closing gtg manually before
 -> plugin settings get lost

Kevin Mehall (kevin-mehall) wrote :

That atk_object_set_name message is bug #475426 and is thought to be harmless.

summary: - plugin selections are not remembered on closing of app
+ plugin selections are not remembered when app is not closed properly
Changed in gtg:
status: New → Confirmed
Luca Invernizzi (invernizzi) wrote :

I can't reproduce that either. Can anybody?

description: updated
mrk (cvs-src) wrote :

I can confirm.

1. Start gtg.
2. Activate 'Hello world' plugin.
3. Do not close gtg!
4. `shutdown -r now` or reboot via gnome

after system is started up (and gtg is now starts atomatically ))) i check the plugins list and 'Hello world' is unchecked.

Seems like gtg saves plugins settings not immediately but on (correct) exit. If so, there may be two solutions:

1. Save the settings immediately after change is occurred.
2. Catch SIGABRT (or what its name) and save the settings before close.

Changed in gtg:
milestone: none → 0.2.4
importance: Undecided → Medium
Luca Invernizzi (invernizzi) wrote :

it should be ok in the latest gtg/0.2 branch (rebuilding the daily repo right now). Please confirm.

Luca Invernizzi (invernizzi) wrote :

Fixed also in trunk. Since the code is different, there it makes more sense to handle the signals directly (since the configuration is saved on exiting the program, instead of inside the task browser).

Changed in gtg:
status: Confirmed → Fix Committed
Sven Bendel (ubuntudroid) wrote :

Tried 0.3~karmic4developersubuntu86. Unfortunately it still doesn't work... I checked the Hello World plugin and rebooted without closing gtg before. On next startup the plugin was unchecked again.

Luca Invernizzi (invernizzi) wrote :

Please make sure to close the preference window before trying (as configuration is saved when that happens).
Instead of rebooting you can use "pkill -9 gtg", which is faster :-D

Sven Bendel (ubuntudroid) wrote :

Did everything like you suggested - sadly it still doesn't work.

Changed in gtg:
status: Fix Committed → Confirmed
Luca Invernizzi (invernizzi) wrote :

Now it should work. Precisely, it reacts to pkill -6 and pkill -15 (TERM and ABORT), which are the two sent upon shutdown.

Please check- and thank you for helping me through this bug!

Changed in gtg:
status: Confirmed → Fix Committed
assignee: nobody → Luca Invernizzi (invernizzi)
Sven Bendel (ubuntudroid) wrote :

Hm, the last build in your daily ppa is 2 days old - are you sure you've uploaded it correctly?

nope, I didn't rebuild it. Doing that now. It will be available in less than
one hour.

On Wed, Mar 10, 2010 at 11:16 PM, Sven Bendel <email address hidden> wrote:

> Hm, the last build in your daily ppa is 2 days old - are you sure you've
> uploaded it correctly?
>
> --
> plugin selections are not remembered when app is not closed properly
> https://bugs.launchpad.net/bugs/533157
> You received this bug notification because you are a bug assignee.
>
> Status in Getting Things GNOME!: Fix Committed
>
> Bug description:
> using version 0.2.3 on Ubuntu 9.10 amd64
>
> For me there are two cases concerning the plugin selections:
>
> 1) CORRECT CASE
> - start gtg
> - modify plugins
> - close gtg
> -> plugin settings are successfully stored
>
> 2) FAILURE CASE
> - start gtg
> - modify plugins
> - shut down the system without closing gtg manually before
> -> plugin settings get lost
>
>
> The plugins I use are:
> - Notification area
> - Evolution
> - Hamster Time Tracker Integration
>
>
>
>
>

Sven Bendel (ubuntudroid) wrote :

pkill -6 and pkill -15 work now!!! Just pkill -9 still erases all changes...

Luca Invernizzi (invernizzi) wrote :

Good. Pkill -9 (SIGKILL) is not intercepted because that is a signal that is only sent by the user, if he actually wants to kill the process. it's the default signal for killall, kill, pkill & co.
I think that we shouldn't save changes in that case, since the process has been voluntarily killed.
If anyone thinks that it should also be trapped, speak up!

Sven Bendel (ubuntudroid) wrote :

I would vote for not storing the data in case of SIGKILL - sounds logical to me.

Anything else left to test concerning this former bug?

Luca Invernizzi (invernizzi) wrote :

I think we're done here :-)

Changed in gtg:
status: Fix Committed → Fix Released

Was the fix really released in Lucid ?
I am still having the issue these days...

Luca Invernizzi (invernizzi) wrote :

It has been recently fixed in trunk,so it's not in lucid. This one was
a different bug with the same effect.

On Thu, Jun 3, 2010 at 9:58 AM, Jean-Christophe Baptiste <email address hidden> wrote:
> Was the fix really released in Lucid ?
> I am still having the issue these days...
>
> --
> plugin selections are not remembered when app is not closed properly
> https://bugs.launchpad.net/bugs/533157
> You received this bug notification because you are a bug assignee.
>
> Status in Getting Things GNOME!: Fix Released
>
> Bug description:
> using version 0.2.3 on Ubuntu 9.10 amd64
>
> For me there are two cases concerning the plugin selections:
>
> 1) CORRECT CASE
>  - start gtg
>  - modify plugins
>  - close gtg
>  -> plugin settings are successfully stored
>
> 2) FAILURE CASE
>  - start gtg
>  - modify plugins
>  - shut down the system without closing gtg manually before
>  -> plugin settings get lost
>
>
> The plugins I use are:
> - Notification area
> - Evolution
> - Hamster Time Tracker Integration
>
>
>
>
>

I just faced this issue on 12.04, where GTG version is 0.2.4

Izidor Matušov (izidor) wrote :

Yevgeniy> I can't reproduce it on GTG 0.2.9 which is going to get into the next Ubuntu release.

Quick workaround: You can enable/disable plugins and restart GTG to remember it. Things like settings of plugins should work correctly.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers