atk_object_set_name: assertion `name != NULL' failed

Reported by Lionel Dricot on 2009-11-05
102
This bug affects 21 people
Affects Status Importance Assigned to Milestone
GTK+
Fix Released
Medium
Getting Things GNOME!
High
Unassigned
atk1.0 (Ubuntu)
Low
Unassigned
gtk+2.0 (Ubuntu)
Low
Ubuntu Desktop Bugs

Bug Description

Many gnome applications in Karmic (including gtg, yelp, fspot, and rhythmbox, among others) cause warnings like the following to appear in the terminal:

** (gtg:6416): CRITICAL **: atk_object_set_name: assertion `name != NULL' failed

Lionel Dricot (ploum) on 2009-11-05
Changed in gtg:
importance: Undecided → High
milestone: none → 0.2
status: New → Confirmed
Lionel Dricot (ploum) wrote :

Mmm, I'm seeing this only on one of my computer, not on the other. Probably not a GTG bug then. (any clue on what can cause this is welcome)

Changed in gtg:
milestone: 0.2 → none
status: Confirmed → Invalid
Lionel Dricot (ploum) wrote :

can reproduce it on my second laptop by enabling the tomboy plugin. It then happens when opening a task. No idea of what it could be :-(

Changed in gtg:
milestone: none → 0.2
status: Invalid → Confirmed
Luca Invernizzi (invernizzi) wrote :

I see that when I enable RTM plugin, but not every task I open. On Karmic I saw that in several other applications (which I cannot remember now), whether in python or not.
A quick search on google shows that evolution outputs that too ( http://<email address hidden>/msg355675.html)

Atk is the Accessibility Toolkit, so it doesn't seem related to gtg.

Lionel Dricot (ploum) wrote :

The fact that it happens to Evolution doen't mean it's not GTG fault as Evolution might also be buggy ;-)

I hate seeing stuffs in the console. I'm wondering why it happens only with plugins. Maybe when the plugin engine add a button, it doesn't add something needed for accessibility ?

Lionel Dricot (ploum) wrote :

So it looks like it happens with :

- RTM plugin (main window)
- Tomboy plugin (task window)

I doesn't happen with the Hello World plugin. Is there a difference in the way the button is added to the toolbar ?

It might also worth to see if the plugin should be fixed or if we should fix the plugin engine so that plugin authors don't have this problem anymore.

Luca Invernizzi (invernizzi) wrote :

I started to write both plugins from the hello world. In RTM, the only real difference when a task is loaded is that the icon is not a stock one. I'll check on it

Luca Invernizzi (invernizzi) wrote :

And, yes. the problem is caused by the line
       #toolbar button
        self.tb_button = gtk.ToolButton(rtm_menu_image)

where rtm_menu_image is a gtk.Image with the custom icon

which doesn't trigger the issue if it's changed in
        #toolbar button
        self.tb_button = gtk.ToolButton(gtk.STOCK_CUT)

This way to create buttons should be the standard one. I don't know how could be improved. F-Spot, Evolution, Rhythmbox, Cairo-Dock all have bugs filed against them with the same issue... Maybe someone more expert could look into this.

Lionel Dricot (ploum) wrote :

It looks like Atk requires a name for the GtkImage but that GtkImage only have a name if it's a stock icon ( http://library.gnome.org/devel/gtk/stable/GtkImage.html#GtkImage--icon-set - http://projects.gnome.org/accessibility/talks/GTK-impl.html )

Could you give the link for the related bug in other software ? We might make this one a duplicate.

Many applications output this error when starting up. It is apparently a bug in the latest gtk library. Programs compiled on Ubuntu 9.04 or earlier do not have this problem.

I see this frequently when running f-spot (0.6.1.4) e.g.

dougie@icarus:~/photos/in$
dougie@icarus:~/photos/in$ icarusfspot
12Nov09_22:15:16 - STARTING script: icarusfspot
12Nov09_22:15:16 - Checking for existence of lock file.
12Nov09_22:15:16 - Writing pid 2646 to lockfile
Taking backup of f-spot database to /home/dougie/fspotbackups/photos.db.12Nov09_22:15:16
Backup successful. Starting f-spot ...
[Info 22:15:19.039] Initializing DBus
[Info 22:15:19.443] Initializing Mono.Addins
[Info 22:15:20.008] Starting new FSpot server (f-spot 0.6.1.4)

** (f-spot:2657): CRITICAL **: atk_object_set_name: assertion `name != NULL' failed

** (f-spot:2657): CRITICAL **: atk_object_set_name: assertion `name != NULL' failed

** (f-spot:2657): CRITICAL **: atk_object_set_name: assertion `name != NULL' failed

** (f-spot:2657): CRITICAL **: atk_object_set_name: assertion `name != NULL' failed

** (f-spot:2657): CRITICAL **: atk_object_set_name: assertion `name != NULL' failed
[Info 22:15:47.887] Starting BeagleService
[Info 22:15:47.993] Hack for gnome-settings-daemon engaged

PJD (pdoucet) wrote :

i also get this in 9.10 trying to open rhythmbox. it gave me an error about daap plugin which refuses to work, but it seems fine otherwise. i would like for daap to work so i can use simplify media.

** (rhythmbox:30711): CRITICAL **: atk_object_set_name: assertion `name != NULL' failed

 is displayed 4 times and then this:

(rhythmbox:30711): Rhythmbox-WARNING **: /home/pjd/.gnome2/rhythmbox/plugins/daap/libdaap.so: undefined symbol: gnome_password_dialog_set_show_username
(rhythmbox:30711): Rhythmbox-WARNING **: Could not load plugin daap
(rhythmbox:30711): Rhythmbox-WARNING **: Error, impossible to activate plugin 'DAAP Music Sharing'

any fixes would be appreciated. more info can be presented if necessary

pd

Lionel Dricot (ploum) wrote :

This is not a GTG bug but well an upstream GTK bug ( https://bugzilla.gnome.org/show_bug.cgi?id=599446 ). Marking it as invalid for us.

Changed in gtg:
milestone: 0.2 → none
status: Confirmed → Invalid

As you can see, upstream have pushed the fix for this to 2.18. Can we get the patch applied here too, please?

Sebastien Bacher (seb128) wrote :

The bug is fixed upstream now

Changed in atk1.0 (Ubuntu):
assignee: nobody → Ubuntu Desktop Bugs (desktop-bugs)
importance: Undecided → Low
status: New → Triaged
assignee: Ubuntu Desktop Bugs (desktop-bugs) → nobody
Changed in gtk+2.0 (Ubuntu):
assignee: nobody → Ubuntu Desktop Bugs (desktop-bugs)
importance: Undecided → Low
status: New → Triaged
status: Triaged → Fix Committed
Changed in atk1.0 (Ubuntu):
status: Triaged → Invalid
Changed in gtk+2.0 (Ubuntu):
status: Fix Committed → New
status: New → Fix Committed
Lionel Dricot (ploum) wrote :

adding it to our milestone to not forget to talk about it in GTG 0.2 release note

Changed in gtg:
milestone: none → 0.2

I also have that bug running karmic

Stingrayl (stingraytestemail) wrote :

I have this but in evolution on Karmic... I just doesn't open... and I get this

atk_object_set_name: assertion `name != NULL' failed

in terminal startup.

Wierd it was working fine, then this happend.

On Mon, 2009-12-07 at 17:23 +0000, Stingrayl wrote:
> I have this but in evolution on Karmic... I just doesn't open... and I
> get this
>
> atk_object_set_name: assertion `name != NULL' failed
>
> in terminal startup.

This is very likely unrelated to your startup failure so please open a
new bug and don't cloud this one with orthogonal issues.

Changed in gtk+2.0 (Ubuntu):
status: Fix Committed → Fix Released
status: Fix Released → Fix Committed

This should be fixed in Ubuntu 10.04. Thanks for reporting.

Changed in gtk+2.0 (Ubuntu):
status: Fix Committed → Fix Released
Antoine RODRIGUEZ (connetport) wrote :

This bug is making Evolution impossible to attach one image inside a mail ..... it should be critical for 9.10 .... no ?

On Tue, 2009-12-15 at 22:04 +0000, antoiner wrote:
> This bug is making Evolution impossible to attach one image inside a
> mail ..... it should be critical for 9.10 .... no ?

Good luck with that.

Sebastien Bacher (seb128) wrote :

the bug describes a warning not a crasher there...

Question: is it fixed (and uploaded) in karmic or not?

Sebastien Bacher (seb128) wrote :

the bug is not fixed in karmic no, command line warnings is not something which qualify for a stable update since no standard user will even notice there is an issue there

Anyway, in karmic it forbids me to use midori.

Antoine RODRIGUEZ (connetport) wrote :

Hummmm yesterday I've had an update of gtk2 and the bug does not show himself anymore ......

ericohg (ericohg) wrote :

Please, can anybody help me on how to fix this awesome 'warning' that makes evolution IMPOSSIBLE to work with? My evol crashes when finisging connecting as I can not even download my messages to my Ubuntu 9.10 from a MS EXCHANGE via MAPI plugin. My Mailbox is getting closer to limit and either I delete some important messages or send it to gmail, which is tiring doing it all the time.

stlubuntu (jlrbennett) wrote :

I have this same issue in 64-bit Karmic, but following the error is:

Segmentation Fault

and the application then shuts down (Rhythmbox in this case) and is therefore unusable. This does not seem to happen in VLC, nor Firefox, nor Thunderbird.

Would someone please either post instructions on how to apply the patch/fix to Karmic or backport the fix to Karmic.

This is more than just an annoying error message. It is clearly causing apps to crash.

Please. Please. Since it will be fixed in lucid, would it be too much to ask for the patch to Karmic?

Thanks.

P.S. The "Good luck with that" comment from the developer is clearly not constructive.

On Sun, 2009-12-27 at 02:16 +0000, stlubuntu wrote:
> I have this same issue in 64-bit Karmic, but following the error is:
>
> Segmentation Fault

That is likely unrelated to this issue and you should open a new bug for
it.

> This is more than just an annoying error message. It is clearly causing
> apps to crash.

I don't think so. You would need to get a backtrace from your segfault
in order to prove your assertion. My guess is that your assertion is in
fact false.

> Please. Please. Since it will be fixed in lucid, would it be too much
> to ask for the patch to Karmic?

Why don't you just apt-get source the gtk package, and put the patch
into the debian/patches dir and dpkg-rebuild, like I did? I don't
bother waiting for fixes for bugs in released versions of Ubuntu any
more. More times than not, they don't come.

> P.S. The "Good luck with that" comment from the developer is clearly
> not constructive.

That was my comment. I am not a (Ubuntu) developer. The comment
however was in reference to the fact that Karmic has been out too long
now to hold out hope for bug fixes such as this one because most of the
developers have switched focus to Lucid now and don't bother with
Karmic.

Yeah. It sucks for all of us who are currently running what Ubuntu
calls their "current stable release" (for whatever value you want to
give to stable), but that's just how this machine seems to operate. We
all have to wait for Lucid now to get these sorts of bugs fixed which in
fact will be a trade for a whole new batch of bugs which we will have to
wait for the M* release (Melancholy Monkey? :-) to fix.

ericohg (ericohg) wrote :

ok, i understood you point of views but developers I still can not wait that long (lucid) as for me evolution is the SOLE survivor among those e-mail clients who can 'talk' to MS ESCHANGE 2007, from which I can not help using it. My mail boxes is at its maximum limit and I may need a good reason to give the email admin staff to increase it and still listening to 'why do you insist in using GNU/LINUX in your Desktop?'.
Is there anything I can do? how to patch it? could any of you please give me some instructions on how to build it as a I am not so much experienced in either compiling or writing codes in C language.

thanks in advance

On Mon, 2010-01-04 at 17:59 +0000, ericohg wrote:
> ok, i understood you point of views but developers I still can not wait that long (lucid) as for me evolution is the SOLE survivor among those e-mail clients who can 'talk' to MS ESCHANGE 2007, from which I can not help using it. My mail boxes is at its maximum limit and I may need a good reason to give the email admin staff to increase it and still listening to 'why do you insist in using GNU/LINUX in your Desktop?'.
> Is there anything I can do? how to patch it? could any of you please give me some instructions on how to build it as a I am not so much experienced in either compiling or writing codes in C language.

As I think I said before, fixing this problem will likely not fix
whatever problem you have with evolution crashing. Try it. Apply the
prescribed patch to your gtk build and rebuild it. I bet evolution
continues to crash even without this (admittedly annoying) message.

ericohg (ericohg) wrote :

Brian,

The error persist when I use IMAP protocol with EXCHANGE 2007 under evolution but it does not crash at all. YOU ARE RIGHT! GTK has little or nothing to do with evolution crash. I decided on reinstalling evolution-mapi. From command line as ROOT, I load evolution and can retrieve all the messages. But after selecting a message, the following error appears:
....
exchange-mapi-connection.c:390: Leaving exchange_mapi_util_read_body_stream libexchangemapi-Message: exchange-mapi-connection.c:1486: exchange_mapi_connection_fetch_item: unlock(connect_lock)
!@>?<@>
exchange-mapi-connection.c:1488: Leaving exchange_mapi_connection_fetch_item Invalid header line: ' SAC0861.ac.correiosnet.int ([::1]) with mapi; Thu, 26 Nov'2009 09:47:20 -0200
'nvalid header line: ' =?iso-8859-1?Q?AC_-_CESEP_-_GCON_-_Gest=E3o_de_Incidentes_-_Caixa_Postal?=
'nvalid header line: ' <email address hidden>
Invalid header line: ''
Falha de segmentação
root@xptomicro:/root

With an ordinary user, it keeps on aborting after retrieving the messages
sounds funny... Any clue?

On Thu, 2010-01-07 at 16:40 +0000, ericohg wrote:
>
> The error persist when I use IMAP protocol with EXCHANGE 2007 under evolution but it does not crash at all. YOU ARE RIGHT!

You are surprised. :-)

> GTK has little or nothing to do with evolution crash.

Right. So please, refrain from muddying up this bug any more and open a
brand new bug for your issue.

Changed in gtg:
milestone: 0.2 → none
Gabe Gorelick (gabegorelick) wrote :

Updated the description to reflect the fact that it effects a lot more gnome apps than gtg.

description: updated
description: updated

On Wed, 2010-01-27 at 22:31 +0000, Gabe Gorelick wrote:
> Updated the description to reflect the fact that it effects a lot more
> gnome apps than gtg.

Why bother? It's a gtk bug and it's fixed upstream and I will be a
monkey's uncle before it every gets fixed in Karmic. All efforts are on
the Lazy Llama or whatever it's going to be.

Gabe Gorelick (gabegorelick) wrote :

@Brian J. Murrell so that people who come across this bug in Karmic and want to report it don't just read the summary and conclude that this bug only has to do with gtg, so they need to file a new bug saying they get the same behavior in application x. That would cause proliferation of duplicate bugs. As it stands, there are probably a lot of duplicates already out there (they're hard to find, since tons of bug reports mention "atk_object_set_name: assertion `name != NULL'" as part of the standard apport collection), but at least this will help stem the tide.

Fair enough.

patrix (neo-patrix) wrote :

After compliation & installation of Qt 4.6.1 on my system (Ubuntu Karmic), I am noting same bug with various Qt Developer GUI - Tools like assistant, linguist, designer.

Eg :

$ assistant

** (<unknown>:24424): CRITICAL **: atk_object_set_name: assertion `name != NULL' failed
--------------------------------------------------------------------------------------------------------------------
According to following discussion thread on nokia forum for Qt.

http://www.forum.nokia.com/forum/showthread.php?t=189084

The problem for Qt Toolkit seems to be GTK-style. If I run same application with different style
the error does not appear.

Eg : $ assistant -style plastique
-------------------------------------------------------------------------------------------------------------------
More astonishing is the fact that if I switch to Karmic repository version of Qt ( i.e 4.5.2), The
critical error message disappears.

shahin (sshatery) wrote :

i have this problem with f-spot too. how can i solve this problem??

Indicate what version are you running and more information.

Tmarketing (javiermo-hotmail) wrote :

** (rhythmbox:3257): CRITICAL **: atk_object_set_name: assertion `name != NULL' failed

** (rhythmbox:3257): CRITICAL **: atk_object_set_name: assertion `name != NULL' failed
WARNING: Unhandled message: interface=org.freedesktop.DBus.Introspectable, path=/, member=Introspect

(<unknown>:3268): GLib-WARNING **: g_set_prgname() called multiple times

(rhythmbox:3257): GLib-CRITICAL **: g_sequence_get: assertion `iter != NULL' failed
Fallo de segmentación

I dont find a solution ??

Stephan (xtephan) wrote :

Same problem. When i run "rhythmbox" on a terminal the output is:

** (rhythmbox:18726): CRITICAL **: atk_object_set_name: assertion `name != NULL' failed

** (rhythmbox:18726): CRITICAL **: atk_object_set_name: assertion `name != NULL' failed
WARNING: Unhandled message: interface=org.freedesktop.DBus.Introspectable, path=/, member=Introspect

(<unknown>:18898): GLib-WARNING **: g_set_prgname() called multiple times

(<unknown>:18924): GLib-WARNING **: g_set_prgname() called multiple times

(<unknown>:18998): GLib-WARNING **: g_set_prgname() called multiple times

I try reinstalling completly the program, but the error continues.

Gabe Gorelick (gabegorelick) wrote :

@Tmarketing
The segmentation fault is not related to this bug. This bug describes a mostly harmless warning. File a separate bug report for your problem if one hasn't already been filed.

@Stephan
Same to you, any problems with any gtk application are most likely not caused by this bug. This bug only causes some warnings on the command line, nothing more.

Changed in gtk:
importance: Unknown → Medium
status: Unknown → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.