[Needs -intel 2.9.1] Cairo/Gdk shapes not visible on Intel gpu since Karmic

Bug #458545 reported by Gioele Barabucci on 2009-10-22
206
This bug affects 48 people
Affects Status Importance Assigned to Milestone
GNOME Mastermind
Unknown
Unknown
Getting Things GNOME!
Critical
Unassigned
gnome-mastermind (Ubuntu)
Undecided
Unassigned
Karmic
Undecided
Unassigned
xserver-xorg-video-intel (Ubuntu)
High
Unassigned
Karmic
Undecided
Unassigned

Bug Description

[Impact]
Just before the 2.9.0 driver released, a major performance regression was isolated and fixed regarding software fallbacks for certain types of cairo rendering ( http://cgit.freedesktop.org/xorg/driver/xf86-video-intel/commit/?h=2.9&id=57fc09cef28bad2e3e8455b93ef2927118f8a3a3 ), but it introduced a new regression causing some things to not get rendered correctly which affected quite a few applications such as gwibber, GTG, and gnome-mastermind. This was fixed shortly after the 2.9.0 release which was included in Karmic and included in the xserver-xorg-video-intel 2.9.1 release.

[Symptoms]
No profile images loading in Gwibber, Colored boxes missing in GTG, missing board graphics in gnome-mastermind, no red boxes displayed in the testcase.

[Test Case]
1) Boot a Karmic system with intel graphics
2) Download testcase attached to comment #13 (CellRendererTags_testcase.py)
3) Run with the command "python CellRendererTags_testcase.py"
4) 4 red boxes will be shown if it is rendering correctly.

[Patch]
http://launchpadlibrarian.net/37466430/xserver-xorg-video-intel_2.9.0-1ubuntu2.1.debdiff

[Original Report]
See the test case at comment #13.

In that test case, a simple python script using pygtk bindings is using Cairo/Gdk to draw red squares in a Gtk widget.

This script is working for any Ubuntu version prior to 9.10.
In 9.10, this script is working for ATI and NVIDIA gpu or under Xnest. But with any Intel GPU, the square are not displayed (see screenshot in comment #14 )

This bug is pretty severe as it makes applications like GTG (and probably others) unusable on a intel Karmic desktop.

Luca Invernizzi (invernizzi) wrote :

Could you rephrase that? From what I understood of your bug, this has already been done (see
http://www.paulocabido.com/wp-content/uploads/2009/07/GTG.png ).
Which version of gtg are you using ?select the Help menu, then About to see it.

Lionel Dricot (ploum) wrote :

Luca > For whatever reason, those boxes don't appear under Ubuntu Karmic. I recently discovered that.

Luca Invernizzi (invernizzi) wrote :

I didn't know that. I'm running karmic (clean install of jaunty + upgrade, since my hd failed) and I do have those boxes.

Le vendredi 23 octobre 2009 à 05:07 +0000, Luca Invernizzi a écrit :
> I didn't know that. I'm running karmic (clean install of jaunty +
> upgrade, since my hd failed) and I do have those boxes.
strange.

I did a clean install of Karmic and, since that, I don't have those
boxes anymore. Looks like a missing dependancy from the default install.
Also, colors are a lot more brighter than with Jaunty.

Switched to confirmed as also Lionel Dricot confirmed the problem.

Changed in gtg:
status: New → Confirmed

Is there any noticeable output on a terminal?

On Fri, Oct 23, 2009 at 3:01 PM, Gioele Barabucci <email address hidden> wrote:

> Switched to confirmed as also Lionel Dricot confirmed the problem.
>
> ** Changed in: gtg
> Status: New => Confirmed
>
> --
> Add color boxes aside tag name
> https://bugs.launchpad.net/bugs/458545
> You received this bug notification because you are a member of Gtg
> developers, which is subscribed to Getting Things GNOME!.
>
> Status in Getting Things GNOME!: Confirmed
>
> Bug description:
> Is it possible to have a color box near each tag name in the left pane so
> that each tag can be easily identified with the corresponding background
> color in the task pane?
>
> _______________________________________________
> Mailing list: https://launchpad.net/~gtg <https://launchpad.net/%7Egtg>
> Post to : <email address hidden>
> Unsubscribe : https://launchpad.net/~gtg <https://launchpad.net/%7Egtg>
> More help : https://help.launchpad.net/ListHelp
>

--
Bertrand Rousseau
Rue Victor Horta, 31/202 1348 Louvain-la-Neuve, Belgium
e-mail : <email address hidden>
tel : +32 485 96 69 86

Lionel Dricot (ploum) wrote :

Le vendredi 23 octobre 2009 à 22:03 +0000, Bertrand Rousseau a écrit :
> Is there any noticeable output on a terminal?

Unfortunatly not :-(

I also see this on Jaunty with backported Karmic kernel and X packages, as well as on Karmic. It seems to be X server related because the color squares show up when GTG is run under Xnest or Xephyr. Intel i965 graphics if it matters.

In GTG/taskbrowser/CellRendererTags.py, I can confirm that on_render() and __roundedrec() are called dozens of times, but somehow the pixels never make it to screen.

Lionel Dricot (ploum) on 2009-10-25
Changed in gtg:
importance: Undecided → Critical
milestone: none → 0.2

Same graphic card here.

Maybe the Ubuntu X Server team should be added to this bug report.

summary: - Add color boxes aside tag name
+ Color boxes aside tag name no longer shown
Lionel Dricot (ploum) wrote :

This is really weird!

On my work laptop, also a fresh Karmic install, it works, I can see the colors and the squares!

I really don't understand and I see only two possibilities :

1) It's related to X and drivers. It works for me on ATI, not on Intel.

2) It's a dependency that I've installed without knowing on my work laptop but not on my personal one.

Kevin's experience seems to confirm that this is one. Could all the people affected by that bug inform us of their video card and if effects are enabled or not. For me : Intel 9xx card and compositing enabled in metacity.

Luca Invernizzi (invernizzi) wrote :

Since the graphics drivers are basically three, I can rule out nvidia, either with composing enabled or not.

If someone could volunteer to make a very minimal usecase (a simple one file python script that displays one colored box), we could assign that bug to the Intel driver as it seems that only Intel users are affected.

summary: - Color boxes aside tag name no longer shown
+ Color boxes aside tag name not visible on Intel gpu
Kevin Mehall (kevin-mehall) wrote :

Here's a test case combining CellRendererTags.py with a PyGTK TreeView example. It exhibits the same behavior as GTG itself.

Kevin Mehall (kevin-mehall) wrote :

Here's a screenshot of my test case.

On the left, running on Xorg (1:7.4~5ubuntu18) on an Intel i965 (xserver-xorg-video-intel 2:2.9.1~git-0ubuntu0tormod), the squares are not shown

and on the right under Xnest, they are visible

Lionel Dricot (ploum) on 2009-11-05
summary: - Color boxes aside tag name not visible on Intel gpu
+ Cairo/Gdk shapes not visible on Intel gpu since Karmic
description: updated
description: updated

Kevin, thanks a lot for the usecase. This is really extremely useful! I hope that Xorg people will take a look at it.

Kevin Mehall (kevin-mehall) wrote :

This is fixed using updated X packages from the Xorg-edgers PPA

Lionel Dricot (ploum) wrote :

This is then not a GTG bug. I hope that the fix will hit Karmic soon if it's available in Xorg-edgers

Changed in gtg:
milestone: 0.2 → none
status: Confirmed → Invalid
Sérgio Almeida (mephx-x) wrote :

Using Ubuntu Karmic Netbook Remix on a Intel Corporation Mobile 945GM graph. card. The squares simply don't get drawn. Also tried with both compiz and metacity as recently many bugs have been found in 9.10's compiz.

Filippo Argiolas (fargiolas) wrote :

It seems gnome-mastermind suffers the same problem (in the upstream bug the reporter says he has an intel card).

Lionel Dricot (ploum) on 2009-11-20
Changed in gtg:
milestone: none → 0.2
Lionel Dricot (ploum) wrote :

This bug makes (at least) two GNOME applications unusable on every computer with an Intel chipset and seems to be confirmed (see the minimal test case in comment #13). Could someone of the Ubuntu-X team raises its importance?

How can we help to debug the issue?

Kevin Mehall (kevin-mehall) wrote :

This also affects the graphs on the overview window of Hamster-applet - see bug #451916

I tried some testing with the xorg-edgers packages to isolate this. The fix is in the xserver-xorg-video-intel package, upgrading it alone and leaving the rest of the Xorg stack with the default Karmic version fixes the problem.

The fix is present in the oldest version still available in the PPA (2:2.9.0+git20091026.10946118-0ubuntu0tormod), and if someone can tell me where to get older packages, I can find an exact version if that would be helpful. I do know that it was likely fixed in the PPA sometime in October. Grepping through the apt logs from my old jaunty install shows that 2:2.9.0~git20091010.8b2d2ff0 was installed at some point, but I can't 100% confirm it was broken on that version.

Hopefully someone on the Ubuntu-X team can find and backport a fix to this issue.

Those looking for an immediate solution can install an xserver-xorg-video-intel .deb from https://launchpad.net/~xorg-edgers/+archive/ppa/+packages?field.name_filter=video-intel&field.status_filter=published&field.series_filter=karmic

Let me know if there is any additional information I can provide.

Lionel Dricot (ploum) wrote :

I confirm that installing the package from Xedgers drivers-only solve the problem for me.

https://edge.launchpad.net/~xorg-edgers/+archive/drivers-only/+files/xserver-xorg-video-intel_2.9.1~git-0ubuntu0tormod_i386.deb

Andre Rossouw (rossouwap) wrote :

+1
Worked for me too. Thanks

Bryce Harrington (bryce) on 2010-01-04
Changed in xserver-xorg-video-intel (Ubuntu):
status: New → Won't Fix
status: Won't Fix → Confirmed
importance: Undecided → High
Bryce Harrington (bryce) wrote :

I get this error when trying to run the test case on either Karmic or Lucid:

bryce@chideok:~$ ./CellRendererTags_testcase.py
./CellRendererTags_testcase.py: line 22: syntax error near unexpected token `'2.0''
./CellRendererTags_testcase.py: line 22: `pygtk.require('2.0')'

bryce@chideok:~$ apt-cache madison python-gtk2
python-gtk2 | 2.16.0-0ubuntu1 | http://archive.ubuntu.com karmic/main Packages
     pygtk | 2.16.0-0ubuntu1 | http://archive.ubuntu.com karmic/main Sources

summary: - Cairo/Gdk shapes not visible on Intel gpu since Karmic
+ [Needs -intel 2.10] Cairo/Gdk shapes not visible on Intel gpu since
+ Karmic

Well, we'll be updating to -intel 2.10 at some point for Lucid, which should have the fix that's in the xorg-edgers git snapshot currently, so I guess we can consider this bug "in progress".

If folks would like to see this solved in Karmic, the step to take would be to git-bisect the -intel package to identify the exact patch that solves it, and then attach that diff to this bug report.

Changed in xserver-xorg-video-intel (Ubuntu):
status: Confirmed → In Progress
Bryce Harrington (bryce) wrote :

Btw, directions on bisecting are at https://wiki.ubuntu.com/X/Bisecting

If you do this and identify the patch that fixes it, please bring it to my attention via email or IRC. (I get a lot of bug mail).

This bug is fixed in Lucid already, with 2.9.1. There are very few
commits between 2.9.0 and 2.9.1 the one that fixes this is probably
http://cgit.freedesktop.org/xorg/driver/xf86-video-intel/commit/?h=2.9&id=7ccf084b7a281d8aa877f91401d3df7192da408c

I've been working on putting a package with this patch into my PPA for
the last hour, but I'm not very experienced with PPAs, so it's not
done yet.

On Mon, Jan 04, 2010 at 07:11:44PM -0500, Geir Ove Myhr wrote:
> This bug is fixed in Lucid already, with 2.9.1. There are very few
> commits between 2.9.0 and 2.9.1 the one that fixes this is probably
> http://cgit.freedesktop.org/xorg/driver/xf86-video-intel/commit/?h=2.9&id=7ccf084b7a281d8aa877f91401d3df7192da408c

Aha, I wondered if this might be the case. So we can mark the bugtask
done in Lucid.

> I've been working on putting a package with this patch into my PPA for
> the last hour, but I'm not very experienced with PPAs, so it's not
> done yet.

How can I help you with this? Pop into #ubuntu-x and we can get it
worked out.

Bryce

I have prepared a test package of xserver-xorg-video-intel for Karmic with the patch at http://cgit.freedesktop.org/xorg/driver/xf86-video-intel/commit/?h=2.9&id=7ccf084b7a281d8aa877f91401d3df7192da408c applied. Unfortunately, I don't have a Karmic system to test on right now (I recently upgraded to Lucid), so it would be nice if you could verify that the package indeed fixes the problems. The package is in my "standard" PPA at https://launchpad.net/~gomyhr/+archive/standard/+packages .

Kevin Mehall (kevin-mehall) wrote :

I just tested your xserver-xorg-video-intel_2.9.0-1ubuntu3~gomyhr2~karmic_i386.deb on my system (Dell Studio 15n with Intel i965 and Karmic) and can confirm that it fixes this problem.

@Bryce: Oops, the testcase doesn't have the proper #! line on top to run directly. It's attempting to treat it as a shell script. Use `python CellRendererTags_testcase.py `

xserver-xorg-video-intel_2.9.0-1ubuntu3~gomyhr2~karmic_i386.deb
fixes this for me too.

Attaching a debdiff cointaining the cherry-picked git commit.

I have also uploaded it to this PPA, but it has the same commit as Geir Ove Myhr's PPA version which was confirmed to fix the problem by multiple people. I have also built -intel locally in lucid twice to verify that the bug does exist in the karmic 2.9.0 package and is fixed by this update thanks to the excellent testcase in comment 13.

PPA:
https://edge.launchpad.net/~sarvatt/+archive/bugs

Changelog in the debdiff:
xserver-xorg-video-intel (2:2.9.0-1ubuntu2.1) karmic-proposed; urgency=low

  * Add 101_uxa_free_scratchpixmapheader.patch. Fixes a problem with
    non anti-aliased cairo shapes not being rendered at all on intel
    graphics. Cherrypick from upstream 2.9.1 release. (LP: #458545)

 -- Robert Hooker <email address hidden> Tue, 05 Jan 2010 17:30:49 -0500

Robert Hooker (sarvatt) on 2010-01-05
description: updated
summary: - [Needs -intel 2.10] Cairo/Gdk shapes not visible on Intel gpu since
+ [Needs -intel 2.9.1] Cairo/Gdk shapes not visible on Intel gpu since
Karmic
Bryce Harrington (bryce) wrote :

Thanks Robert, looks good as always; I've sponsored your upload to karmic-proposed.

It sounds like this has gotten adequate testing, and will get more in -proposed, so I'll go ahead and put this in for an SRU.

Bryce Harrington (bryce) wrote :

Ah, it's already been put in for an SRU. We're impressively on top of things today. :-)

Changed in xserver-xorg-video-intel (Ubuntu):
status: In Progress → Fix Committed

Accepted xserver-xorg-video-intel into karmic-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in gnome-mastermind (Ubuntu):
status: New → Invalid
Changed in gnome-mastermind (Ubuntu Karmic):
status: New → Invalid
tags: added: regression-release
Changed in xserver-xorg-video-intel (Ubuntu):
status: Fix Committed → Fix Released
Changed in xserver-xorg-video-intel (Ubuntu Karmic):
status: New → Fix Committed
tags: added: verification-needed
till kahle (kahle) wrote :

Hi Martin,

I've tested the proposed package xserver-xorg-video-intel and at least for me, Ubuntu is usable again.
(Tested with the hamster-applet bug).
Thanks a lot everybody! I hope this package makes it to the karmic repository soon.

till kahle [2010-01-12 10:36 -0000]:
> I've tested the proposed package xserver-xorg-video-intel and at least for me, Ubuntu is usable again.
> (Tested with the hamster-applet bug).
> Thanks a lot everybody! I hope this package makes it to the karmic repository soon.

Thanks for confirming. Can you please get us the output of "lspci|grep VGA"
here, so that we know which chipset you are using?

For verification I'm also interested in getting testing feedback with
other chipsets (from other people and QA team).

Thanks,

Martin
--
Martin Pitt | http://www.piware.de
Ubuntu Developer (www.ubuntu.com) | Debian Developer (www.debian.org)

confirmed with:
00:02.0 VGA compatible controller: Intel Corporation Mobile 4 Series
Chipset Integrated Graphics Controller (rev 07)

On Tue, Jan 12, 2010 at 23:07, Martin Pitt <email address hidden> wrote:
> till kahle [2010-01-12 10:36 -0000]:
>> I've tested the proposed package xserver-xorg-video-intel and at least for me, Ubuntu is usable again.
>> (Tested with the hamster-applet bug).
>> Thanks a lot everybody! I hope this package makes it to the karmic repository soon.
>
> Thanks for confirming. Can you please get us the output of "lspci|grep VGA"
> here, so that we know which chipset you are using?
>
> For verification I'm also interested in getting testing feedback with
> other chipsets (from other people and QA team).
>
> Thanks,
>
> Martin
> --
> Martin Pitt                        | http://www.piware.de
> Ubuntu Developer (www.ubuntu.com)  | Debian Developer  (www.debian.org)
>
> --
> [Needs -intel 2.9.1] Cairo/Gdk shapes not visible on Intel gpu since Karmic
> https://bugs.launchpad.net/bugs/458545
> You received this bug notification because you are a direct subscriber
> of a duplicate bug.
>

--
Konrad Paumann
Adolf-Kolping-Straße 11/22
2000 Stockerau
Austria
+43 650 8409088

confirmed with:
00:02.0 VGA compatible controller: Intel Corporation Mobile 945GME Express Integrated Graphics Controller (rev 03)

Everything works fine and nice, no side effects noted (Karmic).

darren (d-jones) wrote :

Applying xserver-xorg-video-intel from karmic-proposed has fixed this for me too - hamster and gtg both look fine now. No other adverse effects noticed.

Chipset is:
00:02.0 VGA compatible controller: Intel Corporation 82865G Integrated Graphics Controller (rev 02)

thanks!

Martin Pitt (pitti) on 2010-01-14
tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xserver-xorg-video-intel - 2:2.9.0-1ubuntu2.1

---------------
xserver-xorg-video-intel (2:2.9.0-1ubuntu2.1) karmic-proposed; urgency=low

  * Add 101_uxa_free_scratchpixmapheader.patch. Fixes a problem with
    non anti-aliased cairo shapes not being rendered at all on intel
    graphics. Cherrypick from upstream 2.9.1 release. (LP: #458545)
 -- Robert Hooker <email address hidden> Tue, 05 Jan 2010 17:30:49 -0500

Changed in xserver-xorg-video-intel (Ubuntu Karmic):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.