Comment 5 for bug 1038466

MoLE (moleonthehill) wrote :

I have noticed the same error in precise, same package conflict but different file.
this is on ubuntu precise with the gtg-daily ppa enabled.

Output from sudo apt-get dist-upgrade

The following packages will be upgraded:
  python-liblarch
1 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Need to get 0 B/26.1 kB of archives.
After this operation, 41.0 kB of additional disk space will be used.
Do you want to continue [Y/n]?
(Reading database ... 244082 files and directories currently installed.)
Preparing to replace python-liblarch 0.2.4-1 (using .../python-liblarch_0.2.5.r131~precise1_all.deb) ...
Unpacking replacement python-liblarch ...
dpkg: error processing /var/cache/apt/archives/python-liblarch_0.2.5.r131~precise1_all.deb (--unpack):
 trying to overwrite '/usr/share/pyshared/liblarch_gtk/__init__.py', which is also in package python-liblarch-gtk 0.2.4-1
Errors were encountered while processing:
 /var/cache/apt/archives/python-liblarch_0.2.5.r131~precise1_all.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

I will try the workaround suggested.