Writing a tag in a task leave all the intermediary tags

Bug #1001962 reported by Lionel Dricot on 2012-05-20
50
This bug affects 8 people
Affects Status Importance Assigned to Milestone
Getting Things GNOME!
Critical
Lionel Dricot

Bug Description

1. Open a task

2. write @mytag in it

3. observes that @m, @my, @myt and @myta are still shown in the tag sidebar.

Related branches

Lionel Dricot (ploum) on 2012-05-20
Changed in gtg:
status: New → Confirmed
importance: Undecided → Critical
milestone: none → 0.3
Izidor Matušov (izidor) on 2012-05-21
Changed in gtg:
assignee: nobody → Izidor Matušov (izidor)
Changed in gtg:
assignee: Izidor Matušov (izidor) → Alan Gomes Alvino (alangalvino)
Changed in gtg:
status: Confirmed → Fix Committed
Izidor Matušov (izidor) wrote :

Hi Alan,

the bug can have the state "Fix Comitted" only when the fix is in trunk lp:gtg, i.e. it was merged.

Changed in gtg:
status: Fix Committed → In Progress
Alan Gomes Alvino (alangalvino) wrote :

My mistake, sorry!

Lionel Dricot (ploum) on 2012-06-21
Changed in gtg:
status: In Progress → Confirmed
Changed in gtg:
assignee: Alan Gomes Alvino (alangalvino) → Izidor Matušov (izidor)
Lionel Dricot (ploum) on 2012-07-30
Changed in gtg:
assignee: Izidor Matušov (izidor) → Lionel Dricot (ploum)
status: Confirmed → In Progress
Izidor Matušov (izidor) on 2012-10-02
Changed in gtg:
assignee: Lionel Dricot (ploum) → Izidor Matušov (izidor)
Jeff Fortin Tam (kiddo) wrote :

Again, you are doing way too much. Why are you even updating the UI while the tag is being typed? Only do it once the tag has been set and changed, that is with a whitespace or punctuation delimiter...

Jeff Fortin Tam (kiddo) wrote :

(...or when the typing caret is moved out or the editor window closed)

Izidor Matušov (izidor) wrote :

Yes, you're right. However, there is a regression in the underlining library and it should be fixed first.

Actually it is necessary to update the tag as once collaborative gtg
is implemented, real time updates will become a requirement.

On 10/7/12, Izidor Matušov <email address hidden> wrote:
> Yes, you're right. However, there is a regression in the underlining
> library and it should be fixed first.
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (1026913).
> https://bugs.launchpad.net/bugs/1001962
>
> Title:
> Writing a tag in a task leave all the intermediary tags
>
> Status in Getting Things GNOME!:
> In Progress
>
> Bug description:
> 1. Open a task
>
> 2. write @mytag in it
>
> 3. observes that @m, @my, @myt and @myta are still shown in the tag
> sidebar.
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/gtg/+bug/1001962/+subscriptions
>

--
Nimit Shah,
B Tech 4th year,
Computer Engineering Department,
SVNIT Surat
www.dude-says.blogspot.com

Jeff Fortin Tam (kiddo) wrote :

> Actually it is necessary to update the tag as once collaborative gtg
> is implemented, real time updates will become a requirement.

I don't think you need to update on every single character being typed.
It's going to hammer the network for no good reason and the person at
the other end can certainly wait the 1-2 seconds required for you to
finish typing your tag before having the UI be updated...

Lionel Dricot (ploum) on 2012-10-21
Changed in gtg:
assignee: Izidor Matušov (izidor) → Lionel Dricot (ploum)
Changed in gtg:
status: In Progress → Fix Committed
Nimit Shah (nimit-svnit) wrote :

awesome! I had been tired of using modify_tags dialog for a long time now!

Nimit Shah,
B Tech 4th year,
Computer Engineering Department,
SVNIT Surat
www.dude-says.blogspot.com

On Thu, Nov 1, 2012 at 3:43 PM, Bertrand Rousseau <
<email address hidden>> wrote:

> ** Changed in: gtg
> Status: In Progress => Fix Committed
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (1026913).
> https://bugs.launchpad.net/bugs/1001962
>
> Title:
> Writing a tag in a task leave all the intermediary tags
>
> Status in Getting Things GNOME!:
> Fix Committed
>
> Bug description:
> 1. Open a task
>
> 2. write @mytag in it
>
> 3. observes that @m, @my, @myt and @myta are still shown in the tag
> sidebar.
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/gtg/+bug/1001962/+subscriptions
>

Changed in gtg:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers