Gnome VFS Filesystem Abstraction library

Cannot move cross-filesystem symlinks to Trash

Reported by Peter Parkkali on 2005-12-06
76
Affects Status Importance Assigned to Milestone
GnomeVFS
Won't Fix
Medium
gnome-vfs2 (Ubuntu)
Medium
Ubuntu Desktop Bugs

Bug Description

It's possible to create a symlink in nautilus that references an object on
another filesystem than where the link is housed. However, nautilus refuses move
such links to the Trash.

To reproduce:
1) Open two nautilus windows, showing folders on separate filesystems, where you
have write access to at least one of the folders
2) Middle-click and drag an object from one window to the other, choose "Link here"
3) Remove the link with the "Del" key or Right-click -> "Move to Trash"

Nautilus replies with a dialog:
  Error "not on the same file system" while deleting "/path/to/link".
  Would you like to continue? [Cancel] [Retry]

Retrying will repeat the error.

3b) Using direct "Delete" (if it's enabled in prefs) deletes the link though.

I don't think this is the same as Bug #23068 , altough similar.

http://bugzilla.gnome.org/show_bug.cgi?id=309592: http://bugzilla.gnome.org/show_bug.cgi?id=309592

Sebastien Bacher (seb128) wrote :

Thanks for your bug. What version of Ubuntu do you use?

Peter Parkkali (peter-parkkali) wrote :

Breezy, with latest updates

Sebastien Bacher (seb128) wrote :

It's known upstream: http://bugzilla.gnome.org/show_bug.cgi?id=309592. I've put
a comment with your description.

Changed in gnome-vfs2:
assignee: seb128 → desktop-bugs
status: Unconfirmed → Confirmed
markba (mark-baaijens) wrote :

Same for me, working on Dapper Flight 5 + updates.

Changed in gnome-vfs:
status: Unconfirmed → Confirmed

Same here on Edgy, trying with a symlink between a FAT16 and ext3 filesystem.

Haggai Eran (haggai-eran) wrote :

I suffer from a variant of this bug (more like #43237). I tried to delete a folder from my desktop, and I got the error saying I cannot move to a different filesystem. The difference is that my desktop and my trash are on the same filesystem. However, I do have a chroot and my home directory is also bind-mounted to there. the error I got mention the chroot filesystem so I guess the bug is related to that.

Regards,
Haggai Eran

Changed in gnome-vfs2:
status: Confirmed → Triaged
Patrick Wildgruber (pw-mail) wrote :

Bug still exists on Feisty here. Why does no one fix it? I guess its not that difficult, is it?

Yann Rouillard (yann-pleiades) wrote :

The upstream bug for this issue should rather be http://bugzilla.gnome.org/show_bug.cgi?id=312506
2 patches have already been given (including one of mine) but they haven't yet been applied (since 2005).

Concerning ubuntu, I still can't delete symlink to other filesystem in Gutsy although now no error dialog appears, the file is just not deleted at all.

The patch from Christian Neumair: http://mail.gnome.org/archives/nautilus-list/2005-October/msg00077.html seems to solve this issue.

I put updated nautilus packages including this patch for gutsy in my personal package archive for test. Packages will soon be here: http://ppa.launchpad.net/yann-pleiades/ubuntu/pool/main/n/nautilus

Yann Rouillard (yann-pleiades) wrote :

The patch was not accepted upstream for the reason explained here:
http://mail.gnome.org/archives/nautilus-list/2005-October/msg00159.html

I made another patch to tries to follow Alexander Larsson's advice and sent it upstream:
http://mail.gnome.org/archives/gnome-vfs-list/2007-October/msg00009.html

Dave Vree (hdave) wrote :

I just tried this in Hardy final and it seems to be fixed with the new version of GVS. Can somebody else confirm?

zerwas (zerwas) wrote :

I experienced the same like HDave, looks like it is fixed now. Thanks to everbody!

Gabriel Velo (gabriel-velo) wrote :

The bug still persist in Hardy.

I can't delete sftp:// or smb:// virtual filesystem that appears is the Desktop after the virtual filesystem is mouted , pressing the "DEL" key or dragging to the trash.

It can only be deleted using the option "Unmount Volume" from the contextual menu, which is counterintuitive.

Francesco Potortì (pot) wrote :

Gabriel, what you describe is a issue different from what originally reported. This bug refers to a link to a *file* in a different file system (where both file systems are *local*).

On the other hand, you speak about links to a *virtual file system*.

While I agree with you that the interface should allow unmounting a virtual file system by just dragging its icon to the trash, as it has always worked on Macs, this issue is completely different. Moreover it is not even a bug (in the sense that the behaviour is consistent with the documentation), but rather a wishlist. I suggest that you open a new bug report, after checking that a similar one does not exist already.

Changed in gnome-vfs:
status: Confirmed → Won't Fix
David Futcher (bobbo) wrote :

Patches have been rejected upstream due to gvfs's deprecation.

tags: added: patch-forwarded-upstream
tags: added: patch-rejected-upstream
removed: patch-forwarded-upstream
David Futcher (bobbo) wrote :

Fail, 'gnome-vfs' has been deprecated.

Changed in gnome-vfs:
importance: Unknown → Medium
Mörgæs (moergaes) on 2013-03-12
Changed in gnome-vfs2 (Ubuntu):
status: Triaged → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.