Touchpad enable/disable OSD image is empty

Bug #877058 reported by David Chen on 2011-10-18
38
This bug affects 3 people
Affects Status Importance Assigned to Milestone
GNOME Settings Daemon
Fix Released
Medium
gnome-settings-daemon (Ubuntu)
Low
Unassigned
Oneiric
Low
Didier Roche

Bug Description

Build Version/Date: Ubuntu 11.10 final release amd64
Environment used for testing: Dell laptops with touchpad enable/disable hotkey

Summary:
When pressing the hotkey to disable/enable touchpad, OSD pops up on the notification area, but no touchpad image is displayed. On Ubuntu 10.10 and 11.04, touchpad image shows correctly.
Steps to Reproduce:
1. Install Ubuntu 11.10 on a Dell machine with touchpad enable/disable hotkey
2. After installation, boot system to desktop environment
3. Press the hotkey to disable touchpad

Expected result:
When pressing hotkey to disable touchpad, OSD brings up a touchpad icon with a red cross on it; when re-enabling it, touchpad icon without red cross shows up on notification area.

Actual result:
OSD pops up, but only shows a black box with no touchpad image on it.

Sebastien Bacher (seb128) wrote :

thank you for your bug report, could you take a screenshot of the bug? it seems rather a gnome-settings-daemon issue than a notify-osd one from the description, notify-osd just displays what it's asked to

Changed in notify-osd:
importance: Undecided → Low
status: New → Incomplete
David Chen (david.chen) wrote :
David Chen (david.chen) wrote :

The hotkey works, touchpad can be disabled and enabled correctly, it's just the OSD icon is missing.

Chris Van Hoof (vanhoof) on 2011-10-18
tags: added: hwe-blocker-enablement
Sebastien Bacher (seb128) wrote :

is that issue only happening when the dash is open?

Sebastien Bacher (seb128) wrote :

I don't have a touchpad enable key on my laptop or netbook, could run "dbus-monitor --session", hit the key and copy the log to the bug to see what text and image are sent on the bus?

Ayan George (ayan) wrote :

@seb123 -- I'll try to get that to you ASAP.

Changed in notify-osd:
assignee: nobody → Ayan George (ayan)
David Chen (david.chen) wrote :

This issue has nothing to do with dash, same behavior without dash open.

Changed in notify-osd:
status: Incomplete → Confirmed
tags: added: blocks-hwcert-enablement
Sebastien Bacher (seb128) wrote :

thank you but please keep the bug to Incomplete until somebody provide the requested infos

Changed in notify-osd:
status: Confirmed → Incomplete
Sebastien Bacher (seb128) wrote :

Ok, in fact it seems to be
http://git.gnome.org/browse/gnome-settings-daemon/commit/?h=gnome-3-2&id=387df5458a5b63c3b89baf6f58e2c12c2af78d6d

It should be fixed with this version:
https://launchpad.net/ubuntu/+source/gnome-settings-daemon/3.2.1-0ubuntu1

Could you test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

affects: notify-osd → gnome-settings-daemon
Changed in gnome-settings-daemon:
assignee: Ayan George (ayan) → nobody
status: Incomplete → Fix Committed
importance: Low → Unknown
status: Fix Committed → Unknown
Changed in gnome-settings-daemon (Ubuntu):
status: New → Fix Committed
importance: Undecided → Low
Changed in gnome-settings-daemon (Ubuntu Oneiric):
importance: Undecided → Low
status: New → Fix Committed
summary: - Touchpad enable/disable OSD image cannot be displayed in notification
- area
+ Touchpad enable/disable OSD image is empty
James Schriver (dashua) wrote :

HP DV6 2170US with touchpad disable hotkey. Seems to be still occurring.

Sebastien Bacher (seb128) wrote :

ok, Didier pointed that your distro patch to use notify-osd needs a similar update

Changed in gnome-settings-daemon (Ubuntu Oneiric):
status: Fix Committed → Triaged
Changed in gnome-settings-daemon (Ubuntu):
status: Fix Committed → Triaged
Changed in gnome-settings-daemon (Ubuntu Oneiric):
assignee: nobody → Rodrigo Moya (rodrigo-moya)
Didier Roche (didrocks) wrote :

Will be fixed in 3.2.1-0ubuntu2 or higher once uploaded.

Changed in gnome-settings-daemon:
importance: Unknown → Medium
status: Unknown → Fix Released
Didier Roche (didrocks) on 2011-10-19
Changed in gnome-settings-daemon (Ubuntu Oneiric):
assignee: Rodrigo Moya (rodrigo-moya) → Didier Roche (didrocks)

Hello David, or anyone else affected,

Accepted gnome-settings-daemon into oneiric-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in gnome-settings-daemon (Ubuntu Oneiric):
status: Triaged → Fix Committed
tags: added: verification-needed
David Chen (david.chen) wrote :

Hi Martin,

Verified gnome-settings-daemon 3.2.1-0ubuntu2 in oneiric-proposed, touchpad OSD image can be displayed correctly.

Thanks!

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-settings-daemon - 3.2.1-0ubuntu2

---------------
gnome-settings-daemon (3.2.1-0ubuntu2) oneiric-proposed; urgency=low

  [ Didier Roche ]
  * debian/patches/16_use_synchronous_notifications.patch:
    - make our patch using the new icon name (LP: #877058)

  [ Sebastien Bacher ]
  * debian/patches/git_correct_suspend_bus.patch:
    - git patch to fix a suspend regression in the new version (lp: #878076)

gnome-settings-daemon (3.2.1-0ubuntu1) oneiric-proposed; urgency=low

  * New upstream release (LP: #877326)
  * debian/patches/00git_dont_restore_brightness.patch:
  * debian/patches/00git_fix_reference_leaks.patch:
  * debian/patches/00git_fix_async_dbus_crash.patch:
  * debian/patches/00git_dont_sleep_on_idle_by_default.patch:
  * debian/patches/00git_dont_revert_pre_idle_brigthness.patch:
  * debian/patches/00git_avoid_undesired_sleeps.patch:
  * debian/patches/49_fix_suspend_media_key.patch:
    - Remove upstreamed patches
  * debian/patches/16_use_synchronous_notifications.patch:
    - Rebased
 -- Didier Roche <email address hidden> Wed, 19 Oct 2011 17:25:16 +0200

Changed in gnome-settings-daemon (Ubuntu):
status: Triaged → Fix Released

The gnome-settings-daemon (3.2.1-0ubuntu2) in oneiric-proposed displays the touchpad OSD for me too.

Anthony Wong (anthonywong) wrote :

I think this should be Fix Released as it's fixed in 3.2.1-0ubuntu2

Changed in gnome-settings-daemon (Ubuntu Oneiric):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.