Can't calibrate webcam or monitor

Bug #868803 reported by komputes on 2011-10-06
20
This bug affects 3 people
Affects Status Importance Assigned to Milestone
gnome-control-center
New
Undecided
Unassigned
apt-zip (Ubuntu)
Undecided
Unassigned
gnome-control-center (Ubuntu)
Low
Chris Halse Rogers

Bug Description

System Settings > Color

Can't calibrate webcam or monitor. I think this is because gnome-color-manager is not installed. When I try to install it I get the following error, even though the package is in universe:

ubuntu@ubuntu:~$ apt-cache madison argyll gnome-color-manager
    argyll | 1.3.3-0ubuntu4 | http://us.archive.ubuntu.com/ubuntu/ oneiric/universe i386 Packages
    argyll | 1.3.3-0ubuntu4 | http://us.archive.ubuntu.com/ubuntu/ oneiric/universe Sources
gnome-color-manager | 3.1.2-0ubuntu2 | http://us.archive.ubuntu.com/ubuntu/ oneiric/universe i386 Packages
gnome-color-manager | 3.1.2-0ubuntu2 | http://us.archive.ubuntu.com/ubuntu/ oneiric/universe Sources
ubuntu@ubuntu:~$ sudo apt-get install gnome-color-manager
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following extra packages will be installed:
  argyll
The following NEW packages will be installed:
  argyll gnome-color-manager
0 upgraded, 2 newly installed, 0 to remove and 0 not upgraded.
Need to get 16.7 MB of archives.
After this operation, 39.6 MB of additional disk space will be used.
Do you want to continue [Y/n]?
WARNING: The following packages cannot be authenticated!
  argyll gnome-color-manager
Install these packages without verification [y/N]?
E: Some packages could not be authenticated

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: gnome-control-center 1:3.2.0-0ubuntu5
ProcVersionSignature: Ubuntu 3.0.0-12.19-generic 3.0.4
Uname: Linux 3.0.0-12-generic i686
NonfreeKernelModules: wl
ApportVersion: 1.23-0ubuntu2
Architecture: i386
Date: Wed Oct 5 19:56:38 2011
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Alpha i386 (20110817)
SourcePackage: gnome-control-center
UpgradeStatus: Upgraded to oneiric on 2011-10-05 (0 days ago)
usr_lib_gnome-control-center:
 gnome-bluetooth 3.2.0-0ubuntu1
 indicator-datetime 0.3.0-0ubuntu1

Related branches

komputes (komputes) wrote :
Sebastien Bacher (seb128) wrote :

Could you refresh your update-manager index and try again? it just seems your mirror failed to identificate the signature key

Changed in gnome-control-center (Ubuntu):
importance: Undecided → Low
status: New → Incomplete
komputes (komputes) wrote :

I still can't calibrate webcam or monitor even with argyll gnome-color-manager.

When changing monitor profiles, the color temperature does not change.

When I try to calibrate my webcam it prompts me to download shared-color-targets.
The package fails to install as it doesn't exist.
The process fails with the error: "Failed to calibrate, failed to match display".

Changed in gnome-control-center (Ubuntu):
status: Incomplete → New
Sebastien Bacher (seb128) wrote :

Somebody having the issue should report it to GNOME, the color temperature and the webcam issue are probably different bugs though

Sebastien Bacher (seb128) wrote :

Rodrigo, could you have a look to the "shared-color-targets" package installation, why does it want it and how should that be translated in Ubuntu?

Changed in gnome-control-center (Ubuntu):
assignee: nobody → Rodrigo Moya (rodrigo-moya)
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-control-center (Ubuntu):
status: New → Confirmed
Sebastien Bacher (seb128) wrote :

Chris, could you look if that's something that should be fixed with the "install on demand" work which was planned or done there?

Changed in gnome-control-center (Ubuntu):
assignee: Rodrigo Moya (rodrigo-moya) → Chris Halse Rogers (raof)
Chris Halse Rogers (raof) wrote :

shared-color-targets needs to be packaged; it's not currently packaged.

Needing argyll to be installed before the "calibrate" button works is the install-on-demand WI.

Chris Halse Rogers (raof) wrote :

Or, rather, needing gnome-color-manager to be installed before the "calibrate" button works.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-control-center - 1:3.2.2-2ubuntu6

---------------
gnome-control-center (1:3.2.2-2ubuntu6) precise; urgency=low

  [ Aurélien Gâteau ]
  * debian/patches/58_ubuntu_icon_views_redesign.patch
    - Implement the new category headers (LP: #921061)

  [ Didier Roche ]
  * debian/patches/04_new_appearance_settings.patch, respect new
    design requests:
    - High Contrast misspelled as "HighContrast" etc (LP: #878790)
    - The scope of "Restore defaults" button in Appearance>Behavior is
      not clear enough (LP: #924253)
    - Add a new launcher reveal slider (LP: #923749)
    - The Background section in Appearance panel should have an option
      to display the dotted grid (LP: #922544)
    - Restore Defaults buttons in appearance should be replaced with in
      context hints (LP: #922543)
    - Rename tabs to look and User Interface to Background (LP: #918580)

  [ Christopher James Halse Rogers ]
  * debian/patches/59_install_gcm_components_on_demand.patch:
    - Install gnome-color-manager tools on-demand. Fixes the "calibrate"
      and "View profile" buttons without requiring us to install 33MB of
      Arygll on the CDs. (LP: #868803)
 -- Didier Roche <email address hidden> Tue, 07 Feb 2012 18:13:21 +0100

Changed in gnome-control-center (Ubuntu):
status: Confirmed → Fix Released
Fabri Velas (fabrivelas) wrote :

The issue that shared-color-targets is not installed as mentioned in comment 3 has not been resolved. This issue, though, is related to bug #643168 and bug #790735.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers