Some online accounts cannot be added

Bug #1159411 reported by Alberto Salvia Novella
484
This bug affects 129 people
Affects Status Importance Assigned to Milestone
Online Accounts: GNOME Control Center
Undecided
Unassigned
gnome-control-center-signon (Ubuntu)
High
Alberto Mardegan

Bug Description

********************
HOW TO REPRODUCE
********************
1. Go to "System settings -> Online accounts".
2. Select to add a "AIM" new account.
3. Click on the "done" button.

***********
BEHAVIOUR
***********
- EXPECTED: An account to be created.
- REAL: No account is added, because the screen for entering the information is never shown.

************
WORKAROUND
************
You can write the following line into the Terminal to get a fully working instant messaging client: sudo apt-get install pidgin -y && pidgin

******************
RELEVANT DETAILS
******************
- It affects AIM, ICQ, Salut, Jabber and Yahoo! accounts.
- AIM and Yahoo!' never work.
- Salut and Jabber' work a few times, not clear when they do.
- Affects both existing accounts and the creation of new ones.

ProblemType: Crash
DistroRelease: Ubuntu 13.04
Package: gnome-control-center 1:3.6.3-0ubuntu16
ProcVersionSignature: Ubuntu 3.8.0-14.24-generic 3.8.4
Uname: Linux 3.8.0-14-generic x86_64
ApportVersion: 2.9.2-0ubuntu2
Architecture: amd64
Date: Sun Mar 24 14:08:46 2013
ExecutablePath: /usr/bin/gnome-control-center
InstallationDate: Installed on 2013-03-23 (0 days ago)
InstallationMedia: Ubuntu 13.04 "Raring Ringtail" - Alpha amd64 (20130323)
MarkForUpload: True
ProcCmdline: gnome-control-center
ProcEnviron:
 SHELL=/bin/bash
 XDG_RUNTIME_DIR=<set>
 PATH=(custom, no user)
 LANG=es_ES.UTF-8
SegvAnalysis:
 Segfault happened at: 0x7f8c10069809 <empathy_account_widget_apply_and_log_in+9>: mov 0x38(%rdi),%rax
 PC (0x7f8c10069809) ok
 source "0x38(%rdi)" (0x00000038) not located in a known VMA region (needed readable region)!
 destination "%rax" ok
SegvReason: reading NULL VMA
Signal: 11
SourcePackage: gnome-control-center
StacktraceTop:
 empathy_account_widget_apply_and_log_in () from /usr/lib/empathy/libempathy-gtk-3.6.4.so
 g_cclosure_marshal_VOID(int0_t, void) () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
 ?? () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
 g_signal_emit_valist () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
 g_signal_emit () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
Title: gnome-control-center crashed with SIGSEGV in empathy_account_widget_apply_and_log_in()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
XsessionErrors:
 (gnome-terminal:2352): Vte-2.90-WARNING **: No se pueden convertir caracteres de UTF-8 a actual.
 (gnome-terminal:2352): Gtk-WARNING **: Unknown property: GtkHScale.update-policy
 (process:31025): GLib-CRITICAL **: g_slice_set_config: assertion `sys_page_size == 0' failed
usr_lib_gnome-control-center:
 activity-log-manager-control-center 0.9.4-0ubuntu6.1
 deja-dup 25.5-0ubuntu1
 gnome-control-center-signon 0.1.4-0ubuntu1
 gnome-control-center-unity 1.2daily13.02.15-0ubuntu1
 indicator-datetime 12.10.3daily13.03.07-0ubuntu1

Revision history for this message
Alberto Salvia Novella (es20490446e) wrote :
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-control-center (Ubuntu):
status: New → Confirmed
information type: Private → Public
description: updated
tags: removed: need-amd64-retrace
Changed in hundredpapercuts:
assignee: nobody → Paper Cuts Ninja (papercuts-ninja)
no longer affects: hundredpapercuts
Changed in gnome-control-center (Ubuntu):
assignee: nobody → David King (amigadave)
Revision history for this message
Swen Kühnlein (swen) wrote :

Also happens with AIM.

Revision history for this message
Daniel Seebacher (daniel-seebacher) wrote :

Same Problem with ICQ (account-plugin-icq). "dmesg | tail" shows "gnome-control-c[6323]: segfault at 38 ip 00007fb9db706809 sp 00007fff89616a00 error 4 in libempathy-gtk-3.6.4.so[7fb9db6d1000+ab000]"

description: updated
Revision history for this message
Jakub Budiský (jakub-budisky-deactivatedaccount) wrote :

Generally speaking, it happens with accounts that are not using browser authorization. For me, any type of "waiting workaround" is not working, I just have to restart system in order to set up ICQ account. It messes up again after removing and trying to re-add, and unfortunately, at least ICQ plugin is not working at all (and I believe it is connected to this bug).

description: updated
description: updated
Revision history for this message
bwat47 (bwat47) wrote :

@Jakub, same problem here, can't add am AIM account at all, waiting does not work. It just sits there indefinitely and the part to enter the username/password never appears. Seems to happen with all the non browser based plugins. And in the rare event it does appear and let me add the account, upon a reboot the account stops working again, and when you try to remove/re-add it it doesn't appear again.

Revision history for this message
bwat47 (bwat47) wrote :

actually I'm not sure I can reproduce this anymore after installing from the latest raring ISO. my aim account appears to be working fine as are facebook and google. I will need to test for a few days to confirm, because last time I thought this was fixed it came back after a day, but I'm crossing my fingers.

Revision history for this message
bwat47 (bwat47) wrote :

Nevermind :(, still does it. bug seemed to have been triggered after the first time I suspended the freshly installed raring to ram. after resume the aim account refused to reconnect, and trying to add an aim/jabber account in UOA is messed up again, it just sits there and doesnt bring up the spot to enter my credentials, and then gnome-control-center crashes with the SIGSEGV message in this bug report.

Revision history for this message
abma (abma) wrote :

i still can't connect my irc account. also i'm getting apparmor messages in kernel log:

[ 22.934104] type=1400 audit(1365804121.486:22): apparmor="DENIED" operation="file_mmap" parent=1 profile="/usr/lib/telepathy/telepathy-*" name="/usr/lib/x86_64-linux-gnu/libproxy/0.4.11/modules/config_gnome3.so" pid=2680 comm="telepathy-gabbl" requested_mask="m" denied_mask="m" fsuid=1000 ouid=0

not sure these messages are related.

Revision history for this message
abma (abma) wrote :

also i'm getting (after clicking "allow access" to my irc account):
"Applications can no longer access your <username> at <server> Online account. Choose Online Accounts from the user menu to reinstate access to this account."

Revision history for this message
Greg Michalec (greg-primate) wrote :

As of now (24-4-13), it seems as though the online accounts dialogue no longer is crashing. However, I am still unable to create or edit Yahoo or AIM accounts. I have tested doing a purge and reinstall of empathy and all telepathy packages, and under the guest account. The dialogue with "Please enter your account details" appears, with cancel and done buttons, but no fields for actually entering any details ever appears. This also occurs *sometimes* for Jabber accounts. Let me know if there are any additional details I can provide.

Revision history for this message
Greg Michalec (greg-primate) wrote :

I tested this on a live cd, and was able to create a new yahoo account in Online Accounts. It would seem then that the problem is related to having upgraded my system versus doing a fresh install. However, since the problem occurs even under the guest accounts, the issue must not be anything in my user-level configuration - it is system-wide. I'm pretty confused though, as I have done a apt-get remove --purge and reinstall of every package I thought relevant. I'm out of ideas as to how to track this down. I'm also not sure if this is even the same bug, as I'm not experiencing a crash anymore.

Revision history for this message
Alberto Salvia Novella (es20490446e) wrote :

I'm not experiencing a crash anymore too, but the screen for entering the information is never shown or done after so much time.

description: updated
summary: - gnome-control-center crashed with SIGSEGV in
- empathy_account_widget_apply_and_log_in()
+ Some online accounts cannot be added
description: updated
description: updated
description: updated
description: updated
description: updated
description: updated
Revision history for this message
Scott Hinton (78luphr0rnk2nuqimstywepozxn9kl19tqh0tx66b5dki1x-launchpad-a811i2i3ytqlsztthjth0svbccw8inm65tmkqp9sarr553j) wrote :

Looks like this bug affects both existing accounts and the creation of new ones. After upgrading from 12.10 to 13.04, the only client working for me was Google. My other existing accounts for AIM, Yahoo and ICQ did not appear to be working. I decided to remove my AIM account and re-add it. Like the others above, the login details screen is blank.

Wish I hadn't upgraded my work computer now. I use IM extensively to keep in touch with co-workers and clients. I've been in the dark since upgrading.

description: updated
Revision history for this message
Greg Michalec (greg-primate) wrote : Re: [Bug 1159411] Re: Some online accounts cannot be added

Scott -
I use AIM for work as well. I've installed pidgin (an alternate IM
client) so I can still communicate until this bug is resolved.

On 05/02/2013 07:20 AM, Scott Hinton wrote:
> Looks like this bug affects both existing accounts and the creation of
> new ones. After upgrading from 12.10 to 13.04, the only client working
> for me was Google. My other existing accounts for AIM, Yahoo and ICQ did
> not appear to be working. I decided to remove my AIM account and re-add
> it. Like the others above, the login details screen is blank.
>
> Wish I hadn't upgraded my work computer now. I use IM extensively to
> keep in touch with co-workers and clients. I've been in the dark since
> upgrading.
>

description: updated
description: updated
Revision history for this message
tuxator (steffen-trekki) wrote :

also affects ICQ accounts. I installed the ICQ backend for Empathy and tried to create an account, but the account creation screen is just blank. It does work for Jabber (which I guess is not based upon a website log-in like google or facebook accounts).

Version is Ubuntu 13.04

description: updated
Changed in gnome-control-center (Ubuntu):
importance: Undecided → High
status: Confirmed → Triaged
Changed in gnome-control-center:
importance: Unknown → High
affects: gnome-control-center (Ubuntu) → gnome-control-center-signon (Ubuntu)
no longer affects: gnome-control-center
Revision history for this message
Alberto Mardegan (mardy) wrote :

This seems to be a duplicate of bug #1147639. Steffen (and others), if you still can reproduce it, can you please tell me what version of the following packages do you have installed?

- telepathy-mission-control-5
- empathy

Thanks!

Changed in gnome-control-center-signon (Ubuntu):
assignee: David King (amigadave) → Alberto Mardegan (mardy)
status: Triaged → Incomplete
Revision history for this message
GonzO (gonzo) wrote :

telepathy - mission-control-5 - 1:5.14.0-0ubuntu2
empathy - 3.6.4-0ubuntu4

Revision history for this message
Alberto Salvia Novella (es20490446e) wrote :

telepathy-mission-control-5 1:5.14.0-0ubuntu2
empathy 3.6.4-0ubuntu4

Changed in gnome-control-center-signon (Ubuntu):
status: Incomplete → Triaged
assignee: Alberto Mardegan (mardy) → Alberto Salvia Novella (es20490446e)
Revision history for this message
Alberto Mardegan (mardy) wrote :

Thanks for the informations!
Alberto, I see that you reassigned the bug to yourself. Did you do that accidentally, or do you intend to work on fixing it yourself?

Revision history for this message
Alberto Salvia Novella (es20490446e) wrote :

I reassigned the bug to me because I'm now testing if it is fix released, as the duplicated. But I run out of battery in my mouse when I was doing so, and I had to go to buy them! XD

Revision history for this message
Alberto Salvia Novella (es20490446e) wrote :

The bug is still there, so it seems not to be a duplicate of bug #1147639.

Changed in gnome-control-center-signon (Ubuntu):
assignee: Alberto Salvia Novella (es20490446e) → Alberto Mardegan (mardy)
Revision history for this message
Derek L (ddl-lp) wrote :

I also experience this bug. I can temporarily add and edit configurations in Ubuntu Online Accounts (a.k.a. credentials-preferences) again by killing all empathy and telepathy processes, then loading the panel, but this behaviour recurs shortly after restarting empathy. The problem first started after I performed a release upgrade to 13.04 from 12.10. It happens under both Unity and Gnome. Blowing away the contents of ~/.config/libaccounts-glib allowed me to enter new account details again, but the bug returned later. (I also upgraded to gnome 3.8 via the Gnome team PPA, without any improvement.)

I see some errors in kern.log when reloading the accounts panel after restarting empathy:

 kernel: [ 526.559946] empathy-auth-cl[3249]: segfault at 200000028 ip 00007f909fb0261e sp 00007fff2c7dee10 error 4 in libaccounts-glib.so.0.1.3[7f909faf6000+19000]

Also various other warning messages (not sure how relevant):

(credentials-preferences:6073): credentials-cc-panel-WARNING **: cc-credentials-account-details-page.vala:346: Error looking up theme color
(gnome-control-center:8668): credentials-cc-panel-WARNING **: cc-credentials-login-capture.vala:61: Could not register service.
(gnome-control-center:8668): credentials-cc-panel-WARNING **: cc-credentials-login-capture.vala:33: Could not acquire name.

In addition to this bug, since upgrading to 13.04, I've been unable to connect to my AIM account in Empathy (which works fine in pidgin). Jabber connectivity seems okay, although sometimes Empathy fails to display anything at all in its Contact List until it's been killed and restarted a few times.

I'm attaching an apport crash report which hopefully contains more relevant details about the empathy-auth-client crash.

telepathy-mission-control-5 Version: 1:5.14.0-0ubuntu2
empathy Version: 3.6.4-0ubuntu4.1

Revision history for this message
BsL (bsl-bsl) wrote :

My experience was similar to #14: Finally upgraded from 12.10 to 13.04 the other day, ICQ worked fine on first go after upgrade, but would not connect again after the computer had been suspended. Removed account, but can't add it again because UIN/pass fields are missing.

Revision history for this message
GonzO (gonzo) wrote :

...has this ever been addressed? I'm currently forced to use Pidgen, but that has its own issues....

Revision history for this message
Phil Hord (phil-phord) wrote :
Download full text (3.8 KiB)

I don't know. I'm using pidgen again. Unity's messenger seems more broken
now.
On Aug 5, 2013 2:21 PM, "GonzO" <email address hidden> wrote:

> ...has this ever been addressed? I'm currently forced to use Pidgen,
> but that has its own issues....
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1159411
>
> Title:
> Some online accounts cannot be added
>
> Status in “gnome-control-center-signon” package in Ubuntu:
> Triaged
>
> Bug description:
> ********************
> HOW TO REPRODUCE
> ********************
> 1. Go to "System settings -> Online accounts".
> 2. Select to add a "AIM" new account.
> 3. Click on the "done" button.
>
> ***********
> BEHAVIOUR
> ***********
> - EXPECTED: An account to be created.
> - REAL: No account is added, because the screen for entering the
> information is never shown.
>
> ************
> WORKAROUND
> ************
> You can write the following line into the Terminal to get a fully
> working instant messaging client: sudo apt-get install pidgin -y && pidgin
>
> ******************
> RELEVANT DETAILS
> ******************
> - It affects AIM, ICQ, Salut, Jabber and Yahoo! accounts.
> - AIM and Yahoo!' never work.
> - Salut and Jabber' work a few times, not clear when they do.
> - Affects both existing accounts and the creation of new ones.
>
> ProblemType: Crash
> DistroRelease: Ubuntu 13.04
> Package: gnome-control-center 1:3.6.3-0ubuntu16
> ProcVersionSignature: Ubuntu 3.8.0-14.24-generic 3.8.4
> Uname: Linux 3.8.0-14-generic x86_64
> ApportVersion: 2.9.2-0ubuntu2
> Architecture: amd64
> Date: Sun Mar 24 14:08:46 2013
> ExecutablePath: /usr/bin/gnome-control-center
> InstallationDate: Installed on 2013-03-23 (0 days ago)
> InstallationMedia: Ubuntu 13.04 "Raring Ringtail" - Alpha amd64
> (20130323)
> MarkForUpload: True
> ProcCmdline: gnome-control-center
> ProcEnviron:
> SHELL=/bin/bash
> XDG_RUNTIME_DIR=<set>
> PATH=(custom, no user)
> LANG=es_ES.UTF-8
> SegvAnalysis:
> Segfault happened at: 0x7f8c10069809
> <empathy_account_widget_apply_and_log_in+9>: mov 0x38(%rdi),%rax
> PC (0x7f8c10069809) ok
> source "0x38(%rdi)" (0x00000038) not located in a known VMA region
> (needed readable region)!
> destination "%rax" ok
> SegvReason: reading NULL VMA
> Signal: 11
> SourcePackage: gnome-control-center
> StacktraceTop:
> empathy_account_widget_apply_and_log_in () from /usr/lib/empathy/
> libempathy-gtk-3.6.4.so
> g_cclosure_marshal_VOID(int0_t, void) () from
> /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
> ?? () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
> g_signal_emit_valist () from
> /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
> g_signal_emit () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
> Title: gnome-control-center crashed with SIGSEGV in
> empathy_account_widget_apply_and_log_in()
> UpgradeStatus: No upgrade log present (probably fresh install)
> UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
> XsessionErrors:
> (gnome-terminal:2352): Vte-2.90-WARNING **: No se pueden c...

Read more...

Revision history for this message
shaneonabike (shanebill) wrote :

I *think* I am also experiencing this with Google accounts. It does log in to some of the elements, but then continues to indicate each time I reboot that I needs me to re-enter my password (perhaps for Google Docs or something I'm not sure)

Ubuntu 13.04 x32

Revision history for this message
Alberto Salvia Novella (es20490446e) wrote :

shaneonabike, it appears to me that the problem you are trying to describe needs to be handled in a new bug report. If you need further information about how to create a new report, you can have a look at http://wiki.ubuntu.com/DebuggingProcedures.

Thank you

Revision history for this message
Øyvind Stegard (oyvinst) wrote :

Completely unable to add a simple IRC account in fresh install of Ubuntu 13.10. The accounts dialogue complains about "Giving Ubuntu access", and hitting the "Grant" button just makes the same message reappear instantly. (Ubuntu 13.10 is turning out to be a really hard fight overall.)

Revision history for this message
Alberto Mardegan (mardy) wrote :

Hi Øyvind, can you provide a screenshot for this (or even better, a video)? I don't understand how this can happen: IRC doesn't require any authorization (not even a password!), it only requires that one chooses which IRC network to connect to, and a nickname.
I just tried on my machine, and I didn't see any request for access.

Changed in gnome-control-center-signon (Ubuntu):
status: Triaged → Incomplete
Revision history for this message
Øyvind Stegard (oyvinst) wrote :

Alberto Mardegan <email address hidden> writes:

> Hi Øyvind, can you provide a screenshot for this (or even better, a video)? I
> don't understand how this can happen: IRC doesn't require any authorization (not
> even a password!), it only requires that one chooses which IRC network to
> connect to, and a nickname.
> I just tried on my machine, and I didn't see any request for access.

Hi,

1. Add new IRC account (I tested Freenode), input nick and hit done.

2. Things seem ok, it connects in Empathy (even though the Empathy
   connection button in accounts dialog isn't enabled yet, which is surprising.)

3. I have a registered nick at Freenode, so I need to provide password
   for NickServ at login. Hit "edit options" in accouts dialog and input
   a password, then hit done.

4. Now the access trouble starts (and Empathy disconnects).

Øyvind

Revision history for this message
Øyvind Stegard (oyvinst) wrote :

Added screencast which demonstrates problem.

Revision history for this message
Alberto Mardegan (mardy) wrote :

On 11/20/2013 02:55 PM, Øyvind Stegard wrote:
> 1. Add new IRC account (I tested Freenode), input nick and hit done.
>
> 2. Things seem ok, it connects in Empathy (even though the Empathy
> connection button in accounts dialog isn't enabled yet, which is surprising.)

I noticed as well. It's harmless, but it's indeed a bug.

> 3. I have a registered nick at Freenode, so I need to provide password
> for NickServ at login. Hit "edit options" in accouts dialog and input
> a password, then hit done.
>
> 4. Now the access trouble starts (and Empathy disconnects).

Ah, I didn't find that. It seems that Empathy fails to connect if a
password is given; without password, it can connect (even though then
nickserv asks you to identify).
However, this is a separate issue from the original bug. Do you mind
reporting a new one (just for this IRC issue)?

Revision history for this message
Øyvind Stegard (oyvinst) wrote :

Alberto Mardegan <email address hidden> writes:

[...]

> Ah, I didn't find that. It seems that Empathy fails to connect if a
> password is given; without password, it can connect (even though then
> nickserv asks you to identify).
> However, this is a separate issue from the original bug. Do you mind
> reporting a new one (just for this IRC issue)?

Done:

https://bugs.launchpad.net/ubuntu/+source/empathy/+bug/1253096

Øyvind

Revision history for this message
Alberto Mardegan (mardy) wrote :

Thanks Øyvind!

Changed in gnome-control-center-signon (Ubuntu):
status: Incomplete → Triaged
Changed in gnome-control-center-signon:
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.