Unittests do not succeed with random PYTHONHASHSEED value

Bug #1348818 reported by Clark Boylan on 2014-07-25
34
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Ceilometer
Fix Released
Medium
Chris Dent
Cinder
Medium
Victor Stinner
Icehouse
Medium
Clark Boylan
Designate
Medium
ZhiQiang Fan
Glance
Medium
Louis Taylor
Icehouse
Medium
Unassigned
Glance Client
Undecided
Unassigned
Ironic
Fix Released
Undecided
Dmitry Tantsur
OpenStack Compute (nova)
Low
Timofey Durakov
OpenStack DBaaS (Trove)
High
Nikhil Manchanda
OpenStack Dashboard (Horizon)
Medium
Itxaka Serrano
Icehouse
Undecided
Unassigned
OpenStack Heat
Fix Released
Medium
Tony Wang
OpenStack Identity (keystone)
Medium
Brant Knudson
Sahara
Fix Released
Medium
Andrew Lazarev
WSME
Undecided
Unassigned
neutron
Medium
Cedric Brandily
python-neutronclient
Low
Ilya Shakhat

Bug Description

New tox and python3.3 set a random PYTHONHASHSEED value by default. These projects should support this in their unittests so that we do not have to override the PYTHONHASHSEED value and potentially let bugs into these projects.

To reproduce these failures:

# install latest tox
pip install --upgrade tox
tox --version # should report 1.7.2 or greater
cd $PROJECT_REPO
# edit tox.ini to remove any PYTHONHASHSEED=0 lines
tox -epy27

Most of these failures appear to be related to dict entry ordering.

Changed in designate:
status: New → Triaged
milestone: none → juno-3
importance: Undecided → High
pritesh (pritesh) on 2014-07-25
Changed in neutron:
assignee: nobody → pritesh (pritesh)
Kiall Mac Innes (kiall) wrote :
Changed in designate:
status: Triaged → Fix Committed
assignee: nobody → Kiall Mac Innes (kiall)
Joshua Harlow (harlowja) wrote :

I believe this also will happen with python 2.7.3 (not just 3.3).

https://www.python.org/download/releases/2.7.3/

http://bugs.python.org/issue13703

pritesh (pritesh) wrote :

seems to be already fixed here: https://review.openstack.org/#/c/109729/

Changed in neutron:
assignee: pritesh (pritesh) → nobody
status: New → Fix Committed
Henry Gessau (gessau) on 2014-07-27
Changed in neutron:
assignee: nobody → Henry Gessau (gessau)
status: Fix Committed → Confirmed

Fix proposed to branch: master
Review: https://review.openstack.org/109888

Changed in neutron:
status: Confirmed → In Progress

Fix proposed to branch: master
Review: https://review.openstack.org/109895

Fix proposed to branch: master
Review: https://review.openstack.org/109939

Changed in ironic:
assignee: nobody → Dmitry "Divius" Tantsur (divius)
status: New → In Progress
Chris Dent (cdent) on 2014-07-28
Changed in ceilometer:
assignee: nobody → Chris Dent (chdent)
status: New → In Progress

Fix proposed to branch: master
Review: https://review.openstack.org/110014

Changed in horizon:
assignee: nobody → Christian Berendt (berendt)
status: New → In Progress
Dolph Mathews (dolph) wrote :

I haven't seen this as an issue in Keystone yet - is there anything I need to do to reproduce it other than run tox 1.7.2?

Changed in keystone:
status: New → Incomplete
Dolph Mathews (dolph) wrote :

My first attempt to reproduce this was a complete fail on my part... I easily reproduced on the second attempt, and confirmed the workaround.

Changed in keystone:
assignee: nobody → Dolph Mathews (dolph)
importance: Undecided → Medium
status: Incomplete → Triaged

Fix proposed to branch: master
Review: https://review.openstack.org/110039

Changed in keystone:
status: Triaged → In Progress
Eoghan Glynn (eglynn) on 2014-07-29
Changed in ceilometer:
importance: Undecided → Medium
milestone: none → juno-3
Rakesh H S (rh-s) on 2014-07-29
Changed in heat:
assignee: nobody → Rakesh H S (rh-s)

Reviewed: https://review.openstack.org/110039
Committed: https://git.openstack.org/cgit/openstack/keystone/commit/?id=61b44eaceb3f57ef1d34e6a358398e36f49ba396
Submitter: Jenkins
Branch: master

commit 61b44eaceb3f57ef1d34e6a358398e36f49ba396
Author: Dolph Mathews <email address hidden>
Date: Mon Jul 28 15:55:51 2014 +0000

    Add workaround to support tox 1.7.2

    Change-Id: I58542f6e7dbbad98517c09b6176b9827f66dd1ff
    Partial-Bug: 1348818

Fix proposed to branch: master
Review: https://review.openstack.org/110408

Changed in heat:
status: New → In Progress

Reviewed: https://review.openstack.org/109939
Committed: https://git.openstack.org/cgit/openstack/ironic/commit/?id=b056fca27897947ce5ef1326ee19db767f14f0ae
Submitter: Jenkins
Branch: master

commit b056fca27897947ce5ef1326ee19db767f14f0ae
Author: Dmitry Tantsur <email address hidden>
Date: Mon Jul 28 11:23:12 2014 +0200

    Do not rely on hash ordering in tests

    With tox 1.7.2 hash randomization will be on by default, causing
    random failures of our tests. How to reproduce:
    * Update tox
    * Run something like:
      $ for i in {1..20}; do tox -epy27 || break; done

    Change-Id: I52c10c47a7a1c0e6a9e436efb090bbcb0fb02edc
    Closes-bug: #1348818

Changed in ironic:
status: In Progress → Fix Committed

Change abandoned by Rakesh H S (<email address hidden>) on branch: master
Review: https://review.openstack.org/110408

Rakesh H S (rh-s) on 2014-07-30
Changed in heat:
assignee: Rakesh H S (rh-s) → nobody

Reviewed: https://review.openstack.org/109888
Committed: https://git.openstack.org/cgit/openstack/neutron/commit/?id=c83207ec9726bee2ba295f2a25228b2ac5a89b6d
Submitter: Jenkins
Branch: master

commit c83207ec9726bee2ba295f2a25228b2ac5a89b6d
Author: Henry Gessau <email address hidden>
Date: Sun Jul 27 21:01:46 2014 -0400

    Functional tests work fine with random PYTHONHASHSEED

    Partial-bug: #1348818

    Change-Id: Iccac403585635851c6d121d6e27c1c90b0de5acb

Reviewed: https://review.openstack.org/109994
Committed: https://git.openstack.org/cgit/openstack/ceilometer/commit/?id=3a009031be349fb20738ba295a63c2fc2cefa4fd
Submitter: Jenkins
Branch: master

commit 3a009031be349fb20738ba295a63c2fc2cefa4fd
Author: Chris Dent <email address hidden>
Date: Mon Jul 28 12:34:35 2014 +0100

    Fix dict and set order related issues in tests

    There are several tests where the expected output
    relies on order of strings generated from the arbitrary
    ordering of dictionaries or sets. The new version of
    tox causes that ordering to be different between tests
    runs so tests must be resilient and test either the
    content of the dicts or sets or their sorted output.

    Note: These fixes are only of those cases where a failure
    was generated. If there are issues in skipped tests, this
    patch has not found nor fixed them. The vast majority of
    skipped tests are related to availability of functionality
    so there's little that can be done about that with the
    current testing setup. The best we can do is be on the
    lookout for failures that could be related PYTHONHASHSEED
    down the road and fix them as they happen.

    Closes-Bug: 1348818
    Change-Id: I6b27ca2597c51b0656f441f325f9ffd0e31a606d

Changed in ceilometer:
status: In Progress → Fix Committed
Changed in sahara:
importance: Undecided → Medium
milestone: none → juno-3
status: New → Confirmed
John Vrbanac (john.vrbanac) wrote :

jfyi:
I was able to reliably reproduce two errors with the Barbican tests when running tox locally setting PYTHONHASHSEED=1742787125

Local Tox Output: http://paste.openstack.org/show/89674/
Tox Version: 1.7.2
Barbican Git commit id: e0c542d158128301de3ef778739fd3c313c253e6

When I set the PYTHONHASHSEED=0 these errors stop coming up.

Changed in barbican:
status: New → Confirmed
milestone: none → juno-3

Reviewed: https://review.openstack.org/110233
Committed: https://git.openstack.org/cgit/openstack/barbican/commit/?id=edd887da5b66dfd3428be552e4b7d5bf66343783
Submitter: Jenkins
Branch: master

commit edd887da5b66dfd3428be552e4b7d5bf66343783
Author: Christian Berendt <email address hidden>
Date: Tue Jul 29 10:21:59 2014 +0200

    Set python hash seed to 0 in tox.ini

    New tox (>=1.7.0) sets a random python hash seed by default. This is
    generally good for testing because it will help keep projects working
    regardless of the hash seed, but nova unittests don't currently pass
    with a random hash seed so set it to the python default seed.

    This change will allow us to use new tox again and remove the
    restriction on tox<=1.6.1 to run unittests.

    Also see Ib54364877a251db48c54dfdc43c503281ea1f04a.

    Change-Id: I68695d8bd01a5a2ea683c6da2e1ad248ec69c710
    Closes-Bug: #1348818

Changed in barbican:
status: Confirmed → Fix Committed
Dolph Mathews (dolph) on 2014-08-04
Changed in designate:
status: Fix Committed → Confirmed
Dolph Mathews (dolph) wrote :

Neutron, ironic and ceilometer have so far produced actual fixes for this issue. I re-opened this bug against designate and barbican because the associated patches merely set PYTHONHASHSEED=0 rather than fixing the test suites to work with a random hash seed.

If you're going to apply the workaround to set PYTHONHASHSEED=0, please use Partial-Bug or Related-Bug in your commit message rather than Closes-Bug, so that the bot does not set the task status to Fix Committed.

Changed in barbican:
status: Fix Committed → Confirmed

Fix proposed to branch: master
Review: https://review.openstack.org/111711

Henry Gessau (gessau) wrote :

Neutron has many many affected test cases.
I thought it would be better to spread the work out, so I created this:
https://etherpad.openstack.org/p/neutron-random-hashseed

Ilya Shakhat (shakhat) on 2014-08-04
Changed in python-neutronclient:
assignee: nobody → Ilya Shakhat (shakhat)
Changed in python-neutronclient:
status: New → In Progress

Fix proposed to branch: master
Review: https://review.openstack.org/111809

Changed in neutron:
assignee: Henry Gessau (gessau) → Armando Migliaccio (armando-migliaccio)

Reviewed: https://review.openstack.org/111589
Committed: https://git.openstack.org/cgit/openstack/neutron/commit/?id=5c93dfaf25c81576ddc664d2d30ef8297eb367e1
Submitter: Jenkins
Branch: master

commit 5c93dfaf25c81576ddc664d2d30ef8297eb367e1
Author: Henry Gessau <email address hidden>
Date: Sun Aug 3 13:40:01 2014 -0400

    Do not assume order of quotas dictionary elements

    This fixes the quotas db unit test that breaks with a randomized PYTHONHASHSEED
    (see the bug report).

    The test assumed that the quotas dictionary from plugin.get_all_quotas() had
    elements in a particular order. Found with PYTHONHASHSEED=1235130571.

    The fix refactors the test case to handle an unsorted quotas dictionary. Also
    choose some different quota limits to make it clearer what is being verified.

    Partial-bug: #1348818

    Note: There are several other unrelated unit tests that also break with a
    randomized PYTHONHASHSEED, but they are not addressed here. They will be
    addressed in separate patches.

    Change-Id: I3892b51082629e6ebce175f64f501717741baa37

Reviewed: https://review.openstack.org/111711
Committed: https://git.openstack.org/cgit/openstack/neutron/commit/?id=5db7c77def326264579f8db3238372b0351407f2
Submitter: Jenkins
Branch: master

commit 5db7c77def326264579f8db3238372b0351407f2
Author: Henry Gessau <email address hidden>
Date: Mon Aug 4 08:47:08 2014 -0400

    Add a tox test environment for random hashseed testing

    The newer versions of tox by default enable a random PYTHONHASHSEED. However,
    this breaks many Neutron unit tests, so PYTHONHASHSEED=0 is currently hard-
    coded for Neutron's unit test environments.

    We want to clean up the unit test cases that break with a random hashseed
    (there are many). To be able to find the broken tests and then verify them,
    we need to have an easy way of enabling random hashseed testing.

    Partial-bug: #1348818

    Change-Id: I51f05cdfa9f8728baabaf315b71e5defb26426b1

Fix proposed to branch: master
Review: https://review.openstack.org/111886

Changed in designate:
status: Confirmed → In Progress

Fix proposed to branch: master
Review: https://review.openstack.org/111924

Changed in neutron:
assignee: Armando Migliaccio (armando-migliaccio) → Kevin Benton (kevinbenton)

Reviewed: https://review.openstack.org/111822
Committed: https://git.openstack.org/cgit/openstack/neutron/commit/?id=31783e2eae339e79225f379ace948a0bb6c157f7
Submitter: Jenkins
Branch: master

commit 31783e2eae339e79225f379ace948a0bb6c157f7
Author: Pritesh Kothari <email address hidden>
Date: Mon Aug 4 13:37:56 2014 -0700

    Do not assume order of network_uuid's

    This fixes the neutron.tests.unit.test_linux_dhcp.TestDnsmasq
    .test_existing_dhcp_networks unit test that breaks with a
    randomized PYTHONHASHSEED (see the bug report).

    The test assumed that the network_uuid's list was sorted, so sort
    the result before comparing.

    Note: There are several other unrelated unit tests that also break with a
    randomized PYTHONHASHSEED, but they are not addressed here. They will be
    addressed in separate patches.

    Partial-bug: #1348818
    Change-Id: Ia6f742e1fae0687164b841beebb4efcf31ff2625

Reviewed: https://review.openstack.org/111809
Committed: https://git.openstack.org/cgit/openstack/neutron/commit/?id=ce567d7410aa92b09072a8030c89ab9d52707e86
Submitter: Jenkins
Branch: master

commit ce567d7410aa92b09072a8030c89ab9d52707e86
Author: armando-migliaccio <email address hidden>
Date: Mon Aug 4 12:24:19 2014 -0700

    Make _build_uri_path output predictable

    This is done by ensuring that filters are
    serialized in their alphabetical order.

    Tweak tests affected by this.

    This is done in the context as defined by
    etherpad: neutron-random-hashseed

    Partial-bug: #1348818

    Change-Id: Ibe79716a340195ca0365f276ef6e3e728f1a94a1

Tracy Jones (tjones-i) on 2014-08-06
tags: added: testing
Changed in sahara:
assignee: nobody → Andrew Lazarev (alazarev)

Reviewed: https://review.openstack.org/110014
Committed: https://git.openstack.org/cgit/openstack/horizon/commit/?id=b30072e47ead3625cbf29a3b2955cae19a8e7533
Submitter: Jenkins
Branch: master

commit b30072e47ead3625cbf29a3b2955cae19a8e7533
Author: Christian Berendt <email address hidden>
Date: Mon Jul 28 17:03:51 2014 +0200

    Set python hash seed to 0 in tox.ini

    New tox (>=1.7.0) sets a random python hash seed by default. This is
    generally good for testing because it will help keep projects working
    regardless of the hash seed, but nova unittests don't currently pass
    with a random hash seed so set it to the python default seed.

    This change will allow us to use new tox again and remove the
    restriction on tox<=1.6.1 to run unittests.

    Also see Ib54364877a251db48c54dfdc43c503281ea1f04a.

    Change-Id: I8834487e8c7bcdbeae8397c1a10a18873976ce61
    Partial-Bug: #1348818

Reviewed: https://review.openstack.org/111835
Committed: https://git.openstack.org/cgit/openstack/neutron/commit/?id=b0f68bb14531b74f54cad6106491ff75b0e8a1d8
Submitter: Jenkins
Branch: master

commit b0f68bb14531b74f54cad6106491ff75b0e8a1d8
Author: Pritesh Kothari <email address hidden>
Date: Mon Aug 4 14:14:20 2014 -0700

    Do not assume order of pci slot list

    This fixes the neutron.tests.unit.sriovnicagent.test_eswitch_manager
    .TestEmbSwitch.test_get_pci_list unit test that breaks with a
    randomized PYTHONHASHSEED (see the bug report).

    The test assumed that the pci slot list was sorted, so sort
    the result before comparing.

    Note: There are several other unrelated unit tests that also break with a
    randomized PYTHONHASHSEED, but they are not addressed here. They will be
    addressed in separate patches.

    Change-Id: Ia2d879cc1251fb9cf9b653a41064e902b30005af
    Partial-bug: #1348818

Changed in heat:
assignee: nobody → George Zhao (george-zhao)
Changed in sahara:
status: Confirmed → In Progress
Kyle Mestery (mestery) on 2014-08-11
Changed in python-neutronclient:
importance: Undecided → Low
milestone: none → 2.3.7

Reviewed: https://review.openstack.org/111886
Committed: https://git.openstack.org/cgit/openstack/designate/commit/?id=6cf1c81a60e8f2e50cb530e45521c61999355ff8
Submitter: Jenkins
Branch: master

commit 6cf1c81a60e8f2e50cb530e45521c61999355ff8
Author: Kiall Mac Innes <email address hidden>
Date: Mon Aug 4 18:53:30 2014 -0700

    Ensure Object change lists are sorted during to_primitive

    This ensures our tests succeed with a random PYTHONHASHSEED value.

    Change-Id: I798e0b91f2e515562188b5d14cd7ce2055bd64fb
    Partial-Bug: 1348818

Louis Taylor (kragniz) on 2014-08-14
Changed in glance:
assignee: nobody → Louis Taylor (kragniz)
status: New → Confirmed

Fix proposed to branch: master
Review: https://review.openstack.org/114194

Changed in glance:
status: Confirmed → In Progress

Reviewed: https://review.openstack.org/112258
Committed: https://git.openstack.org/cgit/openstack/neutron/commit/?id=f103ce48ca60e12952be7aa6d5183f64ef826370
Submitter: Jenkins
Branch: master

commit f103ce48ca60e12952be7aa6d5183f64ef826370
Author: Sam Betts <email address hidden>
Date: Wed Aug 6 00:05:05 2014 +0100

    Predictable field and filter ordering

    This fixes the fields and filters units tests that break with a
    randomized PYTHONHASHSEED (see the bug report).

    The RESOURCE_ATTRIBUTE_MAP is stored as a dict leading to an
    unpredictable output order. Values in kvp strings are being stored as
    sets underpinned by dicts when converted, leading to unpredictable
    ordering of values when read.

    Discovered with PYTHONHASHSEED = 2455351445 on these tests:
    test_api_v2.APIv2TestCase.test_fields
    test_api_v2.APIv2TestCase.test_fields_multiple
    test_api_v2.FiltersTestCase.test_attr_info_with_convert_list_to
    test_api_v2.APIv2TestCase.test_filters_with_fields
    test_api_v2.APIv2TestCase.test_fields_multiple_with_empty

    There are 3 parts to this fix:
    1. Update the APIv2TestCase _do_field_list function to construct
    field list in the same order as the controller constructs its list.
    2. Ensure the APIv2TestCase _get_collection_kwargs maintains order
    throughout.
    3. Use new assertOrderedEqual function to sort values before assertion
    in test_attr_info_with_convert_list_to

    Change-Id: I547cfa80cf83b0340b459279df9283443562326b
    Partial-bug: #1348818

Reviewed: https://review.openstack.org/112034
Committed: https://git.openstack.org/cgit/openstack/neutron/commit/?id=c353a26fb36b97bdc369bd41e0f23a8bbf2a2ea8
Submitter: Jenkins
Branch: master

commit c353a26fb36b97bdc369bd41e0f23a8bbf2a2ea8
Author: John Davidge <email address hidden>
Date: Tue Aug 5 15:13:03 2014 +0100

    Do not assume order of new_peers list elements

    This fixes the vpn unit test that breaks with a randomized PYTHONHASHSEED
    (see the bug report).

    The test assumed that the new_peers list from self.new_update_request had
    elements in a particular order. Found with PYTHONHASHSEED=2455351445.

    The fix refactors the test case to handle an unsorted new_peers list by
    sorting it before running the test.

    Partial-bug: #1348818

    Note: There are several other unrelated unit tests that also break with a
    randomized PYTHONHASHSEED, but they are not addressed here. They will be
    addressed in separate patches.

    Change-Id: I86e7f84cedbdc8e1d7404363a560fd759d264c49

Reviewed: https://review.openstack.org/114582
Committed: https://git.openstack.org/cgit/openstack/glance/commit/?id=68f5243e23f8768d8996d0268eae282ccb3cb83c
Submitter: Jenkins
Branch: master

commit 68f5243e23f8768d8996d0268eae282ccb3cb83c
Author: Louis Taylor <email address hidden>
Date: Fri Aug 15 15:43:36 2014 +0000

    Do not assume order of images

    This fixes the test_tag_lifecycle test, which broke with a randomized
    PYTHONHASHSEED.

    Previously, the test assumed that the values in the list of tag names
    would remain constant. The test now sorts the results and compares to a
    sorted set.

    Change-Id: If5a2ef683fcf55520c7d539f1b90aefaba4739d5
    Partial-bug: #1348818

Reviewed: https://review.openstack.org/114194
Committed: https://git.openstack.org/cgit/openstack/glance/commit/?id=66c987479ae3485d308ec3505a6a6b7404736f1c
Submitter: Jenkins
Branch: master

commit 66c987479ae3485d308ec3505a6a6b7404736f1c
Author: Louis Taylor <email address hidden>
Date: Thu Aug 14 10:21:36 2014 +0000

    Ensure constant order when setting all image tags

    The newer version of tox (>=1.7.0) sets a random hash seed, which makes the
    order of sets unpredictable. This patchset fixes the test_image_tag_set_all
    test, which otherwise broke with a randomized PYTHONHASHSEED. This new tox
    behaviour is consistent with python (>=3.3), meaning this change should avoid
    bugs on that platform at a later date.

    Change-Id: Ie281b04fc9c4c2a96a9eec9bde7b05229ebf57fc
    Partial-bug: #1348818

Changed in cinder:
assignee: nobody → John Griffith (john-griffith)
importance: Undecided → Medium
milestone: none → juno-3
status: New → Confirmed
status: Confirmed → In Progress
tags: added: in-stable-havana
tags: added: in-stable-icehouse
Louis Taylor (kragniz) on 2014-08-25
Changed in glance:
status: In Progress → Fix Committed
gordon chung (chungg) on 2014-08-25
Changed in ceilometer:
status: Fix Committed → Triaged
Changed in trove:
assignee: nobody → Nikhil Manchanda (slicknik)
milestone: none → juno-3
importance: Undecided → Critical
importance: Critical → High
status: New → Triaged
Changed in trove:
status: Triaged → In Progress
Joe Gordon (jogo) on 2014-08-30
tags: added: low-hanging-fruit
Changed in nova:
status: New → Triaged
Eoghan Glynn (eglynn) on 2014-09-02
Changed in ceilometer:
status: Triaged → In Progress
Changed in sahara:
status: In Progress → Fix Committed
Thierry Carrez (ttx) on 2014-09-03
Changed in ceilometer:
milestone: juno-3 → juno-rc1
Changed in cinder:
status: In Progress → Fix Committed
Changed in barbican:
milestone: juno-3 → juno-rc1
Kiall Mac Innes (kiall) on 2014-09-04
Changed in designate:
status: In Progress → Fix Committed
Thierry Carrez (ttx) on 2014-09-04
Changed in cinder:
milestone: juno-3 → none
status: Fix Committed → Fix Released
Thierry Carrez (ttx) on 2014-09-04
Changed in ironic:
status: Fix Committed → Fix Released
Changed in trove:
status: In Progress → Fix Committed
Thierry Carrez (ttx) on 2014-09-05
Changed in trove:
milestone: juno-3 → none
Changed in designate:
milestone: juno-3 → none
Thierry Carrez (ttx) on 2014-09-05
Changed in designate:
status: Fix Committed → Fix Released
Changed in sahara:
milestone: juno-3 → none
Thierry Carrez (ttx) on 2014-09-05
Changed in sahara:
status: Fix Committed → Fix Released
Changed in glance:
status: Fix Committed → Fix Released
Akihiro Motoki (amotoki) on 2014-09-10
Changed in python-neutronclient:
status: In Progress → Fix Committed
Changed in barbican:
assignee: nobody → John Vrbanac (john.vrbanac)
Dina Belova (dbelova) on 2014-09-22
Changed in ceilometer:
status: In Progress → Fix Committed
Dina Belova (dbelova) on 2014-09-22
Changed in ceilometer:
status: Fix Committed → In Progress
Alan Pevec (apevec) on 2014-09-22
Changed in glance:
importance: Undecided → Medium
Alan Pevec (apevec) on 2014-09-22
no longer affects: horizon/havana
no longer affects: glance/havana
no longer affects: keystone/havana
tags: removed: in-stable-havana in-stable-icehouse
Changed in trove:
milestone: none → juno-rc1
Eoghan Glynn (eglynn) on 2014-09-29
Changed in ceilometer:
milestone: juno-rc1 → kilo-1
Changed in barbican:
status: Confirmed → Fix Committed
Changed in barbican:
importance: Undecided → Medium
Thierry Carrez (ttx) on 2014-10-03
Changed in trove:
status: Fix Committed → Fix Released
Thierry Carrez (ttx) on 2014-10-07
Changed in barbican:
milestone: juno-rc1 → none
no longer affects: barbican
Changed in neutron:
assignee: Kevin Benton (kevinbenton) → Bradley Jones (bradjones)
Thierry Carrez (ttx) on 2014-10-16
Changed in trove:
milestone: juno-rc1 → 2014.2
Louis Taylor (kragniz) on 2014-10-17
Changed in python-glanceclient:
status: New → Confirmed
Changed in neutron:
assignee: Bradley Jones (bradjones) → Sam Betts (sambetts)
Changed in neutron:
assignee: Sam Betts (sambetts) → Bradley Jones (bradjones)
Changed in neutron:
assignee: Bradley Jones (bradjones) → Sam Betts (sambetts)
Changed in neutron:
assignee: Sam Betts (sambetts) → John Davidge (john-davidge)
Changed in neutron:
assignee: John Davidge (john-davidge) → Sam Betts (sambetts)
Changed in neutron:
assignee: Sam Betts (sambetts) → John Davidge (john-davidge)
Louis Taylor (kragniz) on 2014-11-14
Changed in python-glanceclient:
status: Confirmed → Fix Committed
Changed in python-glanceclient:
assignee: nobody → Roman Vasilets (rvasilets)
Changed in python-glanceclient:
assignee: Roman Vasilets (rvasilets) → nobody
Changed in keystone:
assignee: Dolph Mathews (dolph) → Brant Knudson (blk-u)
Joe Gordon (jogo) on 2014-12-11
Changed in nova:
importance: Undecided → Low
Eoghan Glynn (eglynn) on 2014-12-12
Changed in ceilometer:
milestone: kilo-1 → kilo-2
Changed in neutron:
assignee: John Davidge (john-davidge) → Sam Betts (sambetts)
Changed in nova:
assignee: nobody → Timofey Durakov (tdurakov)
status: Triaged → In Progress
Eoghan Glynn (eglynn) on 2015-02-02
Changed in ceilometer:
milestone: kilo-2 → kilo-3
Changed in keystone:
status: In Progress → Fix Committed
Akihiro Motoki (amotoki) on 2015-03-03
tags: added: released-neutronclient
Thierry Carrez (ttx) on 2015-03-19
Changed in ceilometer:
milestone: kilo-3 → kilo-rc1
Thierry Carrez (ttx) on 2015-03-19
Changed in keystone:
milestone: none → kilo-3
status: Fix Committed → Fix Released
Eric Harney (eharney) on 2015-03-19
Changed in cinder:
assignee: John Griffith (john-griffith) → nobody
status: Fix Released → Confirmed
Changed in cinder:
assignee: nobody → Eric Harney (eharney)
status: Confirmed → In Progress
Eoghan Glynn (eglynn) on 2015-03-26
Changed in ceilometer:
milestone: kilo-rc1 → next
Eoghan Glynn (eglynn) on 2015-03-27
Changed in ceilometer:
milestone: next → kilo-rc1
Changed in ceilometer:
status: In Progress → Fix Committed
Angus Salkeld (asalkeld) on 2015-04-01
Changed in heat:
assignee: George Zhao (george-zhao) → nobody
status: In Progress → Triaged
Kiall Mac Innes (kiall) on 2015-04-01
Changed in designate:
importance: High → Medium
milestone: none → liberty-1
status: Fix Released → Triaged
Thierry Carrez (ttx) on 2015-04-09
Changed in ceilometer:
status: Fix Committed → Fix Released
Changed in nova:
assignee: Timofey Durakov (tdurakov) → Jay Pipes (jaypipes)
Jay Pipes (jaypipes) on 2015-04-17
Changed in nova:
assignee: Jay Pipes (jaypipes) → Timofey Durakov (tdurakov)
Changed in nova:
status: In Progress → Fix Committed
Thierry Carrez (ttx) on 2015-04-30
Changed in keystone:
milestone: kilo-3 → 2015.1.0
Thierry Carrez (ttx) on 2015-04-30
Changed in ceilometer:
milestone: kilo-rc1 → 2015.1.0
Changed in wsme:
status: New → Fix Released
Changed in neutron:
assignee: Sam Betts (sambetts) → Cedric Brandily (cbrandily)
152 comments hidden view all 232 comments

Reviewed: https://review.openstack.org/186122
Committed: https://git.openstack.org/cgit/openstack/neutron/commit/?id=36a1d14b58028d0294e67786129a2a09ce393cde
Submitter: Jenkins
Branch: master

commit 36a1d14b58028d0294e67786129a2a09ce393cde
Author: Cedric Brandily <email address hidden>
Date: Wed May 27 20:30:28 2015 +0200

    Do not assume order of security group rules

    This fixes the unit tests[1] that breaks with a randomized
    PYTHONHASHSEED (see the bug report).

    The test assumed that the security_group_rules_for_devices method from
    neutron.agent.securitygroups_rpc returned security group rules in a
    particular order. Found with PYTHONHASHSEED=2.

    The fix refactors the test case to handle unsorted security group rules.

    [1] neutron.tests.unit.plugins.ml2.test_security_group.\
        TestMl2SGServerRpcCallBack.\
        test_security_group_rules_for_devices_ipv4_ingress_addr_pair

    Partial-bug: #1348818

    Note: There are several other unrelated unit tests that also break with
    a randomized PYTHONHASHSEED, but they are not addressed here. They will
    be addressed in separate patches.

    Change-Id: I1b2bd4100c19004f12822c414aefc86aae9849db

Reviewed: https://review.openstack.org/185633
Committed: https://git.openstack.org/cgit/openstack/neutron/commit/?id=77303fbeaa060bcee2befad65dccb457fbb6ab65
Submitter: Jenkins
Branch: master

commit 77303fbeaa060bcee2befad65dccb457fbb6ab65
Author: Cedric Brandily <email address hidden>
Date: Tue May 26 14:38:26 2015 +0000

    Sort _get_new/deleted_set_ips responses in unittests

    This fixes the test_set_members_adding/deleting_less_than_5 unit test
    that breaks with a randomized PYTHONHASHSEED (see the bug report).

    The test assumed that the _get_new/deleted_set_ips from
    neutron.agent.linux.ipset_manager return elements in a particular order.
    Found with PYTHONHASHSEED=1.

    The fix refactors the test case to force sorted responses from
    _get_new/deleted_set_ips during unittests.

    Partial-bug: #1348818

    Note: There are several other unrelated unit tests that also break with
    a randomized PYTHONHASHSEED, but they are not addressed here. They will
    be addressed in separate patches.

    Change-Id: I8408365825ec1e97a83c2181f38ec1f9468df91e

Reviewed: https://review.openstack.org/185858
Committed: https://git.openstack.org/cgit/openstack/neutron/commit/?id=9ff8cd524621daf6cd20da939238eee14b5a231f
Submitter: Jenkins
Branch: master

commit 9ff8cd524621daf6cd20da939238eee14b5a231f
Author: Cedric Brandily <email address hidden>
Date: Wed May 27 08:53:00 2015 +0200

    Improve test_set_members_deleting_less_than_5

    In test_set_members_deleting_less_than_5[1], 3 ips are deleted from
    ipset but test_set_members_deleting_less_than_5 checked that the
    first one was deleted because the call ordering was non-trivial.

    The test was successful because
    assert_has_calls(expected_calls, any_order=False) allows extra calls
    before and after expected_calls.

    A parent change[2] forces the call ordering, this allows to check that
    the 3 ips are deleted.

    [1] neutron.tests.unit.agent.linux.test_ipset_manager
    [2] I8408365825ec1e97a83c2181f38ec1f9468df91e

    Related-Bug: #1348818

    Change-Id: I773e2cd19fdec634b728d0c3a78c1d66392c743f

Reviewed: https://review.openstack.org/185572
Committed: https://git.openstack.org/cgit/openstack/neutron/commit/?id=ef5b4f52749b246d8165058ff320399c9c13f5ac
Submitter: Jenkins
Branch: master

commit ef5b4f52749b246d8165058ff320399c9c13f5ac
Author: Cedric Brandily <email address hidden>
Date: Tue May 26 14:29:15 2015 +0200

    Enable random hash seeds

    Neutron tests have been updated in order to support random hash seed. It
    allows to remove PYTHONHASHSEED=0 in tox.ini and remove hashtest tox
    environment.

    Closes-Bug: #1348818
    Change-Id: I1063304dda887eb82c0de8516d5a483fa8943fc1
    Depends-On: I8408365825ec1e97a83c2181f38ec1f9468df91e
    Depends-On: I1b2bd4100c19004f12822c414aefc86aae9849db
    Depends-On: I5077764045a34d1be0e85bb4b80f3655e87692cc

Changed in neutron:
status: In Progress → Fix Committed
Henry Gessau (gessau) on 2015-05-31
Changed in neutron:
importance: Undecided → Medium
milestone: none → liberty-1
Cedric Brandily (cbrandily) wrote :

neutron-*aas have to be fixed

Changed in neutron:
status: Fix Committed → In Progress

Fix proposed to branch: master
Review: https://review.openstack.org/187107

Fix proposed to branch: master
Review: https://review.openstack.org/187231

Fix proposed to branch: master
Review: https://review.openstack.org/187293

Reviewed: https://review.openstack.org/187106
Committed: https://git.openstack.org/cgit/openstack/neutron-vpnaas/commit/?id=40c004f9877dd47673c849a0e81dc7aff52c4d7c
Submitter: Jenkins
Branch: master

commit 40c004f9877dd47673c849a0e81dc7aff52c4d7c
Author: Cedric Brandily <email address hidden>
Date: Sun May 31 21:56:43 2015 +0200

    Do not assume order of mounts in execute_with_mount

    This fixes the unit tests[1] that breaks with a randomized
    PYTHONHASHSEED (see the bug report).

    The test assumed that the execute_with_mount method[2] performs
    filesystem mounts in a particular order. Found with PYTHONHASHSEED=1.

    The fix refactors the test case to handle unsorted mounts.

    [1] neutron_vpnaas.tests.unit.services.vpn.common.test_netns_wrapper.\
        TestNetnsWrapper.test_netns_wrap
    [2] neutron_vpnaas.services.vpn.common.netns_wrapper

    Partial-bug: #1348818

    Note: There are several other unrelated unit tests that also break with
    a randomized PYTHONHASHSEED, but they are not addressed here. They will
    be addressed in separate patches.

    Change-Id: I164c477f32c6781e9974d4d13a4f91a15b99201c

Reviewed: https://review.openstack.org/187292
Committed: https://git.openstack.org/cgit/openstack/neutron-lbaas/commit/?id=52d40851418db73cde4d9459637de69797ba2bd4
Submitter: Jenkins
Branch: master

commit 52d40851418db73cde4d9459637de69797ba2bd4
Author: Cedric Brandily <email address hidden>
Date: Mon Jun 1 21:06:46 2015 +0200

    Do not assume http expected_codes ordering

    This fixes the unit tests[1] that breaks with a randomized
    PYTHONHASHSEED (see the bug report).

    The test assumed that expected_codes had elements in particular order.
    Found with PYTHONHASHSEED=1.

    The fix refactors the test case by injecting values using the same
    ordering.

    [1] neutron_lbaas.tests.unit.services.loadbalancer.drivers.haproxy.\
        test_jinja_cfg

    Partial-bug: #1348818

    Note: There are several other unrelated unit tests that also break with
    a randomized PYTHONHASHSEED, but they are not addressed here. They will
    be addressed in separate patches.

    Change-Id: I5d761c392bf37a0b3626abc64e0e428f978638df

Reviewed: https://review.openstack.org/187107
Committed: https://git.openstack.org/cgit/openstack/neutron-vpnaas/commit/?id=363c45713474c9f27e02132c3ab3492b67cb0852
Submitter: Jenkins
Branch: master

commit 363c45713474c9f27e02132c3ab3492b67cb0852
Author: Cedric Brandily <email address hidden>
Date: Mon Jun 1 07:53:41 2015 +0200

    Enable random hash seeds

    neutron-vpnaas tests have been updated in order to support random hash
    seed. It allows to remove PYTHONHASHSEED=0 in tox.ini and remove
    hashtest tox environment.

    Change-Id: I94c160c56d074c7a14aaae1fff379fc1c51bd16a
    Partial-Bug: #1348818

Changed in heat:
assignee: nobody → pradeep kumar singh (pradeep-singh-u)
Changed in heat:
importance: Undecided → Medium

Reviewed: https://review.openstack.org/187230
Committed: https://git.openstack.org/cgit/openstack/neutron-fwaas/commit/?id=0660c0518ebc349fa678ddcb56255577ff7d57cc
Submitter: Jenkins
Branch: master

commit 0660c0518ebc349fa678ddcb56255577ff7d57cc
Author: Cedric Brandily <email address hidden>
Date: Mon Jun 1 15:19:59 2015 +0000

    Do not assume jsonutils.dumps ordering

    This fixes the unit tests[1] that breaks with a randomized
    PYTHONHASHSEED (see the bug report).

    The test assumed that the oslo_serializarion.jsonutils.dumps performs
    dictionary json dump in particular order. Found with PYTHONHASHSEED=1.

    The fix refactors the test case by disabling json dumps and comparing
    dictionnaries instead of their json dumps.

    [1] neutron_fwaas.tests.unit.services.firewall.drivers.mcafee.\
        test_ngfw_fwaas:
      NGFWFwaasTestCase.test_create_firewall
      NGFWFwaasTestCase.test_update_firewall

    Partial-bug: #1348818

    Note: There are several other unrelated unit tests that also break with
    a randomized PYTHONHASHSEED, but they are not addressed here. They will
    be addressed in separate patches.

    Change-Id: I67fe1ab69bcfd99c2e778963b97c0d6b4b039802

Reviewed: https://review.openstack.org/187231
Committed: https://git.openstack.org/cgit/openstack/neutron-fwaas/commit/?id=e91970f370868b3c157d9ea6ec522a566e96d218
Submitter: Jenkins
Branch: master

commit e91970f370868b3c157d9ea6ec522a566e96d218
Author: Cedric Brandily <email address hidden>
Date: Mon Jun 1 15:20:48 2015 +0000

    Enable random hash seeds

    neutron-fwaas tests have been updated in order to support random hash
    seed. It allows to remove PYTHONHASHSEED=0 in tox.ini and remove
    hashtest tox environment.

    Change-Id: I35f89a9ab6883f5fd600be804d75b67275e6629a
    Partial-Bug: #1348818

Changed in neutron:
status: In Progress → Fix Committed

Reviewed: https://review.openstack.org/187293
Committed: https://git.openstack.org/cgit/openstack/neutron-lbaas/commit/?id=b6c8ece12c5f45a688537c5075d01d2668d206d9
Submitter: Jenkins
Branch: master

commit b6c8ece12c5f45a688537c5075d01d2668d206d9
Author: Cedric Brandily <email address hidden>
Date: Mon Jun 1 21:11:22 2015 +0200

    Enable random hash seeds

    neutron-lbaas tests have been updated in order to support random hash
    seed. It allows to remove PYTHONHASHSEED=0 in tox.ini and remove
    hashtest tox environment.

    Closes-Bug: #1348818
    Change-Id: I7dce768feeb7c34cdd67bcd54a253d97f4e88f4e
    Depends-On: I1063304dda887eb82c0de8516d5a483fa8943fc1
    Depends-On: I35f89a9ab6883f5fd600be804d75b67275e6629a
    Depends-On: I94c160c56d074c7a14aaae1fff379fc1c51bd16a

Fix proposed to branch: master
Review: https://review.openstack.org/191567

Changed in horizon:
assignee: Christian Berendt (berendt) → Kirill Zaitsev (kzaitsev)
Kiall Mac Innes (kiall) on 2015-06-18
Changed in designate:
assignee: Kiall Mac Innes (kiall) → nobody
Changed in designate:
assignee: nobody → ZhiQiang Fan (aji-zqfan)
status: Triaged → In Progress
Changed in designate:
status: In Progress → Fix Committed
Thierry Carrez (ttx) on 2015-06-24
Changed in nova:
milestone: none → liberty-1
status: Fix Committed → Fix Released
Thierry Carrez (ttx) on 2015-06-24
Changed in designate:
status: Fix Committed → Fix Released
Thierry Carrez (ttx) on 2015-06-24
Changed in neutron:
status: Fix Committed → Fix Released

Change abandoned by Kyle Mestery (<email address hidden>) on branch: feature/pecan
Review: https://review.openstack.org/196701
Reason: This is lacking the functional fix [1], so I'll propose a new merge commit which includes that one.

[1] https://review.openstack.org/#/c/196711/

Download full text (171.5 KiB)

Reviewed: https://review.openstack.org/196920
Committed: https://git.openstack.org/cgit/openstack/neutron/commit/?id=7f759c077f8f860c13db92d2ea6b353ef6b70900
Submitter: Jenkins
Branch: feature/pecan

commit 8123144fadd7c5d5e6e56a76ea860512619a2cf6
Author: Moshe Levi <email address hidden>
Date: Sun Jun 28 14:37:14 2015 +0300

    Fix Consolidate sriov agent and driver code

    This patch add mising __init to mech_sriov/mech_driver/
    and update the setup.cfg to the new agent entrypoint

    Trivial Fix

    Change-Id: I53a527081feb78472f496675bbb3c5121d38a14a

commit 8942fccf02e6e179d47582fdb2792a1ca972da21
Author: Assaf Muller <email address hidden>
Date: Mon Jun 29 11:38:51 2015 -0400

    Remove failing SafeFixture tests

    The fixtures 1.3 release attempted to fix the fixtures resource
    leak issue, but failed to do so completely. Our own SafeFixture
    is still needed: The 1.3 release broke our SafeFixture tests,
    but not the usage of SafeFixture itself. This patch removes
    those failing tests for now to unbreak the gate. Jakub reported
    a bug on fixtures 1.3:
    https://bugs.launchpad.net/python-fixtures/+bug/1469759

    We will continue to use SafeFixture until that bug is fixed
    in fixtures, at which point we will be able to require
    fixtures > 1.3.

    Change-Id: I59457c3bb198ff86d5ad55a1e623d008f0034b8f
    Closes-Bug: #1469734

commit 71dffb0a2c1720cd8233a329d32958a0160dd6f5
Author: Kevin Benton <email address hidden>
Date: Mon Jun 29 08:27:41 2015 +0000

    Revert "Removed test_lib module"

    This reverts commit 9a6536de6e1a7fe9b2552adc142e254426b82b6f.

    We pulled all of the plugins out of the tree, many of which still inherit
    from neutron test classes. This change then stated that we no longer
    support testing other plugins. I think this is a bit premature and should
    have been discussed under the subject
    "Neutron plugins can't use neutron plugin unit tests" or something
    similar.

    Change-Id: I68318589f010b731574ea3bfa8df98492bab31fc

commit b20fd81dbd497e058384a0af065dd0f1fdc4c728
Author: Jakub Libosvar <email address hidden>
Date: Fri Jun 5 14:32:51 2015 +0000

    Refactor NetcatTester class

    Following capabilities were added:
       - used transport protocol is passed as a constant instead of bool
       - src port for testing was added
       - connection can be established explicitly
       - change constructor parameters of NetcatTester

    As a part of removing bool for protocol definition
    get_free_namespace_port() was also modified to match the behavior.

    Change-Id: Id2ec322e7f731c05a3754a65411c9a5d8b258126

commit 83e37980dcd0b2bad6d64dd2cb23bcd2891cafca
Author: jingliuqing <email address hidden>
Date: Sat Jun 27 13:41:54 2015 +0800

    Use REST rather than ReST

    Change-Id: I06c9deaab58c5ec13bfeec39fb8fd4b1fe21f42d

commit 1b60df85ba3ad442c2e4e7e52538e1b9a1bf9378
Author: Kevin Benton <email address hidden>
Date: Thu Jun 25 18:34:38 2015 -0700

    Add a double-mock guard to the base test case

    Use mock to patch mock with a check to prevent multiple active
    patches to the...

tags: added: in-feature-pecan
Changed in heat:
assignee: Pradeep Kumar Singh (pradeep-singh-u) → nobody
Tony Wang (wwwjfy) on 2015-08-16
Changed in heat:
assignee: nobody → Wang Muyu (muyu)
status: Triaged → In Progress

Reviewed: https://review.openstack.org/214539
Committed: https://git.openstack.org/cgit/openstack/heat/commit/?id=b070ed0286206fcde36df5e0da39a227e2dfdb38
Submitter: Jenkins
Branch: master

commit b070ed0286206fcde36df5e0da39a227e2dfdb38
Author: Wang Muyu <email address hidden>
Date: Sun Aug 16 11:21:24 2015 -0400

    Improve unit tests to succeed without hash tweak

    PYTHONHASHSEED was set to 0 to disable hash randomization, because some
    tests assertions were order sensitive. This commit is to improve the
    assertions, so the PYTHONHASHSEED hack in tox.ini is not needed.

    Change-Id: I4ff09d202af818d27321e8e83718e82d0c48e3d2
    Closes-Bug: 1348818

Changed in heat:
status: In Progress → Fix Committed
Changed in python-glanceclient:
milestone: none → 1.0.0
status: Fix Committed → Fix Released
Changed in cinder:
status: In Progress → Fix Released
Derrick Wippler (thrawn01) wrote :

Mistakenly Change cinder status from 'In Progress' to 'Fix Released', Unable to revert change.

Changed in heat:
milestone: none → liberty-3
status: Fix Committed → Fix Released

Change abandoned by David Lyle (<email address hidden>) on branch: master
Review: https://review.openstack.org/191567
Reason: This review is > 4 weeks without comment, and failed Jenkins the last time it was checked. We are abandoning this for now. Feel free to reactivate the review by pressing the restore button and leaving a 'recheck' comment to get fresh test results.

Eric Harney (eharney) on 2015-09-14
Changed in cinder:
status: Fix Released → Confirmed
no longer affects: keystone/icehouse
Changed in cinder:
assignee: Eric Harney (eharney) → Victor Stinner (victor-stinner)
status: Confirmed → In Progress

Reviewed: https://review.openstack.org/229991
Committed: https://git.openstack.org/cgit/openstack/cinder/commit/?id=2e20e70e1430b1f05a98616ba47464829e764390
Submitter: Jenkins
Branch: master

commit 2e20e70e1430b1f05a98616ba47464829e764390
Author: Victor Stinner <email address hidden>
Date: Thu Oct 1 18:04:30 2015 +0200

    Fix volume throttling to Python 3

    BlkioCgroup._set_limits(): sort devices before iterating on them to
    have a reliable behaviour.

    The devs variable is a dictionary. On Python 3, the hash function is
    now randomized, so iterating on a dictionary gives items in a random
    order. Use sorted() to iterate on the list of sorted devices instead.

    tox.ini: add cinder.tests.unit.test_volume_throttling to Python 3.

    Blueprint cinder-python3
    Partial-Bug: #1348818
    Change-Id: Icf7141f772397c7ac08f0f1e21ad74cb86a06351

Thierry Carrez (ttx) on 2015-10-15
Changed in designate:
milestone: liberty-1 → 1.0.0
Thierry Carrez (ttx) on 2015-10-15
Changed in nova:
milestone: liberty-1 → 12.0.0
Thierry Carrez (ttx) on 2015-10-15
Changed in heat:
milestone: liberty-3 → 5.0.0
Thierry Carrez (ttx) on 2015-10-15
Changed in neutron:
milestone: liberty-1 → 7.0.0
Changed in horizon:
importance: Undecided → Medium
Akihiro Motoki (amotoki) wrote :

We cannot update the status to Fix Released in neutronclient. Instead i will remove neutronclient from the affected projects to make the bug list simple. It was fixed in neutronclient long time ago, so the impact of removing neutronclient from the list would be small.

Changed in python-neutronclient:
milestone: 2.3.7 → none
status: Fix Committed → Fix Released
Akihiro Motoki (amotoki) on 2015-12-10
tags: removed: released-neutronclient

Fix proposed to branch: master
Review: https://review.openstack.org/267677

Changed in horizon:
assignee: Kirill Zaitsev (kzaitsev) → Itxaka Serrano (itxakaserrano)
Changed in horizon:
milestone: none → mitaka-2

Change abandoned by Itxaka Serrano Garcia (<email address hidden>) on branch: master
Review: https://review.openstack.org/267677
Reason: This change requires a whole refactor of the projects tests.

The tests failing are some pretty bad ones, where we change names, quotas, roles and members ALL in the same test. Not only that but the order of members is hardcoded heavily and the code is unreadable.

Abandoning this.

Fix proposed to branch: master
Review: https://review.openstack.org/272736

Related fix proposed to branch: master
Review: https://review.openstack.org/280241

Change abandoned by Victor Stinner (<email address hidden>) on branch: master
Review: https://review.openstack.org/280224
Reason: tox.ini runs tests with PYTHONHASHSEED=0, so this bug is more "theorical". I prefer to abandon it.

Reviewed: https://review.openstack.org/280241
Committed: https://git.openstack.org/cgit/openstack/cinder/commit/?id=f0ef5e50e4bda799d870a5694b01eae73a9f1a58
Submitter: Jenkins
Branch: master

commit f0ef5e50e4bda799d870a5694b01eae73a9f1a58
Author: Victor Stinner <email address hidden>
Date: Mon Feb 15 14:43:32 2016 +0100

    Port test_emc_vnx to Python 3

    * Configuration.__getattr__(): replace self.local_conf with
      object.__getattribute__(self, 'local_conf') to avoid reentrant call
      to __getattr__() in copy.copy(conf) on Python 3.
    * test_emc_vnx: Don't compare directly provider_location strings but
      set of provider_location items to support hash randomization. On
      Python 3, hash randomization is enabled by default and so
      dictionary items are rendered in an random order.
    * test_emc_vnx: use assertIn() to check if the provider_location
      contains 'type^smp' substring. Before, the test failed if the
      substring was a the beginning of the string (position 0).
    * tests-py3.txt: add cinder.tests.unit.test_emc_vnx

    Partial-Implements: blueprint cinder-python3
    Related-Bug: 1348818
    Change-Id: If3be17ca6a1d14d6f1a16ee9934221f77e161686

Changed in horizon:
assignee: Itxaka Serrano (itxakaserrano) → nobody
milestone: mitaka-2 → ongoing
status: In Progress → Confirmed
Itxaka Serrano (itxaka) on 2016-03-19
Changed in horizon:
assignee: nobody → Itxaka Serrano (itxakaserrano)
status: Confirmed → In Progress
Changed in horizon:
milestone: ongoing → next
Changed in horizon:
milestone: next → newton-1

Reviewed: https://review.openstack.org/272729
Committed: https://git.openstack.org/cgit/openstack/horizon/commit/?id=ff30c682fb71500272b94d239acac82a2373889a
Submitter: Jenkins
Branch: master

commit ff30c682fb71500272b94d239acac82a2373889a
Author: Itxaka <email address hidden>
Date: Tue Jan 26 21:34:35 2016 +0100

    Use InAnyOrder for role creation mocks

    The user/roles can be created in any order due to
    python random seed ordering dictionaries, so the
    mocks should be in random order

    Change-Id: I23a9380fb65ac634831beb496af388381d0230d4
    Partial-Bug: #1348818

Reviewed: https://review.openstack.org/272736
Committed: https://git.openstack.org/cgit/openstack/horizon/commit/?id=0c118e43395465387b2c911129ec237efaf7db48
Submitter: Jenkins
Branch: master

commit 0c118e43395465387b2c911129ec237efaf7db48
Author: Itxaka <email address hidden>
Date: Tue Jan 26 21:52:51 2016 +0100

    Remove PYTHONHASHSEED=0 from tox

    Remove PYTHONHASHSEED=0 so the tests run
    with a random seed.

    Change-Id: I681d2b37453642b4823e8341a03d077ebc9cb9a7
    Closes-Bug: #1348818

Changed in horizon:
status: In Progress → Fix Released

This issue was fixed in the openstack/horizon 10.0.0.0b1 development milestone.

Changed in cinder:
status: In Progress → Fix Released

Reviewed: https://review.openstack.org/465636
Committed: https://git.openstack.org/cgit/openstack/cinder/commit/?id=52965d8974ca62bfaa4201d3057a0b5742e5c818
Submitter: Zuul
Branch: master

commit 52965d8974ca62bfaa4201d3057a0b5742e5c818
Author: Eric Harney <email address hidden>
Date: Wed May 17 11:29:58 2017 -0400

    Enable hash randomization in unit tests

    This is needed to ensure that unit tests match how
    deployed environments run.

    Related-Bug: #1348818
    Related-Bug: #1658725
    Related-Bug: #1715915

    Depends-On: I91a53fdef98c9a14ccc536403063e228e99d6971
    Depends-On: Ie548c90f5657e5270fd966207f453d5211e21867
    Depends-On: I754d48d8bc4081b96fdf90465c4897d0fadd6262
    Depends-On: Ia8762aff6fd9954d350310b4c68ee4fe94de68bf
    Depends-On: I6fe0ae5da270d9c77cb248551dcb32a5c063977a
    Depends-On: I96b9b413387f2ef02ea7ccfb6e676cad0b87c6f1
    Depends-On: Icdde5e3f213adfe4893d1b9e8f2bfe4f61704037
    Depends-On: I29a874ebe0ebaeca58b428faa0bab50482baf6f1
    Depends-On: I30817ae767e08c45f9540b19e922864fe2f7a9c2
    Depends-On: I281ad59fa518f936aa8d1b518acf61800ba949f5
    Depends-On: I0abd0415306c0c0544eb5d9a6ed08640ff6bb0cf
    Depends-On: I599b585444cbd51182d9f17fddd97bd91637e1e3
    Depends-On: I6e4093ca8e79128ed23a4d5068e5d2870e16332c
    Depends-On: I574dca83a971e746a54895a87e394befda0ccdcf
    Depends-On: Id5a961c66a62e289a96daa7437374768ef407bb6
    Depends-On: Ibc6c20e6ffce58c6bbef3155f73e54909d76e132
    Change-Id: I4c7396f9d8e58ac8420754503f8ed60cd7473426

Displaying first 40 and last 40 comments. View all 232 comments or add a comment.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.