Exceptions when importing mixed graph

Bug #662488 reported by Tobias Schultze on 2010-10-18
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Gephi
Fix Released
Low
Mathieu Bastian
0.7
Fix Released
Low
Unassigned

Bug Description

I know that parallel edges get merged. This works quite well for directed and undirected graphs.
But importing mixed graphs raises exceptions:
When you try to import the attached graphML file as "directed" in the drop down menu
an alert box appears with the message "Index must be > 0". (Sometimes you need to repeat it twice in the same window.)
When you instead chose "mixed" graph you will get a NullPointerException.
So mixed graph do not work at all and I tried several edge combinations. It's clear that its not defined what happens when you try to convert a mixed graph with 2 nodes connected by a directed und undirected edge to a directed graph. But edge weight should then be added to both directions for the undirected edges.
Also something like this doesn't work either although it seems pretty natural:
<edge source="1" target="2"/>
<edge source="2" target="1"/>
<edge source="1" target="3" directed="false"/>

Also importing a pure directed graph as a mixed graph seems to remove all edges!
And sometimes Gephi is not frozen but does not respond to actions like "close project" although no error appeared.

Hi, thanks for your report

I'm not able to reproduce the exceptions. Did you updated Gephi recently? I've fixed some things that may patch the issues on mixed graphs. Let me know if not.

For the mixed import, there are some things the importer is not able to do:
- When working with mixed graph, you need to put directed='true' as well, though the graph is declared as directed. That could be a possible improvement of the importer, but it's already quite complex.
- Remember different types with parallel edges. In your example, there is a directed and undirected edge between '1' and '2'. This situation was not part of the specifications, so this will just be ignored and the first type may be used only.

I notice an issue on a routine that cleans up undirected edges. It wrongly removes some edges with mixed graphs. I'll fix that.

Changed in gephi:
status: New → Confirmed
importance: Undecided → Low
assignee: nobody → Mathieu Bastian (mathieu.bastian)
Changed in gephi:
status: Confirmed → Fix Committed
Changed in gephi:
milestone: none → 0.7beta
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers