gdm

[regression] Can't log in to Wayland Gnome sessions at all

Bug #1704050 reported by Daniel van Vugt on 2017-07-13
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
gdm
Fix Released
Medium
gdm3 (Ubuntu)
Critical
Daniel van Vugt

Bug Description

Today I can't log in to Gnome Wayland sessions at all. Although the usual Xorg Gnome sessions work.

When a Wayland login fails I get dumped to a black VT screen and digging around via SSH, journalctl shows:

Jul 13 12:56:55 haz failsafeXServer[2100]: xinit: giving up
Jul 13 12:56:55 haz failsafeXServer[2100]: xinit: unable to connect to X server: Connection refused
Jul 13 12:56:55 haz failsafeXServer[2100]: xinit: server error

which is weird. I'm not trying to use X.

Related branches

Daniel van Vugt (vanvugt) wrote :

Bisected: The problem started in gdm 3.24.2-1ubuntu6

FAILS: 3.24.2-1ubuntu7
FAILS: 3.24.2-1ubuntu6
WORKS: 3.24.2-1ubuntu5

So the workaround is to downgrade to:
https://launchpad.net/ubuntu/+source/gdm3/3.24.2-1ubuntu5/+build/13073822

tags: added: regression
Changed in gnome-shell (Ubuntu):
importance: Undecided → Critical
affects: gnome-shell (Ubuntu) → gdm3 (Ubuntu)
summary: - Can't log in to Wayland Gnome sessions at all
+ [regression] Can't log in to Wayland Gnome sessions at all
Changed in gdm3 (Ubuntu):
assignee: nobody → Didier Roche (didrocks)
Daniel van Vugt (vanvugt) wrote :

journalctl shows (grepping just gdm):

Jul 13 14:30:44 haz gdm-launch-environment][1051]: pam_unix(gdm-launch-environment:session): session opened for user gdm by (uid=0)
Jul 13 14:30:44 haz systemd[1]: Created slice User Slice of gdm.
Jul 13 14:30:44 haz systemd-logind[905]: New session c1 of user gdm.
Jul 13 14:30:44 haz systemd[1]: Started Session c1 of user gdm.
Jul 13 14:30:44 haz systemd[1061]: pam_unix(systemd-user:session): session opened for user gdm by (uid=0)
Jul 13 14:30:46 haz gnome-shell[1089]: JS WARNING: [resource:///org/gnome/shell/gdm/util.js 331]: reference to undefined property this._preemptingService
Jul 13 14:31:15 haz gdm-password][1429]: pam_unix(gdm-password:session): session opened for user dan by (uid=0)
Jul 13 14:31:15 haz gdm3[1046]: Cannot find a command for specified session: ubuntu-wayland
Jul 13 14:31:15 haz systemd[1]: gdm.service: Main process exited, code=exited, status=1/FAILURE
Jul 13 14:31:15 haz systemd[1]: gdm.service: Unit entered failed state.
Jul 13 14:31:15 haz systemd[1]: gdm.service: Triggering OnFailure= dependencies.
Jul 13 14:31:15 haz systemd[1]: gdm.service: Failed with result 'exit-code'.
Jul 13 14:31:16 haz systemd[1]: gdm.service: Service hold-off time over, scheduling restart.
Jul 13 14:31:16 haz gdm-launch-environment][1517]: pam_unix(gdm-launch-environment:session): session opened for user gdm by (uid=0)
Jul 13 14:31:16 haz systemd-logind[905]: New session c2 of user gdm.
Jul 13 14:31:16 haz systemd[1]: Started Session c2 of user gdm.

Daniel van Vugt (vanvugt) wrote :

Debug log

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gdm3 (Ubuntu):
status: New → Confirmed
Changed in gdm3 (Ubuntu):
assignee: Didier Roche (didrocks) → Daniel van Vugt (vanvugt)
status: Confirmed → In Progress
Didier Roche (didrocks) wrote :

For people interested into glory details:
https://irclogs.ubuntu.com/2017/07/13/%23ubuntu-desktop.html#t06:19
(to 07:22)

Changed in gdm3 (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gdm3 - 3.24.2-1ubuntu8

---------------
gdm3 (3.24.2-1ubuntu8) artful; urgency=medium

  * Avoid double-NULL terminated array that breaks append operations
    and so prevents Wayland sessions from working (LP: #1704050)

 -- Daniel van Vugt <email address hidden> Thu, 13 Jul 2017 16:29:46 +0800

Changed in gdm3 (Ubuntu):
status: Fix Committed → Fix Released
Changed in gdm:
importance: Unknown → Medium
status: Unknown → Confirmed
Changed in gdm:
status: Confirmed → Fix Released
Owen Pimm (owen-pimm) wrote :

Hi Daniel. I've just carried out a fresh install of Ubuntu 17.10. This problem is affecting me. I can log in using X but not Wayland. As I can log into X, this hasn't stopped me but thought I'd let you know, I'm also affected. Since it looks as though you've provided the fix, I assume this will be corrected as I continue to do software updates as usual. If not, please advise. Appreciate your generous help.
Regards Owen

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.