[TestImpact][system-tests] Tests for admin network != eth0

Bug #1439417 reported by Sergii Golovatiuk on 2015-04-01
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Fuel for OpenStack
High
Alexandr Kostrikov
6.1.x
High
Alexandr Kostrikov
7.0.x
High
Alexandr Kostrikov
8.0.x
High
Alexandr Kostrikov
Future
High
Alexandr Kostrikov
Mitaka
High
Alexandr Kostrikov

Bug Description

Fuel doesn't have scenarios where admin interface != eth0, that leads to problems we stepped in twice.

There should environment test where admin interface is assigned to !=eth0 (eth2 for instance). Environment should be bootstrapped and deployed using such settings using cobbler or IBP as provision methods.

Changed in fuel:
status: New → Confirmed
importance: Undecided → High
assignee: nobody → Fuel QA Team (fuel-qa)
Mike Scherbakov (mihgen) wrote :

I would set it just as default thing for BVT. We test eth0 anyway for all manual tests being done by QA and Dev people.

Changed in fuel:
milestone: none → 6.1
Mike Scherbakov (mihgen) wrote :

Original issue for reference: https://bugs.launchpad.net/fuel/+bug/1439150

Changed in fuel:
assignee: Fuel QA Team (fuel-qa) → Alexandr Kostrikov (akostrikov-mirantis)
tags: added: non-release system-tests
summary: - Tests for admin network != eth0
+ [system-tests] Tests for admin network != eth0
Changed in fuel:
status: Confirmed → In Progress

Change abandoned by Alexandr Kostrikov (<email address hidden>) on branch: master
Review: https://review.openstack.org/188038
Reason: As changes in this review are only for informational purposes, I am closing this review with intent to use this information in documentation and in code.

Reviewed: https://review.openstack.org/186400
Committed: https://git.openstack.org/cgit/stackforge/fuel-main/commit/?id=85c1d925f9c443b370ab35faf9b3d9e71f530193
Submitter: Jenkins
Branch: master

commit 85c1d925f9c443b370ab35faf9b3d9e71f530193
Author: Alexandr Kostrikov <email address hidden>
Date: Wed May 20 20:41:54 2015 +0300

    Enable ethernet device setup.
    Admin net can be set through kickstart
    with device parameter.

    Change-Id: I9c46752632cd3c741f1036c7b7ea93f9b975bd0d
    Partial-Bug: #1439417

summary: - [system-tests] Tests for admin network != eth0
+ [TestImpact][system-tests] Tests for admin network != eth0
Changed in fuel:
status: Confirmed → In Progress

Reviewed: https://review.openstack.org/188039
Committed: https://git.openstack.org/cgit/stackforge/fuel-devops/commit/?id=7e97a1c611f7c40b1d83ab4fa8efb508c39c1dd4
Submitter: Jenkins
Branch: master

commit 7e97a1c611f7c40b1d83ab4fa8efb508c39c1dd4
Author: Alexandr Kostrikov <email address hidden>
Date: Wed Jun 3 17:09:32 2015 +0300

    Enable show bootmenu in special cases.
    It is turned off by default.

    Special cases are:
    - node is admin and it is booting via USB;
    - node is a slave and it is booting via
    pxe on interface not equal to eth0.

    Partial-Bug: #1439417
    Change-Id: I87db9734418347161f60b854c1619c253ac9ab97

Igor Shishkin (teran) on 2015-10-08
no longer affects: fuel/7.0.x
Dmitry Pyzhov (dpyzhov) on 2015-10-12
Changed in fuel:
milestone: 7.0 → 8.0
status: In Progress → Confirmed
no longer affects: fuel/8.0.x
Changed in fuel:
status: Confirmed → In Progress
Dmitry Pyzhov (dpyzhov) on 2015-10-22
tags: added: area-qa
Changed in fuel:
milestone: 8.0 → 9.0
status: In Progress → New

Looks like status was changes mistakenly. Revert back to 'In progress'

Changed in fuel:
status: New → In Progress

Change abandoned by Alexandr Kostrikov (<email address hidden>) on branch: master
Review: https://review.openstack.org/229052
Reason: I am going to rewrite it based on new network devops system

Unhardcode at fuelweb_test/models/environment.py enp0s3.
Add logging.

Sample run parameters
export ENV_NAME=133
export VENV_PATH=../fuel-devops-venv
export ISO_PATH=/home/akostrikov/Images/fuel-8.0-518-2016-02-03_07-53-27.iso
export NODES_COUNT=4
export INTERFACE_ORDER='public,admin,management,private,storage'
export IFACE_0=enp0s4
export IFACE_1=enp0s3
./utils/jenkins/system_tests.sh -t test -w $(pwd) -j fuelweb_test -i $ISO_PATH -kK -o --group=deploy_neutron_vlan

tags: removed: non-release
Vitaly Sedelnik (vsedelnik) wrote :

Removed from 7.0-mu-3 milestone as this is not product but tests issue

Changed in fuel:
milestone: 9.0 → 10.0
tags: added: non-release
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers