IBP set eth0 as admin interface instead of eth2 in Centos installation case

Bug #1439150 reported by Leontiy Istomin on 2015-04-01
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Fuel for OpenStack
Critical
Vladimir Kozhukalov
6.0.x
High
Fuel Python (Deprecated)

Bug Description

api: '1.0'
astute_sha: 3f1ece0318e5e93eaf48802fefabf512ca1dce40
auth_required: true
build_id: 2015-03-26_21-32-43
build_number: '233'
feature_groups:
- mirantis
fuellib_sha: 9c7716bc2ce6075065d7d9dcf96f4c94662c0b56
fuelmain_sha: 320b5f46fc1b2798f9e86ed7df51d3bda1686c10
nailgun_sha: b163f6fc77d6639aaffd9dd992e1ad96951c3bbf
ostf_sha: a4cf5f218c6aea98105b10c97a4aed8115c15867
production: docker
python-fuelclient_sha: e5e8389d8d481561a4d7107a99daae07c6ec5177
release: '6.1'

Tried to deploy the following configuration:
Baremetal, Centos, IBP, HA, Neutron-vlan,Ceph-all, Debug, nova-quotas, 6.1-233
Controllers:3 Computes:48

But nodes can't go back from provisioning state. IBP is used.
If look at ipmi console, we can see a lot of:
netlink: 20 bytes leftover after parsing attributes.

Actually, the nodes was provisioned, however they tried to set eth0 as an admin interface instead of eth2.
There is no ifcfg-eth2 file on the node. only for eth0.

snapshot is attached

Leontiy Istomin (listomin) wrote :
Leontiy Istomin (listomin) wrote :

here is /var/log folder from node-1

Leontiy Istomin (listomin) wrote :

I brought up eth2 on node-1 manually. Therefore the node is in provisioned state

Dina Belova (dbelova) on 2015-04-01
Changed in fuel:
importance: Undecided → High
status: New → Confirmed
milestone: none → 6.1
Dina Belova (dbelova) wrote :

Moved to critical, as this prevents CentOS + IBP installation at all

Changed in fuel:
assignee: nobody → Vladimir Kozhukalov (kozhukalov)
importance: High → Critical
tags: added: feature-image-based

Fix proposed to branch: master
Review: https://review.openstack.org/169736

Changed in fuel:
status: Confirmed → In Progress

Reviewed: https://review.openstack.org/169736
Committed: https://git.openstack.org/cgit/stackforge/fuel-web/commit/?id=c3dc05f4d4cdf814b656c2718564efbabd4f3082
Submitter: Jenkins
Branch: master

commit c3dc05f4d4cdf814b656c2718564efbabd4f3082
Author: Vladimir Kozhukalov <email address hidden>
Date: Wed Apr 1 19:59:53 2015 +0300

    IBP: fixed configuring admin interface for centos

    Change-Id: Ibb0123ceb9a05cb5bd8db1a4f44d51cc92bbe2fa
    Closes-Bug: #1439150

Changed in fuel:
status: In Progress → Fix Committed
Alexander Gordeev (a-gordeev) wrote :

is native provisioning affected by this bug too?

Maksym Strukov (unbelll) wrote :

Verified as fixed in 6.1-352

{"build_id": "2015-04-26_22-54-38", "build_number": "352", "release_versions": {"2014.2.2-6.1": {"VERSION": {"build_id": "2015-04-26_22-54-38", "build_number": "352", "api": "1.0", "fuel-library_sha": "6bdf783e2bffdce80ecffcca2915e6d32a8ccdd7", "nailgun_sha": "f9f17fe395f3e38c27d3d484302728a37ad8012d", "feature_groups": ["mirantis"], "openstack_version": "2014.2.2-6.1", "production": "docker", "python-fuelclient_sha": "2b311b3b82a1e2df1dc3484a0f37e282273cd988", "astute_sha": "c1793f982fda7e3fc7b937ccaa613c649be6a144", "fuel-ostf_sha": "b38602c841deaa03ddffc95c02f319360462cbe3", "release": "6.1", "fuelmain_sha": "01288380950bc89d572cf5902141c9a393ada950"}}}, "auth_required": true, "api": "1.0", "fuel-library_sha": "6bdf783e2bffdce80ecffcca2915e6d32a8ccdd7", "nailgun_sha": "f9f17fe395f3e38c27d3d484302728a37ad8012d", "feature_groups": ["mirantis"], "openstack_version": "2014.2.2-6.1", "production": "docker", "python-fuelclient_sha": "2b311b3b82a1e2df1dc3484a0f37e282273cd988", "astute_sha": "c1793f982fda7e3fc7b937ccaa613c649be6a144", "fuel-ostf_sha": "b38602c841deaa03ddffc95c02f319360462cbe3", "release": "6.1", "fuelmain_sha": "01288380950bc89d572cf5902141c9a393ada950"}

Centos, 1 controller + 1 compute + ceph deployed ok
Ubuntu, 1 controller + 1 compute + cinder deployed ok

Changed in fuel:
status: Fix Committed → Fix Released
Alexander Gordeev (a-gordeev) wrote :

re-assigning to fuel-python with 'ibp' tag.

tags: added: ibp
Vitaly Sedelnik (vsedelnik) wrote :

Won't Fix for 6.0-updates as IBP is not present in 6.0

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers