Release data contain liberty name on mitaka packages

Bug #1548776 reported by Tatyanka
40
This bug affects 5 people
Affects Status Importance Assigned to Milestone
Fuel for OpenStack
Fix Released
High
Roman Prykhodchenko

Bug Description

We switch to mitaka deployment, but do not update release name for 9.0

Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Related fix proposed to fuel-web (master)

Related fix proposed to branch: master
Review: https://review.openstack.org/283526

Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Related fix proposed to fuel-library (master)

Related fix proposed to branch: master
Review: https://review.openstack.org/283530

Changed in fuel:
status: New → In Progress
assignee: Fuel Python Team (fuel-python) → Tatyanka (tatyana-leontovich)
Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Related fix proposed to fuel-plugins (master)

Related fix proposed to branch: master
Review: https://review.openstack.org/284146

Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Change abandoned on fuel-plugins (master)

Change abandoned by tatyana-leontovich (<email address hidden>) on branch: master
Review: https://review.openstack.org/284146

Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Change abandoned on fuel-web (master)

Change abandoned by tatyana-leontovich (<email address hidden>) on branch: master
Review: https://review.openstack.org/283526

Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Change abandoned on fuel-library (master)

Change abandoned by tatyana-leontovich (<email address hidden>) on branch: master
Review: https://review.openstack.org/283530

Changed in fuel:
assignee: Tatyanka (tatyana-leontovich) → Fuel Python Team (fuel-python)
importance: Medium → High
tags: added: swarm-blocker
Changed in fuel:
assignee: Fuel Python Team (fuel-python) → Arthur Svechnikov (asvechnikov)
Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix proposed to fuel-web (master)

Fix proposed to branch: master
Review: https://review.openstack.org/295731

Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix proposed to fuel-library (master)

Fix proposed to branch: master
Review: https://review.openstack.org/295737

Revision history for this message
Dmitry Pyzhov (dpyzhov) wrote :

Our plugins should work without this fix. Please show the list of broken plugins or remove swarm-blocker tag.

Revision history for this message
Alexander Kurenyshev (akurenyshev) wrote :

Okay, we have a few plugins which are built on the master node. For example a reboot plugin [0]. We use FPB to build the plugin and for now accordingly to [1] FPB builds plugins with a supported openstack version 'mitaka-9.0' and this is correct.

[0] https://product-ci.infra.mirantis.net/job/9.0.system_test.ubuntu.fuel_plugin_reboot/55/console
[1] https://review.openstack.org/#/c/287853/6/fuel_plugin_builder/templates/v4/plugin_data/metadata.yaml.mako

Revision history for this message
Matthew Mosesohn (raytrac3r) wrote :

Alexander, use liberty-9.0 until Tatyana's patches land. Whoever introduced 9.0-mitaka to fuel-plugin-reboot instead of 9.0-liberty is the cause of swarm-blocker.

Revision history for this message
Tatyanka (tatyana-leontovich) wrote :

Matthew, we do not have actually liberty-9.0 release officially, It is buggy name, so I can not agree that we should force tests use wrong release version just because we need wait while patches that fixes release name become merged. So please, fix release name in our product

Dmitry Pyzhov (dpyzhov)
Changed in fuel:
assignee: Arthur Svechnikov (asvechnikov) → Roman Prykhodchenko (romcheg)
Revision history for this message
Simon Pasquier (simon-pasquier) wrote :

+1 to Tatyana's comment. You're putting the burden on plugin developers that will have to remove 'liberty-9.0' from the supported releases once the patch lands.

Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix merged to fuel-library (master)

Reviewed: https://review.openstack.org/295737
Committed: https://git.openstack.org/cgit/openstack/fuel-library/commit/?id=22f3765d2dd861833aab76663c04e86a5ee98ed0
Submitter: Jenkins
Branch: master

commit 22f3765d2dd861833aab76663c04e86a5ee98ed0
Author: Artur Svechnikov <email address hidden>
Date: Tue Mar 22 14:43:50 2016 +0300

    [library] Update releases data to Mitaka

    Since Fuel uses Mitaka instead of Liberty, it's
    time to change Liberty to Mitaka.

    Change-Id: I5a6a245886b315d05e473f0f353f766b22ed6f4b
    Partial-Bug: #1548776

Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix merged to fuel-web (master)

Reviewed: https://review.openstack.org/295731
Committed: https://git.openstack.org/cgit/openstack/fuel-web/commit/?id=2aa28a749e0a8d3c350c14ccba09a87720b4c82c
Submitter: Jenkins
Branch: master

commit 2aa28a749e0a8d3c350c14ccba09a87720b4c82c
Author: Artur Svechnikov <email address hidden>
Date: Tue Mar 22 14:31:07 2016 +0300

    [nailgun] Update releases name to Mitaka

    Since Fuel uses Mitaka instead of Liberty, it's
    time to change Liberty to Mitaka in releases.

    Change-Id: I061ea0a62151e8c36d2bb50e119efe3bb82a91c5
    Partial-Bug: #1548776

Changed in fuel:
status: In Progress → Fix Committed
Revision history for this message
Tatyanka (tatyana-leontovich) wrote :

verified 140 iso

Changed in fuel:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers