Comment 14 for bug 1477932

Dan (enyalius) wrote :

As added information; I have now tried the build 195 from the link https://ci.fuel-infra.org/ (the fuel-infra.org page does not seem updated). I received the same problem with the 195 build. The only thing I can think of is that either I am missing a key step to setup nailgun that causes this error or the hardware I am using is not compatible.

The setup I am doing involves; Installing the iso on a virtualbox image on a laptop, once the install is done configuring the fuel setup using the /usr/local/sbin/bootstrap_admin_node.sh once that is done I have two networks eth0 is the statically assigned network that connects to my hardware, and eth1 is my internet connection. Once I have finished configuration I run fuel-createmirror to prep for the reduced footprint build as per https://docs.fuel-infra.org/openstack/fuel/fuel-7.0/operations.html#using-the-reduced-footprint-feature

Once that is completed I login to the webportal and create the environment using the following options; kilo ubuntu and kvm (everything else is default). Once the environment is created I add my nodes and this is when I see the error that is mentioned above; "Could not get url from configuration file: No such file or directory - /etc/nailgun-agent/config.yaml, trying other ways.."