Controller CPU/RAM are counted as cloud's capacity

Bug #1375750 reported by Dmitriy Novakovskiy on 2014-09-30
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Fuel for OpenStack
Medium
Fuel UI Team
Mitaka
Medium
Fuel UI Team
Newton
Medium
Fuel UI Team

Bug Description

In Fuel 5.1, "My OpenStack Environments" seems to be counting non-compute nodes' CPU and RAM capacity when showing summary of clouds:

1) Shows 9 cores and 9 gigs of RAM: https://www.dropbox.com/s/q16xg065tgigp20/Screenshot%202014-09-30%2013.54.54.png?dl=0
2) The cloud has only 8 cores and 8 gigs of RAM on Compute nodes: https://www.dropbox.com/s/1gyfaxzb0ufbbab/Screenshot%202014-09-30%2013.56.27.png?dl=0

It doesn't make sense to show non-Compute CPU and RAM capacity on summary screen - this confuses user about what capacity is potentially available in given cloud

Changed in fuel:
assignee: nobody → Fuel UI Team (fuel-ui)
milestone: none → 6.0
Aleksey Kasatkin (alekseyk-ru) wrote :

How about nodes count? Show both computes count and overall nodes count?

it makes sense to count/display:

- amount of compute nodes
- CPU and RAM on compute nodes
- Storage
-- for LVM+Swift - total LVM space available via Cinder, total net capacity
available via Swift
-- for Ceph - total net storage available via Ceph (for all types together
- image, object, cinder)

---
Regards,

*Dmitriy Novakovskiy*
Sales Engineer, Mirantis EMEA

*Skype:* dmitriy.novakovskiy
*Operating from:* Ukraine

On Tue, Sep 30, 2014 at 2:57 PM, Aleksey Kasatkin <email address hidden>
wrote:

> How about nodes count? Show both computes count and overall nodes count?
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1375750
>
> Title:
> Controller CPU/RAM are counted as cloud's capacity
>
> Status in Fuel: OpenStack installer that works:
> New
>
> Bug description:
> In Fuel 5.1, "My OpenStack Environments" seems to be counting non-
> compute nodes' CPU and RAM capacity when showing summary of clouds:
>
> 1) Shows 9 cores and 9 gigs of RAM:
> https://www.dropbox.com/s/q16xg065tgigp20/Screenshot%202014-09-30%2013.54.54.png?dl=0
> 2) The cloud has only 8 cores and 8 gigs of RAM on Compute nodes:
> https://www.dropbox.com/s/1gyfaxzb0ufbbab/Screenshot%202014-09-30%2013.56.27.png?dl=0
>
> It doesn't make sense to show non-Compute CPU and RAM capacity on
> summary screen - this confuses user about what capacity is potentially
> available in given cloud
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/fuel/+bug/1375750/+subscriptions
>

it makes sense to count/display:

- amount of compute nodes
- CPU and RAM on compute nodes
- Storage
-- for LVM+Swift - total LVM space available via Cinder, total net capacity available via Swift
-- for Ceph - total net storage available via Ceph (for all types together - image, object, cinder)

Changed in fuel:
importance: Undecided → Medium
Changed in fuel:
status: New → Confirmed

It gets worse on deployments w/ vCenter - https://www.dropbox.com/s/ftypjgmroljxsbz/Screenshot%202014-10-06%2013.14.30.png?dl=0. 80 GB HDD and 1 Gb RAM is from 1 controller I have in this env, completely useless info here :).

I think it makes sense to fetch capacity data from OpenStack itself (the same source where Admin->Hypervisors screen of Horizon takes it from)

What should be the correct fix for this? Fetching capacity data from server (and it will be calculated there) or calculate it on UI as Dmitriy descibed above?

Changed in fuel:
milestone: 6.0 → 6.1
tags: added: ui
Vitaly Kramskikh (vkramskikh) wrote :

I think we need to be able to define in in openstack.yaml for every role what category its resources should be counted for as we already have 3 roles for storage (ceph-osd, cinder, cinder-vmware)

Changed in fuel:
milestone: 6.1 → 7.0
tags: added: feature
Nastya Urlapova (aurlapova) wrote :

Vitaliy, could you transform your idea to BP.

tags: added: qa-agree-7.0
removed: feature
Sheena Conant (sheena-conant) wrote :

Let's close this out on LP - I've transitioned this to JIRA (PROD-1067) as a feature request due to scope.

Sheena Conant (sheena-conant) wrote :

I was incorrect about closing the LP bug - please create a blueprint, we'll leave this bug open until the feature lands.

Changed in fuel:
status: Confirmed → Won't Fix
Dmitry Pyzhov (dpyzhov) on 2015-10-12
Changed in fuel:
milestone: 7.0 → 8.0
status: Won't Fix → Confirmed
no longer affects: fuel/8.0.x
tags: added: tricky
Dmitry Pyzhov (dpyzhov) on 2015-10-22
tags: added: area-ui
tags: added: feature
removed: tricky
Changed in fuel:
status: Confirmed → Won't Fix

Fix proposed to branch: master
Review: https://review.openstack.org/280737

Changed in fuel:
status: Won't Fix → In Progress
Dmitry Pyzhov (dpyzhov) on 2016-02-16
no longer affects: fuel/mitaka
Changed in fuel:
milestone: 8.0 → 9.0

Reviewed: https://review.openstack.org/280737
Committed: https://git.openstack.org/cgit/openstack/fuel-web/commit/?id=e2c346227c96210e5b9add0d4abbda24a35acc92
Submitter: Jenkins
Branch: master

commit e2c346227c96210e5b9add0d4abbda24a35acc92
Author: Kate Pimenova <email address hidden>
Date: Tue Feb 16 17:42:13 2016 +0300

    Cluster capacity calculation fix

      - "HDD" capacity is counting from nodes with "stogare" roles
      - "CPU" & "RAM" are counting from nodes with "compute" roles

    DocImpact
    Closes-bug: #1375750

    Change-Id: I0a44cbfa60625ad06c879cf1aac01317b073b802

Changed in fuel:
status: In Progress → Fix Committed

Hi team,

it looks like we still have issues with HDD field.

Steps To Reproduce:
1. Create new environment in MOS 9.0
2. Add 3 controller nodes. Verify that HDD size is "0 bytes" in Fuel UI > env details.
3. Add 2 compute nodes to the environment. Verify that HDD size is "0 bytes" in Fuel UI > env details.
4. Add role Cinder to the compute nodes. Check the size of HDD for the cluster. It is equal to 384 Gb on my environment, 2 compute+cinder nodes have 192Gb+192Gb in total, 384 Gb is the full sum of HDD space of compute + storage nodes (it is actually not true)
5. Update the default configuration for disks partitioning for Cinder nodes. Allocate 40 Gb on each node for Cinder LVM. Check information about HDD size for the environment. It is still unchanged, 384 Gb total. In fact, changes in disks partitioning don't affect the size of HDD for the environment.

Observed Result:
HDD size for the cluster depends only on roles and doesn't depend on size of the real partitions which allocated for storage.

Vitaly Kramskikh (vkramskikh) wrote :

The fix was reverted - decided it would be better to show all resources across all the nodes than count them using roles (which is incorrect - we should count using partitions instead). So reopening this bug.

Dmitry Dmitriev (dmdmitriev) wrote :

Bug is discussed with fuel-ui team (Vitaly Kramskikh):
- Fuel UI shows information received from Fuel via REST API
- an additional parameter of a volume named capacity is needed (0 - do not count in the cloud capacity, 1 - count in the cloud capacity)

Dmitry Dmitriev (dmdmitriev) wrote :

Bug is discussed with fuel-web team (Dmitry Pyzhov):
- we shouldn't change the logic because we can't predict the role of every volume (especially when we have custom node roles)
- current design is stable
- new design can rise a number of new bugs

Dmitry Dmitriev (dmdmitriev) wrote :

Problem is discussed with author of the bug Dmitriy Novakovskiy:
- problem is still actual
- we should count compute CPU/Memory and Ceph HDD only

Dmitry Dmitriev (dmdmitriev) wrote :

A message with screenshots and description of current and old design is sent to the openstack-dev mailing list.

Julia Aranovich (jkirnosova) wrote :

Assigned back to Fuel UI team because no activity on the ticket in the last weeks.

Changed in fuel:
milestone: 10.0 → 11.0
assignee: Dmitry Dmitriev (dmdmitriev) → Fuel UI Team (fuel-ui)
no longer affects: fuel/newton
Changed in fuel:
milestone: 11.0 → 10.1
Changed in fuel:
milestone: 10.1 → 11.0
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers