firefox-locale-ca does not work in Firefox 18

Bug #1098312 reported by Markus Klyver on 2013-01-10
118
This bug affects 21 people
Affects Status Importance Assigned to Milestone
Mozilla Firefox
Fix Released
Medium
firefox (Ubuntu)
High
Unassigned
Lucid
Undecided
Unassigned
Oneiric
Undecided
Unassigned
Precise
Undecided
Unassigned
Quantal
Undecided
Unassigned
Raring
High
Unassigned

Bug Description

After updated to Firefox via apt-get all the menus is in English.
apt-get install firefox-locale-ca just gives the output "firefox-locale-ca" is already installed on this system". In Firefox, under Tools > Add-ons > Languages there is no Catalan language pack.

This seems to affect both 12.04 and 12.10 (tested both, running in VirtualBox).

New bug reported using Apport.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: firefox-locale-ca 18.0+build1-0ubuntu0.12.04.3
ProcVersionSignature: Ubuntu 3.2.0-23.36-generic 3.2.14
Uname: Linux 3.2.0-23-generic x86_64
AddonCompatCheckDisabled: False
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.24.
AplayDevices:
 **** List of PLAYBACK Hardware Devices ****
 card 0: I82801AAICH [Intel 82801AA-ICH], device 0: Intel ICH [Intel 82801AA-ICH]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
ApportVersion: 2.0.1-0ubuntu5
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: ubuntu 3303 F.... pulseaudio
BuildID: 20130107224849
CRDA: Error: command ['iw', 'reg', 'get'] failed with exit code 1: nl80211 not found.
Card0.Amixer.info:
 Card hw:0 'I82801AAICH'/'Intel 82801AA-ICH with STAC9700,83,84 at irq 21'
   Mixer name : 'SigmaTel STAC9700,83,84'
   Components : 'AC97a:83847600'
   Controls : 34
   Simple ctrls : 24
CasperVersion: 1.315
Channel: Unavailable
Date: Thu Jan 10 20:02:09 2013
Dependencies:

ForcedLayersAccel: False
IfupdownConfig:
 auto lo
 iface lo inet loopback
IpRoute:
 default via 10.0.2.2 dev eth0 proto static
 10.0.2.0/24 dev eth0 proto kernel scope link src 10.0.2.15 metric 1
 169.254.0.0/16 dev eth0 scope link metric 1000
IwConfig:
 lo no wireless extensions.

 eth0 no wireless extensions.
LiveMediaBuild: Ubuntu 12.04 LTS "Precise Pangolin" - Release amd64 (20120425)
Plugins:
 iTunes Application Detector - /usr/lib/mozilla/plugins/librhythmbox-itms-detection-plugin.so (rhythmbox-mozilla)
 VLC Multimedia Plugin (compatible Totem 3.0.1) - /usr/lib/mozilla/plugins/libtotem-cone-plugin.so (totem-mozilla)
 DivX® Web Player - /usr/lib/mozilla/plugins/libtotem-mully-plugin.so (totem-mozilla)
 Windows Media Player Plug-in 10 (compatible; Totem) - /usr/lib/mozilla/plugins/libtotem-gmp-plugin.so (totem-mozilla)
 QuickTime Plug-in 7.6.6 - /usr/lib/mozilla/plugins/libtotem-narrowspace-plugin.so (totem-mozilla)
PrefSources: prefs.js
ProcEnviron:
 PATH=(custom, no user)
 LANG=sv_SE.UTF-8
 SHELL=/bin/bash
Profiles: Profile0 (Default) - LastVersion=18.0/20130107224849 (In use)
RelatedPackageVersions:
 rhythmbox-mozilla 2.96-0ubuntu4
 totem-mozilla 3.0.1-0ubuntu21
RfKill:

RunningIncompatibleAddons: False
SourcePackage: firefox
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 12/01/2006
dmi.bios.vendor: innotek GmbH
dmi.bios.version: VirtualBox
dmi.board.name: VirtualBox
dmi.board.vendor: Oracle Corporation
dmi.board.version: 1.2
dmi.chassis.type: 1
dmi.chassis.vendor: Oracle Corporation
dmi.modalias: dmi:bvninnotekGmbH:bvrVirtualBox:bd12/01/2006:svninnotekGmbH:pnVirtualBox:pvr1.2:rvnOracleCorporation:rnVirtualBox:rvr1.2:cvnOracleCorporation:ct1:cvr:
dmi.product.name: VirtualBox
dmi.product.version: 1.2
dmi.sys.vendor: innotek GmbH

Markus Klyver (markusklyver) wrote :
Markus Klyver (markusklyver) wrote :

Same bug, but not reported using Apport: https://bugs.launchpad.net/ubuntu/+source/firefox/+bug/1098296.

Created attachment 700641
Catalan install.rdf

The Catalan language pack xpi for Firefox 18 has a malformed install.rdf. There are 2 lines of whitespace at the start of the file (attached), which results in the addon manager not loading it.

It's caused by this change: http://hg.mozilla.org/releases/l10n/mozilla-release/ca/diff/3b0b37ceb8b0/browser/defines.inc

Changed in firefox (Ubuntu):
importance: Undecided → High
status: New → Triaged

Mmm, this was caused by applying patch from bug 792717 I suppose.

We can try to add it back to all defines.inc in different branches.

Ccing Gerv as well.

Changed in firefox:
importance: Unknown → Medium
status: Unknown → Confirmed
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in firefox (Ubuntu Lucid):
status: New → Confirmed
Changed in firefox (Ubuntu Oneiric):
status: New → Confirmed
Changed in firefox (Ubuntu Precise):
status: New → Confirmed
Changed in firefox (Ubuntu Quantal):
status: New → Confirmed

None of the 3 patches attached to bug 792717 patch a file called defines.inc. And the changes in those patches are not missing newlines, which it seems this change was. Perhaps it was done by hand by someone?

Gerv

*** Bug 829955 has been marked as a duplicate of this bug. ***

A quick grep shows up some more affected locales too:

chr1s@farnsworth:~/src/firefox/build-area/firefox-18.0+build1$ grep '^.\+#filter emptyLines' l10n/*/browser/defines.inc
l10n/ar/browser/defines.inc:# This Source Code Form is subject to the terms of the Mozilla Public# License, v. 2.0. If a copy of the MPL was not distributed with this# file, You can obtain one at http://mozilla.org/MPL/2.0/.#filter emptyLines
l10n/bn-BD/browser/defines.inc:# This Source Code Form is subject to the terms of the Mozilla Public# License, v. 2.0. If a copy of the MPL was not distributed with this# file, You can obtain one at http://mozilla.org/MPL/2.0/.#filter emptyLines
l10n/ca/browser/defines.inc:# This Source Code Form is subject to the terms of the Mozilla Public# License, v. 2.0. If a copy of the MPL was not distributed with this# file, You can obtain one at http://mozilla.org/MPL/2.0/.#filter emptyLines
l10n/fa/browser/defines.inc:# This Source Code Form is subject to the terms of the Mozilla Public# License, v. 2.0. If a copy of the MPL was not distributed with this# file, You can obtain one at http://mozilla.org/MPL/2.0/.#filter emptyLines
l10n/ff/browser/defines.inc:# This Source Code Form is subject to the terms of the Mozilla Public# License, v. 2.0. If a copy of the MPL was not distributed with this# file, You can obtain one at http://mozilla.org/MPL/2.0/.#filter emptyLines
l10n/gd/browser/defines.inc:# This Source Code Form is subject to the terms of the Mozilla Public# License, v. 2.0. If a copy of the MPL was not distributed with this# file, You can obtain one at http://mozilla.org/MPL/2.0/.#filter emptyLines
l10n/nso/browser/defines.inc:# This Source Code Form is subject to the terms of the Mozilla Public# License, v. 2.0. If a copy of the MPL was not distributed with this# file, You can obtain one at http://mozilla.org/MPL/2.0/.#filter emptyLines

Dwayne, can this be a bug in the translate toolkit handling of .inc files?

@Axel, almost definitely the bug fixed by https://github.com/translate/translate/commit/e0d8001989dcf891976df8bb4e17cf9c68f85a9e

@Toni using Toolkit from master or the 1.10.0.RC1 release from http://translate.sourceforge.net/snapshots/ will solve this for you.

I only spotted the bug after struggling to get Samoan language packs to build from, I think, earlier then 18. Since most people don't/can't install the language pack I was hoping the issue would just filter its way out as the release train got rid of those broken language packs. So unfortunately I didn't audit the .inc files that had gone before the discovery.

The fix is quite obvious so could be easy to role out. Would be nice to know if there are any remaining in Beta. Not sure what happens on release though i.e. if it is needed/easy to deploy such a fix.

Thanks Dwaine! I've upgraded translate-toolkit in the server where we host our translations.

Eduard will fix defines.inc in aurora, beta and release branches.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package firefox - 19.0~b2+build1-0ubuntu1

---------------
firefox (19.0~b2+build1-0ubuntu1) raring; urgency=low

  * New upstream release from the beta channel (FIREFOX_19_0b2_BUILD1)

  * Fix LP: #1098312 - Some language packs don't load in Firefox 18
    - add debian/patches/fix-broken-langpack-install-manifests.patch
    - update debian/patches/series.in
  * Drop revert-restartless-language-packs.patch, as this changeset has
    been backed out upstream now
 -- Chris Coulson <email address hidden> Wed, 16 Jan 2013 10:33:28 +0000

Changed in firefox (Ubuntu Raring):
status: Triaged → Fix Released

SRU Justification for firefox-locale-ca

Impact: Firefox menus and messages are in English and Ubuntu users only knowing Catalan cannot use them

How Addressed: Simply apply the same patch as in Raring

Reproduction: On an affected machine fully updated, simply set the locale to ca and open Firefox.

Regression Potential: None expected.

Chris Coulson (chrisccoulson) wrote :

Hmmm, this doesn't need a SRU justification and isn't going out via the SRU route (it's going out through the security pocket, and builds were done yesterday in the security PPA already). We didn't write SRU justifications for any of the other few thousand changesets that were in the Firefox 18 update.

Great, thank you, good to know.

Sorry, but these patches don't do what's expected.

browser/defines.inc should look like this, with no leading whitespace:

# This Source Code Form is subject to the terms of the Mozilla Public
# License, v. 2.0. If a copy of the MPL was not distributed with this
# file, You can obtain one at http://mozilla.org/MPL/2.0/.
#filter emptyLines

#define MOZ_LANGPACK_CREATOR Mozilla.org / Softcatalà

# If non-English locales wish to credit multiple contributors, uncomment this
# variable definition and use the format specified.
#define MOZ_LANGPACK_CONTRIBUTORS <em:contributor>Softcatalà</em:contributor>

#unfilter emptyLines

Does that make sense or would you rather have someone else provide a patch?

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package firefox - 18.0.1+build1-0ubuntu0.12.04.1

---------------
firefox (18.0.1+build1-0ubuntu0.12.04.1) precise-security; urgency=low

  * New upstream stable release (FIREFOX_18_0_1_BUILD1)
    - see LP: #1100488 for USN information

  * Fix LP: #1098312 - Some language packs don't load in Firefox 18
    - add debian/patches/fix-broken-langpack-install-manifests.patch
    - update debian/patches/series.in
  * Drop revert-restartless-language-packs.patch, as this changeset has
    been backed out upstream now
 -- Chris Coulson <email address hidden> Wed, 16 Jan 2013 10:33:28 +0000

Changed in firefox (Ubuntu Precise):
status: Confirmed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package firefox - 18.0.1+build1-0ubuntu0.10.04.1

---------------
firefox (18.0.1+build1-0ubuntu0.10.04.1) lucid-security; urgency=low

  * New upstream stable release (FIREFOX_18_0_1_BUILD1)
    - see LP: #1100488 for USN information
    - Fix crash in js::DebugScopeProxy::has with Firebug

  * Fix LP: #1098312 - Some language packs don't load in Firefox 18
    - add debian/patches/fix-broken-langpack-install-manifests.patch
    - update debian/patches/series.in
  * Drop revert-restartless-language-packs.patch, as this changeset has
    been backed out upstream now
 -- Chris Coulson <email address hidden> Wed, 16 Jan 2013 10:33:28 +0000

Changed in firefox (Ubuntu Lucid):
status: Confirmed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package firefox - 18.0.1+build1-0ubuntu0.12.10.1

---------------
firefox (18.0.1+build1-0ubuntu0.12.10.1) quantal-security; urgency=low

  * New upstream stable release (FIREFOX_18_0_1_BUILD1)
    - see LP: #1100488 for USN information

  * Fix LP: #1098312 - Some language packs don't load in Firefox 18
    - add debian/patches/fix-broken-langpack-install-manifests.patch
    - update debian/patches/series.in
  * Drop revert-restartless-language-packs.patch, as this changeset has
    been backed out upstream now
 -- Chris Coulson <email address hidden> Wed, 16 Jan 2013 10:33:28 +0000

Changed in firefox (Ubuntu Quantal):
status: Confirmed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package firefox - 18.0.1+build1-0ubuntu0.11.10.1

---------------
firefox (18.0.1+build1-0ubuntu0.11.10.1) oneiric-security; urgency=low

  * New upstream stable release (FIREFOX_18_0_1_BUILD1)
    - see LP: #1100488 for USN information

  * Fix LP: #1098312 - Some language packs don't load in Firefox 18
    - add debian/patches/fix-broken-langpack-install-manifests.patch
    - update debian/patches/series.in
  * Drop revert-restartless-language-packs.patch, as this changeset has
    been backed out upstream now
 -- Chris Coulson <email address hidden> Wed, 16 Jan 2013 10:33:28 +0000

Changed in firefox (Ubuntu Oneiric):
status: Confirmed → Fix Released
Francesc Vilaubi (fvilaubi) wrote :

Today's update 18.0.1 catalan language pack works as expected.
Thanks.

Hi Axel,
I took en_GB and fr as an example and it didn't work. Maybe it's faster and safer if somebody more experienced provides a patch.
Thanks

I've signed off in Dashboard. I assume that builds were not taking last Edu's changes. We're affecting too much users here! :(
Please, accept anyway, Axel. It's not working anyway right now (and we need to test it's not happening in beta). We can sign off more later.

Edu, you have missed .'#filter emptyLines' attached to the license string. Moreover, Axel is suggesting that the order of license info and filter should be the reverse. Overall situation now is not cute, but I think it should not be affecting the outcome and I'd dare to say that XPI should be valid with this patch applied.

We've missed 19.0b4. It's not working yet.

*** Bug 828151 has been marked as a duplicate of this bug. ***

19.0b5 seems to work fine :)
I guess it's unlikely there will be a 18.0.3:
http://hg.mozilla.org/releases/l10n/mozilla-release/ca

Changed in firefox:
status: Confirmed → In Progress
Markus Klyver (markusklyver) wrote :

Isn't this bug fixed yet?

I change it as fixed. Reopen if something may still be done with 18 branch.

Changed in firefox:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.